Updated to Mozilla-0.6, work done by Taya; some minor cleanup (removing

bogus patches). Changes are numerous, see the homepage for details.
This commit is contained in:
martin 2000-12-15 07:16:21 +00:00
parent f0aca8cbd3
commit daafe24eed
9 changed files with 30 additions and 386 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.48 2000/10/31 09:59:21 jlam Exp $
# $NetBSD: Makefile,v 1.49 2000/12/15 07:16:21 martin Exp $
DISTNAME= mozilla-source-M18
PKGNAME= mozilla-0.m18nb1
DISTNAME= mozilla-source
PKGNAME= mozilla-0.6
WRKSRC= ${WRKDIR}/mozilla
CATEGORIES= www
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla/releases/m18/src/
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla0.6/src/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= packages@netbsd.org
@ -18,6 +18,8 @@ DEPENDS+= ORBit>=0.5.1:../../net/ORBit
DEPENDS+= jpeg-6b:../../graphics/jpeg
DEPENDS+= png>=1.0.6:../../graphics/png
DIST_SUBDIR= ${PKGNAME}
ONLY_FOR_PLATFORM= NetBSD-1.4[Y-Z]-i386 NetBSD-1.4Z[A-Z]-i386 \
NetBSD-1.5_ALPHA-i386 NetBSD-1.5_BETA-* \
NetBSD-1.[5-9]*-*
@ -31,7 +33,8 @@ CONFIGURE_ARGS= --disable-tests \
--with-jpeg=${LOCALBASE} \
--with-png=${LOCALBASE} \
--enable-mathml \
--enable-svg
--enable-svg \
--with-extensions=cookie,irc,wallet,xmlextras,psm-glue,xml-rpc
MOZ_LIBDIR= ${PREFIX}/lib/mozilla
MAKE_ENV+= LIBRUNPATH=${MOZ_LIBDIR}

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.18 2000/10/29 03:51:19 mycroft Exp $
$NetBSD: md5,v 1.19 2000/12/15 07:16:22 martin Exp $
MD5 (mozilla-source-M18.tar.bz2) = c92aadfd0a15ca7f48fafc2bbf321e0d
MD5 (mozilla-0.6/mozilla-source.tar.bz2) = d56e61cfeb77f6889e62ab953e8a723d

View file

@ -1,8 +1,7 @@
$NetBSD: patch-sum,v 1.36 2000/12/14 18:18:50 abs Exp $
$NetBSD: patch-sum,v 1.37 2000/12/15 07:16:22 martin Exp $
MD5 (patch-17146) = 4238a105874cd574f587bba8572ffc6c
MD5 (patch-aa) = a07a4956a8c6a91fce0ef653b59c902f
MD5 (patch-ab) = 2f3494ebc4c115ce359fee85fb6da34e
MD5 (patch-ab) = dfa8ac0ffaac96293904adb6372c5b8d
MD5 (patch-ac) = 37c5e93a87f43262c38c9fe46a513740
MD5 (patch-ad) = 20c5cd3f70cae6cca5b1f3eff4421f8b
MD5 (patch-ae) = 576be09ebce960ac0d970c3a80b8591e
@ -11,7 +10,5 @@ MD5 (patch-ag) = 37e370b4c51c8ffb5fc4c9dd2f1ace98
MD5 (patch-ah) = 8f6975c0fb5454958416f2b87d789c99
MD5 (patch-ai) = ebd71ac01fc02d0fa639af6348d1926e
MD5 (patch-aj) = dae5f7b6f80a833fd63721c5c751fe0b
MD5 (patch-ak) = 287b726e245828a0ef5801a621573e09
MD5 (patch-al) = c84bb29314da78f57bbb72c9b9834dc6
MD5 (patch-am) = ae0011f145fee15042a104d9a67a7b44
MD5 (patch-an) = d675e27cb5f6cd403aafab081b8e84c7

View file

@ -1,329 +0,0 @@
$NetBSD: patch-17146,v 1.1 2000/11/26 04:08:11 mycroft Exp $
--- layout/base/src/nsHTMLContentSerializer.cpp.orig Mon Sep 11 20:55:46 2000
+++ layout/base/src/nsHTMLContentSerializer.cpp Sun Nov 26 01:57:32 2000
@@ -62,6 +62,7 @@
mColPos = 0;
mIndent = 0;
mInBody = PR_FALSE;
+ mInCDATA = PR_FALSE;
}
nsHTMLContentSerializer::~nsHTMLContentSerializer()
@@ -272,6 +273,12 @@
mColPos = 0;
}
+ if ((name.get() == nsHTMLAtoms::script) ||
+ (name.get() == nsHTMLAtoms::style) ||
+ (name.get() == nsHTMLAtoms::noscript)) {
+ mInCDATA = PR_TRUE;
+ }
+
return NS_OK;
}
@@ -298,7 +305,8 @@
nsCOMPtr<nsIParserService> parserService;
GetParserService(getter_AddRefs(parserService));
- if (parserService) {
+
+ if (parserService && (name.get() != nsHTMLAtoms::style)) {
nsAutoString nameStr(sharedName);
PRBool isContainer;
@@ -322,6 +330,8 @@
mColPos = 0;
}
+ mInCDATA = PR_FALSE;
+
return NS_OK;
}
@@ -422,7 +432,7 @@
mColPos += aStr.Length();
- if (aTranslateEntities) {
+ if (aTranslateEntities && !mInCDATA) {
nsCOMPtr<nsIEntityConverter> converter;
GetEntityConverter(getter_AddRefs(converter));
--- layout/base/src/nsHTMLContentSerializer.h.orig Sun Sep 10 22:22:58 2000
+++ layout/base/src/nsHTMLContentSerializer.h Sun Nov 26 01:58:13 2000
@@ -89,6 +89,17 @@
PRBool mBodyOnly;
PRInt32 mPreLevel;
+ /*
+ * mInCDATA is set to PR_TRUE while the serializer is serializing
+ * the content of a element whose content is considerd CDATA by the
+ * serializer (such elements are 'script', 'style', 'noscript' and
+ * possibly others) This doesn't have anything to do with if the
+ * element is defined as CDATA in the DTD, it simply means we'll
+ * output the content of the element without doing any entity encoding
+ * what so ever.
+ */
+ PRBool mInCDATA;
+
PRInt32 mMaxColumn;
nsString mLineBreak;
--- layout/html/base/src/nsHTMLAtomList.h.orig Wed Sep 27 19:23:36 2000
+++ layout/html/base/src/nsHTMLAtomList.h Sun Nov 26 01:58:46 2000
@@ -195,6 +195,7 @@
HTML_ATOM(name, "name")
HTML_ATOM(nohref, "nohref")
HTML_ATOM(noresize, "noresize")
+HTML_ATOM(noscript, "noscript")
HTML_ATOM(noshade, "noshade")
HTML_ATOM(nowrap, "nowrap")
HTML_ATOM(object, "object")
--- layout/html/document/src/nsHTMLContentSink.cpp.orig Tue Sep 19 22:35:50 2000
+++ layout/html/document/src/nsHTMLContentSink.cpp Sun Nov 26 02:23:23 2000
@@ -2995,6 +2995,7 @@
NS_IMETHODIMP
HTMLContentSink::OpenNoscript(const nsIParserNode& aNode) {
+ nsresult result=NS_OK;
MOZ_TIMER_DEBUGLOG(("Start: nsHTMLContentSink::OpenNoscript()\n"));
MOZ_TIMER_START(mWatch);
@@ -3002,23 +3003,21 @@
"HTMLContentSink::OpenNoscript", aNode,
mCurrentContext->mStackPos, this);
- nsresult result=mCurrentContext->OpenContainer(aNode);
+ nsCOMPtr<nsIPref> prefs(do_GetService("@mozilla.org/preferences;1", &result));
if(NS_SUCCEEDED(result)) {
- NS_WITH_SERVICE(nsIPref, prefs, "@mozilla.org/preferences;1", &result);
- if(NS_SUCCEEDED(result)) {
- PRBool jsEnabled;
- result=prefs->GetBoolPref("javascript.enabled", &jsEnabled);
- if(NS_SUCCEEDED(result)){
- if(!jsEnabled) {
- nsIHTMLContent* content=mCurrentContext->mStack[mCurrentContext->mStackPos -1].mContent;
- nsCOMPtr<nsIDOMElement> element=do_QueryInterface(content, &result);
- if(NS_SUCCEEDED(result)) {
- result=element->SetAttribute(NS_ConvertASCIItoUCS2("style"),NS_ConvertASCIItoUCS2("display:inline"));
- }
- }
- else {
+ PRBool jsEnabled;
+ result=prefs->GetBoolPref("javascript.enabled", &jsEnabled);
+ if(NS_SUCCEEDED(result)){
+ // If JS is disabled then we want to lose the noscript element
+ // ,and therefore don't OpenContainer, so that the noscript contents
+ // get handled as if noscript wasn't present.
+ if(jsEnabled) {
+
+ result=mCurrentContext->OpenContainer(aNode);
+
+ if(NS_SUCCEEDED(result)) {
mInsideNoXXXTag++; // To indicate that no processing should be done to this content
- result=NS_HTMLPARSER_ALTERNATECONTENT; // Inform DTD that the content is not regular, but an alternate content.
+ result=NS_HTMLPARSER_ALTERNATECONTENT; // Inform DTD that the noscript content should be treated as CDATA.
}
}
}
@@ -3026,6 +3025,7 @@
MOZ_TIMER_DEBUGLOG(("Stop: nsHTMLContentSink::OpenNoscript()\n"));
MOZ_TIMER_STOP(mWatch);
+
return result;
}
@@ -3039,6 +3039,9 @@
*/
NS_IMETHODIMP
HTMLContentSink::CloseNoscript(const nsIParserNode& aNode) {
+
+ // When JS is diabled this method wouldn't get called because
+ // noscript element will not be present then.
MOZ_TIMER_DEBUGLOG(("Start: nsHTMLContentSink::CloseNoscript()\n"));
MOZ_TIMER_START(mWatch);
--- htmlparser/src/CNavDTD.cpp.orig Thu Sep 21 04:00:34 2000
+++ htmlparser/src/CNavDTD.cpp Sun Nov 26 02:07:58 2000
@@ -658,6 +658,31 @@
return result;
}
}
+ else if(mDTDState==NS_HTMLPARSER_ALTERNATECONTENT) {
+ if(eHTMLTag_noscript!=theTag || theType!=eToken_end) {
+ // attribute source is a part of start token.
+ if(theType!=eToken_attribute) {
+ aToken->AppendSource(mScratch);
+ }
+ IF_FREE(aToken);
+ return result;
+ }
+ else {
+ // If you're here then we have seen a /noscript.
+ // After handling the text token intentionally
+ // fall thro' such that /noscript gets handled.
+ CTextToken theTextToken(mScratch);
+ result=HandleStartToken(&theTextToken);
+
+ if(NS_FAILED(result)) {
+ return result;
+ }
+
+ mScratch.Truncate();
+ mScratch.SetCapacity(0);
+ }
+ }
+
/* ---------------------------------------------------------------------------------
This section of code is used to "move" misplaced content from one location in
@@ -666,7 +691,7 @@
deque until we can deal with it.
---------------------------------------------------------------------------------
*/
- if(!execSkipContent && mDTDState!=NS_HTMLPARSER_ALTERNATECONTENT) {
+ if(!execSkipContent) {
switch(theTag) {
case eHTMLTag_html:
@@ -1203,7 +1228,7 @@
STOP_TIMER()
MOZ_TIMER_DEBUGLOG(("Stop: Parse Time: CNavDTD::WillHandleStartTag(), this=%p\n", this));
- if(mParser && mDTDState!=NS_HTMLPARSER_ALTERNATECONTENT) {
+ if(mParser) {
CObserverService* theService=mParser->GetObserverService();
if(theService) {
@@ -3150,17 +3175,16 @@
if(result==NS_HTMLPARSER_ALTERNATECONTENT) {
// We're here because the sink has identified that
// JS is enabled and therefore noscript content should
- // not be treated as a regular content,i.e., make sure
- // that head elements are handled correctly and may be
- // residual style.
+ // not be treated as regular content
+ ++mHasOpenNoXXX;
+ mScratch.Truncate();
+ mScratch.SetCapacity(0);
+
+ mBodyContext->Push(aNode,aStyleStack);
+
mDTDState=result;
- // Though NS_HTMLPARSER_ALTERNATECONTENT is a succeeded message we don't want to propagate it
- // because there are lots of places where we don't check for succeeded result instead
- // we check for NS_OK. Also, this message is pertinent to the DTD only
result=NS_OK;
}
- mHasOpenNoXXX++;
- mBodyContext->Push(aNode,aStyleStack);
}
}
@@ -3722,46 +3746,43 @@
// within NOSCRIPT and since JS is enanbled we should not process
// this content. However, when JS is disabled alternate content
// would become regular content.
- if(mDTDState!=NS_HTMLPARSER_ALTERNATECONTENT) {
- result=OpenHead(aNode);
- if(NS_OK==result) {
- if(eHTMLTag_title==theTag) {
-
- const nsString& theString=aNode->GetSkippedContent();
- PRInt32 theLen=theString.Length();
- CBufDescriptor theBD(theString.GetUnicode(), PR_TRUE, theLen+1, theLen);
- nsAutoString theString2(theBD);
-
- theString2.CompressWhitespace();
-
- STOP_TIMER()
- MOZ_TIMER_DEBUGLOG(("Stop: Parse Time: CNavDTD::AddHeadLeaf(), this=%p\n", this));
- mSink->SetTitle(theString2);
- MOZ_TIMER_DEBUGLOG(("Start: Parse Time: CNavDTD::AddHeadLeaf(), this=%p\n", this));
- START_TIMER()
-
- }
- else result=AddLeaf(aNode);
- // XXX If the return value tells us to block, go
- // ahead and close the tag out anyway, since its
- // contents will be consumed.
-
- // Fix for Bug 31392
- // Do not leave a head context open no matter what the result is.
- if(mHasOpenHead) {
- nsresult rv=CloseHead(aNode);
- // XXX Only send along a failure. If the close
- // succeeded we still may need to indicate that the
- // parser has blocked (i.e. return the result of
- // the AddLeaf.
- if (rv != NS_OK) {
- result = rv;
- }
+ result=OpenHead(aNode);
+ if(NS_OK==result) {
+ if(eHTMLTag_title==theTag) {
+
+ const nsString& theString=aNode->GetSkippedContent();
+ PRInt32 theLen=theString.Length();
+ CBufDescriptor theBD(theString.GetUnicode(), PR_TRUE, theLen+1, theLen);
+ nsAutoString theString2(theBD);
+
+ theString2.CompressWhitespace();
+ STOP_TIMER()
+ MOZ_TIMER_DEBUGLOG(("Stop: Parse Time: CNavDTD::AddHeadLeaf(), this=%p\n", this));
+ mSink->SetTitle(theString2);
+ MOZ_TIMER_DEBUGLOG(("Start: Parse Time: CNavDTD::AddHeadLeaf(), this=%p\n", this));
+ START_TIMER()
+
+ }
+ else result=AddLeaf(aNode);
+ // XXX If the return value tells us to block, go
+ // ahead and close the tag out anyway, since its
+ // contents will be consumed.
+
+ // Fix for Bug 31392
+ // Do not leave a head context open no matter what the result is.
+ if(mHasOpenHead) {
+ nsresult rv=CloseHead(aNode);
+ // XXX Only send along a failure. If the close
+ // succeeded we still may need to indicate that the
+ // parser has blocked (i.e. return the result of
+ // the AddLeaf.
+ if (rv != NS_OK) {
+ result = rv;
}
- }
- }
- else result=AddLeaf(aNode);
+ }
+ }
}
+
return result;
}
--- htmlparser/src/nsElementTable.cpp.orig Thu Sep 21 02:58:10 2000
+++ htmlparser/src/nsElementTable.cpp Sun Nov 26 02:08:28 2000
@@ -310,7 +310,7 @@
/*rootnodes,endrootnodes*/ &gRootTags,&gRootTags,
/*autoclose starttags and endtags*/ 0,0,0,0,
/*parent,incl,exclgroups*/ kBlock, kNone, kNone,
- /*special props, prop-range*/ 0,kNoPropRange,
+ /*special props, prop-range*/ kLegalOpen, kNoPropRange,
/*special parents,kids,skip*/ &gInHead,0,eHTMLTag_unknown);
Initialize(
--- htmlparser/src/nsHTMLTokenizer.cpp.orig Thu Sep 21 02:58:10 2000
+++ htmlparser/src/nsHTMLTokenizer.cpp Sun Nov 26 02:09:05 2000
@@ -689,7 +689,7 @@
//XXX - Find a better soution to record content
//Added _plaintext to fix bug 46054.
- if((eHTMLTag_textarea==theTag || eHTMLTag_xmp==theTag || eHTMLTag_plaintext==theTag) && !mRecordTrailingContent) {
+ if((eHTMLTag_textarea==theTag || eHTMLTag_xmp==theTag || eHTMLTag_plaintext==theTag || eHTMLTag_noscript==theTag) && !mRecordTrailingContent) {
mRecordTrailingContent=PR_TRUE;
}

View file

@ -1,7 +1,8 @@
$NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
$NetBSD: patch-ab,v 1.13 2000/12/15 07:16:22 martin Exp $
--- configure.in.orig Sat Sep 30 23:16:13 2000
+++ configure.in Wed Dec 13 10:11:27 2000
diff -ru /usr/local/src/mozilla/configure.in ./configure.in
--- /usr/local/src/mozilla/configure.in Sun Oct 1 15:16:13 2000
+++ ./configure.in Fri Oct 13 11:23:07 2000
@@ -360,8 +360,6 @@
TARGET_MD_ARCH=unix
DIRENT_INO=d_ino
@ -11,7 +12,7 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
MOZ_JPEG_CFLAGS=
MOZ_JPEG_LIBS='-L$(DIST)/lib -ljpeg'
@@ -705,31 +703,26 @@
@@ -705,31 +703,24 @@
if $CC -E - -dM </dev/null | grep __ELF__ >/dev/null; then
DLL_SUFFIX=".so"
DSO_PIC_CFLAGS='-fPIC -DPIC'
@ -19,21 +20,18 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
- SHLIB_LDSTARTFILE=/usr/lib/crtbeginS.o
- SHLIB_LDENDFILE=/usr/lib/crtendS.o
+ DSO_LDOPTS='-shared -Wl,-soname,lib$(LIBRARY_NAME)$(DLL_SUFFIX)'
+ MKSHLIB_FORCE_ALL='-Wl,--whole-archive'
+ MKSHLIB_UNFORCE_ALL='-Wl,--no-whole-archive'
else
DSO_PIC_CFLAGS='-fPIC -DPIC'
DLL_SUFFIX=".so.1.0"
- DSO_LDOPTS='-x -shared'
- SHLIB_LDSTARTFILE=/usr/lib/c++rt0.o
+ DSO_LDOPTS='-shared'
+ MKSHLIB_FORCE_ALL=''
+ MKSHLIB_UNFORCE_ALL=''
+ # a.out ignores --no-whole-archive; using --whole-archive breaks link
fi
- # At least for 1.3 and up, ld supports this, despite the test failing above.
# At least for 1.3 and up, ld supports this, despite the test failing above.
- MKSHLIB_FORCE_ALL='--whole-archive'
- MKSHLIB_UNFORCE_ALL='--no-whole-archive'
+ MKSHLIB_FORCE_ALL='-Wl,--whole-archive'
+ MKSHLIB_UNFORCE_ALL='-Wl,--no-whole-archive'
case $OS_TEST in
alpha)
dnl NetBSD/alpha can't find a shared lib
@ -51,7 +49,7 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
fi
;;
@@ -981,8 +974,6 @@
@@ -981,8 +972,6 @@
dnl See above (netbsd)
AC_SUBST(NEED_BASE_DLL_NAME_ALSO)
@ -60,7 +58,7 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
dnl Only one oddball right now (QNX), but this gives us flexibility
dnl if any other platforms need to override this in the future.
@@ -1195,12 +1186,6 @@
@@ -1195,12 +1184,6 @@
AM_PATH_GTK($GTK_VERSION,,
AC_MSG_ERROR(Test for GTK failed.))
@ -73,7 +71,7 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
dnl ========================================================
dnl = =
dnl = --with-java-supplement =
@@ -1691,13 +1676,6 @@
@@ -1691,13 +1674,6 @@
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
@ -87,7 +85,7 @@ $NetBSD: patch-ab,v 1.12 2000/12/14 18:18:50 abs Exp $
dnl Checks for typedefs, structures, and compiler characteristics.
dnl ========================================================
AC_C_CONST
@@ -2046,6 +2024,9 @@
@@ -2046,6 +2022,9 @@
CXXFLAGS="$CXXFLAGS -mt"
fi
;;

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ak,v 1.6 2000/11/09 07:26:29 mycroft Exp $
--- nsprpub/pr/src/io/prsocket.c.orig Wed Apr 26 21:27:38 2000
+++ nsprpub/pr/src/io/prsocket.c Thu Nov 9 07:08:43 2000
@@ -1302,6 +1302,7 @@
if (listenSock == INVALID_SOCKET) {
goto failed;
}
+ memset(&selfAddr, 0, sizeof(selfAddr));
selfAddr.sin_family = AF_INET;
selfAddr.sin_port = 0;
selfAddr.sin_addr.s_addr = htonl(INADDR_LOOPBACK); /* BugZilla: 35408 */

View file

@ -1,17 +0,0 @@
$NetBSD: patch-al,v 1.6 2000/11/15 04:53:35 martin Exp $
--- rdf/base/src/nsRDFContentSink.cpp.orig Sun Oct 29 23:19:05 2000
+++ rdf/base/src/nsRDFContentSink.cpp Tue Nov 14 20:41:57 2000
@@ -1198,11 +1198,11 @@
ContainerInfo gContainerInfo[] = {
{ &RDFContentSinkImpl::kRDF_Alt, &nsIRDFContainerUtils::IsAlt, &nsIRDFContainerUtils::MakeAlt },
{ &RDFContentSinkImpl::kRDF_Bag, &nsIRDFContainerUtils::IsBag, &nsIRDFContainerUtils::MakeBag },
{ &RDFContentSinkImpl::kRDF_Seq, &nsIRDFContainerUtils::IsSeq, &nsIRDFContainerUtils::MakeSeq },
- { 0, 0, 0 },
+ { 0 }, // 0, 0 },
};
nsresult
RDFContentSinkImpl::InitContainer(nsIRDFResource* aContainerType, nsIRDFResource* aContainer)
{

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST-ELF,v 1.6 2000/10/30 00:01:17 mycroft Exp $
@comment $NetBSD: PLIST-ELF,v 1.7 2000/12/15 07:16:23 martin Exp $
bin/mozilla
@comment begin PROGRAMS
lib/mozilla/mozilla-bin
@ -114,6 +114,7 @@ lib/mozilla/plugins/libnullplugin.so
@comment begin DATA
lib/mozilla/bloaturls.txt
lib/mozilla/chrome/blue.jar
lib/mozilla/chrome/chatzilla.jar
lib/mozilla/chrome/classic.jar
lib/mozilla/chrome/comm.jar
lib/mozilla/chrome/embed.jar
@ -128,6 +129,7 @@ lib/mozilla/components/appshell.xpt
lib/mozilla/components/autocomplete.xpt
lib/mozilla/components/bookmarks.xpt
lib/mozilla/components/caps.xpt
lib/mozilla/components/chatzilla-service.js
lib/mozilla/components/chrome.xpt
lib/mozilla/components/cookieviewer.xpt
lib/mozilla/components/directory.xpt

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST-a.out,v 1.6 2000/10/30 00:01:17 mycroft Exp $
@comment $NetBSD: PLIST-a.out,v 1.7 2000/12/15 07:16:23 martin Exp $
bin/mozilla
@comment begin PROGRAMS
lib/mozilla/mozilla-bin
@ -114,6 +114,7 @@ lib/mozilla/plugins/libnullplugin.so.1.0
@comment begin DATA
lib/mozilla/bloaturls.txt
lib/mozilla/chrome/blue.jar
lib/mozilla/chrome/chatzilla.jar
lib/mozilla/chrome/classic.jar
lib/mozilla/chrome/comm.jar
lib/mozilla/chrome/embed.jar
@ -128,6 +129,7 @@ lib/mozilla/components/appshell.xpt
lib/mozilla/components/autocomplete.xpt
lib/mozilla/components/bookmarks.xpt
lib/mozilla/components/caps.xpt
lib/mozilla/components/chatzilla-service.js
lib/mozilla/components/chrome.xpt
lib/mozilla/components/cookieviewer.xpt
lib/mozilla/components/directory.xpt