Update guile-gtk to 0.19. Also change the dependency from gnome-core to gtk+,
since that's all we really need. Changes from version 0.17: * Guile-gtk now supports new guile 1.4 * Guile-gtk now calls gtk_set_locale during initialization. * Support for type conversions with composites due to libltdl support from libguile. * Lots of improvements with the build-guile-gtk script. * Functions for getting the Gtk+ and guile-gtk version. * Lots of additions and corrections to the *.defs files. * The usual, uncountable number of minor and major bug fixes.
This commit is contained in:
parent
0887544aee
commit
dab62890d3
6 changed files with 16 additions and 42 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.4 2000/07/15 02:49:52 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2000/08/05 19:04:44 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= guile-gtk-0.17
|
||||
DISTNAME= guile-gtk-0.19
|
||||
CATEGORIES= devel x11 gnome
|
||||
MASTER_SITES= http://www.ping.de/sites/zagadka/guile-gtk/download/ \
|
||||
http://erin.netpedia.net/download/ \
|
||||
|
@ -11,12 +11,13 @@ MASTER_SITES= http://www.ping.de/sites/zagadka/guile-gtk/download/ \
|
|||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://www.ping.de/sites/zagadka/guile-gtk/
|
||||
|
||||
DEPENDS+= gnome-core-*:../../x11/gnome-core
|
||||
DEPENDS+= guile>=1.3.2:../../lang/guile
|
||||
DEPENDS+= gtk+-1.2.*:../../x11/gtk
|
||||
DEPENDS+= guile>=1.4:../../lang/guile
|
||||
|
||||
GNU_CONFIGURE= # defined
|
||||
USE_X11= # defined
|
||||
USE_LIBTOOL= # defined
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
|
||||
GNU_CONFIGURE= # defined
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/12/20 11:58:46 rh Exp $
|
||||
$NetBSD: md5,v 1.2 2000/08/05 19:04:44 jlam Exp $
|
||||
|
||||
MD5 (guile-gtk-0.17.tar.gz) = 3c990bcfcf7c6082ea331acd11b4e5ea
|
||||
MD5 (guile-gtk-0.19.tar.gz) = ec4c28e1edfc21e075046eae6b99d945
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: patch-sum,v 1.4 2000/06/21 01:09:07 jlam Exp $
|
||||
$NetBSD: patch-sum,v 1.5 2000/08/05 19:04:44 jlam Exp $
|
||||
|
||||
MD5 (patch-aa) = 60b88d1a54ed59e3c8fd80fabcfcfae9
|
||||
MD5 (patch-ab) = d28b87615af6c07fcc7a5a79933f103d
|
||||
This placeholder file is generated by the ``makepatchsum'' target
|
||||
whenever the patches directory is empty or missing. Its purpose
|
||||
is to ensure that the presence of any obsolete patches will cause
|
||||
the proper error to be emitted at build time.
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2000/06/21 01:09:07 jlam Exp $
|
||||
|
||||
--- configure.orig Sat Oct 16 19:16:57 1999
|
||||
+++ configure Tue Jun 20 20:59:41 2000
|
||||
@@ -2562,7 +2562,7 @@
|
||||
|
||||
echo $ac_n "checking whether libtool wins""... $ac_c" 1>&6
|
||||
echo "configure:2565: checking whether libtool wins" >&5
|
||||
-if grep -q '^deplibs_check_method' ./libtool; then
|
||||
+if true; then
|
||||
LIBTOOL_IS_WINNING="#t"
|
||||
echo "$ac_t""yes" 1>&6
|
||||
else
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2000/04/12 06:58:09 rh Exp $
|
||||
|
||||
--- guile-gtk.h.orig Thu Sep 23 00:20:27 1999
|
||||
+++ guile-gtk.h Wed Apr 12 08:54:06 2000
|
||||
@@ -232,9 +232,6 @@
|
||||
GtkWidget* gtk_radio_menu_item_new_from_widget (GtkRadioMenuItem *group);
|
||||
GtkWidget* gtk_pixmap_new_interp (char *file, GtkWidget *intended_parent);
|
||||
|
||||
-GdkColor* gdk_color_copy (GdkColor *);
|
||||
-void gdk_color_free (GdkColor *);
|
||||
-
|
||||
GdkColor *gdk_color_parse_interp (char *spec);
|
||||
GdkColor *gtk_style_get_white_interp (GtkStyle *style);
|
||||
|
|
@ -1,11 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/06/21 01:09:07 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/08/05 19:04:45 jlam Exp $
|
||||
bin/build-guile-gtk
|
||||
bin/guile-gtk
|
||||
bin/guile-gtk-1.2
|
||||
include/guile-gtk.h
|
||||
lib/libguiledlopenhelper.a
|
||||
lib/libguiledlopenhelper.la
|
||||
lib/libguiledlopenhelper.so.0.0
|
||||
lib/libguilegtk-1.2.a
|
||||
lib/libguilegtk-1.2.la
|
||||
lib/libguilegtk-1.2.so.0.0
|
||||
|
@ -14,10 +11,11 @@ share/guile-gtk/gtk-1.2.defs
|
|||
share/guile/gtk-1.2/gdk.scm
|
||||
share/guile/gtk-1.2/gtk.scm
|
||||
share/guile/gtk/config.scm
|
||||
share/guile/gtk/dynlink-old.scm
|
||||
share/guile/gtk/dynlink.scm
|
||||
share/guile/gtk/event-repl.scm
|
||||
share/guile/gtk/gdk.scm
|
||||
share/guile/gtk/gtk.scm
|
||||
@dirrm share/guile/gtk-1.2
|
||||
@dirrm share/guile/gtk
|
||||
@dirrm share/guile/gtk-1.2
|
||||
@dirrm share/guile-gtk
|
||||
|
|
Loading…
Reference in a new issue