Add Zoularis/Linux support
This commit is contained in:
parent
55622ada9a
commit
dadf1b3e08
7 changed files with 110 additions and 36 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.4 2002/09/20 21:40:35 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2002/09/24 18:06:22 tsarna Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Python-2.2.1
|
||||
|
@ -13,7 +13,20 @@ COMMENT= Interpreted, interactive, object-oriented programming language
|
|||
|
||||
USE_BUILDLINK2= YES
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PLIST_SUBST+= PY_PLATNAME=${LOWER_OPSYS}${OS_VERSION:C/\..*//}
|
||||
PLIST_SRC= ${PKGDIR}/PLIST.common ${PKGDIR}/PLIST.${LOWER_OPSYS} \
|
||||
${PKGDIR}/PLIST.common_end
|
||||
|
||||
CONFIGURE_ARGS+= --without-mpz --without-gdbm
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
CONFIGURE_ARGS+= --without-threads
|
||||
.endif
|
||||
|
||||
PLIST_SRC+=
|
||||
|
||||
INSTALL_TARGET= altinstall
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2002/04/15 12:13:38 drochner Exp $
|
||||
@comment $NetBSD: PLIST.common,v 1.1 2002/09/24 18:06:24 tsarna Exp $
|
||||
bin/pydoc2.2
|
||||
bin/python2.2
|
||||
include/python2.2/Python.h
|
||||
|
@ -748,7 +748,6 @@ lib/python2.2/lib-dynload/_testcapi.so
|
|||
lib/python2.2/lib-dynload/_weakref.so
|
||||
lib/python2.2/lib-dynload/array.so
|
||||
lib/python2.2/lib-dynload/binascii.so
|
||||
lib/python2.2/lib-dynload/bsddb.so
|
||||
lib/python2.2/lib-dynload/cPickle.so
|
||||
lib/python2.2/lib-dynload/cStringIO.so
|
||||
lib/python2.2/lib-dynload/cmath.so
|
||||
|
@ -955,10 +954,10 @@ lib/python2.2/pickle.pyo
|
|||
lib/python2.2/pipes.py
|
||||
lib/python2.2/pipes.pyc
|
||||
lib/python2.2/pipes.pyo
|
||||
lib/python2.2/plat-${LOWER_OPSYS}1/IN.py
|
||||
lib/python2.2/plat-${LOWER_OPSYS}1/IN.pyc
|
||||
lib/python2.2/plat-${LOWER_OPSYS}1/IN.pyo
|
||||
lib/python2.2/plat-${LOWER_OPSYS}1/regen
|
||||
lib/python2.2/plat-${PY_PLATNAME}/IN.py
|
||||
lib/python2.2/plat-${PY_PLATNAME}/IN.pyc
|
||||
lib/python2.2/plat-${PY_PLATNAME}/IN.pyo
|
||||
lib/python2.2/plat-${PY_PLATNAME}/regen
|
||||
lib/python2.2/popen2.py
|
||||
lib/python2.2/popen2.pyc
|
||||
lib/python2.2/popen2.pyo
|
||||
|
@ -1951,25 +1950,3 @@ lib/python2.2/xmlrpclib.pyo
|
|||
lib/python2.2/zipfile.py
|
||||
lib/python2.2/zipfile.pyc
|
||||
lib/python2.2/zipfile.pyo
|
||||
@dirrm lib/python2.2/xml/sax
|
||||
@dirrm lib/python2.2/xml/parsers
|
||||
@dirrm lib/python2.2/xml/dom
|
||||
@dirrm lib/python2.2/xml
|
||||
@dirrm lib/python2.2/test/output
|
||||
@dirrm lib/python2.2/test/data
|
||||
@dirrm lib/python2.2/test
|
||||
@dirrm lib/python2.2/site-packages
|
||||
@dirrm lib/python2.2/plat-${LOWER_OPSYS}1
|
||||
@dirrm lib/python2.2/lib-tk
|
||||
@dirrm lib/python2.2/lib-old
|
||||
@dirrm lib/python2.2/lib-dynload
|
||||
@dirrm lib/python2.2/hotshot
|
||||
@dirrm lib/python2.2/encodings
|
||||
@dirrm lib/python2.2/email
|
||||
@dirrm lib/python2.2/distutils/command
|
||||
@dirrm lib/python2.2/distutils
|
||||
@dirrm lib/python2.2/curses
|
||||
@dirrm lib/python2.2/config
|
||||
@dirrm lib/python2.2/compiler
|
||||
@dirrm lib/python2.2
|
||||
@dirrm include/python2.2
|
23
lang/python22/PLIST.common_end
Normal file
23
lang/python22/PLIST.common_end
Normal file
|
@ -0,0 +1,23 @@
|
|||
@comment $NetBSD: PLIST.common_end,v 1.1 2002/09/24 18:06:24 tsarna Exp $
|
||||
@dirrm lib/python2.2/xml/sax
|
||||
@dirrm lib/python2.2/xml/parsers
|
||||
@dirrm lib/python2.2/xml/dom
|
||||
@dirrm lib/python2.2/xml
|
||||
@dirrm lib/python2.2/test/output
|
||||
@dirrm lib/python2.2/test/data
|
||||
@dirrm lib/python2.2/test
|
||||
@dirrm lib/python2.2/site-packages
|
||||
@dirrm lib/python2.2/plat-${PY_PLATNAME}
|
||||
@dirrm lib/python2.2/lib-tk
|
||||
@dirrm lib/python2.2/lib-old
|
||||
@dirrm lib/python2.2/lib-dynload
|
||||
@dirrm lib/python2.2/hotshot
|
||||
@dirrm lib/python2.2/encodings
|
||||
@dirrm lib/python2.2/email
|
||||
@dirrm lib/python2.2/distutils/command
|
||||
@dirrm lib/python2.2/distutils
|
||||
@dirrm lib/python2.2/curses
|
||||
@dirrm lib/python2.2/config
|
||||
@dirrm lib/python2.2/compiler
|
||||
@dirrm lib/python2.2
|
||||
@dirrm include/python2.2
|
12
lang/python22/PLIST.linux
Normal file
12
lang/python22/PLIST.linux
Normal file
|
@ -0,0 +1,12 @@
|
|||
@comment $NetBSD: PLIST.linux,v 1.1 2002/09/24 18:06:25 tsarna Exp $
|
||||
lib/python2.2/plat-linux2/CDROM.py
|
||||
lib/python2.2/plat-linux2/CDROM.pyc
|
||||
lib/python2.2/plat-linux2/CDROM.pyo
|
||||
lib/python2.2/plat-linux2/DLFCN.py
|
||||
lib/python2.2/plat-linux2/DLFCN.pyc
|
||||
lib/python2.2/plat-linux2/DLFCN.pyo
|
||||
lib/python2.2/plat-linux2/TYPES.py
|
||||
lib/python2.2/plat-linux2/TYPES.pyc
|
||||
lib/python2.2/plat-linux2/TYPES.pyo
|
||||
lib/python2.2/lib-dynload/linuxaudiodev.so
|
||||
|
2
lang/python22/PLIST.netbsd
Normal file
2
lang/python22/PLIST.netbsd
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.netbsd,v 1.1 2002/09/24 18:06:25 tsarna Exp $
|
||||
lib/python2.2/lib-dynload/bsddb.so
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.6 2002/09/24 18:06:25 tsarna Exp $
|
||||
|
||||
SHA1 (Python-2.2.1.tgz) = 12905ad4bc4f3006366a495275259661db7b8604
|
||||
Size (Python-2.2.1.tgz) = 6535104 bytes
|
||||
SHA1 (patch-aa) = 7f23b2b5b6f237ef2904f132dc634a8e8b5c540b
|
||||
SHA1 (patch-aa) = b6320ac24c1924d6e7924b6f4d6a42d146e2e8ab
|
||||
SHA1 (patch-ab) = aa06824d9f595a24aaddc96c83f31646f522ab09
|
||||
SHA1 (patch-ae) = aefeec78e25631a6e9e2aa047dce12c9c522715e
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2002/09/24 18:06:26 tsarna Exp $
|
||||
|
||||
--- setup.py.orig Tue Mar 26 14:43:04 2002
|
||||
+++ setup.py Mon Apr 15 11:13:53 2002
|
||||
--- setup.py.orig Tue Mar 26 08:43:04 2002
|
||||
+++ setup.py Tue Sep 24 12:30:40 2002
|
||||
@@ -197,11 +197,15 @@
|
||||
return platform
|
||||
|
||||
|
@ -32,7 +32,7 @@ $NetBSD: patch-aa,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
|||
|
||||
# Modules with some UNIX dependencies -- on by default:
|
||||
# (If you have a really backward UNIX, select and socket may not be
|
||||
@@ -319,13 +323,13 @@
|
||||
@@ -319,16 +323,16 @@
|
||||
# These represent audio samples or images as strings:
|
||||
|
||||
# Disabled on 64-bit platforms
|
||||
|
@ -49,7 +49,11 @@ $NetBSD: patch-aa,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
|||
+# exts.append( Extension('rgbimg', ['rgbimgmodule.c']) )
|
||||
|
||||
# readline
|
||||
if self.compiler.find_library_file(lib_dirs, 'readline'):
|
||||
- if self.compiler.find_library_file(lib_dirs, 'readline'):
|
||||
+ if 0 and self.compiler.find_library_file(lib_dirs, 'readline'):
|
||||
readline_libs = ['readline']
|
||||
if self.compiler.find_library_file(lib_dirs,
|
||||
'ncurses'):
|
||||
@@ -352,14 +356,10 @@
|
||||
# socket(2)
|
||||
# Detect SSL support for the socket module
|
||||
|
@ -67,6 +71,32 @@ $NetBSD: patch-aa,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
|||
|
||||
if (ssl_incs is not None and
|
||||
ssl_libs is not None):
|
||||
@@ -390,9 +390,9 @@
|
||||
exts.append( Extension('dbm', ['dbmmodule.c']) )
|
||||
|
||||
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
|
||||
- if (self.compiler.find_library_file(lib_dirs, 'gdbm')):
|
||||
- exts.append( Extension('gdbm', ['gdbmmodule.c'],
|
||||
- libraries = ['gdbm'] ) )
|
||||
+ #if (self.compiler.find_library_file(lib_dirs, 'gdbm')):
|
||||
+ # exts.append( Extension('gdbm', ['gdbmmodule.c'],
|
||||
+ # libraries = ['gdbm'] ) )
|
||||
|
||||
# Berkeley DB interface.
|
||||
#
|
||||
@@ -446,9 +446,9 @@
|
||||
# FTP archive sites. One URL for it is:
|
||||
# ftp://gatekeeper.dec.com/.b/usenet/comp.sources.misc/volume40/fgmp/part01.Z
|
||||
|
||||
- if (self.compiler.find_library_file(lib_dirs, 'gmp')):
|
||||
- exts.append( Extension('mpz', ['mpzmodule.c'],
|
||||
- libraries = ['gmp'] ) )
|
||||
+ #if (self.compiler.find_library_file(lib_dirs, 'gmp')):
|
||||
+ # exts.append( Extension('mpz', ['mpzmodule.c'],
|
||||
+ # libraries = ['gmp'] ) )
|
||||
|
||||
|
||||
# Unix-only modules
|
||||
@@ -475,8 +475,8 @@
|
||||
|
||||
if (self.compiler.find_library_file(lib_dirs, 'ncurses')):
|
||||
|
@ -89,6 +119,23 @@ $NetBSD: patch-aa,v 1.5 2002/04/15 12:13:38 drochner Exp $
|
|||
|
||||
# If the curses module is enabled, check for the panel module
|
||||
if (module_enabled(exts, '_curses') and
|
||||
@@ -566,11 +566,11 @@
|
||||
else:
|
||||
expat_incs = find_file('xmlparse.h', inc_dirs, [])
|
||||
|
||||
- if (expat_incs is not None and
|
||||
- self.compiler.find_library_file(lib_dirs, 'expat')):
|
||||
- exts.append( Extension('pyexpat', ['pyexpat.c'],
|
||||
- define_macros = expat_defs,
|
||||
- libraries = ['expat']) )
|
||||
+ #if (expat_incs is not None and
|
||||
+ # self.compiler.find_library_file(lib_dirs, 'expat')):
|
||||
+ # exts.append( Extension('pyexpat', ['pyexpat.c'],
|
||||
+ # define_macros = expat_defs,
|
||||
+ # libraries = ['expat']) )
|
||||
|
||||
# Platform-specific libraries
|
||||
if platform == 'linux2':
|
||||
@@ -793,7 +793,7 @@
|
||||
ext_modules=[Extension('struct', ['structmodule.c'])],
|
||||
|
||||
|
|
Loading…
Reference in a new issue