Update to 3.7.2.
Changes from 3.7.1 to 3.7.2 Released November 12, 2006 New Features: * Data Table adds JD, HJD and PA columns. * Earth View adds inertial reference frame option. * Earth View allows picking earth satellite via orbit marker. * Earth View shows altitude and range in satellite right-click data. * Earth View shows satellite position in space. * Earth View can draw orbits on cylindrical projection. * Earth objects table has new column-wide toggles. * Main menu can remember to start RT mode automatically. * Makefiles now support building Mac OS X universal binaries. * Object index search supports using glob patterns. * Observing log adds JD, HJD and Airmass fields. * Observing log replaces Search with List feature. * Observing log search supports using glob patterns. * Preferences can now remember and restore which views were open. * Print adds new option to draw with thicker lines. * Several improvements to XML and INDI tools. * Shared app defaults file, XEphem, may now be in /etc. * Sites list search supports using glob patterns. * Sky View draws simplistic antialiased stars. * Mars, Jupiter, Saturn and Uranus satellite models extended to 2021. * Native binary support for Mac OSX Intel. Bugs fixed: * .fts added as default suffix when downloading DSS images. * Data menu was not cutting spect field at 2 chars. * Earth View uses unique names for satellite object listing fields. * Fix logic to detect no natural satellite models. * Main menu now only shows progress meter if using fewer than 1000 steps. * Numbers like 2e-2 were considered negative in some situations. * Sky View RADec grid was inaccurate in AA mode near celestial poles * Sky View compass correct now when showing tilted/rotated FITS image. * Sky View labels N and S ecliptic poles. * Sky View no longer prevents panning below horizon. * Sky View telescope marker turned off when manually point only if also recentering. * Sky View was leaving constellation figure files open. * Solver properly guards XML entity characters when saving functions. * Support ISO 8601 in FITS DATE-OBS field. * Support much longer edb entries when downloading from web. * Updated Delta-T table. * WCS solver window labels CDELT2 as pixels up, not down. * astorb2edb.pl updated for longer object names. INDI enhancements: * add IEDeferLoop function for inline waiting. * add IUCrackNumber and IUCrackText utility functions. * change indiserver to use select(2) not threads (10-20% more efficient). * command line tools can inherit socket from parent script to maintain a single session * fix bug in very rapid timeouts. * guarantee getProperties is first command sent to drivers. * improve efficiency of traffic to remote drivers. * indiserver sniffs client devices from all commands, not just getProperties. * library sends doubles with more precision. * merge stderr from drivers into indiserver's log with date stamp. * more robust IUSaveText.
This commit is contained in:
parent
299b60cfd6
commit
db3bb39fdc
3 changed files with 15 additions and 17 deletions
|
@ -1,9 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.45 2007/01/15 18:30:48 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.46 2007/01/31 14:07:16 gdt Exp $
|
||||
|
||||
DISTNAME= xephem-3.7.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= xephem-3.7.2
|
||||
CATEGORIES= x11
|
||||
PKGREVISION= 1
|
||||
MASTER_SITES= http://www.clearskyinstitute.com/xephem/ \
|
||||
ftp://iphcip1.physik.uni-mainz.de/pub/xephem/
|
||||
|
||||
|
@ -34,7 +32,7 @@ REPLACE_PERL+= auxil/*.pl
|
|||
|
||||
LIBS.SunOS+= -lnsl -lsocket
|
||||
X11_LDFLAGS+= ${LIBS}
|
||||
PKGSRC_MAKE_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}
|
||||
MAKE_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}
|
||||
|
||||
REPLACE_INTERPRETER+= perl
|
||||
REPLACE.perl.old= .*/bin/perl
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.8 2006/05/10 16:45:35 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/01/31 14:07:16 gdt Exp $
|
||||
|
||||
SHA1 (xephem-3.7.1.tar.gz) = e6567b358c3b00f696e71eace20f4f5226bab011
|
||||
RMD160 (xephem-3.7.1.tar.gz) = 7debeb25b9e76b3e796ae5349d84d6b36ae04e54
|
||||
Size (xephem-3.7.1.tar.gz) = 12986819 bytes
|
||||
SHA1 (patch-aa) = ea4d59efc966e41487357cd511b3e737dbd971d3
|
||||
SHA1 (xephem-3.7.2.tar.gz) = 8027f73e934e257316d15c474c88d435241c521d
|
||||
RMD160 (xephem-3.7.2.tar.gz) = 585ed51d167869919b512561714d380c83db8865
|
||||
Size (xephem-3.7.2.tar.gz) = 19369598 bytes
|
||||
SHA1 (patch-aa) = aeae377b7e8006e97d604edc8e5ae14ea76d4b14
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.6 2006/05/10 16:45:35 gdt Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2007/01/31 14:07:16 gdt Exp $
|
||||
|
||||
--- Makefile.orig 2005-11-18 08:43:09.000000000 -0500
|
||||
--- Makefile.orig 2006-05-13 19:06:06.000000000 -0400
|
||||
+++ Makefile
|
||||
@@ -32,9 +32,9 @@ endif
|
||||
# for linux and Apple OS X
|
||||
# for linux and pure ppc Apple OS X
|
||||
CC = gcc
|
||||
CLDFLAGS = -g
|
||||
-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
|
||||
-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
|
||||
-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lSM -lICE -lXmu -lX11
|
||||
-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
|
||||
+CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I/usr/X11R6/include
|
||||
+LDFLAGS = $(LIBLNK) $(CLDFLAGS) $(X11_LDFLAGS)
|
||||
+XLIBS = $(MOTIFLIB) -lXp -lXt -lXext -lSM -lICE -lXmu -lX11
|
||||
+LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L/usr/X11R6/lib
|
||||
+XLIBS = $(MOTIFLIB) -lXp -lXt -lXext -lXmu -lX11
|
||||
LIBS = $(XLIBS) $(LIBLIB) -lm
|
||||
|
||||
# MKS Enterprise toolkit
|
||||
# for ppc Apple OS X to make universal (i386 and ppc binary), requires
|
||||
|
|
Loading…
Reference in a new issue