Solaris doesn't have <paths.h>. Should fix the last traces of PR 39717.

This commit is contained in:
dholland 2009-05-17 22:04:11 +00:00
parent 60359a8e65
commit db43590888
2 changed files with 16 additions and 11 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.26 2009/02/04 04:52:46 dholland Exp $
$NetBSD: distinfo,v 1.27 2009/05/17 22:04:11 dholland Exp $
SHA1 (gentoo-0.11.57.tar.gz) = ac5859b489a6b88161d5b0f2ddd06490ce9915eb
RMD160 (gentoo-0.11.57.tar.gz) = 675333aa740f297a0d41d5795689b8e4280d2bdf
@ -7,7 +7,7 @@ SHA1 (patch-aa) = 5d8f1fcd4110b09e02f44584e2ccd921a7175929
SHA1 (patch-ab) = e84931dbc57434881f8071e389ebe8df061ee0b6
SHA1 (patch-ac) = 4e5d52849887b816eb4388fb2c75aefb3443f5c8
SHA1 (patch-ad) = 7e41b435aff7af5e57bfb82902a6bb88af37ad97
SHA1 (patch-ae) = 6009cce4f1c6aac47881f98de08417626d803ddf
SHA1 (patch-ae) = 92a0efdb319b33db09f96d8d2a4729f9fdf2c9af
SHA1 (patch-af) = 2b80f24bd545177b0d089696e7b3ed7f0d72a3b0
SHA1 (patch-ag) = 3045a4eb72f8c50d147fe09256ec791359053418
SHA1 (patch-ah) = c14c80a7c821f69b98cb23156ec5b30ac40ed2ec

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ae,v 1.6 2009/02/04 04:52:46 dholland Exp $
$NetBSD: patch-ae,v 1.7 2009/05/17 22:04:11 dholland Exp $
Fix insecure-temp-files. Replaces older nonworking patch with similar
intent. XXX inadequately tested, lack of time.
@ -6,16 +6,21 @@ intent. XXX inadequately tested, lack of time.
Upstream: sent upstream by obache@: http://sourceforge.net/tracker/?func=detail&atid=406763&aid=2537314&group_id=32880
--- src/types.c.orig 2008-07-09 15:51:26.000000000 -0400
+++ src/types.c 2009-01-25 23:36:47.000000000 -0500
@@ -27,6 +27,7 @@
#include <signal.h>
+++ src/types.c 2009-05-17 17:55:28.000000000 -0400
@@ -28,6 +28,12 @@
#include <sys/wait.h>
#include <unistd.h>
+#include <paths.h>
+#ifdef __sun /* paths.h missing in solaris */
+#define _PATH_TMP "/tmp/"
+#else
+#include <paths.h>
+#endif
+
#include <stddef.h>
@@ -345,14 +346,18 @@ static FType * match_file(GList *list, D
#include "strutil.h"
@@ -345,14 +351,18 @@ static FType * match_file(GList *list, D
void typ_identify_end(MainInfo *min, const gchar *path)
{
const GList *here;
@ -36,7 +41,7 @@ Upstream: sent upstream by obache@: http://sourceforge.net/tracker/?func=detail&
return;
if(pipe(fd) != 0)
return;
@@ -360,20 +365,16 @@ void typ_identify_end(MainInfo *min, con
@@ -360,20 +370,16 @@ void typ_identify_end(MainInfo *min, con
file_pid = fork();
if(file_pid == 0)
{
@ -67,7 +72,7 @@ Upstream: sent upstream by obache@: http://sourceforge.net/tracker/?func=detail&
_exit(EXIT_FAILURE);
}
else if(file_pid < 0)
@@ -382,21 +381,21 @@ void typ_identify_end(MainInfo *min, con
@@ -382,21 +388,21 @@ void typ_identify_end(MainInfo *min, con
return;
}
/* We don't need the input part of the pipe, so close it. */
@ -93,7 +98,7 @@ Upstream: sent upstream by obache@: http://sourceforge.net/tracker/?func=detail&
{
const gchar *fout;
gchar line[MAXNAMLEN + 256];
@@ -412,10 +411,14 @@ void typ_identify_end(MainInfo *min, con
@@ -412,10 +418,14 @@ void typ_identify_end(MainInfo *min, con
}
fclose(in);
}