Import ptex-2.1.28 as graphics/ptex.
Ptex is a texture mapping system developed by Walt Disney Animation Studios for production-quality rendering: - No UV assignment is required! Ptex applies a separate texture to each face of a subdivision or polygon mesh. - The Ptex file format can efficiently store hundreds of thousands of texture images in a single file. - The Ptex API provides cached file I/O and high-quality filtering, everything that is needed to easily add Ptex support to a production-quality renderer or texture authoring application.
This commit is contained in:
parent
5f4cd2bb4d
commit
db4376e4ec
6 changed files with 80 additions and 0 deletions
12
graphics/ptex/DESCR
Normal file
12
graphics/ptex/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
Ptex is a texture mapping system developed by Walt Disney Animation Studios for
|
||||
production-quality rendering:
|
||||
|
||||
- No UV assignment is required! Ptex applies a separate texture to each face
|
||||
of a subdivision or polygon mesh.
|
||||
|
||||
- The Ptex file format can efficiently store hundreds of thousands of texture
|
||||
images in a single file.
|
||||
|
||||
- The Ptex API provides cached file I/O and high-quality filtering, everything
|
||||
that is needed to easily add Ptex support to a production-quality renderer
|
||||
or texture authoring application.
|
22
graphics/ptex/Makefile
Normal file
22
graphics/ptex/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1 2016/10/18 02:47:16 kamil Exp $
|
||||
|
||||
DISTNAME= ptex-2.1.28
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=wdas/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://ptex.us/
|
||||
COMMENT= Per-Face Texture Mapping for Production Rendering
|
||||
LICENSE= modified-bsd # with slightly changes spelling
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
BUILDLINK_TRANSFORM+= opt:-std=c++98:-std=gnu++98 # alloca(3)
|
||||
|
||||
TEST_TARGET= test
|
||||
|
||||
TEST_ENV+= LD_LIBRARY_PATH=${WRKSRC}/src/ptex/
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
graphics/ptex/PLIST
Normal file
9
graphics/ptex/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/10/18 02:47:16 kamil Exp $
|
||||
bin/ptxinfo
|
||||
include/PtexHalf.h
|
||||
include/PtexInt.h
|
||||
include/PtexUtils.h
|
||||
include/PtexVersion.h
|
||||
include/Ptexture.h
|
||||
lib/libPtex.a
|
||||
lib/libPtex.so
|
12
graphics/ptex/buildlink3.mk
Normal file
12
graphics/ptex/buildlink3.mk
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2016/10/18 02:47:16 kamil Exp $
|
||||
|
||||
BUILDLINK_TREE+= ptex
|
||||
|
||||
.if !defined(PTEX_BUILDLINK3_MK)
|
||||
PTEX_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.ptex+= ptex>=2.1.28
|
||||
BUILDLINK_PKGSRCDIR.ptex?= ../../graphics/ptex
|
||||
.endif # PTEX_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -ptex
|
7
graphics/ptex/distinfo
Normal file
7
graphics/ptex/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/10/18 02:47:16 kamil Exp $
|
||||
|
||||
SHA1 (ptex-2.1.28.tar.gz) = 67ba20b98247a12f075631b6e65271953e519eda
|
||||
RMD160 (ptex-2.1.28.tar.gz) = eecce0d629551a827a866c63e2ca17651deef5fd
|
||||
SHA512 (ptex-2.1.28.tar.gz) = ddce3c79f14d196e550c1e8a5b371482f88190cd667a2e2aa84601de1639f7cabb8571c1b3a49b48df46ce550d27088a00a67b1403c3bfec2ed73437c3dca3e8
|
||||
Size (ptex-2.1.28.tar.gz) = 305327 bytes
|
||||
SHA1 (patch-src_ptex_PtexPlatform.h) = f3c859f62b3f4ef0b0274939c522c735681fb70e
|
18
graphics/ptex/patches/patch-src_ptex_PtexPlatform.h
Normal file
18
graphics/ptex/patches/patch-src_ptex_PtexPlatform.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-src_ptex_PtexPlatform.h,v 1.1 2016/10/18 02:47:17 kamil Exp $
|
||||
|
||||
The alloca(3) function is an extension and place of its definition varies.
|
||||
The <alloca.h> header is required on SunOS and acceptable on other systems, but
|
||||
unavailable on NetBSD.
|
||||
|
||||
--- src/ptex/PtexPlatform.h.orig 2016-04-04 17:14:05.000000000 +0000
|
||||
+++ src/ptex/PtexPlatform.h
|
||||
@@ -62,7 +62,9 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
|
||||
|
||||
// linux/unix/posix
|
||||
#include <stdlib.h>
|
||||
+#if !defined(__NetBSD__)
|
||||
#include <alloca.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
#include <pthread.h>
|
||||
|
Loading…
Reference in a new issue