Update to 0.9:

Changes between 0.8 and 0.9:
----------------------------
  * fix for a buffer overflow in the line rendering
  * fixed resizing in the ncurses and slang drivers
  * aspect ratio and finer zoom support in cacaview
  * minor compilation fixes
Changes between 0.7 and 0.8:
----------------------------
  * window resizing support
  * native Win32 port
  * autorepeat emulation in the ncurses and slang drivers
  * support for more keycodes in the ncurses and slang drivers
  * cacaplas, a plasma animation example
  * cacamoir, a moiré circles animation example
  * MSVC project file
Changes between 0.6 and 0.7:
----------------------------
  * many bugfixes in the event handling
  * cacaball, a metaball animation example
Changes between 0.5 and 0.6:
----------------------------
  * 30% speed increase in the bitmap rendering routine
  * mouse support and various speed optimisations in the X11 driver
  * X11 is now the preferred driver
  * improved documentation
  * minor bugfixes

Package change: use (n)curses by default instead of slang.
This commit is contained in:
wiz 2004-08-15 12:40:07 +00:00
parent 2c98e20afc
commit db7c0615a9
6 changed files with 94 additions and 10 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2004/08/12 19:36:00 wiz Exp $
# $NetBSD: Makefile,v 1.6 2004/08/15 12:40:07 wiz Exp $
#
DISTNAME= libcaca-0.5
DISTNAME= libcaca-0.9
CATEGORIES= graphics
MASTER_SITES= http://sam.zoy.org/projects/libcaca/
EXTRACT_SUFX= .tar.bz2
@ -15,7 +15,7 @@ USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-slang --disable-ncurses
CONFIGURE_ARGS+= --disable-slang --enable-ncurses --disable-imlib2 --disable-doc
.include "../../mk/bsd.prefs.mk"
@ -23,5 +23,5 @@ CONFIGURE_ARGS+= --enable-slang --disable-ncurses
LDFLAGS= -ldl
.endif
.include "../../devel/libslang/buildlink3.mk"
.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,14 +1,15 @@
@comment $NetBSD: PLIST,v 1.2 2003/12/26 09:38:52 jmmv Exp $
@comment $NetBSD: PLIST,v 1.3 2004/08/15 12:40:07 wiz Exp $
bin/caca-config
bin/caca-spritedit
bin/cacaball
bin/cacademo
bin/cacafire
bin/cacamoir
bin/cacaplas
bin/cacaview
include/caca.h
lib/libcaca.a
lib/libcaca_pic.a
man/man1/caca-config.1
man/man1/caca-spritedit.1
man/man1/cacademo.1
man/man1/cacaview.1
share/doc/libcaca-dev/AUTHORS
@ -16,6 +17,7 @@ share/doc/libcaca-dev/BUGS
share/doc/libcaca-dev/NEWS
share/doc/libcaca-dev/NOTES
share/doc/libcaca-dev/README
share/doc/libcaca-dev/THANKS
share/doc/libcaca-dev/TODO
share/libcaca/caca.txt
@dirrm share/libcaca

View file

@ -1,4 +1,7 @@
$NetBSD: distinfo,v 1.3 2003/12/26 09:38:52 jmmv Exp $
$NetBSD: distinfo,v 1.4 2004/08/15 12:40:07 wiz Exp $
SHA1 (libcaca-0.5.tar.bz2) = 672632842f78aad4b56bd8fbc18babb0b860c392
Size (libcaca-0.5.tar.bz2) = 140661 bytes
SHA1 (libcaca-0.9.tar.bz2) = 55428c11427e8a411062a2699149f912b251d7a6
Size (libcaca-0.9.tar.bz2) = 171854 bytes
SHA1 (patch-aa) = e289d72faafd370301256d870933c9af47839d93
SHA1 (patch-ab) = 72b0ab0ac7783a339a700da2352e7d97c26b4ef9
SHA1 (patch-ac) = cdf05ae24b1f35df39a5f446b13057fbc7e0ec68

View file

@ -0,0 +1,46 @@
$NetBSD: patch-aa,v 1.1 2004/08/15 12:40:07 wiz Exp $
--- src/caca.c.orig 2004-02-02 04:00:19.000000000 +0100
+++ src/caca.c
@@ -70,7 +70,8 @@ static void caca_init_terminal(void);
enum caca_driver _caca_driver;
#endif
-#if defined(USE_NCURSES)
+/* #define MOUSE_SUPPORT 1 */
+#if defined(USE_NCURSES) && defined(MOUSE_SUPPORT)
static mmask_t oldmask;
#endif
@@ -89,7 +90,7 @@ static CONSOLE_CURSOR_INFO cci;
*/
int caca_init(void)
{
-#if defined(USE_NCURSES)
+#if defined(USE_NCURSES) && defined(MOUSE_SUPPORT)
mmask_t newmask;
#endif
@@ -147,10 +148,12 @@ int caca_init(void)
nodelay(stdscr, TRUE);
curs_set(0);
+#if defined(MOUSE_SUPPORT)
/* Activate mouse */
newmask = REPORT_MOUSE_POSITION | ALL_MOUSE_EVENTS;
mousemask(newmask, &oldmask);
mouseinterval(-1); /* No click emulation */
+#endif
/* Set the escape delay to a ridiculously low value */
ESCDELAY = 10;
@@ -385,7 +388,9 @@ void caca_end(void)
#if defined(USE_NCURSES)
if(_caca_driver == CACA_DRIVER_NCURSES)
{
+#if defined(MOUSE_SUPPORT)
mousemask(oldmask, NULL);
+#endif
curs_set(1);
noraw();
endwin();

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2004/08/15 12:40:07 wiz Exp $
--- src/event.c.orig 2004-02-02 04:00:19.000000000 +0100
+++ src/event.c
@@ -387,6 +387,7 @@ static unsigned int _lowlevel_event(void
return CACA_EVENT_KEY_PRESS | intkey;
}
+#if defined(MOUSE_SUPPORT)
if(intkey == KEY_MOUSE)
{
MEVENT mevent;
@@ -515,6 +516,7 @@ static unsigned int _lowlevel_event(void
return CACA_EVENT_MOUSE_MOTION | (mouse_x << 12) | mouse_y;
}
+#endif
event = CACA_EVENT_KEY_PRESS;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2004/08/15 12:40:07 wiz Exp $
--- src/graphics.c.orig 2004-02-02 04:00:19.000000000 +0100
+++ src/graphics.c
@@ -1309,7 +1309,7 @@ static void caca_handle_resize(void)
{
_caca_width = size.ws_col;
_caca_height = size.ws_row;
- resize_term(_caca_height, _caca_width);
+ resizeterm(_caca_height, _caca_width);
wrefresh(curscr);
}
}