reimport of postgresql as postgresql73
PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS), derived from the Berkeley Postgres database management system. While PostgreSQL retains the powerful object-relational data model, rich data types and easy extensibility of Postgres, it replaces the PostQuel query language with an extended subset of SQL. PostgreSQL is free and the complete source is available. This is the meta-package for the PostgreSQL database system.
This commit is contained in:
parent
8a0aa09673
commit
dba14855c6
16 changed files with 429 additions and 0 deletions
9
databases/postgresql73/DESCR
Normal file
9
databases/postgresql73/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS),
|
||||
derived from the Berkeley Postgres database management system. While
|
||||
PostgreSQL retains the powerful object-relational data model, rich data types
|
||||
and easy extensibility of Postgres, it replaces the PostQuel query language
|
||||
with an extended subset of SQL.
|
||||
|
||||
PostgreSQL is free and the complete source is available.
|
||||
|
||||
This is the meta-package for the PostgreSQL database system.
|
20
databases/postgresql73/Makefile
Normal file
20
databases/postgresql73/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
PKGNAME= postgresql73-${BASE_VERS}
|
||||
COMMENT= Robust, next generation, object-relational DBMS
|
||||
|
||||
DEPENDS+= postgresql73-client>=${BASE_VERS}:../../databases/postgresql73-client
|
||||
DEPENDS+= postgresql73-server>=${BASE_VERS}:../../databases/postgresql73-server
|
||||
DEPENDS+= postgresql73-docs>=${BASE_VERS}:../../databases/postgresql73-docs
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
EXTRACT_ONLY= # empty
|
||||
NO_CHECKSUM= YES
|
||||
NO_CONFIGURE= YES
|
||||
NO_BUILD= YES
|
||||
|
||||
do-install: # empty
|
||||
do-patch: # empty
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
90
databases/postgresql73/Makefile.common
Normal file
90
databases/postgresql73/Makefile.common
Normal file
|
@ -0,0 +1,90 @@
|
|||
# $NetBSD: Makefile.common,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
#
|
||||
# This Makefile fragment is included by all PostgreSQL packages built from
|
||||
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
|
||||
#
|
||||
# The PostgreSQL package naming scheme, aside from the obvious piecewise
|
||||
# packages, is as follows:
|
||||
#
|
||||
# <lang>-postgresql client-side interface to PostgreSQL
|
||||
# postgresql-<lang> server-side module for PostgreSQL backend
|
||||
|
||||
DISTNAME?= postgresql-${DIST_VERS}
|
||||
CATEGORIES+= databases
|
||||
MASTER_SITES?= http://www.postgresql.org/ftpsite/source/v${DIST_VERS}/ \
|
||||
ftp://ftp.postgresql.org/pub/source/v${DIST_VERS}/ \
|
||||
ftp://ftp.de.postgresql.org/mirror/postgresql/source/v${DIST_VERS}/ \
|
||||
ftp://gd.tuwien.ac.at/db/www.postgresql.org/pub/source/v${DIST_VERS}/ \
|
||||
ftp://ftp.sunsite.auc.dk/mirrors/postgresql/source/v${DIST_VERS}/ \
|
||||
ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/source/v${DIST_VERS}/
|
||||
|
||||
MAINTAINER?= tech-pkg@NetBSD.org
|
||||
HOMEPAGE?= http://www.postgresql.org/
|
||||
|
||||
CONFLICTS+= postgresql-[0-9]* postgresql74-[0-9]*
|
||||
|
||||
DISTINFO_FILE?= ${.CURDIR}/../postgresql73/distinfo
|
||||
COMMON_FILESDIR?= ${.CURDIR}/../postgresql73/files
|
||||
PATCHDIR?= ${.CURDIR}/../postgresql73/patches
|
||||
|
||||
# Version numbering scheme:
|
||||
#
|
||||
# DIST_VERS version number on the postgresql distfile
|
||||
# BASE_VERS pkgsrc-mangled version number (convert pl -> .)
|
||||
#
|
||||
# Note: Do not forget jdbc-postgresql when updating version
|
||||
DIST_VERS?= 7.3.6
|
||||
BASE_VERS?= ${DIST_VERS}
|
||||
|
||||
BUILDLINK_DEPENDS.postgresql73-lib?= postgresql73-lib>=${BASE_VERS}
|
||||
BUILDLINK_DEPENDS.tcl-postgresql73?= tcl-postgresql73>=${BASE_VERS}
|
||||
|
||||
USE_GNU_TOOLS+= make
|
||||
GNU_CONFIGURE= YES
|
||||
PKG_SYSCONFSUBDIR= postgresql
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PGSQL_TEMPLATE.SunOS= solaris
|
||||
.if !defined(PGSQL_TEMPLATE.${OPSYS})
|
||||
PGSQL_TEMPLATE.${OPSYS}= ${LOWER_OPSYS}
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --with-template="${PGSQL_TEMPLATE.${OPSYS}}"
|
||||
CONFIGURE_ARGS+= --without-readline
|
||||
CONFIGURE_ARGS+= --without-zlib
|
||||
|
||||
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/postgresql
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
CONFIGURE_ARGS+= --with-htmldir=${PREFIX}/share/doc/html/postgresql
|
||||
|
||||
CONFIGURE_ARGS+= --without-java
|
||||
CONFIGURE_ARGS+= --without-perl
|
||||
CONFIGURE_ARGS+= --without-python
|
||||
CONFIGURE_ARGS+= --without-tcl
|
||||
CONFIGURE_ARGS+= --without-tk
|
||||
|
||||
# Postgresql explicitly forbids any use of -ffast-math
|
||||
CFLAGS:= ${CFLAGS:S/-ffast-math//}
|
||||
|
||||
post-extract:
|
||||
if [ -d ${WRKSRC}/src ]; then \
|
||||
${RM} -f ${WRKSRC}/src/Makefile.custom; \
|
||||
${CP} -f ${COMMON_FILESDIR}/Makefile.custom \
|
||||
${WRKSRC}/src/Makefile.custom; \
|
||||
fi
|
||||
if [ -d ${WRKSRC}/src/interfaces/libpq ]; then \
|
||||
${RM} -f ${WRKSRC}/src/interfaces/libpq/GNUmakefile; \
|
||||
${CP} -f ${COMMON_FILESDIR}/GNUmakefile.libpq \
|
||||
${WRKSRC}/src/interfaces/libpq/GNUmakefile; \
|
||||
fi
|
||||
if [ -d ${WRKSRC}/src/interfaces/libpgtcl ]; then \
|
||||
${RM} -f ${WRKSRC}/src/interfaces/libpgtcl/GNUmakefile; \
|
||||
${CP} -f ${COMMON_FILESDIR}/GNUmakefile.libpgtcl \
|
||||
${WRKSRC}/src/interfaces/libpgtcl/GNUmakefile; \
|
||||
fi
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && ${AUTOCONF}
|
||||
|
||||
.include "../../mk/autoconf.mk"
|
2
databases/postgresql73/PLIST
Normal file
2
databases/postgresql73/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
@comment this plist intentionally left empty
|
12
databases/postgresql73/distinfo
Normal file
12
databases/postgresql73/distinfo
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
SHA1 (postgresql-7.3.6.tar.gz) = 5135ed429a22f8290eece18d67a459716a80871a
|
||||
Size (postgresql-7.3.6.tar.gz) = 11288430 bytes
|
||||
SHA1 (patch-aa) = 61fbeb664b0d89c83a36c79cca3fbdc78d6f5059
|
||||
SHA1 (patch-ac) = 5a647cc31873ae81a5bd5a6cf4ec6f44a43448e7
|
||||
SHA1 (patch-ad) = d9e010b38855bf9f1d7b85404ea6770066831093
|
||||
SHA1 (patch-ae) = 5b46ea9782da574ee0c4b1c02534e0f74d640559
|
||||
SHA1 (patch-af) = 8268b66b062f0228e73ecaf928104f0c9bdc02f5
|
||||
SHA1 (patch-ag) = 6d12184b8401e63b8a05c620beb27f28248c22da
|
||||
SHA1 (patch-ah) = 210c0dda3c32481280fe5f2a9525d33f1d989c6d
|
||||
SHA1 (patch-ai) = d7889e05ab7963f2b93b46c953cbf1a44e9c0fe5
|
20
databases/postgresql73/files/GNUmakefile.libpgtcl
Normal file
20
databases/postgresql73/files/GNUmakefile.libpgtcl
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: GNUmakefile.libpgtcl,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
#
|
||||
# This GNUmakefile overrides the `all' target of $(libpgtcl_srcdir)/Makefile
|
||||
# to be empty if INSTALLED_LIBPGTCL is defined. This handles the submake
|
||||
# targets sprinkled throughout the PostgreSQL Makefiles that execute
|
||||
#
|
||||
# @$(MAKE) -C $(libpgtcl_builddir) all
|
||||
#
|
||||
# to ensure that the libpgtcl libraries are built first. If INSTALLED_LIBPGTCL
|
||||
# is defined, then have the `all' target simple return success.
|
||||
|
||||
ifdef INSTALLED_LIBPGTCL
|
||||
all:
|
||||
@test -f libpgtcl.a || touch libpgtcl.a
|
||||
endif
|
||||
|
||||
%: force
|
||||
@$(MAKE) -f Makefile $@
|
||||
|
||||
force: ;
|
20
databases/postgresql73/files/GNUmakefile.libpq
Normal file
20
databases/postgresql73/files/GNUmakefile.libpq
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: GNUmakefile.libpq,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
#
|
||||
# This GNUmakefile overrides the `all' target of $(libpq_srcdir)/Makefile
|
||||
# to be empty if INSTALLED_LIBPQ is defined. This handles the submake
|
||||
# targets sprinkled throughout the PostgreSQL Makefiles that execute
|
||||
#
|
||||
# @$(MAKE) -C $(libpq_builddir) all
|
||||
#
|
||||
# to ensure that the libpq libraries are built first. If INSTALLED_LIBPQ
|
||||
# is defined, then have the `all' target simple return success.
|
||||
|
||||
ifdef INSTALLED_LIBPQ
|
||||
all:
|
||||
@test -f libpq.a || touch libpq.a
|
||||
endif
|
||||
|
||||
%: force
|
||||
@$(MAKE) -f Makefile $@
|
||||
|
||||
force: ;
|
15
databases/postgresql73/files/Makefile.custom
Normal file
15
databases/postgresql73/files/Makefile.custom
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: Makefile.custom,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
#
|
||||
# This file is included by Makefile.global, which is included by every
|
||||
# sub-Makefile in the build tree. Makefiles for shared libraries include
|
||||
# Makefile.global then Makefile.shlib.
|
||||
|
||||
pkglibdir = $(exec_prefix)/lib/postgresql
|
||||
|
||||
ifdef INSTALLED_LIBPQ
|
||||
libpq = -lpq
|
||||
endif
|
||||
|
||||
ifdef INSTALLED_LIBPGTCL
|
||||
libpgtcl = -lpgtcl
|
||||
endif
|
40
databases/postgresql73/patches/patch-aa
Normal file
40
databases/postgresql73/patches/patch-aa
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
--- configure.in.orig Mon Feb 3 04:56:45 2003
|
||||
+++ configure.in
|
||||
@@ -330,6 +330,16 @@
|
||||
|
||||
|
||||
#
|
||||
+# Location for HTML documentation
|
||||
+#
|
||||
+htmldir='${docdir}/html'
|
||||
+AC_MSG_CHECKING([where to install HTML documentation])
|
||||
+PGAC_ARG_REQ(with, htmldir, [ --with-htmldir=DIR install HTML documentation into DIR], [htmldir=$withval])
|
||||
+AC_MSG_RESULT([$htmldir])
|
||||
+AC_SUBST([htmldir])
|
||||
+
|
||||
+
|
||||
+#
|
||||
# Tcl/Tk
|
||||
#
|
||||
AC_MSG_CHECKING([whether to build with Tcl])
|
||||
@@ -373,6 +383,18 @@
|
||||
PGAC_ARG_BOOL(with, python, no, [ --with-python build Python interface module])
|
||||
AC_MSG_RESULT([$with_python])
|
||||
AC_SUBST(with_python)
|
||||
+
|
||||
+# If python is enabled (above), then optionally byte-compile the modules.
|
||||
+AC_MSG_CHECKING([whether to byte-compile Python modules])
|
||||
+if test "$with_python" = yes; then
|
||||
+ PGAC_ARG_BOOL(with, python_compile, no,
|
||||
+ [ --with-python-compile byte-compile modules if Python is enabled])
|
||||
+else
|
||||
+ with_python_compile=no
|
||||
+fi
|
||||
+AC_MSG_RESULT([$with_python_compile])
|
||||
+AC_SUBST([with_python_compile])
|
||||
+
|
||||
|
||||
#
|
||||
# Optionally build the Java/JDBC tools
|
31
databases/postgresql73/patches/patch-ac
Normal file
31
databases/postgresql73/patches/patch-ac
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
--- doc/Makefile.orig Wed Nov 27 18:21:20 2002
|
||||
+++ doc/Makefile
|
||||
@@ -70,7 +70,7 @@ endif # found_man
|
||||
|
||||
install: all installdirs
|
||||
ifdef found_html
|
||||
- gzip -d -c postgres.tar.gz | ( cd $(DESTDIR)$(docdir)/html && $(TAR) xf - )
|
||||
+ gzip -d -c postgres.tar.gz | ( cd $(DESTDIR)$(htmldir) && $(TAR) xf - )
|
||||
endif
|
||||
ifdef found_man
|
||||
for file in man1/*.1 man$(sqlmansectnum)/*.$(sqlmansect) ; do \
|
||||
@@ -81,7 +81,7 @@ endif
|
||||
|
||||
installdirs:
|
||||
ifdef found_html
|
||||
- $(mkinstalldirs) $(DESTDIR)$(docdir)/html
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(htmldir)
|
||||
endif
|
||||
ifdef found_man
|
||||
$(mkinstalldirs) $(addprefix $(DESTDIR)$(mandir)/man, 1 $(sqlmansectnum))
|
||||
@@ -90,7 +90,7 @@ endif
|
||||
|
||||
uninstall:
|
||||
ifdef found_html
|
||||
- -rm -f $(addprefix $(DESTDIR)$(docdir)/html/, $(shell gunzip -c $(srcdir)/postgres.tar.gz | tar tf -))
|
||||
+ -rm -f $(addprefix $(DESTDIR)$(htmldir)/, $(shell gunzip -c $(srcdir)/postgres.tar.gz | tar tf -))
|
||||
endif
|
||||
ifdef found_man
|
||||
-rm -f $(addprefix $(DESTDIR)$(mandir)/, $(shell gunzip -c $(srcdir)/man.tar.gz | tar tf - | sed -e 's,man$(sqlmansect_dummy)/,man$(sqlmansectnum)/,' -e 's/.$(sqlmansect_dummy)$$/.$(sqlmansect)/'))
|
48
databases/postgresql73/patches/patch-ad
Normal file
48
databases/postgresql73/patches/patch-ad
Normal file
|
@ -0,0 +1,48 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
--- src/Makefile.global.in.orig Thu Sep 5 07:54:18 2002
|
||||
+++ src/Makefile.global.in
|
||||
@@ -111,6 +111,13 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+htmldir := @htmldir@
|
||||
+ifeq "$(findstring pgsql, $(htmldir))" ""
|
||||
+ifeq "$(findstring postgres, $(htmldir))" ""
|
||||
+override htmldir := $(docdir)/postgresql
|
||||
+endif
|
||||
+endif
|
||||
+
|
||||
javadir := $(DESTDIR)$(datadir)/java
|
||||
localedir := @localedir@
|
||||
|
||||
@@ -124,6 +131,7 @@
|
||||
with_java = @with_java@
|
||||
with_perl = @with_perl@
|
||||
with_python = @with_python@
|
||||
+with_python_compile = @with_python_compile@
|
||||
with_tcl = @with_tcl@
|
||||
with_tk = @with_tk@
|
||||
enable_shared = @enable_shared@
|
||||
@@ -285,13 +293,20 @@
|
||||
libpq_builddir = $(top_builddir)/src/interfaces/libpq
|
||||
libpq = -L$(libpq_builddir) -lpq
|
||||
|
||||
+libpgtcl_srcdir = $(top_srcdir)/src/interfaces/libpgtcl
|
||||
+libpgtcl_builddir = $(top_builddir)/src/interfaces/libpgtcl
|
||||
+libpgtcl = -L$(libpgtcl_builddir) -lpgtcl
|
||||
+
|
||||
submake-libpq:
|
||||
$(MAKE) -C $(libpq_builddir) all
|
||||
|
||||
submake-libpgport:
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
||||
|
||||
-.PHONY: submake-libpq submake-libpgport
|
||||
+submake-libpgtcl:
|
||||
+ $(MAKE) -C $(libpgtcl_builddir) all
|
||||
+
|
||||
+.PHONY: submake-libpq submake-libpgport submake-libpgtcl
|
||||
|
||||
|
||||
##########################################################################
|
41
databases/postgresql73/patches/patch-ae
Normal file
41
databases/postgresql73/patches/patch-ae
Normal file
|
@ -0,0 +1,41 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
--- src/bin/pgtclsh/Makefile.orig Thu Jun 20 16:29:42 2002
|
||||
+++ src/bin/pgtclsh/Makefile
|
||||
@@ -15,19 +15,17 @@ top_builddir = ../../..
|
||||
include $(top_builddir)/src/Makefile.global
|
||||
|
||||
|
||||
-libpgtcl_srcdir = $(top_srcdir)/src/interfaces/libpgtcl
|
||||
-libpgtcl_builddir = $(top_builddir)/src/interfaces/libpgtcl
|
||||
-libpgtcl = -L$(libpgtcl_builddir) -lpgtcl
|
||||
-
|
||||
override CPPFLAGS := -I$(libpgtcl_srcdir) $(CPPFLAGS) $(TK_XINCLUDES)
|
||||
|
||||
|
||||
# If we are here then Tcl is available
|
||||
PROGRAMS = pgtclsh
|
||||
+INSTALL_TARGETS = install-tcl
|
||||
|
||||
# Add Tk targets if Tk is available
|
||||
ifeq ($(with_tk), yes)
|
||||
PROGRAMS += pgtksh
|
||||
+INSTALL_TARGETS += install-tk
|
||||
endif
|
||||
|
||||
all: submake $(PROGRAMS)
|
||||
@@ -42,9 +40,13 @@ pgtksh: pgtkAppInit.o
|
||||
submake:
|
||||
$(MAKE) -C $(libpgtcl_builddir) all
|
||||
|
||||
-install: all installdirs
|
||||
+install: $(INSTALL_TARGETS)
|
||||
+
|
||||
+install-tcl: pgtclsh installdirs
|
||||
$(INSTALL_PROGRAM) pgtclsh $(DESTDIR)$(bindir)/pgtclsh
|
||||
+
|
||||
ifeq ($(with_tk), yes)
|
||||
+install-tk: pgtksh installdirs
|
||||
$(INSTALL_PROGRAM) pgtksh $(DESTDIR)$(bindir)/pgtksh
|
||||
endif
|
||||
|
13
databases/postgresql73/patches/patch-af
Normal file
13
databases/postgresql73/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
||||
|
||||
--- src/interfaces/ecpg/lib/Makefile.orig Tue Dec 10 23:08:04 2002
|
||||
+++ src/interfaces/ecpg/lib/Makefile
|
||||
@@ -14,7 +14,7 @@ include $(top_builddir)/src/Makefile.glo
|
||||
|
||||
NAME= ecpg
|
||||
SO_MAJOR_VERSION= 3
|
||||
-SO_MINOR_VERSION= 4.1
|
||||
+SO_MINOR_VERSION= 6
|
||||
|
||||
override CPPFLAGS := -I$(top_srcdir)/src/interfaces/ecpg/include -I$(libpq_srcdir) $(CPPFLAGS)
|
||||
|
16
databases/postgresql73/patches/patch-ag
Normal file
16
databases/postgresql73/patches/patch-ag
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2004/07/24 22:14:41 recht Exp $
|
||||
|
||||
--- src/include/Makefile.orig Tue Aug 28 10:20:28 2001
|
||||
+++ src/include/Makefile
|
||||
@@ -15,7 +15,10 @@ top_builddir = ../..
|
||||
include $(top_builddir)/src/Makefile.global
|
||||
|
||||
|
||||
-all: pg_config.h pg_config_os.h
|
||||
+all: pg_config.h pg_config_os.h utils/fmgroids.h parser/parse.h
|
||||
+
|
||||
+utils/fmgroids.h parser/parse.h:
|
||||
+ $(MAKE) -C $(top_builddir)/src/backend $(top_builddir)/src/include/$@
|
||||
|
||||
|
||||
# Install only selected headers
|
43
databases/postgresql73/patches/patch-ah
Normal file
43
databases/postgresql73/patches/patch-ah
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2004/07/24 22:14:41 recht Exp $
|
||||
|
||||
--- src/interfaces/python/GNUmakefile.orig Thu Dec 13 13:39:04 2001
|
||||
+++ src/interfaces/python/GNUmakefile
|
||||
@@ -19,7 +19,14 @@ include $(top_srcdir)/src/Makefile.shlib
|
||||
|
||||
override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS) $(python_includespec)
|
||||
|
||||
-all: all-lib
|
||||
+PY_SCRIPTS = pg.py pgdb.py
|
||||
+ifeq ($(with_python_compile), yes)
|
||||
+PY_COMPILED_SCRIPTS = $(PY_SCRIPTS:%.py=%.pyc) $(PY_SCRIPTS:%.py=%.pyo)
|
||||
+else
|
||||
+PY_COMPILED_SCRIPTS =
|
||||
+endif
|
||||
+
|
||||
+all: all-lib $(PY_COMPILED_SCRIPTS)
|
||||
|
||||
all-lib: libpq-all
|
||||
|
||||
@@ -27,6 +34,12 @@ all-lib: libpq-all
|
||||
libpq-all:
|
||||
$(MAKE) -C $(libpq_builddir) all
|
||||
|
||||
+%.pyc: %.py
|
||||
+ $(PYTHON) -c "import py_compile; py_compile.compile(\"$<\")"
|
||||
+
|
||||
+%.pyo: %.py
|
||||
+ $(PYTHON) -O -c "import py_compile; py_compile.compile(\"$<\")"
|
||||
+
|
||||
install-warning-msg := { \
|
||||
echo "*** Skipping the installation of the Python interface module for lack"; \
|
||||
echo "*** of permissions. To install it, change to the directory"; \
|
||||
@@ -35,6 +48,9 @@ echo "*** become the appropriate user, a
|
||||
|
||||
install: all installdirs
|
||||
@if test -w $(DESTDIR)$(python_moduleexecdir) && test -w $(DESTDIR)$(python_moduledir); then \
|
||||
+ for i in $(PY_SCRIPTS) $(PY_COMPILED_SCRIPTS); do \
|
||||
+ $(INSTALL_DATA) $$i $(python_moduledir) ; \
|
||||
+ done ; \
|
||||
echo "$(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduleexecdir)/_pgmodule$(DLSUFFIX)"; \
|
||||
$(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduleexecdir)/_pgmodule$(DLSUFFIX); \
|
||||
\
|
9
databases/postgresql73/patches/patch-ai
Normal file
9
databases/postgresql73/patches/patch-ai
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: patch-ai,v 1.1.1.1 2004/07/24 22:14:41 recht Exp $
|
||||
|
||||
--- src/interfaces/python/Setup.in.raw.orig Sun Mar 25 14:44:04 2001
|
||||
+++ src/interfaces/python/Setup.in.raw
|
||||
@@ -1,3 +1,3 @@
|
||||
*shared*
|
||||
|
||||
-_pg pgmodule.c -I@libpq_srcdir@ @INCLUDES@ -L@libpq_builddir@ -lpq @EXTRA_LIBS@
|
||||
+_pg pgmodule.c -I@libpq_srcdir@ @INCLUDES@ @libpq@ @EXTRA_LIBS@
|
Loading…
Reference in a new issue