Initial import of wm/whiteBOX using package provided by Julio Merino
(jmmv at hispabsd dot org) in PR pkg/18232. Minor modifications by me: - remove dependency on blackbox (this application works without and could be used for openbox as well) - remove build-dependencies on autoconf and automake by creating the necessary installation directories by hand DESCR: whiteBOX is an attempt to make a flexible yet simple to use multi-purpose configuration tool for the Blackbox window manager. whiteBOX is written using GTK+ and the C programming language.
This commit is contained in:
parent
e8b5af3327
commit
dba63cec16
8 changed files with 181 additions and 0 deletions
4
wm/whiteBOX/DESCR
Normal file
4
wm/whiteBOX/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
whiteBOX is an attempt to make a flexible yet simple to use
|
||||
multi-purpose configuration tool for the Blackbox window
|
||||
manager. whiteBOX is written using GTK+ and the C programming
|
||||
language.
|
30
wm/whiteBOX/Makefile
Normal file
30
wm/whiteBOX/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
#
|
||||
|
||||
DISTNAME= whiteBOX-0.4.2
|
||||
CATEGORIES= wm x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=whitebox/}
|
||||
|
||||
MAINTAINER= jmmv@hispabsd.org
|
||||
HOMEPAGE= http://whitebox.sourceforge.net/
|
||||
COMMENT= Multi-purpose configuration tool for Blackbox
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
# this prevents us from build-depending on autoconf and automake
|
||||
# is it worth it?
|
||||
pre-install:
|
||||
${RM} -f ${WRKSRC}/mkinstalldirs
|
||||
${ECHO} "#!${SH}" > ${WRKSRC}/mkinstalldirs
|
||||
${ECHO} "${ECHO}" >> ${WRKSRC}/mkinstalldirs
|
||||
${CHMOD} 755 ${WRKSRC}/mkinstalldirs
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/whiteBOX/pixmaps
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/whiteBOX/plugins
|
||||
|
||||
.include "../../graphics/gdk-pixbuf/buildlink2.mk"
|
||||
.include "../../x11/gtk/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
29
wm/whiteBOX/PLIST
Normal file
29
wm/whiteBOX/PLIST
Normal file
|
@ -0,0 +1,29 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
bin/whiteBOX
|
||||
bin/whiteBOX-config
|
||||
share/whiteBOX/pixmaps/arrowdn.xpm
|
||||
share/whiteBOX/pixmaps/arrowup.xpm
|
||||
share/whiteBOX/pixmaps/del2.xpm
|
||||
share/whiteBOX/pixmaps/doc1.xpm
|
||||
share/whiteBOX/pixmaps/doccopy.xpm
|
||||
share/whiteBOX/pixmaps/down.xpm
|
||||
share/whiteBOX/pixmaps/down2.xpm
|
||||
share/whiteBOX/pixmaps/exclaim1.xpm
|
||||
share/whiteBOX/pixmaps/new1.xpm
|
||||
share/whiteBOX/pixmaps/open1.xpm
|
||||
share/whiteBOX/pixmaps/save4.xpm
|
||||
share/whiteBOX/pixmaps/up.xpm
|
||||
share/whiteBOX/pixmaps/up2.xpm
|
||||
share/whiteBOX/pixmaps/wb2.xpm
|
||||
share/whiteBOX/plugins/libwbbgset.a
|
||||
share/whiteBOX/plugins/libwbbgset.la
|
||||
share/whiteBOX/plugins/libwbbgset.so
|
||||
share/whiteBOX/plugins/libwbmenu.a
|
||||
share/whiteBOX/plugins/libwbmenu.la
|
||||
share/whiteBOX/plugins/libwbmenu.so
|
||||
share/whiteBOX/plugins/libwbstyle.a
|
||||
share/whiteBOX/plugins/libwbstyle.la
|
||||
share/whiteBOX/plugins/libwbstyle.so
|
||||
@dirrm share/whiteBOX/plugins
|
||||
@dirrm share/whiteBOX/pixmaps
|
||||
@dirrm share/whiteBOX
|
8
wm/whiteBOX/distinfo
Normal file
8
wm/whiteBOX/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
|
||||
SHA1 (whiteBOX-0.4.2.tar.gz) = d2a66f738af482e34ad14165862708e5d193eb1b
|
||||
Size (whiteBOX-0.4.2.tar.gz) = 271823 bytes
|
||||
SHA1 (patch-aa) = d40936263e7176cdfe91bc47f9053ce94bddde6d
|
||||
SHA1 (patch-ab) = e59cdac0f8b2fd6ec5b87b6ca974f80fa0f40732
|
||||
SHA1 (patch-ac) = a97f77b3a8aed2aae3d14c35bcf847d5ef355fc4
|
||||
SHA1 (patch-ad) = 9becf38e5af3a42c99a7d836a315f3ac6814459b
|
11
wm/whiteBOX/patches/patch-aa
Normal file
11
wm/whiteBOX/patches/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
|
||||
--- src/Makefile.am.orig Sun Sep 8 12:29:37 2002
|
||||
+++ src/Makefile.am Sun Sep 8 12:29:48 2002
|
||||
@@ -21,5 +21,5 @@
|
||||
|
||||
SUBDIRS = plugins
|
||||
|
||||
-whiteBOX_LDADD = @GTK_LIBS@ $(INTLLIBS)
|
||||
+whiteBOX_LDADD = @GTK_LIBS@ $(INTLLIBS) -export-dynamic
|
||||
|
13
wm/whiteBOX/patches/patch-ab
Normal file
13
wm/whiteBOX/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
|
||||
--- src/Makefile.in.orig Sun Sep 8 12:29:52 2002
|
||||
+++ src/Makefile.in Sun Sep 8 12:30:04 2002
|
||||
@@ -107,7 +107,7 @@
|
||||
|
||||
SUBDIRS = plugins
|
||||
|
||||
-whiteBOX_LDADD = @GTK_LIBS@ $(INTLLIBS)
|
||||
+whiteBOX_LDADD = @GTK_LIBS@ $(INTLLIBS) -export-dynamic
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
CONFIG_CLEAN_FILES =
|
50
wm/whiteBOX/patches/patch-ac
Normal file
50
wm/whiteBOX/patches/patch-ac
Normal file
|
@ -0,0 +1,50 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
|
||||
--- configure.orig Thu Jan 24 03:14:48 2002
|
||||
+++ configure Wed Nov 20 16:07:37 2002
|
||||
@@ -281,7 +281,7 @@
|
||||
-prefix | --prefix | --prefi | --pref | --pre | --pr | --p)
|
||||
ac_prev=prefix ;;
|
||||
-prefix=* | --prefix=* | --prefi=* | --pref=* | --pre=* | --pr=* | --p=*)
|
||||
- prefix="$ac_optarg" ;;
|
||||
+ ac_default_prefix="$ac_optarg" ;;
|
||||
|
||||
-program-prefix | --program-prefix | --program-prefi | --program-pref \
|
||||
| --program-pre | --program-pr | --program-p)
|
||||
@@ -549,21 +549,21 @@
|
||||
fi
|
||||
|
||||
|
||||
-ac_aux_dir=
|
||||
-for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
|
||||
- if test -f $ac_dir/install-sh; then
|
||||
- ac_aux_dir=$ac_dir
|
||||
- ac_install_sh="$ac_aux_dir/install-sh -c"
|
||||
- break
|
||||
- elif test -f $ac_dir/install.sh; then
|
||||
- ac_aux_dir=$ac_dir
|
||||
- ac_install_sh="$ac_aux_dir/install.sh -c"
|
||||
- break
|
||||
- fi
|
||||
-done
|
||||
-if test -z "$ac_aux_dir"; then
|
||||
- { echo "configure: error: can not find install-sh or install.sh in $srcdir $srcdir/.. $srcdir/../.." 1>&2; exit 1; }
|
||||
-fi
|
||||
+ac_aux_dir=.
|
||||
+#for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
|
||||
+# if test -f $ac_dir/install-sh; then
|
||||
+# ac_aux_dir=$ac_dir
|
||||
+# ac_install_sh="$ac_aux_dir/install-sh -c"
|
||||
+# break
|
||||
+# elif test -f $ac_dir/install.sh; then
|
||||
+# ac_aux_dir=$ac_dir
|
||||
+# ac_install_sh="$ac_aux_dir/install.sh -c"
|
||||
+# break
|
||||
+# fi
|
||||
+#done
|
||||
+#if test -z "$ac_aux_dir"; then
|
||||
+# { echo "configure: error: can not find install-sh or install.sh in $srcdir $srcdir/.. $srcdir/../.." 1>&2; exit 1; }
|
||||
+#fi
|
||||
ac_config_guess=$ac_aux_dir/config.guess
|
||||
ac_config_sub=$ac_aux_dir/config.sub
|
||||
ac_configure=$ac_aux_dir/configure # This should be Cygnus configure.
|
36
wm/whiteBOX/patches/patch-ad
Normal file
36
wm/whiteBOX/patches/patch-ad
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2002/11/20 21:39:37 jschauma Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Nov 20 16:00:40 2002
|
||||
+++ Makefile.in Wed Nov 20 16:01:01 2002
|
||||
@@ -424,15 +424,6 @@
|
||||
done \
|
||||
fi
|
||||
|
||||
- if test -d $(srcdir)/docs; then \
|
||||
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/docs; \
|
||||
- for doc in $(srcdir)/docs/*; do \
|
||||
- if test -f $$doc; then \
|
||||
- $(INSTALL_DATA) $$doc $(DESTDIR)$(pkgdatadir)/docs; \
|
||||
- fi \
|
||||
- done \
|
||||
- fi
|
||||
-
|
||||
dist-hook:
|
||||
if test -d pixmaps; then \
|
||||
mkdir $(distdir)/pixmaps; \
|
||||
@@ -442,15 +433,6 @@
|
||||
fi \
|
||||
done \
|
||||
fi
|
||||
-
|
||||
- if test -d docs; then \
|
||||
- mkdir $(distdir)/docs; \
|
||||
- for doc in docs/*; do \
|
||||
- if test -f $$doc; then \
|
||||
- cp -p $$doc $(distdir)/docs; \
|
||||
- fi \
|
||||
- done \
|
||||
- fi
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
Loading…
Reference in a new issue