Fix build with getline() in libc.
From http://bugs.gentoo.org/show_bug.cgi?id=270263 via roy
This commit is contained in:
parent
0fa57b6ff6
commit
dbbdbe3e37
4 changed files with 61 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.20 2009/05/10 01:58:20 hira Exp $
|
||||
$NetBSD: distinfo,v 1.21 2009/07/16 10:47:11 wiz Exp $
|
||||
|
||||
SHA1 (openoffice-3.1.0/OOo_3.1.0_src_binfilter.tar.bz2) = 7128a2f8af0b0f1163a2f03331057242ec254f34
|
||||
RMD160 (openoffice-3.1.0/OOo_3.1.0_src_binfilter.tar.bz2) = e7ff15bd78713dcdbfd0df0ca499727cd412b070
|
||||
|
@ -87,3 +87,6 @@ SHA1 (patch-eh) = 4f4b2cebe22e83ca6acd2b226281bf756fbc9083
|
|||
SHA1 (patch-ei) = 66a1280fec23204e3f919ab1d5280f87ff68161d
|
||||
SHA1 (patch-ej) = 54cf0ae5619aae6655a66cd4c03191109546de12
|
||||
SHA1 (patch-ek) = 8539878661657b9c5a84e7084ab7289cd26f859f
|
||||
SHA1 (patch-ga) = bc76285681afe91b48399e0886344925d9086b5d
|
||||
SHA1 (patch-gb) = 70c11692129ef17cf47afa8dbff25e5e41719599
|
||||
SHA1 (patch-gc) = 51c00c2fbb64c299d528c072fe68e1f9786a0fff
|
||||
|
|
16
misc/openoffice3/patches/patch-ga
Normal file
16
misc/openoffice3/patches/patch-ga
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ga,v 1.1 2009/07/16 10:47:11 wiz Exp $
|
||||
|
||||
Fix build with getline() in libc.
|
||||
From http://bugs.gentoo.org/show_bug.cgi?id=270263
|
||||
|
||||
--- soltools/mkdepend/def.h.orig 2008-04-10 18:05:14.000000000 +0000
|
||||
+++ soltools/mkdepend/def.h
|
||||
@@ -154,7 +154,7 @@ char *realloc();
|
||||
|
||||
char *copy();
|
||||
char *base_name();
|
||||
-char *getline();
|
||||
+char *ooo_getline();
|
||||
char *isdefined();
|
||||
struct filepointer *getfile();
|
||||
struct inclist *newinclude();
|
16
misc/openoffice3/patches/patch-gb
Normal file
16
misc/openoffice3/patches/patch-gb
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-gb,v 1.1 2009/07/16 10:47:11 wiz Exp $
|
||||
|
||||
Fix build with getline() in libc.
|
||||
From http://bugs.gentoo.org/show_bug.cgi?id=270263
|
||||
|
||||
--- soltools/mkdepend/main.c.orig 2008-07-22 17:24:34.000000000 +0000
|
||||
+++ soltools/mkdepend/main.c
|
||||
@@ -548,7 +548,7 @@ int match(str, list)
|
||||
* Get the next line. We only return lines beginning with '#' since that
|
||||
* is all this program is ever interested in.
|
||||
*/
|
||||
-char *getline(filep)
|
||||
+char *ooo_getline(filep)
|
||||
register struct filepointer *filep;
|
||||
{
|
||||
register char *p, /* walking pointer */
|
25
misc/openoffice3/patches/patch-gc
Normal file
25
misc/openoffice3/patches/patch-gc
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-gc,v 1.1 2009/07/16 10:47:11 wiz Exp $
|
||||
|
||||
Fix build with getline() in libc.
|
||||
From http://bugs.gentoo.org/show_bug.cgi?id=270263
|
||||
|
||||
--- soltools/mkdepend/parse.c.orig 2008-04-10 18:06:39.000000000 +0000
|
||||
+++ soltools/mkdepend/parse.c
|
||||
@@ -45,7 +45,7 @@ int find_includes(filep, file, file_red,
|
||||
register int type;
|
||||
boolean recfailOK;
|
||||
|
||||
- while ((line = getline(filep))) {
|
||||
+ while ((line = ooo_getline(filep))) {
|
||||
switch(type = deftype(line, filep, file_red, file, TRUE, symbols)) {
|
||||
case IF:
|
||||
doif:
|
||||
@@ -168,7 +168,7 @@ int gobble(filep, file, file_red, symbol
|
||||
register char *line;
|
||||
register int type;
|
||||
|
||||
- while ((line = getline(filep))) {
|
||||
+ while ((line = ooo_getline(filep))) {
|
||||
switch(type = deftype(line, filep, file_red, file, FALSE, symbols)) {
|
||||
case IF:
|
||||
case IFFALSE:
|
Loading…
Reference in a new issue