Convert to use buildlink.mk files and mark as USE_BUILDLINK_ONLY. By using

ncurses/buildlink.mk, we can refer to the ncurses header as ncurses.h and
the ncurses lib as libncurses.
This commit is contained in:
jlam 2001-06-19 15:53:11 +00:00
parent 4015e855b6
commit dbfddb7cdc
4 changed files with 43 additions and 48 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2001/02/17 18:08:58 wiz Exp $
# $NetBSD: Makefile,v 1.9 2001/06/19 15:53:11 jlam Exp $
#
DISTNAME= dialog-0.6z
@ -8,24 +8,23 @@ MASTER_SITES= ${MASTER_SITE_SUNSITE:=utils/shell/}
MAINTAINER= jlam@netbsd.org
COMMENT= Display dialog boxes from shell scripts
NO_CONFIGURE= # defined
USE_GMAKE= # defined
USE_CURSES= # defined
USE_BUILDLINK_ONLY= # defined
USE_GMAKE= # defined
#USE_CURSES= # undefined
EGDIR= ${PREFIX}/share/examples/dialog
EGFILES= checklist guage infobox inputbox menubox msgbox
EGFILES+= radiolist textbox yesno
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/dialog
.for file in checklist guage infobox inputbox menubox msgbox radiolist textbox yesno
${SED} "s,\.\./dialog,${PREFIX}/bin/dialog,g" \
${WRKSRC}/samples/${file} > ${WRKSRC}/samples/${file}.tmp
${INSTALL_SCRIPT} ${WRKSRC}/samples/${file}.tmp \
${PREFIX}/share/examples/dialog/${file}
${RM} ${WRKSRC}/samples/${file}.tmp
.endfor
.include "../../mk/bsd.prefs.mk"
.if defined(NEED_NCURSES) && ${NEED_NCURSES} == "YES"
MAKE_ENV+= HAVE_TRUE_NCURSES=true
.endif
${INSTALL_DATA_DIR} ${EGDIR}
cd ${WRKSRC}/samples; for file in ${EGFILES}; do \
${MV} $${file} $${file}.tmp; \
${SED} "s|\.\./dialog|${PREFIX}/bin/dialog|g" \
$${file}.tmp > $${file}; \
${RM} $${file}.tmp; \
${INSTALL_SCRIPT} $${file} ${EGDIR}; \
done
.include "../../devel/ncurses/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.2 2001/04/20 13:52:10 agc Exp $
$NetBSD: distinfo,v 1.3 2001/06/19 15:53:11 jlam Exp $
SHA1 (dialog-0.6z.tar.gz) = 3c9483554bbb63bb8838e1f7b31f2600a33198ad
Size (dialog-0.6z.tar.gz) = 50901 bytes
SHA1 (patch-aa) = 4358fb2f6d473ca203f3107e5e7943f667e57fc8
SHA1 (patch-aa) = 267ffec46c4c7ae070df8eb78ac7db77310a2bad
SHA1 (patch-ab) = 39318c50019277ffa1cecdb33f16e16c11ad37af
SHA1 (patch-ac) = 8bea96e1dd96a6f04404e8af0d08e2d48da28077
SHA1 (patch-ac) = 6179f418b01a778fedf16d0885e420a96dd604a4
SHA1 (patch-ad) = 90a88a838923423cfe3bdbfc5d9de6d40bd10cee
SHA1 (patch-ae) = c0aae5c99837a17919fea47734d90fb6006dd381
SHA1 (patch-af) = 4b47fa64e73deca0bb69ad1bc83102e46eaa01fe

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.7 2000/10/31 16:26:34 jlam Exp $
$NetBSD: patch-aa,v 1.8 2001/06/19 15:53:11 jlam Exp $
--- Makefile.orig Thu Jan 9 01:19:34 1997
+++ Makefile
@@ -17,8 +17,8 @@
@@ -17,20 +17,20 @@
# can be disabled to make dialog a bit smaller (could be done for more things)
HAVE_GUAGE=true
@ -11,35 +11,35 @@ $NetBSD: patch-aa,v 1.7 2000/10/31 16:26:34 jlam Exp $
+BINDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man/man1
CC = gcc
CPP = gcc -E
@@ -29,8 +29,8 @@
-CC = gcc
-CPP = gcc -E
-OPTIM = -O2 -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe
+#CC = gcc
+CPP = $(CC) -E
+#OPTIM = -O2 -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe
#OPTIM = -O -Wall -Wstrict-prototypes -g -pipe
# end of the configuration part
#----------------------------------------------------------------------------
# do not edit below this line
-CFLAGS = $(OPTIM) -DLOCALE -DVERSION=\"0.6z\"
-LDFLAGS = -L .
+CFLAGS += $(OPTIM) -DLOCALE -DVERSION=\"0.6z\"
+LDFLAGS += -L . -L${LOCALBASE}/lib
+LDFLAGS += -L .
LDLIBS = -ldialog
OBJS = checklist.o inputbox.o menubox.o msgbox.o \
@@ -42,8 +42,13 @@
@@ -42,7 +42,7 @@
OBJS+=mouse.o
endif
ifeq ($(HAVE_NCURSES), true)
-CFLAGS+=-DHAVE_NCURSES -I/usr/include/ncurses
+CFLAGS+=-DHAVE_NCURSES
+endif
+ifeq ($(HAVE_TRUE_NCURSES), true)
+CFLAGS+=-DHAVE_TRUE_NCURSES -I${LOCALBASE}/include
LDLIBS+=-lncurses
+else
+LDLIBS+=-lcurses
endif
ifeq ($(HAVE_RC_FILE), true)
CFLAGS+=-DHAVE_RC_FILE
@@ -59,7 +64,7 @@
@@ -59,7 +59,7 @@
all: libdialog.a dialog
libdialog.a: $(OBJS)
@ -48,7 +48,7 @@ $NetBSD: patch-aa,v 1.7 2000/10/31 16:26:34 jlam Exp $
dialog: dialog.o
@@ -70,7 +75,7 @@
@@ -70,7 +70,7 @@
include .depend
install: dialog libdialog.a
@ -57,7 +57,7 @@ $NetBSD: patch-aa,v 1.7 2000/10/31 16:26:34 jlam Exp $
cp dialog.man dialog.1
ifeq ($(HAVE_RC_FILE),false)
mv dialog.1 dialog.in
@@ -82,7 +87,7 @@
@@ -82,7 +82,7 @@
endif
mv dialog.1 dialog.in
sed -e "/COMMENTSTART/,/COMMENTEND/d" dialog.in >dialog.1

View file

@ -1,21 +1,17 @@
$NetBSD: patch-ac,v 1.6 2000/11/10 00:40:35 wiz Exp $
$NetBSD: patch-ac,v 1.7 2001/06/19 15:53:11 jlam Exp $
--- dialog.h.orig Fri Aug 18 13:35:06 1995
--- dialog.h.orig Fri Aug 18 07:35:06 1995
+++ dialog.h
@@ -28,8 +28,12 @@
@@ -28,7 +28,7 @@
#ifdef ultrix
#include <cursesX.h>
#else
+#if defined(HAVE_TRUE_NCURSES)
-#include <curses.h>
+#include <ncurses.h>
+#else
#include <curses.h>
#endif
+#endif
/*
* Change these if you want
@@ -42,6 +46,7 @@
@@ -42,6 +42,7 @@
#define TAB 9
#define MAX_LEN 2048
#define BUF_SIZE (10*1024)
@ -23,7 +19,7 @@ $NetBSD: patch-ac,v 1.6 2000/11/10 00:40:35 wiz Exp $
#define MIN(x,y) (x < y ? x : y)
#define MAX(x,y) (x > y ? x : y)
@@ -151,6 +156,9 @@
@@ -151,6 +152,9 @@
void draw_shadow (WINDOW * win, int y, int x, int height, int width);
#endif
@ -33,7 +29,7 @@ $NetBSD: patch-ac,v 1.6 2000/11/10 00:40:35 wiz Exp $
int dialog_yesno (const char *title, const char *prompt, int height, int width);
int dialog_msgbox (const char *title, const char *prompt, int height,
int width, int pause);
@@ -196,6 +204,7 @@
@@ -196,6 +200,7 @@
extern __inline__ int
mouse_wgetch (WINDOW * win)
{