Make this build with gcc3. Patch obtained from PR pkg/23643.

This commit is contained in:
xtraeme 2003-12-06 01:52:10 +00:00
parent c3b7fcea3e
commit dc095f12f6
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2001/10/25 20:16:54 agc Exp $
$NetBSD: distinfo,v 1.4 2003/12/06 01:52:10 xtraeme Exp $
SHA1 (gated-3-5-11.tar.gz) = a6abdc59beb881dee06c9433b690fa6eab99fe07
Size (gated-3-5-11.tar.gz) = 1565263 bytes
@ -9,3 +9,4 @@ SHA1 (patch-ae) = c02081fa9281cbe5adfab53f24c3c662fcdf9beb
SHA1 (patch-af) = 3b27a9b1e13533f4dd6dc6c2dc7d23c0a3ae725e
SHA1 (patch-ag) = 375e91f1e04995ef4f7d3f7dcc592d90901fa21c
SHA1 (patch-ah) = b1ebbf21e0bf8978503ff4b40f5019c02a2d619a
SHA1 (patch-ai) = 93d75b6132bcd0d79c075a53c9fb121571464fc9

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ai,v 1.1 2003/12/06 01:52:10 xtraeme Exp $
--- src/gdc.c 2003-12-04 02:05:57.000000000 +0000
+++ src/gdc.c 2003-12-04 02:04:15.000000000 +0000
@@ -506,8 +506,8 @@
break;
case 'l':
if (strlen(optarg) > MAXPATHLEN) {
- (void) fprintf(stderr, "%s: pidfile path
- must be less than %d in length\n",
+ (void) fprintf(stderr, "%s: pidfile path "
+ "must be less than %d in length\n",
progname, MAXPATHLEN+1);
errflg++;
}