py-asyncpg: updated to 0.29.0

v0.29.0

Improvements

Python 3.12 and PostgreSQL 16 support
Add support for tuple-format custom codecs on composite types
Support target_session_attrs in URL format, add tests
Infinity numeric support
Add support for the WHERE clause in copy_to methods
Add query logging callbacks and context manager

Fixes

When prepared statements are disabled, avoid relying on them harder
Handle environments with HOME set to a not-a-directory
Fix handling of non-ASCII passwords
Disable JIT while doing type introspection
Remove connection parameter caching in Pool
Switch to Python 3.12-style wait_for
Update automatic PostGIS type conversion for Shapely 2.0
Use the timeout context manager in the connection path
Small fix for documentation on using SSL in Connection
Use cleanup_ctx in pool usage doc
Close cursor portals once the iterator is exhausted
Cut BaseProtocol circular reference on close.
Allow passing hosts as tuples to connect() (in addition to lists)
This commit is contained in:
adam 2023-11-06 11:02:55 +00:00
parent bfca0ab525
commit dc43d88ee0
4 changed files with 25 additions and 30 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.26 2023/07/08 07:04:32 adam Exp $
# $NetBSD: Makefile,v 1.27 2023/11/06 11:02:55 adam Exp $
DISTNAME= asyncpg-0.28.0
DISTNAME= asyncpg-0.29.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/asyncpg/}
@ -10,13 +10,20 @@ HOMEPAGE= https://github.com/MagicStack/asyncpg
COMMENT= Asyncio PosgtreSQL driver
LICENSE= apache-2.0
TEST_DEPENDS+= ${PYPKGPREFIX}-flake8>=3.9.2:../../devel/py-flake8
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools>=60:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
TEST_DEPENDS+= ${PYPKGPREFIX}-flake8>=6.1:../../devel/py-flake8
TEST_DEPENDS+= ${PYPKGPREFIX}-uvloop>=0.15.3:../../devel/py-uvloop
PYTHON_VERSIONS_INCOMPATIBLE= 27
# Testing requires postgresql-contrib
.include "../../lang/python/pyversion.mk"
.if ${PYTHON_VERSION} < 312
DEPENDS+= ${PYPKGPREFIX}-async-timeout>=4.0.3:../../devel/py-async-timeout
.endif
.include "../../devel/py-cython/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,13 +1,16 @@
@comment $NetBSD: PLIST,v 1.11 2023/07/08 07:04:32 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.12 2023/11/06 11:02:55 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/AUTHORS
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/asyncpg/__init__.py
${PYSITELIB}/asyncpg/__init__.pyc
${PYSITELIB}/asyncpg/__init__.pyo
${PYSITELIB}/asyncpg/_asyncio_compat.py
${PYSITELIB}/asyncpg/_asyncio_compat.pyc
${PYSITELIB}/asyncpg/_asyncio_compat.pyo
${PYSITELIB}/asyncpg/_testbase/__init__.py
${PYSITELIB}/asyncpg/_testbase/__init__.pyc
${PYSITELIB}/asyncpg/_testbase/__init__.pyo

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.23 2023/07/08 07:04:32 adam Exp $
$NetBSD: distinfo,v 1.24 2023/11/06 11:02:55 adam Exp $
BLAKE2s (asyncpg-0.28.0.tar.gz) = e160be39016225c898deaae9da51de3fa3860521b996a0f4626e112dc84317cb
SHA512 (asyncpg-0.28.0.tar.gz) = 904f4e22723cb0ccfda82cefcbea1c1fdaf874fac4fdf9276c31da2e3c9a15d12a64d222c3e15e4021d01bb898078732f5de64909abead4242465e3461a6b0f1
Size (asyncpg-0.28.0.tar.gz) = 807997 bytes
SHA1 (patch-asyncpg_pgproto_hton.h) = c6a35e75dfd1f275ff2790dcb1c425d394787b2e
BLAKE2s (asyncpg-0.29.0.tar.gz) = d6586af84a9c51dd3676043cf09b3e116306b1fb588df9992bbee3ca884a1c01
SHA512 (asyncpg-0.29.0.tar.gz) = 5db979496323fcf4068d5de111b52f2ae1ad9efe68f80c28e6303ad936eb051d1792409f1e31fb86dc35caad5ef9b92c40e4f6dcbcccc3907ab2247f61db5504
Size (asyncpg-0.29.0.tar.gz) = 820455 bytes

View File

@ -1,14 +0,0 @@
$NetBSD: patch-asyncpg_pgproto_hton.h,v 1.1 2023/05/09 08:27:10 tm Exp $
Provide illumos/solaris support to include the required endian.h
--- asyncpg/pgproto/hton.h.orig 2022-10-26 21:41:11.000000000 +0000
+++ asyncpg/pgproto/hton.h
@@ -1,6 +1,6 @@
#include <stdint.h>
-#if defined(__linux__) || defined(__CYGWIN__)
+#if defined(__linux__) || defined(__CYGWIN__) || defined(__sun)
#include <endian.h>
#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) \
|| defined(__DragonFly__)