Re-import graphics/dvdbackup as multimedia/dvdbackup.

This commit is contained in:
wiz 2006-04-13 20:14:51 +00:00
parent c515f728c8
commit dca11bba01
5 changed files with 57 additions and 0 deletions

View file

@ -0,0 +1,3 @@
DVDBACKUP enables users to create backups from DVDs they own.
It requires the libdvdread library and is hence capable of reading encrypted
DVDs on systems that have the libdvdcss library installed.

View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/04/13 20:14:51 wiz Exp $
DISTNAME= dvdbackup-0.1.1
PKGREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= http://dvd-create.sourceforge.net/
MAINTAINER= wulf@NetBSD.org
HOMEPAGE= http://dvd-create.sourceforge.net/
COMMENT= DVD backup utility
WRKSRC= ${WRKDIR}/dvdbackup/src
INSTALLATION_DIRS= bin
do-build:
cd ${WRKSRC}; \
${CC} -o dvdbackup dvdbackup.c ${CFLAGS} ${LDFLAGS} -ldvdread
do-install:
cd ${WRKSRC}; \
${INSTALL_PROGRAM} dvdbackup ${PREFIX}/bin;
.include "../../multimedia/libdvdread/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/04/13 20:14:51 wiz Exp $
bin/dvdbackup

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/04/13 20:14:51 wiz Exp $
SHA1 (dvdbackup-0.1.1.tar.gz) = 11bbbd0182f80bff1974b86bb989e9a2ab89f717
RMD160 (dvdbackup-0.1.1.tar.gz) = bd0d1824df92b493e4ea5ab4f24740c41ca826ef
Size (dvdbackup-0.1.1.tar.gz) = 24806 bytes
SHA1 (patch-aa) = 4c3a6ef36cb3422899ca9ea66a3a5b64a374c85b

View file

@ -0,0 +1,21 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/04/13 20:14:51 wiz Exp $
--- dvdbackup.c.orig 2002-08-05 06:08:39.000000000 +0000
+++ dvdbackup.c
@@ -20,6 +20,7 @@
#include <stdio.h>
+#include <stdint.h>
#include <stdlib.h>
#include <string.h>
#include <sys/errno.h>
@@ -782,7 +783,7 @@ titles_info_t * DVDGetInfo(dvd_reader_t
to consider the second one a feature title we are doing two checks (biggest + biggest - second) /second == 1
and biggest%second * 3 < biggest */
- if ( CheckSizeArray(size_size_array, 0, 1) == 1 ) {
+ if ( title_sets > 1 && CheckSizeArray(size_size_array, 0, 1) == 1 ) {
/* We have a dual DVD with two feature films - now lets see if they have the same amount of chapters*/
chapters_1 = 0;