Update php53 to 5.3.24.
11 Apr 2013, PHP 5.3.24 - Core . Fixed bug #64370 (microtime(true) less than $_SERVER['REQUEST_TIME_FLOAT']). (Anatol) . Fixed bug #63914 (zend_do_fcall_common_helper_SPEC does not handle exceptions properly). (Jeff Welch) . Fixed bug #62343 (Show class_alias In get_declared_classes()) (Dmitry) - PCRE: . Merged PCRE 8.32). (Anatol) - mysqlnd . Fixed bug #63530 (mysqlnd_stmt::bind_one_parameter crashes, uses wrong alloc for stmt->param_bind). (Andrey) - DateTime . Fixed bug #62852 (Unserialize Invalid Date causes crash). (Anatol) - Zip: . Bug #64452 (Zip crash intermittently). (Anatol)
This commit is contained in:
parent
1428910b43
commit
dcbf40893d
4 changed files with 28 additions and 31 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.23 2013/03/16 01:58:18 taca Exp $
|
||||
# $NetBSD: Makefile.common,v 1.24 2013/04/12 16:59:51 taca Exp $
|
||||
# used by lang/php53/Makefile.php
|
||||
# used by lang/php/ext.mk
|
||||
# used by meta-pkgs/php53-extensions/Makefile
|
||||
|
@ -38,7 +38,7 @@ EXTRACT_SUFX?= .tar.bz2
|
|||
MAINTAINER?= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE?= http://www.php.net/
|
||||
|
||||
PHP_BASE_VERS= 5.3.23
|
||||
PHP_BASE_VERS= 5.3.24
|
||||
|
||||
PHP_EXTENSION_DIR= lib/php/20090630
|
||||
PLIST_SUBST+= PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.php,v 1.30 2013/04/12 11:56:46 taca Exp $
|
||||
# $NetBSD: Makefile.php,v 1.31 2013/04/12 16:59:51 taca Exp $
|
||||
# used by lang/php53/Makefile
|
||||
# used by www/ap-php/Makefile
|
||||
|
||||
|
@ -58,7 +58,7 @@ PKG_SUGGESTED_OPTIONS+= inet6 ssl
|
|||
|
||||
.if !empty(PKG_OPTIONS:Msuhosin)
|
||||
SUHOSIN_PHPVER= 5.3.23
|
||||
. if ${SUHOSIN_PHPVER} != ${PHP_BASE_VERS}
|
||||
. if ${SUHOSIN_PHPVER} != ${PHP_BASE_VERS} && PHP_BASE_VERS != "5.3.24"
|
||||
PKG_FAIL_REASON+= "The suhosin patch is currently not available for"
|
||||
PKG_FAIL_REASON+= "this version of PHP. You may have to wait until"
|
||||
PKG_FAIL_REASON+= "an updated patch is released or temporarily"
|
||||
|
|
|
@ -1,13 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.61 2013/04/12 11:56:46 taca Exp $
|
||||
$NetBSD: distinfo,v 1.62 2013/04/12 16:59:51 taca Exp $
|
||||
|
||||
SHA1 (php-5.3.23.tar.bz2) = fe9d84ada4747629f31051f9c689629261558056
|
||||
RMD160 (php-5.3.23.tar.bz2) = a537ed70a94ebbc8c1ee12a897f2f78b98a1dee4
|
||||
Size (php-5.3.23.tar.bz2) = 11410987 bytes
|
||||
SHA1 (suhosin-patch-5.3.23-0.9.10.patch.bz2) = 4db2a9266013c9647d14a6e5875c3081fce263ca
|
||||
RMD160 (suhosin-patch-5.3.23-0.9.10.patch.bz2) = 82f3c4f80cef7e7d44fb23bec9fa349c4cba6762
|
||||
Size (suhosin-patch-5.3.23-0.9.10.patch.bz2) = 32474 bytes
|
||||
SHA1 (php-5.3.24.tar.bz2) = ff591a89d77123c7823adf94fea4aca7de5a3dc6
|
||||
RMD160 (php-5.3.24.tar.bz2) = 09e6ee41912f38d203869b79e15c6ec0168dc93d
|
||||
Size (php-5.3.24.tar.bz2) = 11428201 bytes
|
||||
SHA1 (patch-aa) = b0dc6cd0b2103d5858280202506b33322a98496e
|
||||
SHA1 (patch-ab) = 718248326c74ffa8a0f7df47b641fed39b838ba1
|
||||
SHA1 (patch-ab) = 7e9aab00e1d5f18e320ef5e513c0ff6833a5b69a
|
||||
SHA1 (patch-ac) = b6eb40116f3770464120b6ea9061624609b9564e
|
||||
SHA1 (patch-ad) = 1608c58860a43b4e31df8646b5ded253ec9aa881
|
||||
SHA1 (patch-ae) = e590db60a60f4e5ef2da4e5edb786335a67a3d56
|
||||
|
|
|
@ -1,62 +1,62 @@
|
|||
$NetBSD: patch-ab,v 1.5 2013/03/16 01:58:18 taca Exp $
|
||||
$NetBSD: patch-ab,v 1.6 2013/04/12 16:59:51 taca Exp $
|
||||
|
||||
--- configure.orig 2013-03-14 17:17:01.000000000 +0000
|
||||
--- configure.orig 2013-04-10 07:50:37.000000000 +0000
|
||||
+++ configure
|
||||
@@ -17392,7 +17392,7 @@ echo "${ECHO_T}no" >&6
|
||||
@@ -14121,7 +14121,7 @@ EOF
|
||||
PHP_VAR_SUBST="$PHP_VAR_SUBST SAPI_CGI_PATH"
|
||||
|
||||
|
||||
- INSTALL_IT="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
|
||||
+ INSTALL_IT="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)@CGIDIR@\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)@CGIDIR@/php"
|
||||
|
||||
|
||||
if test "$PHP_SAPI" != "default"; then
|
||||
{ { echo "$as_me:$LINENO: error:
|
||||
@@ -33475,7 +33475,7 @@ echo "$as_me: error: OpenSSL version 0.9
|
||||
{ echo "configure: error:
|
||||
@@ -23462,7 +23462,7 @@ fi
|
||||
if test "$found_openssl" = "no"; then
|
||||
|
||||
|
||||
if test "$PHP_OPENSSL_DIR" = "yes"; then
|
||||
- PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
|
||||
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl /"
|
||||
fi
|
||||
|
||||
for i in $PHP_OPENSSL_DIR; do
|
||||
@@ -35650,7 +35650,7 @@ echo "${ECHO_T}yes" >&6
|
||||
@@ -25453,7 +25453,7 @@ echo "configure:25433: checking bundled
|
||||
PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
|
||||
|
||||
|
||||
|
||||
|
||||
- for header_file in ext/sqlite3/libsqlite/sqlite3.h; do
|
||||
+ for header_file; do
|
||||
|
||||
|
||||
|
||||
|
||||
unique=`echo $header_file|$SED 's/[^a-zA-Z0-9]/_/g'`
|
||||
@@ -47718,7 +47718,7 @@ echo "$as_me: error: OpenSSL version 0.9
|
||||
@@ -36315,7 +36315,7 @@ fi
|
||||
if test "$found_openssl" = "no"; then
|
||||
|
||||
|
||||
if test "$PHP_OPENSSL_DIR" = "yes"; then
|
||||
- PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
|
||||
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl /"
|
||||
fi
|
||||
|
||||
for i in $PHP_OPENSSL_DIR; do
|
||||
@@ -65336,7 +65336,7 @@ echo "$as_me: error: OpenSSL version 0.9
|
||||
@@ -50360,7 +50360,7 @@ fi
|
||||
if test "$found_openssl" = "no"; then
|
||||
|
||||
|
||||
if test "$PHP_OPENSSL_DIR" = "yes"; then
|
||||
- PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
|
||||
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl /"
|
||||
fi
|
||||
|
||||
for i in $PHP_OPENSSL_DIR; do
|
||||
@@ -106941,7 +106941,7 @@ echo "$as_me: error: OpenSSL version 0.9
|
||||
@@ -84478,7 +84478,7 @@ fi
|
||||
if test "$found_openssl" = "no"; then
|
||||
|
||||
|
||||
if test "$PHP_OPENSSL_DIR" = "yes"; then
|
||||
- PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
|
||||
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl /"
|
||||
fi
|
||||
|
||||
for i in $PHP_OPENSSL_DIR; do
|
||||
@@ -138087,12 +138087,7 @@ old_CC=$CC
|
||||
@@ -107641,12 +107641,7 @@ old_CC=$CC
|
||||
if test "$PHP_THREAD_SAFETY" = "yes" && test -n "$ac_cv_pthreads_cflags"; then
|
||||
CXXFLAGS="$CXXFLAGS $ac_cv_pthreads_cflags"
|
||||
INLINE_CFLAGS="$INLINE_CFLAGS $ac_cv_pthreads_cflags"
|
||||
|
|
Loading…
Reference in a new issue