Festival really uses termcap, not curses.

This commit is contained in:
roy 2013-10-11 11:16:12 +00:00
parent d7f695a8e2
commit dcbf69d952
4 changed files with 107 additions and 4 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.66 2013/05/31 12:39:36 wiz Exp $
# $NetBSD: Makefile,v 1.67 2013/10/11 11:16:12 roy Exp $
DISTNAME= festival-2.1-release
PKGNAME= festival-2.1
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://festvox.org/packed/festival/2.1/
DISTFILES= ${DISTNAME}.tar.gz \
@ -111,5 +111,5 @@ do-install:
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/festival_client.1
.include "../../audio/nas/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.23 2013/07/18 20:19:51 joerg Exp $
$NetBSD: distinfo,v 1.24 2013/10/11 11:16:12 roy Exp $
SHA1 (festival-2.1-release.tar.gz) = f0c5a4282667898c584516e3605742835f59cb77
RMD160 (festival-2.1-release.tar.gz) = b3c646ecc532e4e05f846db06bbab12a13ec1d6b
@ -19,6 +19,8 @@ SHA1 (patch-speech__tools_base__class_inst__tmpl_vector__dvector__t.cc) = 8a2a4c
SHA1 (patch-speech__tools_base__class_inst__tmpl_vector__fmatrix__t.cc) = 1d64a2e5aa1dc8c5b7d275e2bf66b2e96b599c35
SHA1 (patch-speech__tools_config_compilers_gcc__defaults.mak) = 7441f2e424046dd50c1531160a5b5f94b8506e9d
SHA1 (patch-speech__tools_config_rules_compile__options.mak) = d3aa93029edba84f8130f1bc33c8d74219bafd9a
SHA1 (patch-speech__tools_configure) = b26108be7d30be0847e1caccbe82eb805e5ab8b1
SHA1 (patch-speech__tools_configure.in) = 58b3b3b6dfb2b085c638b3637ece67bb6e5b014e
SHA1 (patch-speech__tools_include_EST__Ngrammar.h) = bd63f89cbdc11baf76c6d6c42aa814ac5b9daca9
SHA1 (patch-speech__tools_include_EST__SCFG.h) = d58bc030dec4d526a89719e32c3624c642f33f3e
SHA1 (patch-speech__tools_include_EST__String.h) = 21961c1864eddc025a763081315b7f40f2450735

View file

@ -0,0 +1,85 @@
$NetBSD: patch-speech__tools_configure,v 1.1 2013/10/11 11:16:12 roy Exp $
Test for termcap before ncurses
--- speech_tools/configure.orig 2013-10-11 10:22:29.000000000 +0000
+++ speech_tools/configure
@@ -3838,6 +3838,70 @@ presetting ac_cv_c_bigendian=no (or yes)
esac
+{ echo "$as_me:$LINENO: checking for tputs in -ltermcap" >&5
+echo $ECHO_N "checking for tputs in -ltermcap... $ECHO_C" >&6; }
+if test "${ac_cv_lib_termcap_tputs+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-ltermcap $LIBS"
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char tputs ();
+int
+main ()
+{
+return tputs ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext &&
+ $as_test_x conftest$ac_exeext; then
+ ac_cv_lib_termcap_tputs=yes
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_lib_termcap_tputs=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tputs" >&5
+echo "${ECHO_T}$ac_cv_lib_termcap_tputs" >&6; }
+if test $ac_cv_lib_termcap_tputs = yes; then
+ TERMCAPLIB=-ltermcap
+else
{ echo "$as_me:$LINENO: checking for tputs in -lncurses" >&5
echo $ECHO_N "checking for tputs in -lncurses... $ECHO_C" >&6; }
if test "${ac_cv_lib_ncurses_tputs+set}" = set; then
@@ -3905,6 +3969,7 @@ else
TERMCAPLIB=-lcurses
fi
+fi
COMPILERTYPE=gcc

View file

@ -0,0 +1,16 @@
$NetBSD: patch-speech__tools_configure.in,v 1.1 2013/10/11 11:16:12 roy Exp $
Test for termcap before ncurses
--- speech_tools/configure.in.orig 2013-10-11 10:22:22.000000000 +0000
+++ speech_tools/configure.in
@@ -42,7 +42,8 @@ AC_CHECK_TOOL(AR, ar)
AC_C_BIGENDIAN
-AC_CHECK_LIB(ncurses, tputs, [TERMCAPLIB=-lncurses], [TERMCAPLIB=-lcurses])
+AC_CHECK_LIB(termcap, tputs, [TERMCAPLIB=-ltermcap],
+[AC_CHECK_LIB(ncurses, tputs, [TERMCAPLIB=-lncurses], [TERMCAPLIB=-lcurses])])
dnl if test "$TERMCAPLIB" != "-ltermcap"; then
dnl AC_CHECK_LIB(termcap, tputs, [TERMCAPLIB=-ltermcap], [TERMCAPLIB=-lncurses])
dnl