* Fix a problem of installing gem with Ruby 1.8.7 noted by David Holland.
* Clean up patch files. Bump PKGREVISION.
This commit is contained in:
parent
8d60c99942
commit
dcfce9e560
7 changed files with 39 additions and 23 deletions
|
@ -1,6 +1,7 @@
|
||||||
# $NetBSD: Makefile,v 1.51 2013/06/11 14:55:54 taca Exp $
|
# $NetBSD: Makefile,v 1.52 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
DISTNAME= rubygems-2.0.3
|
DISTNAME= rubygems-2.0.3
|
||||||
|
PKGREVISION= 1
|
||||||
CATEGORIES= misc ruby
|
CATEGORIES= misc ruby
|
||||||
MASTER_SITES= http://production.cf.rubygems.org/rubygems/
|
MASTER_SITES= http://production.cf.rubygems.org/rubygems/
|
||||||
EXTRACT_SUFX= .tgz
|
EXTRACT_SUFX= .tgz
|
||||||
|
|
|
@ -1,16 +1,17 @@
|
||||||
$NetBSD: distinfo,v 1.40 2013/06/11 14:55:54 taca Exp $
|
$NetBSD: distinfo,v 1.41 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
SHA1 (rubygems-2.0.3.tgz) = 51b2d002874a30ae729bcc48a3a0c5983ffb508b
|
SHA1 (rubygems-2.0.3.tgz) = 51b2d002874a30ae729bcc48a3a0c5983ffb508b
|
||||||
RMD160 (rubygems-2.0.3.tgz) = e2abad996a2380ba5f764a55304c3e416b715080
|
RMD160 (rubygems-2.0.3.tgz) = e2abad996a2380ba5f764a55304c3e416b715080
|
||||||
Size (rubygems-2.0.3.tgz) = 334203 bytes
|
Size (rubygems-2.0.3.tgz) = 334203 bytes
|
||||||
SHA1 (patch-aa) = 02958c28dc9da54bf6d9f854335aa8d8e071497b
|
SHA1 (patch-aa) = 02958c28dc9da54bf6d9f854335aa8d8e071497b
|
||||||
SHA1 (patch-ab) = 916311c3b957c173356fbd89e22dcc11f4966703
|
SHA1 (patch-ab) = 9339a71c9c45b8990d72075a68a8992a40b8c0d0
|
||||||
SHA1 (patch-ac) = 1a59a5d2fc090dfcf6d3bd3b9c133f0ce4a1feee
|
SHA1 (patch-ac) = 1a59a5d2fc090dfcf6d3bd3b9c133f0ce4a1feee
|
||||||
SHA1 (patch-ad) = de5b5a08035c2da3e8b08bcc5295d3998f13a854
|
SHA1 (patch-ad) = de5b5a08035c2da3e8b08bcc5295d3998f13a854
|
||||||
SHA1 (patch-af) = d96d5dafd830b0c94bf6c191a3274701ebc6d564
|
SHA1 (patch-af) = d96d5dafd830b0c94bf6c191a3274701ebc6d564
|
||||||
SHA1 (patch-ag) = 5b94252ea03eba04849770bc141dfc58de932389
|
SHA1 (patch-ag) = 5b94252ea03eba04849770bc141dfc58de932389
|
||||||
SHA1 (patch-ah) = 7552374df9c34fc4fabe4b5340dd7e84491aa949
|
SHA1 (patch-ah) = dd50c10662c0a295a8790446f9cd7159d0b498dd
|
||||||
SHA1 (patch-aj) = 3b77a675470ea3702b9870843d2bb39bb6a83f3e
|
SHA1 (patch-aj) = 3b77a675470ea3702b9870843d2bb39bb6a83f3e
|
||||||
SHA1 (patch-am) = 90658b73df4382eab1d6f2d1b21fdcac6ed85891
|
SHA1 (patch-am) = 24b664a1c360e90c0874cdad9d107477f86e4fd5
|
||||||
SHA1 (patch-ao) = 4a8be3bdab5e465814b626d17a5f2811fbfc808c
|
SHA1 (patch-ao) = 4a8be3bdab5e465814b626d17a5f2811fbfc808c
|
||||||
SHA1 (patch-test_rubygems_test__gem.rb) = 65b03305af606e72d9bb41a54fce6877240cf383
|
SHA1 (patch-lib_rubygems_ext_ext__conf__builder.rb) = c532aee8aa9dbf92c48a643d8da65bebb50a0348
|
||||||
|
SHA1 (patch-test_rubygems_test__gem.rb) = 883675c1af0314c66c3d02fb9c012fac768ebb9b
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
$NetBSD: patch-ab,v 1.15 2013/06/11 14:55:54 taca Exp $
|
$NetBSD: patch-ab,v 1.16 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
Add install_root option for pkgsrc's rubygems support.
|
Add install_root option for pkgsrc's rubygems support.
|
||||||
|
|
||||||
--- lib/rubygems/dependency_installer.rb.orig 2013-02-20 00:27:36.000000000 +0000
|
--- lib/rubygems/dependency_installer.rb.orig 2013-03-05 21:25:39.000000000 +0000
|
||||||
+++ lib/rubygems/dependency_installer.rb
|
+++ lib/rubygems/dependency_installer.rb
|
||||||
@@ -50,6 +50,7 @@ class Gem::DependencyInstaller
|
@@ -50,6 +50,7 @@ class Gem::DependencyInstaller
|
||||||
# :format_executable:: See Gem::Installer#initialize.
|
# :format_executable:: See Gem::Installer#initialize.
|
||||||
|
@ -29,7 +29,7 @@ Add install_root option for pkgsrc's rubygems support.
|
||||||
end
|
end
|
||||||
|
|
||||||
options = DEFAULT_OPTIONS.merge options
|
options = DEFAULT_OPTIONS.merge options
|
||||||
@@ -91,7 +93,12 @@ class Gem::DependencyInstaller
|
@@ -92,7 +94,12 @@ class Gem::DependencyInstaller
|
||||||
@installed_gems = []
|
@installed_gems = []
|
||||||
@toplevel_specs = nil
|
@toplevel_specs = nil
|
||||||
|
|
||||||
|
@ -43,7 +43,7 @@ Add install_root option for pkgsrc's rubygems support.
|
||||||
|
|
||||||
# Set with any errors that SpecFetcher finds while search through
|
# Set with any errors that SpecFetcher finds while search through
|
||||||
# gemspecs for a dep
|
# gemspecs for a dep
|
||||||
@@ -353,6 +360,7 @@ class Gem::DependencyInstaller
|
@@ -364,6 +371,7 @@ class Gem::DependencyInstaller
|
||||||
:format_executable => @format_executable,
|
:format_executable => @format_executable,
|
||||||
:ignore_dependencies => @ignore_dependencies,
|
:ignore_dependencies => @ignore_dependencies,
|
||||||
:install_dir => @install_dir,
|
:install_dir => @install_dir,
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
$NetBSD: patch-ah,v 1.11 2013/06/11 14:55:54 taca Exp $
|
$NetBSD: patch-ah,v 1.12 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
Add install_root option for pkgsrc's rubygems support.
|
Add install_root option for pkgsrc's rubygems support.
|
||||||
|
|
||||||
--- lib/rubygems.rb.orig 2013-02-21 22:01:26.000000000 +0000
|
--- lib/rubygems.rb.orig 2013-03-12 04:25:22.000000000 +0000
|
||||||
+++ lib/rubygems.rb
|
+++ lib/rubygems.rb
|
||||||
@@ -286,11 +286,17 @@ module Gem
|
@@ -286,11 +286,17 @@ module Gem
|
||||||
##
|
##
|
||||||
|
@ -26,7 +26,7 @@ Add install_root option for pkgsrc's rubygems support.
|
||||||
end
|
end
|
||||||
|
|
||||||
##
|
##
|
||||||
@@ -538,12 +544,12 @@ module Gem
|
@@ -546,12 +552,12 @@ module Gem
|
||||||
##
|
##
|
||||||
# The index to insert activated gem paths into the $LOAD_PATH.
|
# The index to insert activated gem paths into the $LOAD_PATH.
|
||||||
#
|
#
|
||||||
|
@ -41,7 +41,7 @@ Add install_root option for pkgsrc's rubygems support.
|
||||||
|
|
||||||
index
|
index
|
||||||
end
|
end
|
||||||
@@ -716,6 +722,7 @@ module Gem
|
@@ -724,6 +730,7 @@ module Gem
|
||||||
prefix = File.dirname RUBYGEMS_DIR
|
prefix = File.dirname RUBYGEMS_DIR
|
||||||
|
|
||||||
if prefix != File.expand_path(ConfigMap[:sitelibdir]) and
|
if prefix != File.expand_path(ConfigMap[:sitelibdir]) and
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
$NetBSD: patch-am,v 1.4 2013/06/11 14:55:54 taca Exp $
|
$NetBSD: patch-am,v 1.5 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
Make sure to setup under DESTDIR.
|
Make sure to setup under DESTDIR.
|
||||||
|
|
||||||
--- lib/rubygems/commands/setup_command.rb.orig 2013-02-12 20:04:54.000000000 +0000
|
--- lib/rubygems/commands/setup_command.rb.orig 2013-03-11 20:40:09.000000000 +0000
|
||||||
+++ lib/rubygems/commands/setup_command.rb
|
+++ lib/rubygems/commands/setup_command.rb
|
||||||
@@ -143,7 +143,7 @@ By default, this RubyGems will install g
|
@@ -145,7 +145,7 @@ By default, this RubyGems will install g
|
||||||
|
|
||||||
uninstall_old_gemcutter
|
uninstall_old_gemcutter
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ Make sure to setup under DESTDIR.
|
||||||
|
|
||||||
say
|
say
|
||||||
if @verbose then
|
if @verbose then
|
||||||
@@ -160,7 +160,11 @@ By default, this RubyGems will install g
|
@@ -162,7 +162,11 @@ By default, this RubyGems will install g
|
||||||
release_notes = File.join Dir.pwd, 'History.txt'
|
release_notes = File.join Dir.pwd, 'History.txt'
|
||||||
|
|
||||||
release_notes = if File.exist? release_notes then
|
release_notes = if File.exist? release_notes then
|
||||||
|
@ -26,7 +26,7 @@ Make sure to setup under DESTDIR.
|
||||||
history = history.sub(/^# coding:.*?^=/m, '')
|
history = history.sub(/^# coding:.*?^=/m, '')
|
||||||
|
|
||||||
text = history.split(HISTORY_HEADER)
|
text = history.split(HISTORY_HEADER)
|
||||||
@@ -295,11 +299,15 @@ TEXT
|
@@ -306,11 +310,15 @@ TEXT
|
||||||
end
|
end
|
||||||
end
|
end
|
||||||
|
|
||||||
|
@ -43,7 +43,7 @@ Make sure to setup under DESTDIR.
|
||||||
begin
|
begin
|
||||||
Gem.ensure_gem_subdirectories Gem.dir
|
Gem.ensure_gem_subdirectories Gem.dir
|
||||||
rescue SystemCallError
|
rescue SystemCallError
|
||||||
@@ -310,7 +318,7 @@ TEXT
|
@@ -321,7 +329,7 @@ TEXT
|
||||||
(not File.exist? rubygems_doc_dir or
|
(not File.exist? rubygems_doc_dir or
|
||||||
File.writable? rubygems_doc_dir) then
|
File.writable? rubygems_doc_dir) then
|
||||||
say "Removing old RubyGems RDoc and ri" if @verbose
|
say "Removing old RubyGems RDoc and ri" if @verbose
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
$NetBSD: patch-lib_rubygems_ext_ext__conf__builder.rb,v 1.1 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
|
* Expicitly remove a temporary file.
|
||||||
|
|
||||||
|
--- lib/rubygems/ext/ext_conf_builder.rb.orig 2013-03-11 21:05:39.000000000 +0000
|
||||||
|
+++ lib/rubygems/ext/ext_conf_builder.rb
|
||||||
|
@@ -49,6 +49,7 @@ class Gem::Ext::ExtConfBuilder < Gem::Ex
|
||||||
|
|
||||||
|
results
|
||||||
|
ensure
|
||||||
|
+ siteconf.close true
|
||||||
|
ENV["RUBYOPT"] = rubyopt
|
||||||
|
ENV["DESTDIR"] = destdir
|
||||||
|
end
|
|
@ -1,10 +1,10 @@
|
||||||
$NetBSD: patch-test_rubygems_test__gem.rb,v 1.3 2013/06/11 14:55:54 taca Exp $
|
$NetBSD: patch-test_rubygems_test__gem.rb,v 1.4 2013/06/15 02:12:48 taca Exp $
|
||||||
|
|
||||||
Use vendorlibdir.
|
Use vendorlibdir.
|
||||||
|
|
||||||
--- test/rubygems/test_gem.rb.orig 2013-02-12 20:20:45.000000000 +0000
|
--- test/rubygems/test_gem.rb.orig 2013-03-11 21:10:40.000000000 +0000
|
||||||
+++ test/rubygems/test_gem.rb
|
+++ test/rubygems/test_gem.rb
|
||||||
@@ -952,12 +952,12 @@ class TestGem < Gem::TestCase
|
@@ -964,12 +964,12 @@ class TestGem < Gem::TestCase
|
||||||
end
|
end
|
||||||
|
|
||||||
def test_self_prefix_sitelibdir
|
def test_self_prefix_sitelibdir
|
||||||
|
|
Loading…
Reference in a new issue