Updated package to latest version, 1.7.0. Also changed upstream (package

moved to github).

Changes include:
 * Switch to git and move repo to github
 * `-safe-string` compatibility
 * use cppo instead of camlp4
 * allow to set the exit code in optParse
 * add new upstream functions in String
This commit is contained in:
jaapb 2016-06-19 10:07:47 +00:00
parent f9047620ee
commit dd42eda781
4 changed files with 34 additions and 16 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.6 2016/06/17 12:36:50 jaapb Exp $
# $NetBSD: Makefile,v 1.7 2016/06/19 10:07:47 jaapb Exp $
DISTNAME= extlib-1.6.1
PKGNAME= ocaml-${DISTNAME}
PKGREVISION= 4
VERSION= 1.7.0
GITHUB_PROJECT= ocaml-extlib
DISTNAME= ${GITHUB_PROJECT}-${VERSION}
CATEGORIES= devel
MASTER_SITES= https://ocaml-extlib.googlecode.com/files/
MASTER_SITES= ${MASTER_SITE_GITHUB:=ygrek/}
MAINTAINER= jaapb@NetBSD.org
HOMEPAGE= http://code.google.com/p/ocaml-extlib/
@ -18,10 +18,8 @@ OCAML_USE_FINDLIB= yes
.include "../../mk/ocaml.mk"
BUILD_TARGET= all
.if ${OCAML_USE_OPT_COMPILER} == "yes"
BUILD_TARGET+= opt
.endif
BUILD_TARGET= build
.include "../../lang/camlp4/buildlink3.mk"
.include "../../devel/ocaml-cppo/buildlink3.mk"
#.include "../../lang/camlp4/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2014/10/26 10:54:36 jaapb Exp $
@comment $NetBSD: PLIST,v 1.2 2016/06/19 10:07:47 jaapb Exp $
${OCAML_SITELIB}/extlib/IO.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/IO.cmx
${OCAML_SITELIB}/extlib/IO.mli
@ -21,6 +21,12 @@ ${OCAML_SITELIB}/extlib/enum.mli
${OCAML_SITELIB}/extlib/extArray.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extArray.cmx
${OCAML_SITELIB}/extlib/extArray.mli
${OCAML_SITELIB}/extlib/extBuffer.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extBuffer.cmx
${OCAML_SITELIB}/extlib/extBuffer.mli
${OCAML_SITELIB}/extlib/extBytes.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extBytes.cmx
${OCAML_SITELIB}/extlib/extBytes.mli
${OCAML_SITELIB}/extlib/extHashtbl.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extHashtbl.cmx
${OCAML_SITELIB}/extlib/extHashtbl.mli
@ -29,6 +35,7 @@ ${OCAML_SITELIB}/extlib/extLib.cma
${OCAML_SITELIB}/extlib/extLib.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extLib.cmx
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extLib.cmxa
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extLib.cmxs
${OCAML_SITELIB}/extlib/extList.cmi
${PLIST.ocaml-opt}${OCAML_SITELIB}/extlib/extList.cmx
${OCAML_SITELIB}/extlib/extList.mli

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2015/11/03 03:27:52 agc Exp $
$NetBSD: distinfo,v 1.3 2016/06/19 10:07:47 jaapb Exp $
SHA1 (extlib-1.6.1.tar.gz) = 0022ed273affff85432d5587d46a8721817d315e
RMD160 (extlib-1.6.1.tar.gz) = 4d92f55e71ee6effe58b07126458caa118472aa3
SHA512 (extlib-1.6.1.tar.gz) = 9473f474bee99248bdc5e3c56741a191a8f0b89dbf750a4d9e92692b7871c997c584a2dc7e57f55b36b5ddcaf7a11d45b490b117ac15806e35813b82b696f541
Size (extlib-1.6.1.tar.gz) = 72780 bytes
SHA1 (ocaml-extlib-1.7.0.tar.gz) = 92d3ff333bb9b3f2effe19abdcb49229539b5c3a
RMD160 (ocaml-extlib-1.7.0.tar.gz) = 0a5cd78ad58fc76c3e0bf9889b577dffc846f129
SHA512 (ocaml-extlib-1.7.0.tar.gz) = 3f268e22f7f415e81bbc07c28561fc067ca87748fcdcb6515691d1270858f452ec2ba0eb7b80ca29f06b40f01c1e89a6b71380c7d9de37c60d2bb86093cb8be2
Size (ocaml-extlib-1.7.0.tar.gz) = 83327 bytes
SHA1 (patch-Makefile) = d4b332b440bf03a49d8067212a4911a7b050a749

View file

@ -0,0 +1,12 @@
$NetBSD: patch-Makefile,v 1.1 2016/06/19 10:07:47 jaapb Exp $
Do not call git for version stuff
--- Makefile.orig 2015-08-29 23:24:19.000000000 +0000
+++ Makefile
@@ -1,5 +1,5 @@
-VERSION:=$(shell git describe --always --long)
+#VERSION:=$(shell git describe --always --long)
RELEASE:=1.7.0
ifndef VERSION