Update to Asterisk 18.22.0:

pkgsrc changes
- adapt for newer version of pjsip
- adapt for new dependency (required for STIR/SHAKEN):  libjwt

Change Log for Release asterisk-18.22.0
========================================

Summary:
----------------------------------------

- res_pjsip_stir_shaken.c:  Add checks for missing parameters
- app_dial: Add dial time for progress/ringing.
- app_voicemail: Properly reinitialize config after unit tests.
- app_queue.c : fix "queue add member" usage string
- app_voicemail: Allow preventing mark messages as urgent.
- res_pjsip: Use consistent type for boolean columns.
- attestation_config.c: Use ast_free instead of ast_std_free
- Makefile: Add stir_shaken/cache to directories created on install
- Stir/Shaken Refactor
- alembic: Synchronize alembic heads between supported branches.
- translate.c: implement new direct comp table mode
- README.md: Removed outdated link
- strings.h: Ensure ast_str_buffer(…) returns a 0 terminated string.
- res_rtp_asterisk.c: Correct coefficient in MOS calculation.
- dsp.c: Fix and improve potentially inaccurate log message.
- pjsip show channelstats: Prevent possible segfault when faxing
- Reduce startup/shutdown verbose logging
- configure: Rerun bootstrap on modern platform.
- Upgrade bundled pjproject to 2.14.
- app_speech_utils.c: Allow partial speech results.
- utils: Make behavior of ast_strsep* match strsep.
- app_chanspy: Add 'D' option for dual-channel audio
- app_if: Fix next priority calculation.
- res_pjsip_t38.c: Permit IPv6 SDP connection addresses.
- BuildSystem: Bump autotools versions on OpenBSD.
- main/utils: Simplify the FreeBSD ast_get_tid() handling
- res_pjsip_session.c: Correctly format SDP connection addresses.
- rtp_engine.c: Correct sample rate typo for L16/44100.
- manager.c: Fix erroneous reloads in UpdateConfig.
- res_calendar_icalendar: Print iCalendar error on parsing failure.
- app_confbridge: Don't emit warnings on valid configurations.
- app_voicemail: add NoOp alembic script to maintain sync
- chan_dahdi: Allow MWI to be manually toggled on channels.
- chan_rtp.c: MulticastRTP missing refcount without codec option
- chan_rtp.c: Change MulticastRTP nameing to avoid memory leak
- func_frame_trace: Add CLI command to dump frame queue.

User Notes:
----------------------------------------

- ### app_dial: Add dial time for progress/ringing.
  The timeout argument to Dial now allows
  specifying the maximum amount of time to dial if
  early media is not received.

- ### app_voicemail: Allow preventing mark messages as urgent.
  The leaveurgent mailbox option can now be used to
  control whether callers may leave messages marked as 'Urgent'.

- ### Stir/Shaken Refactor
  Asterisk's stir-shaken feature has been refactored to
  correct interoperability, RFC compliance, and performance issues.
  See https://docs.asterisk.org/Deployment/STIR-SHAKEN for more
  information.

- ### Upgrade bundled pjproject to 2.14.
  Bundled pjproject has been upgraded to 2.14. For more
  information on what all is included in this change, check out the
  pjproject Github page: https://github.com/pjsip/pjproject/releases

- ### app_speech_utils.c: Allow partial speech results.
  The SpeechBackground dialplan application now supports a 'p'
  option that will return partial results from speech engines that
  provide them when a timeout occurs.

- ### app_chanspy: Add 'D' option for dual-channel audio
  The ChanSpy application now accepts the 'D' option which
  will interleave the spied audio within the outgoing frames. The
  purpose of this is to allow the audio to be read as a Dual channel
  stream with separate incoming and outgoing audio. Setting both the
  'o' option and the 'D' option and results in the 'D' option being
  ignored.

- ### chan_dahdi: Allow MWI to be manually toggled on channels.
  The 'dahdi set mwi' now allows MWI on channels
  to be manually toggled if needed for troubleshooting.
  Resolves: #440


Upgrade Notes:
----------------------------------------

- ### Stir/Shaken Refactor
  The stir-shaken refactor is a breaking change but since
  it's not working now we don't think it matters. The
  stir_shaken.conf file has changed significantly which means that
  existing ones WILL need to be changed.  The stir_shaken.conf.sample
  file in configs/samples/ has quite a bit more information.  This is
  also an ABI breaking change since some of the existing objects
  needed to be changed or removed, and new ones added.  Additionally,
  if res_stir_shaken is enabled in menuselect, you'll need to either
  have the development package for libjwt v1.15.3 installed or use
  the --with-libjwt-bundled option with ./configure.
This commit is contained in:
jnemeth 2024-03-25 03:36:33 +00:00
parent 08507c5111
commit dd54d07e8a
5 changed files with 55 additions and 66 deletions

View File

@ -1,11 +1,12 @@
# $NetBSD: Makefile,v 1.156 2024/02/19 05:59:51 jnemeth Exp $
# $NetBSD: Makefile,v 1.157 2024/03/25 03:36:33 jnemeth Exp $
#
# NOTE: when updating this package, there are two places that sound
# tarballs need to be checked; look in ${WRKSRC}/sounds/Makefile
# to find out the current sound file versions
# Also look in ${WRKSRC}/third-party/versions.mak for pjproject
# and libjwt
DISTNAME= asterisk-18.21.0
DISTNAME= asterisk-18.22.0
#PKGREVISION= 24
CATEGORIES= comms net audio
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/
@ -47,6 +48,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --datarootdir=${PREFIX}/libdata
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --without-gtk2
CONFIGURE_ARGS+= --with-libjwt-bundled=yes
# XXX remove when lang/lua gets builtin.mk
CONFIGURE_ARGS+= --without-lua
@ -160,7 +162,7 @@ CONFIGURE_ARGS+= --without-unbound
DISTFILES+= asterisk-extra-sounds-en-gsm-1.5.2.tar.gz
# pjproject
PJPROJ_VERSION= 2.13.1
PJPROJ_VERSION= 2.14
SITES.pjproject-${PJPROJ_VERSION}.tar.bz2= \
-https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/${PJPROJ_VERSION}/pjproject-${PJPROJ_VERSION}.tar.bz2
SITES.pjproject-${PJPROJ_VERSION}.md5= \
@ -168,6 +170,14 @@ SITES.pjproject-${PJPROJ_VERSION}.md5= \
DISTFILES+= pjproject-${PJPROJ_VERSION}.tar.bz2 pjproject-${PJPROJ_VERSION}.md5
ALL_ENV+= EXTERNALS_CACHE_DIR=${DISTDIR}/${DIST_SUBDIR}
# libjwt
LIBJWT_VERSION= 1.15.3
SITES.libjwt-${LIBJWT_VERSION}.tar.gz= \
-https://raw.githubusercontent.com/asterisk/third-party/master/libjwt/${LIBJWT_VERSION}/libjwt-${LIBJWT_VERSION}.tar.gz
SITES.libjwt-${LIBJWT_VERSION}.md5= \
-https://raw.githubusercontent.com/asterisk/third-party/master/libjwt/${LIBJWT_VERSION}/MD5SUM.TXT
DISTFILES+= libjwt-${LIBJWT_VERSION}.tar.gz libjwt-${LIBJWT_VERSION}.md5
# Override default paths in config files
SUBST_CLASSES+= configs
SUBST_STAGE.configs= pre-configure

View File

@ -1,17 +1,23 @@
$NetBSD: distinfo,v 1.74 2024/02/19 05:59:51 jnemeth Exp $
$NetBSD: distinfo,v 1.75 2024/03/25 03:36:33 jnemeth Exp $
BLAKE2s (asterisk-18.21.0/asterisk-18.21.0.tar.gz) = dee2f2c4205d419c30a7d35dafc8dbaf42889cb1879288521a4789302640458b
SHA512 (asterisk-18.21.0/asterisk-18.21.0.tar.gz) = 4a3c57af70b74918b61e1c67423667a876fcc519376f1795054a55700acb5d05da8e4e0a3e3187760203bc262678a6c29eae07ed2a5e2df84a9a555ec79cb48f
Size (asterisk-18.21.0/asterisk-18.21.0.tar.gz) = 28446501 bytes
BLAKE2s (asterisk-18.21.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 3f7e5fe212d7e7cdca14c52527a2552311ab7762c3f1464b09ddedc7c66aebde
SHA512 (asterisk-18.21.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 3f2f7bf3d5bce3544bc013f913c352f0204a3ce96239987403eb9dce8bc87e64a61d437762323a422a87b2fad1f3bf3e7a5f3d0d340f912a1b1dbfea9479d41d
Size (asterisk-18.21.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 4253587 bytes
BLAKE2s (asterisk-18.21.0/pjproject-2.13.1.md5) = 933be89ea03bc24a3a965d37a8985a2af3ea404e24a8fdd296a2be07d5390de0
SHA512 (asterisk-18.21.0/pjproject-2.13.1.md5) = 5a8c35e79d10760f74d02332f35aad3517fc3c72e62e2b1c35fcb1d613bbad4d96fa07f1cea89514dba2d237a36a698e94b1242be938d492d20b76a130c0d0f1
Size (asterisk-18.21.0/pjproject-2.13.1.md5) = 172 bytes
BLAKE2s (asterisk-18.21.0/pjproject-2.13.1.tar.bz2) = 7c04ae740c66f92502684de834b4055e7f4842bcb35f0efc12f183c8d8c37f7f
SHA512 (asterisk-18.21.0/pjproject-2.13.1.tar.bz2) = 2f1eb3cb8f52a5536c355b02b1abfa24c7d2263b5338568a7cd8167d349e007c34afafcdd7ed510bfc4fc859494383fac05e8325e46fd66219dbead86c5c3562
Size (asterisk-18.21.0/pjproject-2.13.1.tar.bz2) = 7825201 bytes
BLAKE2s (asterisk-18.22.0/asterisk-18.22.0.tar.gz) = b888fb15642994382ba95a80c54cc38d2c54e855edc66b2e3e0842b712b21e2c
SHA512 (asterisk-18.22.0/asterisk-18.22.0.tar.gz) = 539cd347400c6402462164b53dc75ec8953bb32398d30b0b3e2b4020490e26188c02def2ac1a225f8e52ddb4a1e28aac75de5f25c68ad5e012165771e9519452
Size (asterisk-18.22.0/asterisk-18.22.0.tar.gz) = 28489141 bytes
BLAKE2s (asterisk-18.22.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 3f7e5fe212d7e7cdca14c52527a2552311ab7762c3f1464b09ddedc7c66aebde
SHA512 (asterisk-18.22.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 3f2f7bf3d5bce3544bc013f913c352f0204a3ce96239987403eb9dce8bc87e64a61d437762323a422a87b2fad1f3bf3e7a5f3d0d340f912a1b1dbfea9479d41d
Size (asterisk-18.22.0/asterisk-extra-sounds-en-gsm-1.5.2.tar.gz) = 4253587 bytes
BLAKE2s (asterisk-18.22.0/libjwt-1.15.3.md5) = de87f03f88ad834e26bba2159f5d8ed14637377eba58c48ed0701f44994ae1a2
SHA512 (asterisk-18.22.0/libjwt-1.15.3.md5) = d24818362ec5537c4db58421078c7dc0f8509b89a2802d1e2e6cef6d4c1e817f8304dda486e96187c375b7d1084a1400ac4647ea635f3c9703fa0fadb1c33b44
Size (asterisk-18.22.0/libjwt-1.15.3.md5) = 55 bytes
BLAKE2s (asterisk-18.22.0/libjwt-1.15.3.tar.gz) = 45de6898eeef8791e63469ea1a13157e425e6f9f47cb49d2bcd7e3f5c046ab68
SHA512 (asterisk-18.22.0/libjwt-1.15.3.tar.gz) = 6a99c81258c5302f7dd908f639676d7cfbe09599812cd97ead871cd5962f15e5248b935e1ef643c4dd43bd1ee66d0e12be1b599a6d3b26d461c4b15216a93774
Size (asterisk-18.22.0/libjwt-1.15.3.tar.gz) = 489246 bytes
BLAKE2s (asterisk-18.22.0/pjproject-2.14.md5) = 8cbd12b39e930e684607202c7cff8036d1fa10c0070f8d5b50c1850095b8b28d
SHA512 (asterisk-18.22.0/pjproject-2.14.md5) = ea4c33f75a0cc4afcd7a1f7fd2a53423a182ef16a7abfe2189bce0ef0e6b956c6eb4f89aeabee714dfed0616bfd8f4aa98602b1faeda1671e00ff21a150283d2
Size (asterisk-18.22.0/pjproject-2.14.md5) = 166 bytes
BLAKE2s (asterisk-18.22.0/pjproject-2.14.tar.bz2) = 1e76da2fa893451c66f41e5c3dd2a7594494c0852947ef2146d6b642550604d0
SHA512 (asterisk-18.22.0/pjproject-2.14.tar.bz2) = 5b60a1033c9f09c0fbb5b132229fa99fdc103f8864a7cdeadf217ec47ff6bc784827826f595c4bc76816bc0fbf5cc6e9751cc4f6307eeecb7c7d8f5d0413d4ac
Size (asterisk-18.22.0/pjproject-2.14.tar.bz2) = 8376462 bytes
SHA1 (patch-Makefile) = 676687f298151dbe548ae26a4f6f3fe8bf1f174e
SHA1 (patch-addons_chan__ooh323.c) = 1775da7ca2129a962ed460bd1e78ba3ce6afa62c
SHA1 (patch-apps_app__adsiprog.c) = 031139e5cd1ef6bb2afb0a74fee3d752eded0a2c
@ -32,7 +38,7 @@ SHA1 (patch-channels_chan__pjsip.c) = efd4cbb82133fc5ddf7de70d01c99e185c585211
SHA1 (patch-channels_chan__sip.c) = ed285612eae6cbfde19ded87db9360c0bca153c7
SHA1 (patch-channels_pjsip_cli__commands.c) = 01baa9d242e3af02a1f3540cfb3064ad68c71d67
SHA1 (patch-channels_pjsip_dialplan__functions.c) = 2cf8199c4ec9d4894eb922c2703d49ecc06188ef
SHA1 (patch-configure) = d04ab000b8472b997816069c57fa5cd271e9ef90
SHA1 (patch-configure) = 5936f59ed9834ee18ea198c0f6ecf2db7ed38656
SHA1 (patch-configure.ac) = b972730a2be3bf54502116f1f7e03afee76a02cc
SHA1 (patch-contrib_scripts_vmail.cgi) = 7935ce96ea319eb19cc2ce999813eb837d5357c0
SHA1 (patch-funcs_func__cdr.c) = 79c743df264948e5ea9e1c292012a1f6362d0c1e
@ -58,7 +64,7 @@ SHA1 (patch-main_callerid.c) = 0ea1b3df8aaf3969fcd9e06055c8e6184d50d3d3
SHA1 (patch-main_cdr.c) = 540fbdb354aba100fa37392b879b92a85d1d8620
SHA1 (patch-main_cel.c) = 22fa21db8e0afa0958d34014f52e2c4fe9c73ba2
SHA1 (patch-main_cli.c) = ee72bcaac7dce397354cbc09af4ed7441dbb4650
SHA1 (patch-main_config.c) = d5159f2c16cc6324b79f51cfc797d26c64995a6f
SHA1 (patch-main_config.c) = f4b5fd991a755d6b5429d1ecd33e3525b65d6a02
SHA1 (patch-main_conversions.c) = a516ef4f706fabbd250f66a3159825a2a6085344
SHA1 (patch-main_dns__naptr.c) = 4fa3fe5d2acf7bcd84ca2044280c644e4bd15d7f
SHA1 (patch-main_enum.c) = c5f620297cf98f95ce74aa0d98eddc697946a77b
@ -75,7 +81,7 @@ SHA1 (patch-main_stdtime_localtime.c) = 1e3c62d70eab62c46ac29e03e842229cf7587d2b
SHA1 (patch-main_taskprocessor.c) = f90805bd78fd4096beb9ee1cf9c794c50b87481a
SHA1 (patch-main_tdd.c) = 9f525971938dd4f222622cb3e78a35822bd08389
SHA1 (patch-main_test.c) = f38b370cdb5788304e02c71ef05d2130ead9de98
SHA1 (patch-main_utils.c) = 2762f982f7a66979e363e984b0948364e1b03b7e
SHA1 (patch-main_utils.c) = 07584ece44df8c5041e9c0a21b735e1fcf8c21cc
SHA1 (patch-menuselect_menuselect.c) = 8bae3a2c6b8c6e7927b35bd83147a55e380efd7f
SHA1 (patch-pbx_pbx__config.c) = cc5e6d2b383f86abfb354c9bf14fc93374fba0a3
SHA1 (patch-pbx_pbx__dundi.c) = 1bc28ff2412da569f139f245c5223845a2f6cebe

View File

@ -1,50 +1,23 @@
$NetBSD: patch-configure,v 1.4 2024/02/19 05:59:52 jnemeth Exp $
$NetBSD: patch-configure,v 1.5 2024/03/25 03:36:33 jnemeth Exp $
--- configure.orig 2023-07-20 13:04:41.000000000 +0000
--- configure.orig 2024-03-18 13:18:36.000000000 +0000
+++ configure
@@ -9303,12 +9303,12 @@ else
@@ -10230,12 +10230,12 @@ else $as_nop
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for clang -fblocks" >&5
$as_echo_n "checking for clang -fblocks... " >&6; }
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for clang -fblocks" >&5
printf %s "checking for clang -fblocks... " >&6; }
- if test "`echo 'int main(){return ^{return 42;}();}' | ${CC} -o /dev/null -fblocks -x c - 2>&1`" = ""; then
+ if test "`echo 'int main(){return ^{return 42;}();}' | ${CC} ${LDFLAGS} -o /dev/null -fblocks -x c - 2>&1`" = ""; then
AST_CLANG_BLOCKS_LIBS=""
AST_CLANG_BLOCKS="-Wno-unknown-warning-option -fblocks"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
printf "%s\n" "yes" >&6; }
- elif test "`echo 'int main(){return ^{return 42;}();}' | ${CC} -o /dev/null -fblocks -x c -lBlocksRuntime - 2>&1`" = ""; then
+ elif test "`echo 'int main(){return ^{return 42;}();}' | ${CC} ${LDFLAGS} -o /dev/null -fblocks -x c -lBlocksRuntime - 2>&1`" = ""; then
AST_CLANG_BLOCKS_LIBS="-lBlocksRuntime"
AST_CLANG_BLOCKS="-fblocks"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
@@ -15580,7 +15580,7 @@ fi
done
-ac_fn_c_check_header_mongrel "$LINENO" "sys/poll.h" "ac_cv_header_sys_poll_h" "$ac_includes_default"
+ac_fn_c_check_header_mongrel "$LINENO" "poll.h" "ac_cv_header_sys_poll_h" "$ac_includes_default"
if test "x$ac_cv_header_sys_poll_h" = xyes; then :
else
@@ -17562,7 +17562,7 @@ fi
done
-for ac_func in asprintf atexit closefrom dup2 eaccess endpwent euidaccess ffsll ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday glob ioperm inet_ntoa isascii memchr memmove memset mkdir mkdtemp munmap newlocale pipe2 ppoll putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtod strtol strtold strtoq unsetenv uselocale utime vasprintf getpeereid sysctl swapctl malloc_trim
+for ac_func in asprintf atexit closefrom dup2 eaccess endpwent euidaccess ffsll ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday glob ioperm inet_ntoa isascii memchr memmove memset mkdir mkdtemp munmap newlocale pipe2 ppoll putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strftime_l strlcat strlcpy strncasecmp strndup strnlen strptime_l strrchr strsep strspn strstr strtod strtol strtold strtoq unsetenv uselocale utime vasprintf getpeereid sysctl swapctl malloc_trim
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -17797,7 +17797,7 @@ rm -f core conftest.err conftest.$ac_obj
LDFLAGS=${old_LDFLAGS}
rm -f conftest.dynamics
-ac_fn_c_check_header_mongrel "$LINENO" "sys/poll.h" "ac_cv_header_sys_poll_h" "$ac_includes_default"
+ac_fn_c_check_header_mongrel "$LINENO" "poll.h" "ac_cv_header_sys_poll_h" "$ac_includes_default"
if test "x$ac_cv_header_sys_poll_h" = xyes; then :
HAS_POLL=1
@@ -20126,6 +20126,148 @@ rm -f core conftest.err conftest.$ac_obj
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
@@ -22295,6 +22295,148 @@ rm -f core conftest.err conftest.$ac_obj

View File

@ -1,6 +1,6 @@
$NetBSD: patch-main_config.c,v 1.1 2024/02/19 05:59:52 jnemeth Exp $
$NetBSD: patch-main_config.c,v 1.2 2024/03/25 03:36:33 jnemeth Exp $
--- main/config.c.orig 2024-02-12 05:14:56.251989318 +0000
--- main/config.c.orig 2024-03-18 13:18:36.000000000 +0000
+++ main/config.c
@@ -44,6 +44,9 @@
#include <libgen.h>

View File

@ -1,10 +1,10 @@
$NetBSD: patch-main_utils.c,v 1.2 2021/06/13 07:57:53 jnemeth Exp $
$NetBSD: patch-main_utils.c,v 1.3 2024/03/25 03:36:33 jnemeth Exp $
--- main/utils.c.orig 2018-05-01 20:12:26.000000000 +0000
--- main/utils.c.orig 2024-03-18 13:18:36.000000000 +0000
+++ main/utils.c
@@ -39,6 +39,10 @@
#elif defined(HAVE_SYS_THR_H)
#include <sys/thr.h>
@@ -41,6 +41,10 @@
#elif defined(__NetBSD__)
#include <lwp.h>
#endif
+#if defined(HAVE_GETIFADDRS)
+#include <ifaddrs.h>
@ -13,7 +13,7 @@ $NetBSD: patch-main_utils.c,v 1.2 2021/06/13 07:57:53 jnemeth Exp $
#include "asterisk/network.h"
#include "asterisk/ast_version.h"
@@ -204,7 +208,7 @@ struct hostent *ast_gethostbyname(const
@@ -213,7 +217,7 @@ struct hostent *ast_gethostbyname(const
while (s && *s) {
if (*s == '.')
dots++;
@ -22,7 +22,7 @@ $NetBSD: patch-main_utils.c,v 1.2 2021/06/13 07:57:53 jnemeth Exp $
break;
s++;
}
@@ -612,7 +616,7 @@ const char *ast_inet_ntoa(struct in_addr
@@ -937,7 +941,7 @@ const char *ast_inet_ntoa(struct in_addr
static int dev_urandom_fd = -1;
@ -31,7 +31,7 @@ $NetBSD: patch-main_utils.c,v 1.2 2021/06/13 07:57:53 jnemeth Exp $
#undef pthread_create /* For ast_pthread_create function only */
#endif /* !__linux__ */
@@ -1820,13 +1824,13 @@ int ast_false(const char *s)
@@ -2238,13 +2242,13 @@ int ast_false(const char *s)
static struct timeval tvfix(struct timeval a)
{
if (a.tv_usec >= ONE_MILLION) {
@ -49,7 +49,7 @@ $NetBSD: patch-main_utils.c,v 1.2 2021/06/13 07:57:53 jnemeth Exp $
a.tv_usec = 0;
}
return a;
@@ -1986,7 +1990,7 @@ char *ast_to_camel_case_delim(const char
@@ -2404,7 +2408,7 @@ char *ast_to_camel_case_delim(const char
while (front) {
size = strlen(front);