fix pygtk detection with python>=2.6.6
This commit is contained in:
parent
aacdfd8b7f
commit
dd7c2e7b23
3 changed files with 19 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.100 2012/10/08 23:01:13 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.101 2012/10/17 13:52:03 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rhythmbox-0.12.8
|
||||
PKGREVISION= 19
|
||||
PKGREVISION= 20
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/rhythmbox/0.12/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.36 2010/11/15 18:56:52 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.37 2012/10/17 13:52:03 drochner Exp $
|
||||
|
||||
SHA1 (rhythmbox-0.12.8.tar.bz2) = 5d27923cc29b81d7bfbc73d867d7976a5295f964
|
||||
RMD160 (rhythmbox-0.12.8.tar.bz2) = 072d4fa06408ebc181b40147db1575d0ef4c99fe
|
||||
|
@ -8,3 +8,4 @@ SHA1 (patch-ad) = 367a6014863472ec73fccd47a32437632a4492a2
|
|||
SHA1 (patch-ae) = 95bc80c0b6e760613f2e1ad715e05de7b45af0bb
|
||||
SHA1 (patch-af) = 8babe8d7e5912f0fbd3a12d0c39dfecf75fef4af
|
||||
SHA1 (patch-ag) = de1b458b7a8510f9aded9763947e878597e28b43
|
||||
SHA1 (patch-ah) = 2cbaa1c2ed1637b269269a4c8828ebc8d5c8421d
|
||||
|
|
15
audio/rhythmbox/patches/patch-ah
Normal file
15
audio/rhythmbox/patches/patch-ah
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ah,v 1.1 2012/10/17 13:52:03 drochner Exp $
|
||||
|
||||
gnome bug #617587
|
||||
|
||||
--- shell/rb-python-module.c.orig 2010-03-25 00:10:15.000000000 +0000
|
||||
+++ shell/rb-python-module.c
|
||||
@@ -169,7 +169,7 @@ rb_python_module_init_python (void)
|
||||
|
||||
mdict = PyModule_GetDict (pygtk);
|
||||
require = PyDict_GetItemString (mdict, "require");
|
||||
- PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.8")));
|
||||
+ PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.0")));
|
||||
|
||||
/* import gobject */
|
||||
init_pygobject ();
|
Loading…
Reference in a new issue