Changes 5.0.0:

* The memory usage limit is now disabled by default.
* Added support for XZ_DEFAULTS environment variable.
* The compression settings associated with the preset levels
  -0 ... -9 have been changed. --extreme was changed a little too.
* If a preset level (-0 ... -9) is specified after a custom filter
  chain options have been used (e.g. --lzma2), the custom filter
  chain will be forgotten. Earlier the preset options were
  completely ignored after custom filter chain options had been seen.
* xz will create sparse files when decompressing if the uncompressed
  data contains long sequences of binary zeros.
* Support for "xz --list" was added. Combine with --verbose or
  --verbose --verbose (-vv) for detailed output.
* I had hoped that liblzma API would have been stable after
  4.999.9beta, but there have been a couple of changes in the
  advanced features, which don't affect most applications:
  - Index handling code was revised. If you were using the old
    API, you will get a compiler error (so it's easy to notice).
  - A subtle but important change was made to the Block handling
    API. lzma_block.version has to be initialized even for
    lzma_block_header_decode(). Code that doesn't do it will work
    for now, but might break in the future, which makes this API
    change easy to miss.
* The major soname has been bumped to 5.0.0. liblzma API and ABI
  are now stable, so the need to recompile programs linking against
  liblzma shouldn't arise soon.
This commit is contained in:
adam 2010-11-03 14:21:49 +00:00
parent 556985876b
commit dd86fdf4e4
6 changed files with 14 additions and 40 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.6 2010/03/20 19:46:14 wiz Exp $
#
# $NetBSD: Makefile,v 1.7 2010/11/03 14:21:49 adam Exp $
DISTNAME= xz-4.999.9beta
PKGREVISION= 1
DISTNAME= xz-5.0.0
CATEGORIES= archivers
MASTER_SITES= http://tukaani.org/xz/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://tukaani.org/xz/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2009/08/31 08:59:11 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2010/11/03 14:21:49 adam Exp $
bin/lzcat
bin/lzcmp
bin/lzdiff
@ -30,11 +30,11 @@ include/lzma/check.h
include/lzma/container.h
include/lzma/delta.h
include/lzma/filter.h
include/lzma/hardware.h
include/lzma/index.h
include/lzma/index_hash.h
include/lzma/lzma.h
include/lzma/stream_flags.h
include/lzma/subblock.h
include/lzma/version.h
include/lzma/vli.h
lib/liblzma.la
@ -73,3 +73,6 @@ share/doc/xz/faq.txt
share/doc/xz/history.txt
share/doc/xz/lzma-file-format.txt
share/doc/xz/xz-file-format.txt
share/locale/cs/LC_MESSAGES/xz.mo
share/locale/de/LC_MESSAGES/xz.mo
share/locale/it/LC_MESSAGES/xz.mo

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2009/12/13 13:26:17 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.2 2010/11/03 14:21:49 adam Exp $
BUILDLINK_TREE+= xz
.if !defined(XZ_BUILDLINK3_MK)
XZ_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.xz+= xz>=4.999.9beta
BUILDLINK_API_DEPENDS.xz+= xz>=5.0.0
BUILDLINK_PKGSRCDIR.xz?= ../../archivers/xz
.endif # XZ_BUILDLINK3_MK

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.4 2010/03/20 19:46:14 wiz Exp $
$NetBSD: distinfo,v 1.5 2010/11/03 14:21:49 adam Exp $
SHA1 (xz-4.999.9beta.tar.gz) = 9627de3997ddcdb02f8d327e84b2cf1941ecd230
RMD160 (xz-4.999.9beta.tar.gz) = 1253ce01746c748c8549effa5041224044919c4e
Size (xz-4.999.9beta.tar.gz) = 1037541 bytes
SHA1 (patch-aa) = db92bd036c6e449efbe1b2dff8993214c584adc4
SHA1 (patch-ab) = 95261cc5700f554a825c4b7c9d64c02c25336745
SHA1 (xz-5.0.0.tar.bz2) = 6bc5a6054a8f71ed48b29fff94b2e5c6a1b59650
RMD160 (xz-5.0.0.tar.bz2) = 11aae2085907c74874ef8086f64b79b5e387abab
Size (xz-5.0.0.tar.bz2) = 1003920 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2010/03/20 19:46:14 wiz Exp $
--- src/common/cpucores.h.orig 2009-08-27 15:37:12.000000000 +0000
+++ src/common/cpucores.h
@@ -40,7 +40,7 @@ cpucores(void)
int name[2] = { CTL_HW, HW_NCPU };
int cpus;
size_t cpus_size = sizeof(cpus);
- if (!sysctl(name, &cpus, &cpus_size, NULL, NULL)
+ if (sysctl(name, 2, &cpus, &cpus_size, NULL, 0) != -1
&& cpus_size == sizeof(cpus) && cpus > 0)
ret = (uint32_t)(cpus);
#endif

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.2 2010/03/20 19:46:14 wiz Exp $
--- src/common/physmem.h.orig 2009-08-27 15:37:12.000000000 +0000
+++ src/common/physmem.h
@@ -104,7 +104,7 @@ physmem(void)
uint64_t u64;
} mem;
size_t mem_ptr_size = sizeof(mem.u64);
- if (!sysctl(name, 2, &mem.u64, &mem_ptr_size, NULL, NULL)) {
+ if (sysctl(name, 2, &mem.u64, &mem_ptr_size, NULL, 0) != -1) {
// IIRC, 64-bit "return value" is possible on some 64-bit
// BSD systems even with HW_PHYSMEM (instead of HW_PHYSMEM64),
// so support both.