Update php4 to 4.3.11.
This is a maintenance release that in addition to over 70 non-critical bug fixes addresses several security issues inside the exif and fbsql extensions as well as the unserialize(), swf_definepoly() and getimagesize() functions. All Users of PHP are strongly encouraged to upgrade to this release. Bugfix release * Crash in bzopen() if supplied path to non-existent file. * DOM crashing when attribute appended to Document. * unserialize() float problem on non-English locales. * Crash in msg_send() when non-string is stored without being serialized. * Possible infinite loop in imap_mail_compose(). * Fixed crash in chunk_split(), when chunklen > strlen. * session_set_save_handler crashes PHP when supplied non-existent object ref. * Memory leak in zend_language_scanner.c. * Compile failures of zend_strtod.c. * Fixed crash in overloaded objects & overload() function. * cURL functions bypass open_basedir. PHP4 also doesn't bundle PEAR Net_Socket and Net_SMTP anymore now.
This commit is contained in:
parent
f64b8278d2
commit
ddc89cd2e3
10 changed files with 104 additions and 183 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES,v 1.9827 2005/04/11 19:02:54 tv Exp $
|
||||
$NetBSD: CHANGES,v 1.9828 2005/04/11 20:02:56 jdolecek Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2005:
|
||||
|
||||
|
@ -1986,3 +1986,4 @@ Changes to the packages collection and infrastructure in 2005:
|
|||
Updated wl to 2.14.0 [hira 2005-04-11]
|
||||
Updated pkglint to 4.12 [tv 2005-04-11]
|
||||
Updated url2pkg to 1.28 [tv 2005-04-11]
|
||||
Updated php4 to 4.3.11 [jdolecek 2005-04-11]
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.6 2004/11/23 19:46:14 jdolecek Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
MODNAME= gd
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= # empty
|
||||
CATEGORIES+= graphics
|
||||
COMMENT= PHP extension for GD graphics library
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.4 2005/01/03 15:59:12 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
MODNAME= curl
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= # empty
|
||||
CATEGORIES+= www
|
||||
COMMENT= PHP extension for curl functions
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.41 2004/12/17 07:40:45 jdolecek Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
PKGNAME= php-${PHP_BASE_VERS}
|
||||
CATEGORIES+= lang
|
||||
|
@ -39,7 +39,7 @@ OWN_DIRS= ${PREFIX}/${PHP_EXTENSION_DIR}
|
|||
# some of the bundled Pear extensions have newer versions, which fix
|
||||
# some known bugs
|
||||
PEAR_CMD= ${PREFIX}/bin/pear
|
||||
UPGRADE_PKG= Net_Socket-1.0.2
|
||||
UPGRADE_PKG=
|
||||
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sapi/cli/php ${PREFIX}/bin/php
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.46 2004/12/18 16:01:42 jdolecek Exp $
|
||||
# $NetBSD: Makefile.common,v 1.47 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
DISTNAME?= php-${PHP_DIST_VERS}
|
||||
CATEGORIES+= www php4
|
||||
|
@ -15,7 +15,7 @@ HOMEPAGE?= http://www.php.net/
|
|||
# PHP_DIST_VERS version number on the php distfile
|
||||
# PHP_BASE_VERS pkgsrc-mangled version number (convert pl -> .)
|
||||
#
|
||||
PHP_DIST_VERS= 4.3.10
|
||||
PHP_DIST_VERS= 4.3.11
|
||||
PHP_BASE_VERS= ${PHP_DIST_VERS}
|
||||
|
||||
DISTFILES?= ${PHP_DISTFILE}
|
||||
|
|
213
www/php4/PLIST
213
www/php4/PLIST
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2004/12/17 00:36:09 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2005/04/11 20:02:57 jdolecek Exp $
|
||||
bin/pear
|
||||
bin/php
|
||||
bin/php-config
|
||||
|
@ -132,6 +132,7 @@ include/php/ext/xml/expat/expat.h
|
|||
include/php/ext/xml/expat/asciitab.h
|
||||
include/php/ext/xml/expat/xmltok_impl.h
|
||||
include/php/ext/xml/php_xml.h
|
||||
include/php/ext/mbstring/libmbfl/mbfl/eaw_table.h
|
||||
include/php/ext/mbstring/libmbfl/mbfl/mbfl_string.h
|
||||
include/php/ext/mbstring/libmbfl/mbfl/mbfl_memory_device.h
|
||||
include/php/ext/mbstring/libmbfl/mbfl/mbfl_language.h
|
||||
|
@ -192,139 +193,82 @@ include/php/regex/regex.h
|
|||
include/php/regex/cname.h
|
||||
include/php/regex/cclass.h
|
||||
include/php/acconfig.h
|
||||
lib/php/.filemap
|
||||
lib/php/.lock
|
||||
lib/php/.registry/archive_tar.reg
|
||||
lib/php/.registry/console_getopt.reg
|
||||
lib/php/.registry/html_template_it.reg
|
||||
lib/php/.registry/net_useragent_detect.reg
|
||||
lib/php/.registry/pear.reg
|
||||
lib/php/.registry/db.reg
|
||||
lib/php/.registry/http.reg
|
||||
lib/php/.registry/mail.reg
|
||||
lib/php/.registry/net_smtp.reg
|
||||
lib/php/.registry/net_socket.reg
|
||||
lib/php/.registry/xml_parser.reg
|
||||
lib/php/.registry/xml_rpc.reg
|
||||
lib/php/.filemap
|
||||
lib/php/Archive/Tar.php
|
||||
lib/php/Console/Getopt.php
|
||||
lib/php/PEAR/Registry.php
|
||||
lib/php/PEAR/Packager.php
|
||||
lib/php/PEAR/Installer.php
|
||||
lib/php/PEAR/Frontend/CLI.php
|
||||
lib/php/PEAR/ErrorStack.php
|
||||
lib/php/PEAR/Downloader.php
|
||||
lib/php/PEAR/Dependency.php
|
||||
lib/php/PEAR/Config.php
|
||||
lib/php/PEAR/Common.php
|
||||
lib/php/PEAR/Command/Remote.php
|
||||
lib/php/PEAR/Command/Registry.php
|
||||
lib/php/PEAR/Command/Package.php
|
||||
lib/php/PEAR/Command/Mirror.php
|
||||
lib/php/PEAR/Command/Install.php
|
||||
lib/php/PEAR/Command/Config.php
|
||||
lib/php/PEAR/Command/Common.php
|
||||
lib/php/PEAR/Command/Build.php
|
||||
lib/php/PEAR/Command/Auth.php
|
||||
lib/php/PEAR/Command.php
|
||||
lib/php/PEAR/Builder.php
|
||||
lib/php/PEAR/Remote.php
|
||||
lib/php/PEAR/Autoloader.php
|
||||
lib/php/doc/Archive_Tar/docs/Archive_Tar.txt
|
||||
lib/php/doc/DB/doc/MAINTAINERS
|
||||
lib/php/doc/DB/doc/STATUS
|
||||
lib/php/doc/DB/doc/TESTERS
|
||||
lib/php/doc/DB/doc/IDEAS
|
||||
lib/php/doc/Net_SMTP/docs/guide.txt
|
||||
lib/php/doc/Net_SMTP/docs/examples/basic.php
|
||||
lib/php/DB/dbase.php
|
||||
lib/php/DB/fbsql.php
|
||||
lib/php/DB/ibase.php
|
||||
lib/php/DB/ifx.php
|
||||
lib/php/DB/msql.php
|
||||
lib/php/DB/mssql.php
|
||||
lib/php/DB/mysqli.php
|
||||
lib/php/DB/mysql.php
|
||||
lib/php/DB/oci8.php
|
||||
lib/php/DB/odbc.php
|
||||
lib/php/DB/pgsql.php
|
||||
lib/php/DB/sybase.php
|
||||
lib/php/DB/storage.php
|
||||
lib/php/DB/sqlite.php
|
||||
lib/php/DB/common.php
|
||||
lib/php/data/PEAR/template.spec
|
||||
lib/php/data/PEAR/package.dtd
|
||||
lib/php/System.php
|
||||
lib/php/pearcmd.php
|
||||
lib/php/Net/SMTP.php
|
||||
lib/php/Net/Socket.php
|
||||
lib/php/HTML/Template/IT.php
|
||||
lib/php/HTML/Template/ITX.php
|
||||
lib/php/HTML/Template/IT_Error.php
|
||||
lib/php/Net/UserAgent/Detect.php
|
||||
lib/php/OS/Guess.php
|
||||
lib/php/XML/Parser.php
|
||||
lib/php/XML/RPC/Server.php
|
||||
lib/php/XML/RPC.php
|
||||
lib/php/DB.php
|
||||
lib/php/Mail/sendmail.php
|
||||
lib/php/Mail/smtp.php
|
||||
lib/php/Mail/RFC822.php
|
||||
lib/php/Mail/null.php
|
||||
lib/php/Mail/mail.php
|
||||
lib/php/test/DB/tests/db_parsedsn.phpt
|
||||
lib/php/test/DB/tests/db_factory.phpt
|
||||
lib/php/test/DB/tests/db_ismanip.phpt
|
||||
lib/php/test/DB/tests/db_error2.phpt
|
||||
lib/php/test/DB/tests/errors.inc
|
||||
lib/php/test/DB/tests/fetchmode_object.inc
|
||||
lib/php/test/DB/tests/fetchmodes.inc
|
||||
lib/php/test/DB/tests/include.inc
|
||||
lib/php/test/DB/tests/limit.inc
|
||||
lib/php/test/DB/tests/numcols.inc
|
||||
lib/php/test/DB/tests/numrows.inc
|
||||
lib/php/test/DB/tests/prepexe.inc
|
||||
lib/php/test/DB/tests/run.cvs
|
||||
lib/php/test/DB/tests/sequences.inc
|
||||
lib/php/test/DB/tests/simplequery.inc
|
||||
lib/php/test/DB/tests/skipif.inc
|
||||
lib/php/test/DB/tests/transactions.inc
|
||||
lib/php/test/DB/tests/driver/01connect.phpt
|
||||
lib/php/test/DB/tests/driver/02fetch.phpt
|
||||
lib/php/test/DB/tests/driver/03simplequery.phpt
|
||||
lib/php/test/DB/tests/driver/04numcols.phpt
|
||||
lib/php/test/DB/tests/driver/05sequences.phpt
|
||||
lib/php/test/DB/tests/driver/06prepexec.phpt
|
||||
lib/php/test/DB/tests/driver/08affectedrows.phpt
|
||||
lib/php/test/DB/tests/driver/09numrows.phpt
|
||||
lib/php/test/DB/tests/driver/10errormap.phpt
|
||||
lib/php/test/DB/tests/driver/11transactions.phpt
|
||||
lib/php/test/DB/tests/driver/13limit.phpt
|
||||
lib/php/test/DB/tests/driver/14fetchmode_object.phpt
|
||||
lib/php/test/DB/tests/driver/15quote.phpt
|
||||
lib/php/test/DB/tests/driver/16tableinfo.phpt
|
||||
lib/php/test/DB/tests/driver/17query.phpt
|
||||
lib/php/test/DB/tests/driver/18get.phpt
|
||||
lib/php/test/DB/tests/driver/bug22328.phpt
|
||||
lib/php/test/DB/tests/driver/connect.inc
|
||||
lib/php/test/DB/tests/driver/mktable.inc
|
||||
lib/php/test/DB/tests/driver/run.cvs
|
||||
lib/php/test/DB/tests/driver/skipif.inc
|
||||
lib/php/test/DB/tests/driver/setup.inc.cvs
|
||||
lib/php/test/DB/tests/db_error.phpt
|
||||
lib/php/test/Net_SMTP/tests/auth.phpt
|
||||
lib/php/test/Net_SMTP/tests/basic.phpt
|
||||
lib/php/test/Net_SMTP/tests/config.php.dist
|
||||
lib/php/test/XML_Parser/tests/002.phpt
|
||||
lib/php/test/XML_Parser/tests/003.phpt
|
||||
lib/php/test/XML_Parser/tests/004.phpt
|
||||
lib/php/test/XML_Parser/tests/005.phpt
|
||||
lib/php/test/XML_Parser/tests/test2.xml
|
||||
lib/php/test/XML_Parser/tests/test3.xml
|
||||
lib/php/test/XML_Parser/tests/001.phpt
|
||||
lib/php/PEAR.php
|
||||
lib/php/HTTP.php
|
||||
lib/php/Mail.php
|
||||
lib/php/build/acinclude.m4
|
||||
lib/php/build/scan_makefile_in.awk
|
||||
lib/php/PEAR/Autoloader.php
|
||||
lib/php/PEAR/Builder.php
|
||||
lib/php/PEAR/Command.php
|
||||
lib/php/PEAR/Command/Auth.php
|
||||
lib/php/PEAR/Command/Build.php
|
||||
lib/php/PEAR/Command/Common.php
|
||||
lib/php/PEAR/Command/Config.php
|
||||
lib/php/PEAR/Command/Install.php
|
||||
lib/php/PEAR/Command/Mirror.php
|
||||
lib/php/PEAR/Command/Package.php
|
||||
lib/php/PEAR/Command/Registry.php
|
||||
lib/php/PEAR/Command/Remote.php
|
||||
lib/php/PEAR/Common.php
|
||||
lib/php/PEAR/Config.php
|
||||
lib/php/PEAR/Dependency.php
|
||||
lib/php/PEAR/Downloader.php
|
||||
lib/php/PEAR/ErrorStack.php
|
||||
lib/php/PEAR/Exception.php
|
||||
lib/php/PEAR/Frontend/CLI.php
|
||||
lib/php/PEAR/Installer.php
|
||||
lib/php/PEAR/Packager.php
|
||||
lib/php/PEAR/Registry.php
|
||||
lib/php/PEAR/Remote.php
|
||||
lib/php/PEAR/RunTest.php
|
||||
lib/php/System.php
|
||||
lib/php/XML/RPC.php
|
||||
lib/php/XML/RPC/Dump.php
|
||||
lib/php/XML/RPC/Server.php
|
||||
lib/php/build/Makefile.global
|
||||
lib/php/build/shtool
|
||||
lib/php/build/acinclude.m4
|
||||
lib/php/build/config.guess
|
||||
lib/php/build/config.sub
|
||||
lib/php/build/libtool.m4
|
||||
lib/php/build/ltmain.sh
|
||||
lib/php/build/mkdep.awk
|
||||
lib/php/build/phpize.m4
|
||||
lib/php/build/scan_makefile_in.awk
|
||||
lib/php/build/shtool
|
||||
lib/php/data/PEAR/package.dtd
|
||||
lib/php/data/PEAR/template.spec
|
||||
lib/php/doc/Archive_Tar/docs/Archive_Tar.txt
|
||||
lib/php/doc/HTML_Template_IT/examples/sample_it.php
|
||||
lib/php/doc/HTML_Template_IT/examples/templates/main.tpl.htm
|
||||
lib/php/pearcmd.php
|
||||
lib/php/test/HTML_Template_IT/tests/Console_TestListener.php
|
||||
lib/php/test/HTML_Template_IT/tests/ITX_api_testcase.php
|
||||
lib/php/test/HTML_Template_IT/tests/ITX_usage_testcase.php
|
||||
lib/php/test/HTML_Template_IT/tests/IT_api_testcase.php
|
||||
lib/php/test/HTML_Template_IT/tests/IT_usage_testcase.php
|
||||
lib/php/test/HTML_Template_IT/tests/templates/__include.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/addblock.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/blockiteration.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/blocks.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/globals.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/include.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/loadtemplatefile.html
|
||||
lib/php/test/HTML_Template_IT/tests/templates/replaceblock.html
|
||||
lib/php/test/HTML_Template_IT/tests/test.php
|
||||
lib/php/test/XML_RPC/tests/protoport.php
|
||||
lib/php/test/XML_RPC/tests/test_Dump.php
|
||||
libexec/cgi-bin/php
|
||||
man/man1/php.1
|
||||
share/examples/php/php.ini-dist
|
||||
|
@ -336,21 +280,17 @@ share/php/php.gif
|
|||
@dirrm lib/php/build
|
||||
@dirrm lib/php/data/PEAR
|
||||
@dirrm lib/php/data
|
||||
@dirrm lib/php/doc/HTML_Template_IT/examples/templates
|
||||
@dirrm lib/php/doc/HTML_Template_IT/examples
|
||||
@dirrm lib/php/doc/HTML_Template_IT
|
||||
@dirrm lib/php/doc/Archive_Tar/docs
|
||||
@dirrm lib/php/doc/Archive_Tar
|
||||
@dirrm lib/php/doc/Net_SMTP/docs/examples
|
||||
@dirrm lib/php/doc/Net_SMTP/docs
|
||||
@dirrm lib/php/doc/Net_SMTP
|
||||
@dirrm lib/php/doc/DB/doc
|
||||
@dirrm lib/php/doc/DB
|
||||
@dirrm lib/php/doc
|
||||
@dirrm lib/php/test/DB/tests/driver
|
||||
@dirrm lib/php/test/DB/tests
|
||||
@dirrm lib/php/test/DB
|
||||
@dirrm lib/php/test/Net_SMTP/tests
|
||||
@dirrm lib/php/test/Net_SMTP
|
||||
@dirrm lib/php/test/XML_Parser/tests
|
||||
@dirrm lib/php/test/XML_Parser
|
||||
@dirrm lib/php/test/HTML_Template_IT/tests/templates
|
||||
@dirrm lib/php/test/HTML_Template_IT/tests
|
||||
@dirrm lib/php/test/HTML_Template_IT
|
||||
@dirrm lib/php/test/XML_RPC/tests
|
||||
@dirrm lib/php/test/XML_RPC
|
||||
@dirrm lib/php/test
|
||||
@dirrm lib/php/XML/RPC
|
||||
@dirrm lib/php/XML
|
||||
|
@ -358,9 +298,10 @@ share/php/php.gif
|
|||
@dirrm lib/php/PEAR/Frontend
|
||||
@dirrm lib/php/PEAR
|
||||
@dirrm lib/php/OS
|
||||
@dirrm lib/php/Net/UserAgent
|
||||
@dirrm lib/php/Net
|
||||
@dirrm lib/php/Mail
|
||||
@dirrm lib/php/DB
|
||||
@dirrm lib/php/HTML/Template
|
||||
@dirrm lib/php/HTML
|
||||
@dirrm lib/php/Console
|
||||
@dirrm lib/php/Archive
|
||||
@dirrm include/php/regex
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.5 2004/11/27 14:00:08 jdolecek Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.6 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
PHP_BUILDLINK3_MK:= ${PHP_BUILDLINK3_MK}+
|
||||
|
@ -12,11 +12,8 @@ BUILDLINK_PACKAGES+= php
|
|||
|
||||
.if !empty(PHP_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.php+= php-4.3.*
|
||||
BUILDLINK_RECOMMENDED.php+= php>=4.3.9nb2
|
||||
BUILDLINK_RECOMMENDED.php+= php>=4.3.11
|
||||
BUILDLINK_PKGSRCDIR.php?= ../../www/php4
|
||||
|
||||
# Use full dependency for extension and pear modules
|
||||
BUILDLINK_DEPMETHOD.php?= full
|
||||
.endif # PHP_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
||||
|
|
|
@ -1,15 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.38 2005/02/24 14:08:38 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.39 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
SHA1 (php-4.3.10.tar.bz2) = 3cef4d103f395eb25fa44fcdc8c692c1cf0a2ac0
|
||||
RMD160 (php-4.3.10.tar.bz2) = fa670a21853b049800edc54508b8fed4cc5ca85d
|
||||
Size (php-4.3.10.tar.bz2) = 4026148 bytes
|
||||
SHA1 (php-4.3.11.tar.bz2) = 617ce50bb125ee841f71e67638c492999cd3bd18
|
||||
RMD160 (php-4.3.11.tar.bz2) = fe44f6c2783ddd469b94744e440e836cff3329e5
|
||||
Size (php-4.3.11.tar.bz2) = 4012575 bytes
|
||||
SHA1 (patch-aa) = feb064407950d0fc732b7240e65cac84420d2407
|
||||
SHA1 (patch-ab) = fd09b2a1f56d50859f2ee632f7feab28e624fe15
|
||||
SHA1 (patch-ad) = 9ca5d2f59bfeea77a98cd0e727546d11669114cd
|
||||
SHA1 (patch-ag) = 1ded1d7f4daac6806f41864c783f16d3403315e4
|
||||
SHA1 (patch-ah) = 0ac37bd35c4594cb58f1ea85ef811154b644a931
|
||||
SHA1 (patch-ai) = 0b9c1c9fb75a64026f2fb3cbd44cc19e0a1f186c
|
||||
SHA1 (patch-aj) = 132b5b5b802f1795deda9487db5f22cfe9edce5d
|
||||
SHA1 (patch-aj) = cc68ce876dc5998becbe2f1f74288b5da5bbaca3
|
||||
SHA1 (patch-ak) = bd2aac1a91ed77208b45747c9d11e87731c6b46f
|
||||
SHA1 (patch-al) = 28ad9006b387e2b9984ad49beea21c9d46e63b46
|
||||
SHA1 (patch-am) = 1b6dc859a71b04682bf290fc747c8fdb1c3864fb
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aj,v 1.8 2004/10/31 18:23:24 jdolecek Exp $
|
||||
$NetBSD: patch-aj,v 1.9 2005/04/11 20:02:57 jdolecek Exp $
|
||||
|
||||
--- ext/imap/config.m4.orig 2004-01-17 01:01:06.000000000 +0100
|
||||
+++ ext/imap/config.m4 2004-10-31 18:49:03.000000000 +0100
|
||||
--- ext/imap/config.m4.orig 2005-04-08 20:55:11.000000000 +0200
|
||||
+++ ext/imap/config.m4 2005-04-08 20:55:01.000000000 +0200
|
||||
@@ -54,6 +54,14 @@
|
||||
])
|
||||
])
|
||||
|
@ -14,13 +14,13 @@ $NetBSD: patch-aj,v 1.8 2004/10/31 18:23:24 jdolecek Exp $
|
|||
+ AC_DEFINE(HAVE_IMAP_LINKAGE, 1, [ ])
|
||||
+fi
|
||||
+
|
||||
AC_DEFUN(PHP_IMAP_KRB_CHK, [
|
||||
AC_ARG_WITH(kerberos,
|
||||
[ --with-kerberos[=DIR] IMAP: Include Kerberos support. DIR is the Kerberos install dir.],[
|
||||
@@ -90,7 +98,7 @@
|
||||
PHP_ADD_LIBRARY(k5crypto, 1, IMAP_SHARED_LIBADD)
|
||||
PHP_ADD_LIBRARY(com_err, 1, IMAP_SHARED_LIBADD)
|
||||
PHP_ADD_INCLUDE($PHP_KERBEROS_DIR/include)
|
||||
AC_DEFUN([PHP_IMAP_KRB_CHK], [
|
||||
if test "$PHP_KERBEROS" != "no"; then
|
||||
PHP_SETUP_KERBEROS(IMAP_SHARED_LIBADD,
|
||||
@@ -65,7 +73,7 @@
|
||||
Check the path given to --with-kerberos (if no path is given, searches in /usr/kerberos, /usr/local and /usr )
|
||||
])
|
||||
])
|
||||
- else
|
||||
+ elif test "$PHP_IMAP_LINKAGE" != "yes"; then
|
||||
AC_EGREP_HEADER(auth_gss, $IMAP_INC_DIR/linkage.h, [
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-am,v 1.1 2004/12/19 03:50:44 grant Exp $
|
||||
|
||||
--- Zend/zend_strtod.c.orig 2004-12-14 19:35:26.000000000 +1100
|
||||
+++ Zend/zend_strtod.c
|
||||
@@ -127,7 +127,11 @@ static char *rcsid = "$OpenBSD: strtod.c
|
||||
#define IEEE_LITTLE_ENDIAN
|
||||
#endif
|
||||
|
||||
+/* the __ppc__ test alone is wrong on Darwin, which doesn't have uintXX_t */
|
||||
+/*
|
||||
#if defined(__sparc__) || defined(__ppc__)
|
||||
+*/
|
||||
+#if defined(__sparc__) || (defined(__ppc__) && !defined(__APPLE__))
|
||||
#define u_int32_t uint32_t
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue