Fix LP64 bugs in testgthread, so `make check' works.
This commit is contained in:
parent
26b2b82afd
commit
ddd6759b83
2 changed files with 19 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2002/07/18 02:19:30 rh Exp $
|
||||
$NetBSD: distinfo,v 1.5 2002/07/19 03:47:00 mycroft Exp $
|
||||
|
||||
SHA1 (glib-1.2.10.tar.gz) = e5a9361c594608d152d5d9650154c2e3260b87fa
|
||||
Size (glib-1.2.10.tar.gz) = 421480 bytes
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-ae) = 222a1f4c470fd1123deb3b4dd918b036b3607e59
|
|||
SHA1 (patch-af) = a1fa53f4c903f42b3f6490abf910ce6276eae5c7
|
||||
SHA1 (patch-ag) = f475066fa24d77b9c5f182abbd060bbb40023de6
|
||||
SHA1 (patch-ah) = be1e06b11cdd6fb91d371101b46ba9dda7935107
|
||||
SHA1 (patch-ai) = 4772651ead781f8024da4577f9fea471d21dca5d
|
||||
|
|
17
devel/glib/patches/patch-ai
Normal file
17
devel/glib/patches/patch-ai
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ai,v 1.1 2002/07/19 03:47:01 mycroft Exp $
|
||||
|
||||
--- testgthread.c.orig Fri Jul 19 03:43:50 2002
|
||||
+++ testgthread.c Fri Jul 19 03:42:15 2002
|
||||
@@ -87,10 +87,10 @@
|
||||
pthread_attr_setdetachstate (&pthread_attr, PTHREAD_CREATE_JOINABLE);
|
||||
*/
|
||||
pthread_create (&thread, &pthread_attr, (void *(*)(void *)) func, data);
|
||||
- return GUINT_TO_POINTER (thread);
|
||||
+ return thread;
|
||||
}
|
||||
#define join_thread(thread) \
|
||||
- pthread_join ((pthread_t)GPOINTER_TO_UINT (thread), NULL)
|
||||
+ pthread_join ((thread), NULL)
|
||||
#define self_thread() GUINT_TO_POINTER (pthread_self ())
|
||||
|
||||
#else /* we are not having a thread implementation, do nothing */
|
Loading…
Reference in a new issue