hexedit: update to 1.4.2.

ChangeLog:

september 2017
	- 1.4.2
	- fix spelling errors in manpage
	- fix build

september 2017
	- 1.4
	- terminal resizing support
	- fix build

november 2016:
	- mark cursor position in both HEX and ASCII
	- skip whitespace when parsing hex-strings

march 2014:
	- fix small but in DIE() which was leaving the terminal in a bad state
	- added --linelength <n> / -l<n> command line option
This commit is contained in:
fcambus 2020-02-05 15:30:25 +00:00
parent 82f31cd667
commit ddea937d4d
3 changed files with 15 additions and 123 deletions

View file

@ -1,19 +1,20 @@
# $NetBSD: Makefile,v 1.34 2020/01/18 23:30:45 rillig Exp $
# $NetBSD: Makefile,v 1.35 2020/02/05 15:30:25 fcambus Exp $
DISTNAME= hexedit-1.2.13
PKGREVISION= 2
DISTNAME= hexedit-1.4.2
CATEGORIES= editors
MASTER_SITES= http://rigaux.org/
EXTRACT_SUFX= .src.tgz
MASTER_SITES= ${MASTER_SITE_GITHUB:=pixel/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://merd.sourceforge.net/pixel/hexedit.html
HOMEPAGE= http://rigaux.org/hexedit.html
COMMENT= To view and edit files in hexadecimal or ASCII
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/hexedit
GNU_CONFIGURE= yes
USE_TOOLS+= aclocal autoconf automake autoheader
INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
GNU_CONFIGURE= yes
pre-configure:
cd ${WRKSRC} && ${SH} autogen.sh
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.13 2015/11/03 03:32:17 agc Exp $
$NetBSD: distinfo,v 1.14 2020/02/05 15:30:25 fcambus Exp $
SHA1 (hexedit-1.2.13.src.tgz) = 1acb7ca37063d9f4b4d118ef223548fde3b753f1
RMD160 (hexedit-1.2.13.src.tgz) = cb4fe716cf8f3bfb614ea890aec20d7865e2c271
SHA512 (hexedit-1.2.13.src.tgz) = df9afb0b9b965e20ea8c427c1986b0200216601b157862199c35bae9e201ccc478ab0bfecd39d0dfaa85bf582f1cf372b0134fadcfeacf4734805a6e6dcaa2bb
Size (hexedit-1.2.13.src.tgz) = 68778 bytes
SHA1 (hexedit-1.4.2.tar.gz) = 4389a1866e7a5cac213131431e5ce757568ef693
RMD160 (hexedit-1.4.2.tar.gz) = 5b4fd5caa7423ddf0e2341c213cce1abc3fa9a05
SHA512 (hexedit-1.4.2.tar.gz) = fb3c05a1783cf4147c5148ef2087f53fd7468da4dfbf2e2e4ee2b3e42eeb8a11492e5533d88c0ccf3d851f4bc34822b15da3eb9ae3509fea2573c88536f548e6
Size (hexedit-1.4.2.tar.gz) = 30179 bytes
SHA1 (patch-ae) = 49627dd5704fb9cd7b6ac08d01d3324ff2d2babd
SHA1 (patch-configure) = 847d7fbf644bc3af97c7deebf5b8c24675f4c4bd

View file

@ -1,108 +0,0 @@
$NetBSD: patch-configure,v 1.1 2013/10/16 21:59:30 roy Exp $
--- configure.orig 2013-10-16 21:54:45.000000000 +0000
+++ configure
@@ -3057,6 +3057,51 @@ test -z "$INSTALL_SCRIPT" && INSTALL_SCR
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
+# ac_fn_c_try_link LINENO
+# -----------------------
+# Try to link conftest.$ac_ext, and return whether this succeeded.
+ac_fn_c_try_link ()
+{
+ as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
+ rm -f conftest.$ac_objext conftest$ac_exeext
+ if { { ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
+$as_echo "$ac_try_echo"; } >&5
+ (eval "$ac_link") 2>conftest.err
+ ac_status=$?
+ if test -s conftest.err; then
+ grep -v '^ *+' conftest.err >conftest.er1
+ cat conftest.er1 >&5
+ mv -f conftest.er1 conftest.err
+ fi
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+ $as_test_x conftest$ac_exeext
+ }; then :
+ ac_retval=0
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_retval=1
+fi
+ # Delete the IPA/IPO (Inter Procedural Analysis/Optimization) information
+ # created by the PGI compiler (conftest_ipa8_conftest.oo), as it would
+ # interfere with the next link command; also delete a directory that is
+ # left behind by Apple's compiler. We do this before executing the actions.
+ rm -rf conftest.dSYM conftest_ipa8_conftest.oo
+ eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
+ as_fn_set_status $ac_retval
+
+} # ac_fn_c_try_link
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for initscr in -lcurses" >&5
$as_echo_n "checking for initscr in -lcurses... " >&6; }
@@ -3106,51 +3151,7 @@ else
LIBS="-lncurses $LIBS"
-# ac_fn_c_try_link LINENO
-# -----------------------
-# Try to link conftest.$ac_ext, and return whether this succeeded.
-ac_fn_c_try_link ()
-{
- as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
- rm -f conftest.$ac_objext conftest$ac_exeext
- if { { ac_try="$ac_link"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
-$as_echo "$ac_try_echo"; } >&5
- (eval "$ac_link") 2>conftest.err
- ac_status=$?
- if test -s conftest.err; then
- grep -v '^ *+' conftest.err >conftest.er1
- cat conftest.er1 >&5
- mv -f conftest.er1 conftest.err
- fi
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; } && {
- test -z "$ac_c_werror_flag" ||
- test ! -s conftest.err
- } && test -s conftest$ac_exeext && {
- test "$cross_compiling" = yes ||
- $as_test_x conftest$ac_exeext
- }; then :
- ac_retval=0
-else
- $as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
- ac_retval=1
-fi
- # Delete the IPA/IPO (Inter Procedural Analysis/Optimization) information
- # created by the PGI compiler (conftest_ipa8_conftest.oo), as it would
- # interfere with the next link command; also delete a directory that is
- # left behind by Apple's compiler. We do this before executing the actions.
- rm -rf conftest.dSYM conftest_ipa8_conftest.oo
- eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
- as_fn_set_status $ac_retval
-
-} # ac_fn_c_try_link
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */