Update to 0.15:

Experimental version released on January 16th, 2012.

* Respect stdin in atf-check.  The previous release silenced stdin for any
  processes spawned by atf, not only test programs, which caused breakage
  in tests that pipe data through atf-check.

* Performance improvements to atf-sh.

* Enabled detection of unused parameters and variables in the code and
  fixed all warnings.

* Changed the behavior of "developer mode".  Compiler warnings are now
  enabled unconditionally regardless of whether we are in developer mode or
  not; developer mode is now only used to perform strict warning checks and
  to enable assertions.  Additionally, developer mode is now only
  automatically enabled when building from the repository, not for formal
  releases.

* Added new Autoconf M4 macros (ATF_ARG_WITH, ATF_CHECK_C and
  ATF_CHECK_CXX) to provide a consistent way of defining a --with-arg flag
  in configure scripts and detecting the presence of any of the ATF
  bindings.  Note that ATF_CHECK_SH was already introduced in 0.14, but it
  has now been modified to also honor --with-atf if instantiated.

* Added timing support to atf-run / atf-report.

* Added support for a 'require.memory' property, to specify the minimum
  amount of physical memory needed by the test case to yield valid results.

* PR bin/45690: Force an ISO-8859-1 encoding in the XML files generated by
  atf-report so that invalid data in the output of test cases does not
  mangle our report.
This commit is contained in:
jmmv 2012-01-16 22:26:55 +00:00
parent 73afc268bb
commit de08b0f723
4 changed files with 11 additions and 23 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.17 2011/06/14 13:55:15 jmmv Exp $
# $NetBSD: Makefile,v 1.18 2012/01/16 22:26:55 jmmv Exp $
#
DISTNAME= atf-0.14
DISTNAME= atf-0.15
CATEGORIES= devel
MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/jmmv/atf/0.14/
MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/jmmv/atf/0.15/
MAINTAINER= jmmv@NetBSD.org
HOMEPAGE= http://www.NetBSD.org/~jmmv/atf/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.16 2011/06/14 13:55:15 jmmv Exp $
@comment $NetBSD: PLIST,v 1.17 2012/01/16 22:26:55 jmmv Exp $
bin/atf-config
bin/atf-report
bin/atf-run
@ -41,6 +41,9 @@ man/man3/atf-sh-api.3
man/man4/atf-test-case.4
man/man5/atf-formats.5
man/man7/atf.7
share/aclocal/atf-c++.m4
share/aclocal/atf-c.m4
share/aclocal/atf-common.m4
share/aclocal/atf-sh.m4
share/atf/atf-run.hooks
share/atf/libatf-sh.subr

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.15 2011/12/07 17:23:04 bsiegert Exp $
$NetBSD: distinfo,v 1.16 2012/01/16 22:26:55 jmmv Exp $
SHA1 (atf-0.14.tar.gz) = 657639873383a4fcc192a551c0fee3763f85454d
RMD160 (atf-0.14.tar.gz) = 8340c75d85f8973ecb4634794fa9de38b08f0ad1
Size (atf-0.14.tar.gz) = 617893 bytes
SHA1 (patch-atf-c_detail_process__test.c) = 0d3033d5b913709adcaed3f0005d1c2976f668ba
SHA1 (atf-0.15.tar.gz) = dd6c9074a0b6a5d6a0c4d987138f733b1bb90ef9
RMD160 (atf-0.15.tar.gz) = ebbc113321c1b2065a5e8f3b019676c47b090859
Size (atf-0.15.tar.gz) = 625384 bytes

View file

@ -1,14 +0,0 @@
$NetBSD: patch-atf-c_detail_process__test.c,v 1.1 2011/12/07 17:23:05 bsiegert Exp $
--- atf-c/detail/process_test.c.orig Sun Aug 21 01:01:24 2011
+++ atf-c/detail/process_test.c
@@ -28,8 +28,8 @@
*/
#include <sys/types.h>
-#include <sys/resource.h>
#include <sys/time.h>
+#include <sys/resource.h>
#include <sys/wait.h>
#include <errno.h>