PR 56708 John Klos: audio/libvorbis fails on macOS El Capitan

When including <stdint.h>, use the types it defines, not the legacy
ones with extra (internal) underscores.
This commit is contained in:
dholland 2022-05-15 05:50:49 +00:00
parent a6124c4ce3
commit de291e4c22
2 changed files with 18 additions and 8 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.19 2021/10/26 11:01:10 nia Exp $
$NetBSD: distinfo,v 1.20 2022/05/15 05:50:49 dholland Exp $
BLAKE2s (libogg-1.3.5.tar.xz) = 85854a6a2f8a2c5073b2f2f0afe6191ff5f20cdfe93d5804084d66700cb1ab7e
SHA512 (libogg-1.3.5.tar.xz) = 5d1cbc2a3a1fcf5543f5729bd5eb560cfc740c5d17a2492ead137970c45e6203ec1f5de536d77c4b73ece9e3b0046eaa9181c02a09de72ac7ae51b1fca1e1ee7
Size (libogg-1.3.5.tar.xz) = 429076 bytes
SHA1 (patch-configure) = 0fd4901eac9d5325185ab42935fa92a80eef34c5
SHA1 (patch-include_ogg_os__types.h) = 001ac30d920b02cd5dbb51883fdacf237e2613bf
SHA1 (patch-include_ogg_os__types.h) = 706ee71a4e86bb739bdc1fca6b2b5cb06abea6b8

View file

@ -1,17 +1,27 @@
$NetBSD: patch-include_ogg_os__types.h,v 1.2 2021/06/07 09:12:32 adam Exp $
$NetBSD: patch-include_ogg_os__types.h,v 1.3 2022/05/15 05:50:49 dholland Exp $
use stdint.h on macos
This was broken by a recent change. See comments in:
https://gitlab.xiph.org/xiph/ogg/issues/2294
also use the types that are defined by stdint.h, not the legacy ones.
--- include/ogg/os_types.h.orig 2021-06-07 08:37:18.000000000 +0000
See https://gitlab.xiph.org/xiph/ogg/issues/2294
--- include/ogg/os_types.h.orig 2020-05-04 17:14:04.000000000 +0000
+++ include/ogg/os_types.h
@@ -70,7 +70,7 @@
@@ -70,13 +70,13 @@
#elif (defined(__APPLE__) && defined(__MACH__)) /* MacOS X Framework build */
-# include <sys/types.h>
+# include <stdint.h>
typedef int16_t ogg_int16_t;
typedef u_int16_t ogg_uint16_t;
- typedef u_int16_t ogg_uint16_t;
+ typedef uint16_t ogg_uint16_t;
typedef int32_t ogg_int32_t;
- typedef u_int32_t ogg_uint32_t;
+ typedef uint32_t ogg_uint32_t;
typedef int64_t ogg_int64_t;
- typedef u_int64_t ogg_uint64_t;
+ typedef uint64_t ogg_uint64_t;
#elif defined(__HAIKU__)