libreplaygain: Support user CFLAGS.

This commit is contained in:
jperkin 2017-12-15 16:00:19 +00:00
parent 919959070d
commit de38a479cb
3 changed files with 25 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1 2014/04/18 12:41:09 wiz Exp $ # $NetBSD: Makefile,v 1.2 2017/12/15 16:00:19 jperkin Exp $
DISTNAME= libreplaygain_r475 DISTNAME= libreplaygain_r475
PKGNAME= libreplaygain-0rc475 PKGNAME= libreplaygain-0rc475
@ -13,6 +13,11 @@ LICENSE= gnu-lgpl-v2.1
USE_CMAKE= yes USE_CMAKE= yes
INSTALLATION_DIRS= include/replaygain INSTALLATION_DIRS= include/replaygain
SUBST_CLASSES+= crlf
SUBST_STAGE.crlf= post-extract
SUBST_FILES.crlf= CMakeLists.txt
SUBST_FILTER_CMD.crlf= ${TR} -d '\r'
post-install: post-install:
${INSTALL_DATA} ${WRKSRC}/include/replaygain/* ${DESTDIR}${PREFIX}/include/replaygain ${INSTALL_DATA} ${WRKSRC}/include/replaygain/* ${DESTDIR}${PREFIX}/include/replaygain

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2015/11/03 01:12:38 agc Exp $ $NetBSD: distinfo,v 1.3 2017/12/15 16:00:19 jperkin Exp $
SHA1 (libreplaygain_r475.tar.gz) = 7739b4b9cf46e0846663f707a9498a4db0345eaf SHA1 (libreplaygain_r475.tar.gz) = 7739b4b9cf46e0846663f707a9498a4db0345eaf
RMD160 (libreplaygain_r475.tar.gz) = b61b087d2b795d8f8dce1bad917dc78fb0170430 RMD160 (libreplaygain_r475.tar.gz) = b61b087d2b795d8f8dce1bad917dc78fb0170430
SHA512 (libreplaygain_r475.tar.gz) = b5fce8daf6aa8c8e0adb4c80089b43824b6503cb7d11e0c47c779c57a933b32f0c24722ca3fcf49711199fddcbb92c3fc13876f22418ca1521c7b8e27ba9d409 SHA512 (libreplaygain_r475.tar.gz) = b5fce8daf6aa8c8e0adb4c80089b43824b6503cb7d11e0c47c779c57a933b32f0c24722ca3fcf49711199fddcbb92c3fc13876f22418ca1521c7b8e27ba9d409
Size (libreplaygain_r475.tar.gz) = 8693 bytes Size (libreplaygain_r475.tar.gz) = 8693 bytes
SHA1 (patch-CMakeLists.txt) = e222ce812c5aed4812eacf05170f79ab9ec462e0

View file

@ -0,0 +1,17 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2017/12/15 16:00:19 jperkin Exp $
Support user CFLAGS.
--- CMakeLists.txt.orig 2017-12-15 15:54:13.974668000 +0000
+++ CMakeLists.txt
@@ -4,8 +4,4 @@ project(libreplaygain C)
set(CMAKE_VERBOSE_MAKEFILE false)
-if(NOT MSVC)
-set(CMAKE_C_FLAGS "-O3 -fomit-frame-pointer -pipe")
-endif(NOT MSVC)
-
-add_subdirectory(src)
\ No newline at end of file
+add_subdirectory(src)