Depend on firefox3 instead of firefox2.

XXX only build tested, I'm not yet sure if the build fix in patch-af is
correct or if more fixes are needed.
This commit is contained in:
tnn 2009-04-21 16:58:18 +00:00
parent 94f62af98a
commit de4e8d58ab
4 changed files with 29 additions and 5 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.11 2008/10/20 07:46:52 wiz Exp $
# $NetBSD: Makefile,v 1.12 2009/04/21 16:58:18 tnn Exp $
#
BROWSER= firefox
BROWSER= firefox3
CONFIGURE_ARGS+= --disable-gtk1
.include "Makefile.common"
.include "../../www/firefox/buildlink3.mk"
.include "../../www/firefox3/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.20 2008/10/20 07:45:57 wiz Exp $
# $NetBSD: Makefile.common,v 1.21 2009/04/21 16:58:18 tnn Exp $
#
DISTNAME= mplayerplug-in-${DIST_VER}
@ -42,6 +42,7 @@ post-extract:
-e "s|@X11BASELIB@|${X11BASE}/lib|g" \
${FILESDIR}/mozilla-${f}.pc.in > ${WRKSRC}/mozilla-${f}.pc
.endfor
_PKG_CONFIG_LIBDIR= ${BUILDLINK_DIR}/lib/pkgconfig:${WRKSRC}
SUBST_CLASSES+= conf
SUBST_STAGE.conf= post-patch

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2008/10/20 07:45:58 wiz Exp $
$NetBSD: distinfo,v 1.7 2009/04/21 16:58:18 tnn Exp $
SHA1 (mplayerplug-in-3.55.tar.gz) = 69726d4e16523b1a39c284efee081c31b0ea7f7f
RMD160 (mplayerplug-in-3.55.tar.gz) = e01224b14883a93211745be0a329a3f524f39d8c
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 2a6724f536ad8a08c7766dfb269458df12bb3603
SHA1 (patch-ab) = 950bec845ef3120e8b63a2343e79d5ded99a8bfa
SHA1 (patch-ad) = 06699a71bb0f8da969d11a812a544e3aefa4d9a7
SHA1 (patch-ae) = 885eafce6747ed1f682eb78a6e15a473806924e3
SHA1 (patch-af) = 812a4921c4a467fbf6163292f04ef5888ef6e8ed

View file

@ -0,0 +1,22 @@
$NetBSD: patch-af,v 1.1 2009/04/21 16:58:18 tnn Exp $
--- Source/nsIScriptableMplayerPlugin.h.orig 2008-06-24 15:12:54.000000000 +0200
+++ Source/nsIScriptableMplayerPlugin.h
@@ -25,7 +25,7 @@
class NS_NO_VTABLE nsIScriptableWMPPlugin : public nsISupports {
public:
- NS_DEFINE_STATIC_IID_ACCESSOR(NS_ISCRIPTABLEWMPPLUGIN_IID)
+ NS_DECLARE_STATIC_IID_ACCESSOR(NS_ISCRIPTABLEWMPPLUGIN_IID)
/* void play (); */
NS_IMETHOD Play(void) = 0;
@@ -120,7 +120,7 @@ NS_IMETHODIMP nsScriptableWMPPlugin::Sto
class NS_NO_VTABLE nsIScriptableMplayerPlugin : public nsISupports {
public:
- NS_DEFINE_STATIC_IID_ACCESSOR(NS_ISCRIPTABLEMPLAYERPLUGIN_IID)
+ NS_DECLARE_STATIC_IID_ACCESSOR(NS_ISCRIPTABLEMPLAYERPLUGIN_IID)
/* void Play (); */
NS_IMETHOD Play(void) = 0;