Update tmux to 1.8.
Incompatible Changes ==================== * layout redo/undo has been removed. Normal Changes ============== * Add halfpage up/down bindings to copy mode. * Session choosing fixed to work with unattached sessions. * New window options window-status-last-{attr,bg,fg} to denote the last window which was active. * Scrolling in copy-mode now scrolls the region without moving the mouse cursor. * run-shell learnt '-t' to specify the pane to use when displaying output. * Support for middle-click pasting. * choose-tree learns '-u' to start uncollapsed. * select-window learnt '-T; to toggle to the last window if it's already current. * New session option 'assume-paste-time' for pasting text versus key-binding actions. * choose-* commands now work outside of an attached client. * Aliases are now shown for list-commands command. * Status learns about formats. * Free-form options can be set with set-option if prepended with an '@' sign. * capture-pane learnt '-p' to send to stdout, and '-e' for capturing escape sequences, and '-a' to capture the alternate screen, and '-P' to dump pending output. * Many new formats added (client_session, client_last_session, etc.) * Control mode, which is a way for a client to send tmux commands. Currently more useful to users of iterm2. * resize-pane learnt '-x' and '-y' for absolute pane sizing. * Config file loading now reports errors from all files which are loaded via the 'source-file' command. * 'copy-pipe' mode command to copy selection and pipe the selection to a command. * Changes panes can now emit focus notifications for certain applications which use those. * run-shell and if-shell now accept format placeholders. * resize-pane learnt '-Z' for zooming a pane temporarily. * new-session learnt '-A' to make it behave like attach-session. * set-option learnt '-o' to prevent setting an option which is already set. * capture-pane and show-options learns '-q' to silence errors. * New command 'wait-for' which blocks a client until woken up again. * Resizing panes will now reflow the text inside them. * Lots and lots of bug fixes, fixing memory-leaks, etc. * Various manpage improvements.
This commit is contained in:
parent
2950da398b
commit
de9f0125f4
3 changed files with 25 additions and 8 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.21 2013/02/06 23:23:03 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2013/04/02 10:59:50 fhajny Exp $
|
||||
|
||||
DISTNAME= tmux-1.7
|
||||
PKGREVISION= 1
|
||||
DISTNAME= tmux-1.8
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=tmux/}
|
||||
|
||||
|
@ -17,7 +16,7 @@ USE_TERMINFO= yes
|
|||
.include "../../mk/compiler.mk"
|
||||
.if !empty(MACHINE_PLATFORM:MSunOS-5.1[0-9]-*) && \
|
||||
!empty(CC_VERSION:Mgcc-4.[6-9].*)
|
||||
BUILDLINK_TRANSFORM+= rename:-D_XPG4_2:-D_XPG6
|
||||
BUILDLINK_TRANSFORM+= rename:-D_XPG4_2:-D_XPG6
|
||||
.endif
|
||||
|
||||
.include "../../devel/libevent/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.19 2013/01/08 12:36:07 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.20 2013/04/02 10:59:50 fhajny Exp $
|
||||
|
||||
SHA1 (tmux-1.7.tar.gz) = ee6942a1bc3fc650036f26921d80bc4b73d56df6
|
||||
RMD160 (tmux-1.7.tar.gz) = ff4f5fec48627378654c902ff0bee49a4ceaa026
|
||||
Size (tmux-1.7.tar.gz) = 407164 bytes
|
||||
SHA1 (tmux-1.8.tar.gz) = 08677ea914e1973ce605b0008919717184cbd033
|
||||
RMD160 (tmux-1.8.tar.gz) = b267ab54f6f55292fa1fa9cd0e892bfd5fd27cfb
|
||||
Size (tmux-1.8.tar.gz) = 417537 bytes
|
||||
SHA1 (patch-client.c) = e37053d721bd26d31783af883a7d1f6870095325
|
||||
SHA1 (patch-server-client.c) = 6c8dd82e2dc1965b8c8f9a8808a262366c80d6b4
|
||||
|
|
17
misc/tmux/patches/patch-server-client.c
Normal file
17
misc/tmux/patches/patch-server-client.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-server-client.c,v 1.1 2013/04/02 10:59:50 fhajny Exp $
|
||||
|
||||
SunOS errno support needs the right include.
|
||||
|
||||
--- server-client.c.orig 2013-04-02 10:54:02.404886167 +0000
|
||||
+++ server-client.c
|
||||
@@ -26,6 +26,10 @@
|
||||
#include <time.h>
|
||||
#include <unistd.h>
|
||||
|
||||
+#ifdef __sun
|
||||
+#include <errno.h>
|
||||
+#endif
|
||||
+
|
||||
#include "tmux.h"
|
||||
|
||||
void server_client_check_focus(struct window_pane *);
|
Loading…
Reference in a new issue