neomutt: build fix on illumos/SmartOS

This commit is contained in:
tm 2020-01-16 13:52:39 +00:00
parent 1e368078b4
commit dec0f82262
3 changed files with 21 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.51 2019/12/18 13:47:58 wiz Exp $
# $NetBSD: Makefile,v 1.52 2020/01/16 13:52:39 tm Exp $
DISTNAME= neomutt-20191129
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GITHUB:=neomutt/}
GITHUB_TAG= ${PKGVERSION_NOREV}
@ -15,12 +16,15 @@ USE_TOOLS+= msgfmt gmake
BUILD_DEPENDS+= gettext-tools-[0-9]*:../../devel/gettext-tools
BUILD_DEPENDS+= libxslt-[0-9]*:../../textproc/libxslt
BUILD_DEPENDS+= docbook-xsl-[0-9]*:../../textproc/docbook-xsl
BUILD_DEPENDS+= w3m-[0-9]*:../../www/w3m
HAS_CONFIGURE= yes
EXTRACT_USING= bsdtar
CONFIGURE_ARGS+= --prefix=${PREFIX}
CONFIGURE_ARGS+= --mandir=${PREFIX}/${PKGMANDIR}
CONFIGURE_ARGS.SunOS+= --disable-inotify
EGDIR= ${PREFIX}/share/examples/neomutt
CONF_FILES= ${EGDIR}/neomuttrc ${PKG_SYSCONFDIR}/neomuttrc
INSTALLATION_DIRS+= ${EGDIR}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.38 2019/12/18 13:47:58 wiz Exp $
$NetBSD: distinfo,v 1.39 2020/01/16 13:52:39 tm Exp $
SHA1 (neomutt-20191129-20191129.tar.gz) = 067db7dcd11c19bf0ab6c51d4a1c09563b6fc803
RMD160 (neomutt-20191129-20191129.tar.gz) = 36f94c043e00b81a2e240f989f6ac4375431cd84
SHA512 (neomutt-20191129-20191129.tar.gz) = 5c39664820ed1a9ac00f5f158f8e96974a700df1edf8ba0615e761140c9ceba9b65ab7a9b87a31f5d6636c6b678b730483f3a15ea239144ce2ec36aa4b649f1d
Size (neomutt-20191129-20191129.tar.gz) = 3227652 bytes
SHA1 (patch-resize.c) = b747f878459950462d56e01bada2d01b49fca088

View file

@ -0,0 +1,14 @@
$NetBSD: patch-resize.c,v 1.3 2020/01/16 13:52:39 tm Exp $
Required to have the correct struct information for winsize.
--- resize.c.orig 2019-11-29 15:02:20.000000000 +0000
+++ resize.c
@@ -43,6 +43,7 @@
#include <ioctl.h>
#endif
#endif
+#include <termios.h>
/**
* mutt_get_winsize - Use an ioctl to get the window size