guile: fix build with GNU texinfo 6.7
GNU texinfo 6.7 fails to parse api-compound.texi because of an unnecessary non-breaking space character (code point 160). (Whereas GNU texinfo 6.5 succeeds there, as does the old C source version bundled with NetBSD's userland.) utf8 "\xA0" does not map to Unicode at ParserNonXS.pm line 1796, <FH> line 908. Malformed UTF-8 character: \xa0 (unexpected continuation byte 0xa0, with no preceding start byte) in pattern match (m//) at ParserNonXS.pm line 3364. Malformed UTF-8 character (fatal) at ParserNonXS.pm line 3364. It's simpler to just replace the byte in that source file with an ASCII space character than attempt to fix the texinfo parsing code (and we're in a freeze right now, too). This should fix the bulk build failures on SmartOS and others.
This commit is contained in:
parent
e31e716085
commit
df1bdf1e25
3 changed files with 20 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.111 2019/07/14 21:46:22 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.112 2019/12/24 01:42:53 gutteridge Exp $
|
||||
|
||||
DISTNAME= guile-1.8.8
|
||||
PKGREVISION= 9
|
||||
PKGREVISION= 10
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=guile/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.51 2018/06/19 11:07:25 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.52 2019/12/24 01:42:53 gutteridge Exp $
|
||||
|
||||
SHA1 (guile-1.8.8.tar.gz) = 548d6927aeda332b117f8fc5e4e82c39a05704f9
|
||||
RMD160 (guile-1.8.8.tar.gz) = 8ac185a72ad8394b14d5377549e5bbf02889faaa
|
||||
|
@ -13,6 +13,7 @@ SHA1 (patch-al) = 6a5fb3136028bb5a5185ce7174a20d5f9d227e18
|
|||
SHA1 (patch-am) = 7a549811ef98f40a6a87f31840109ee2a091489b
|
||||
SHA1 (patch-an) = 89ee76c4e74a7af3a5e2a8e65d889292de1768f1
|
||||
SHA1 (patch-ao) = b648826c5e951cd98ca6e2cdf48435cbdba096ff
|
||||
SHA1 (patch-doc_ref_api-compound.texi) = ba389b94b94abc8944851b35d2d63f920ef7b0ab
|
||||
SHA1 (patch-doc_ref_fdl.texi) = c7e70f9b30f792dd38c18550739673d255f9fc5c
|
||||
SHA1 (patch-doc_ref_gh.texi) = b6b841102111d5c5813ba729c9c0ebfb3d6ca1e0
|
||||
SHA1 (patch-doc_tutorial_guile-tut.texi) = 5ad2c5942dc7715344115847793bd4f2eaacd7ca
|
||||
|
|
16
lang/guile/patches/patch-doc_ref_api-compound.texi
Normal file
16
lang/guile/patches/patch-doc_ref_api-compound.texi
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-doc_ref_api-compound.texi,v 1.1 2019/12/24 01:42:53 gutteridge Exp $
|
||||
|
||||
Remove an unnecessary non-breaking space character (code point 160)
|
||||
that caused GNU texinfo 6.7 to fail during parsing.
|
||||
|
||||
--- doc/ref/api-compound.texi.orig 2010-12-13 17:24:39.000000000 +0000
|
||||
+++ doc/ref/api-compound.texi
|
||||
@@ -905,7 +905,7 @@ Sets the element at position @var{idx} i
|
||||
@end deftypefn
|
||||
|
||||
@deftypefn {C Function} {const SCM *} scm_vector_elements (SCM vec, scm_t_array_handle *handle, size_t *lenp, ssize_t *incp)
|
||||
-Acquire a handle for the vector @var{vec} and return a pointer to the
|
||||
+Acquire a handle for the vector @var{vec} and return a pointer to the
|
||||
elements of it. This pointer can only be used to read the elements of
|
||||
@var{vec}. When @var{vec} is not a vector, an error is signaled. The
|
||||
handle mustr eventually be released with
|
Loading…
Reference in a new issue