Update to latest stable, 4.0.0. Buildlink pthread. Move disabling of
trace and debug configure arguments to options.mk under the debug PKG_OPTION. From ChangeLog: libosip2 (4.0.0) * implement time compensation for android. * reduce path len // remove path in front of logs. * accept only SIP/D.D format message. * fix bug when releasing request with missing major headers. * fix minor memory leak // remove limitation on fifo size. * add system time support for macosx and ios. * use system independant time for osip_gettimeofday on unix platform. * To compile/use osip based application in multi threaded env, you don't need to define -DOSIP_MT any more. Instead, if you wish to disable the feature, you can compile with -DOSIP_MONOTHREAD. * A few other clean up were made inside osip to avoid any define to appear in include files. Also to avoid conflict, config.h has been renamed to osip-config.h.
This commit is contained in:
parent
212df00dc6
commit
df302d9724
4 changed files with 53 additions and 41 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.16 2012/10/31 11:17:19 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2013/07/14 14:55:16 rodent Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libosip2-3.6.0
|
||||
DISTNAME= libosip2-4.0.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=osip/}
|
||||
|
||||
|
@ -15,10 +15,9 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --disable-debug
|
||||
CONFIGURE_ARGS+= --disable-trace
|
||||
CONFIGURE_ARGS+= --enable-md5
|
||||
PKGCONFIG_OVERRIDE+= libosip2.pc.in
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.12 2011/12/19 12:56:04 schwarz Exp $
|
||||
$NetBSD: distinfo,v 1.13 2013/07/14 14:55:16 rodent Exp $
|
||||
|
||||
SHA1 (libosip2-3.6.0.tar.gz) = 6d81be8180a46e045fce676d55913433a5e147c8
|
||||
RMD160 (libosip2-3.6.0.tar.gz) = e74d34dcdaa953f694e4ceaf93919aa4784d8afa
|
||||
Size (libosip2-3.6.0.tar.gz) = 598496 bytes
|
||||
SHA1 (patch-aa) = c0b9121aa56ccf2e0fb78e943ceffbc4109ba4b0
|
||||
SHA1 (libosip2-4.0.0.tar.gz) = 8b773ad63079ad5e1dc329f73ee8d05ca74ecde4
|
||||
RMD160 (libosip2-4.0.0.tar.gz) = 686b9308e3738f11b5a1590457d55c7f6d6fb002
|
||||
Size (libosip2-4.0.0.tar.gz) = 644958 bytes
|
||||
SHA1 (patch-aa) = 509b67cd5f62baf1ba1a3894a54949ef3e242e81
|
||||
|
|
13
devel/libosip/options.mk
Normal file
13
devel/libosip/options.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: options.mk,v 1.1 2013/07/14 14:55:16 rodent Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.libosip
|
||||
PKG_SUPPORTED_OPTIONS= debug
|
||||
PKG_SUGGESTED_OPTIONS+= # blank
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdebug)
|
||||
CONFIGURE_ARGS+= --enable-debug --enable-trace
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-debug --disable-trace
|
||||
.endif
|
|
@ -1,28 +1,28 @@
|
|||
$NetBSD: patch-aa,v 1.5 2011/02/19 17:02:57 schwarz Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2013/07/14 14:55:16 rodent Exp $
|
||||
|
||||
--- src/osip2/port_sema.c.orig 2011-01-28 23:06:14.000000000 +0100
|
||||
+++ src/osip2/port_sema.c 2011-01-28 23:08:19.000000000 +0100
|
||||
@@ -281,7 +281,6 @@
|
||||
|
||||
struct osip_sem *osip_sem_init(unsigned int value)
|
||||
--- src/osip2/port_sema.c.orig 2012-11-16 21:24:10.000000000 +0000
|
||||
+++ src/osip2/port_sema.c
|
||||
@@ -302,7 +302,6 @@ osip_sem_trywait (struct osip_sem *_sem)
|
||||
struct osip_sem *
|
||||
osip_sem_init (unsigned int value)
|
||||
{
|
||||
- union semun val;
|
||||
int i;
|
||||
osip_sem_t *sem = (osip_sem_t *) osip_malloc(sizeof(osip_sem_t));
|
||||
osip_sem_t *sem = (osip_sem_t *) osip_malloc (sizeof (osip_sem_t));
|
||||
|
||||
@@ -294,8 +293,7 @@
|
||||
osip_free(sem);
|
||||
@@ -315,8 +314,7 @@ osip_sem_init (unsigned int value)
|
||||
osip_free (sem);
|
||||
return NULL;
|
||||
}
|
||||
- val.val = (int) value;
|
||||
- i = semctl(sem->semid, 0, SETVAL, val);
|
||||
- i = semctl (sem->semid, 0, SETVAL, val);
|
||||
+ i = semctl(sem->semid, 0, SETVAL, value);
|
||||
if (i != 0) {
|
||||
perror("semctl error");
|
||||
osip_free(sem);
|
||||
@@ -306,13 +304,11 @@
|
||||
|
||||
int osip_sem_destroy(struct osip_sem *_sem)
|
||||
perror ("semctl error");
|
||||
osip_free (sem);
|
||||
@@ -328,13 +326,11 @@ osip_sem_init (unsigned int value)
|
||||
int
|
||||
osip_sem_destroy (struct osip_sem *_sem)
|
||||
{
|
||||
- union semun val;
|
||||
osip_sem_t *sem = (osip_sem_t *) _sem;
|
||||
|
@ -30,8 +30,8 @@ $NetBSD: patch-aa,v 1.5 2011/02/19 17:02:57 schwarz Exp $
|
|||
if (sem == NULL)
|
||||
return OSIP_SUCCESS;
|
||||
- val.val = 0;
|
||||
- semctl(sem->semid, 0, IPC_RMID, val);
|
||||
- semctl (sem->semid, 0, IPC_RMID, val);
|
||||
+ semctl(sem->semid, 0, IPC_RMID, 0);
|
||||
osip_free(sem);
|
||||
osip_free (sem);
|
||||
return OSIP_SUCCESS;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue