Update to unixODBC 2.3.0:
2.3.0 * Try and rationalise the way the connection process find the driver version and supported functions * Sort out problem in isql with blank lines * Stop libthread from being used under AIX * Move the GUI parts off into a new project http://sourceforge.net/projects/unixodbc-gui-qt/ * Strip out the GUI parts. I have also removed the spec files as they will need redoing, * Move the Test parts off into a new project http://sourceforge.net/projects/unixodbc-test/ * Add interface into odbcinstQ to allow for a dialog if SQLDriverConnect is called without a DSN= (as the MS spec) * Allow the setting of a default Threading level in the ODBC section of odbcinst.ini * Change double format string in Postgre7.1 driver * Add missing CR to output of odbcinst * add fixes to MiniSQL driver * Add missing .y in nn driver, now I need to get it to work * Assoured bux fixes and format problems, thanks Tom * SQLBindCol on metadata calls was incorrectly going via the cursor lib if it * fix isql problem with nested definitions. was enabled * Add configure option to enable building of driver config libs * Shift build to using config.h, the compile lines were so big it was hard to see warnings * Fix bug in isql when using -b option. * Check attribute values when setting connection and statement attrs * Check for valid pointers in SQLGetInfo(W) and SQLGetFunctions * Add extra checks for states in SQLCopyDesc * Add --enable-stricterror option to allow compliance with the error reporting definition, driver errors don't have the unixODBC prefix * Check for statements in the NEED_DATA state when calling SQLEndTran * Extra error check for SQLPutData * Check handle type in SQLEndTran * Prevent seg fault if there are no driver error functions * the -n option to isql was not working correctly * Stripped out all the bespoke LDTL configure stull, not just what libtoolize provides * Fix problem where ansi_to_unicode_alloc didn't leave space for the NULL and could cause memory corruption * Add the ODBC 3.80 additions that MS have produced. I am sure I remember the standard being given to XOpen, what do I know :-) * Change the file open mode for the ini file from w to w+ just in case the original open failed but the file did exist * Fix configure problem preventing the CHAR encoding from being passed * Remove white spave from ini write, not all drivers use unixODBC ini functions and can handle the spaces * Update config.guess to current GNU version including support for AIX6 * Create SVN repository at sourceforge * Add cast to fix problem in SQLSetConnectOption * Fix SQLINTEGER<->SQLLEN conversion broblem in SQLNativeSQL * Fix bug that stopped setting SQL_ATTR_CONCURRENCY to SQL_CONCUR_VALUES * Change minor version number because of the SQLLEN change * Remove unintended trailing white space from log generation
This commit is contained in:
parent
52c3dba884
commit
df758f2275
14 changed files with 139 additions and 67 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.27 2009/12/15 21:33:49 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
DISTNAME= unixODBC-2.2.14
|
||||
DISTNAME= unixODBC-2.3.0
|
||||
PKGNAME= ${DISTNAME:S/ODBC/odbc/}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.unixodbc.org/
|
||||
|
||||
|
@ -36,7 +35,7 @@ post-patch: fix-ltdl-and-lexlib
|
|||
|
||||
fix-driver-installation:
|
||||
cd ${WRKSRC}; \
|
||||
files=`${FIND} ODBCConfig DRVConfig Drivers -name Makefile.in -print`;\
|
||||
files=`${FIND} DRVConfig Drivers -name Makefile.in -print`;\
|
||||
for file in $${files}; do \
|
||||
sed -e "s|^\(libdir =\).*|\1 ${PREFIX}/${UNIXODBC_DRIVERS_DIR}|g" \
|
||||
$${file} >> $${file}.fixed; \
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2009/10/19 08:37:39 taca Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2010/05/03 02:10:43 jnemeth Exp $
|
||||
bin/dltest
|
||||
bin/isql
|
||||
bin/iusql
|
||||
bin/odbc_config
|
||||
bin/odbcinst
|
||||
include/autotest.h
|
||||
include/odbcinst.h
|
||||
include/odbcinstext.h
|
||||
include/sql.h
|
||||
|
@ -14,8 +13,6 @@ include/sqlucode.h
|
|||
include/unixodbc_conf.h
|
||||
include/uodbc_extras.h
|
||||
include/uodbc_stats.h
|
||||
lib/libboundparam.la
|
||||
lib/libgtrtst.la
|
||||
lib/libodbc.la
|
||||
lib/libodbccr.la
|
||||
lib/libodbcinst.la
|
||||
|
|
|
@ -1,14 +1,18 @@
|
|||
$NetBSD: distinfo,v 1.9 2009/10/21 04:21:27 taca Exp $
|
||||
$NetBSD: distinfo,v 1.10 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
SHA1 (unixODBC-2.2.14.tar.gz) = ab18464c83d30d7b38b8bb58e1dd01e3ec211488
|
||||
RMD160 (unixODBC-2.2.14.tar.gz) = e2a2d2de636a8b2ee1002cac809ba2a38d7eb4de
|
||||
Size (unixODBC-2.2.14.tar.gz) = 2189755 bytes
|
||||
SHA1 (patch-aa) = db3b99dc6afe4263c41423ef276dba8c98a55877
|
||||
SHA1 (patch-ab) = 7a35dcbc76b7d8b6b50bb1685180874f70c51141
|
||||
SHA1 (patch-ac) = 2e754242b2a1c90fb07e4cabb0bd537fd8eeb1a2
|
||||
SHA1 (unixODBC-2.3.0.tar.gz) = b2839b5210906e3ee286a4b621f177db9c7be7a8
|
||||
RMD160 (unixODBC-2.3.0.tar.gz) = 166a96c31fe013ced6b6ef93da5871f672cfe456
|
||||
Size (unixODBC-2.3.0.tar.gz) = 1804749 bytes
|
||||
SHA1 (patch-aa) = afca440d5765170a33abcb3356f9a21f0f8eec0a
|
||||
SHA1 (patch-ac) = 8925e66b81fa8896badcafda6af5dae9edbda753
|
||||
SHA1 (patch-ad) = b2e695d8c8c682c99af80e362369b0295070c1ab
|
||||
SHA1 (patch-ae) = 0d54c7fe9b42a5b5eb2f8c31176a30a7fb49d183
|
||||
SHA1 (patch-af) = e011c95867a10ae52a9362d0ebdf2fcdc2a92f8a
|
||||
SHA1 (patch-ag) = 1be22add8724176cf97c2e7c78fc069638c3c386
|
||||
SHA1 (patch-ah) = 56d19fa526867fe4bb7462d8a4b25cb580cdff2d
|
||||
SHA1 (patch-ah) = 1e34c499331dfda64b47b1eda27c6485d0d43fb9
|
||||
SHA1 (patch-ai) = 9b147d7a751b10795b5685249c7d8430dcf15936
|
||||
SHA1 (patch-aj) = 538c4335791e913a91e7541f2d2780b162a53848
|
||||
SHA1 (patch-ak) = c5b3b0d7c8888f18b7534dfd787d9c90fecbf943
|
||||
SHA1 (patch-al) = 350c2562cad9b72e41a5f3cb38df39e4f5624199
|
||||
SHA1 (patch-am) = 095ed0aa4e5882160fbf50d53c09ea23eafe1589
|
||||
SHA1 (patch-an) = e3ce589f9dd7e97fa1dac43b9fbe981a352e8f0b
|
||||
SHA1 (patch-ao) = db7d39c31e478162afa48e3effde2d60f0f6cc46
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.5 2009/10/19 08:37:39 taca Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- Makefile.in.orig 2008-11-20 01:11:38.000000000 +0900
|
||||
--- Makefile.in.orig 2010-02-24 16:52:24.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -700,9 +700,6 @@ uninstall-info: uninstall-info-recursive
|
||||
@@ -796,9 +796,6 @@ uninstall-am:
|
||||
|
||||
|
||||
install-data-am:
|
||||
|
@ -10,5 +10,5 @@ $NetBSD: patch-aa,v 1.5 2009/10/19 08:37:39 taca Exp $
|
|||
- -touch $(DESTDIR)${sysconfdir}/odbc.ini
|
||||
- -mkdir -p $(DESTDIR)${sysconfdir}/ODBCDataSources
|
||||
$(DESTDIR)${bindir}/odbc_config --header > $(DESTDIR)${includedir}/unixodbc_conf.h
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2009/10/17 01:59:15 taca Exp $
|
||||
|
||||
--- Drivers/Makefile.in.orig 2008-11-20 01:11:03.000000000 +0900
|
||||
+++ Drivers/Makefile.in
|
||||
@@ -224,7 +224,6 @@ subdirs = @subdirs@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@DRIVERS_TRUE@SUBDIRS = \
|
||||
-@DRIVERS_TRUE@ PostgreSQL \
|
||||
@DRIVERS_TRUE@ Postgre7.1 \
|
||||
@DRIVERS_TRUE@ odbc \
|
||||
@DRIVERS_TRUE@ template \
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ac,v 1.1 2009/04/23 19:43:06 schwarz Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- Drivers/Postgre7.1/md5.h.orig 2009-04-20 23:47:18.000000000 +0200
|
||||
+++ Drivers/Postgre7.1/md5.h 2009-04-20 23:48:30.000000000 +0200
|
||||
--- Drivers/Postgre7.1/md5.h.orig 2009-12-11 16:54:08.000000000 +0000
|
||||
+++ Drivers/Postgre7.1/md5.h
|
||||
@@ -13,6 +13,9 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2009/10/21 04:21:27 taca Exp $
|
||||
|
||||
* Avoid to call call __SQLGetInfo() twice since __SQLGetInfo() calls
|
||||
thread_release() internally and it cause unlocking unlocked mutex.
|
||||
|
||||
--- DriverManager/SQLConnect.c.orig 2008-09-29 23:02:43.000000000 +0900
|
||||
+++ DriverManager/SQLConnect.c
|
||||
@@ -2086,11 +2086,13 @@ int __connect_part_two( DMHDBC connectio
|
||||
char txt[ 20 ];
|
||||
SQLRETURN ret;
|
||||
|
||||
+#if 0
|
||||
ret = __SQLGetInfo( connection,
|
||||
SQL_DRIVER_ODBC_VER,
|
||||
txt,
|
||||
sizeof( txt ),
|
||||
NULL );
|
||||
+#endif
|
||||
|
||||
if ( SQL_SUCCEEDED( ret ))
|
||||
{
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-ah,v 1.1 2009/10/21 04:21:27 taca Exp $
|
||||
$NetBSD: patch-ah,v 1.2 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
* Call function_return() with IGNORE_THREAD after calling thread_release().
|
||||
|
||||
--- DriverManager/SQLTransact.c.orig 2007-08-30 21:54:17.000000000 +0900
|
||||
--- DriverManager/SQLTransact.c.orig 2010-04-13 16:56:08.000000000 +0000
|
||||
+++ DriverManager/SQLTransact.c
|
||||
@@ -439,7 +439,7 @@ SQLRETURN SQLTransact( SQLHENV environme
|
||||
@@ -465,7 +465,7 @@ SQLRETURN SQLTransact( SQLHENV environme
|
||||
|
||||
thread_release( SQL_HANDLE_ENV, environment );
|
||||
|
||||
|
@ -12,13 +12,13 @@ $NetBSD: patch-ah,v 1.1 2009/10/21 04:21:27 taca Exp $
|
|||
+ return function_return( IGNORE_THREAD, environment, SQL_ERROR );
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -474,7 +474,7 @@ SQLRETURN SQLTransact( SQLHENV environme
|
||||
if ( environment -> state == STATE_E2 )
|
||||
@@ -536,7 +536,7 @@ SQLRETURN SQLTransact( SQLHENV environme
|
||||
|
||||
thread_release( SQL_HANDLE_ENV, environment );
|
||||
thread_release( SQL_HANDLE_ENV, environment );
|
||||
|
||||
- return function_return( SQL_HANDLE_ENV, environment, SQL_ERROR );
|
||||
+ return function_return( IGNORE_THREAD, environment, SQL_ERROR );
|
||||
- return function_return( SQL_HANDLE_ENV, environment, SQL_ERROR );
|
||||
+ return function_return( IGNORE_THREAD, environment, SQL_ERROR );
|
||||
}
|
||||
}
|
||||
}
|
||||
else if ( CHECK_SQLENDTRAN( connection ))
|
||||
else if ( CHECK_SQLENDTRAN( connection ))
|
||||
|
|
31
databases/unixodbc/patches/patch-aj
Normal file
31
databases/unixodbc/patches/patch-aj
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-aj,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- libltdl/Makefile.in.orig 2010-04-26 01:42:12.000000000 +0000
|
||||
+++ libltdl/Makefile.in
|
||||
@@ -408,7 +408,7 @@ distclean-hdr:
|
||||
-rm -f config.h stamp-h1
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f=$(am__strip_dir) \
|
||||
@@ -644,7 +644,7 @@ distclean-libtool:
|
||||
-rm -f libtool config.lt
|
||||
install-includeHEADERS: $(include_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
|
||||
+ test -z "$(DESTDIR)$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
|
||||
@list='$(include_HEADERS)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
||||
@@ -661,7 +661,7 @@ uninstall-includeHEADERS:
|
||||
done
|
||||
install-ltdlincludeHEADERS: $(ltdlinclude_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(ltdlincludedir)" || $(MKDIR_P) "$(DESTDIR)$(ltdlincludedir)"
|
||||
+ test -z "$(DESTDIR)$(ltdlincludedir)" || $(MKDIR_P) "$(DESTDIR)$(ltdlincludedir)"
|
||||
@list='$(ltdlinclude_HEADERS)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
13
databases/unixodbc/patches/patch-ak
Normal file
13
databases/unixodbc/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- DriverManager/Makefile.in.orig 2010-04-26 02:28:44.000000000 +0000
|
||||
+++ DriverManager/Makefile.in
|
||||
@@ -483,7 +483,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
||||
$(am__aclocal_m4_deps):
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
|
||||
list2=; for p in $$list; do \
|
||||
if test -f $$p; then \
|
13
databases/unixodbc/patches/patch-al
Normal file
13
databases/unixodbc/patches/patch-al
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-al,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- cur/Makefile.in.orig 2010-04-26 02:28:43.000000000 +0000
|
||||
+++ cur/Makefile.in
|
||||
@@ -388,7 +388,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
||||
$(am__aclocal_m4_deps):
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
|
||||
list2=; for p in $$list; do \
|
||||
if test -f $$p; then \
|
13
databases/unixodbc/patches/patch-am
Normal file
13
databases/unixodbc/patches/patch-am
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-am,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- exe/Makefile.in.orig 2010-04-26 02:28:44.000000000 +0000
|
||||
+++ exe/Makefile.in
|
||||
@@ -319,7 +319,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
||||
$(am__aclocal_m4_deps):
|
||||
install-binPROGRAMS: $(bin_PROGRAMS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
|
||||
+ test -z "$(DESTDIR)$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
|
||||
@list='$(bin_PROGRAMS)'; test -n "$(bindir)" || list=; \
|
||||
for p in $$list; do echo "$$p $$p"; done | \
|
||||
sed 's/$(EXEEXT)$$//' | \
|
13
databases/unixodbc/patches/patch-an
Normal file
13
databases/unixodbc/patches/patch-an
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-an,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- include/Makefile.in.orig 2010-04-26 02:28:43.000000000 +0000
|
||||
+++ include/Makefile.in
|
||||
@@ -301,7 +301,7 @@ clean-libtool:
|
||||
-rm -rf .libs _libs
|
||||
install-includeHEADERS: $(include_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
|
||||
+ test -z "$(DESTDIR)$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
|
||||
@list='$(include_HEADERS)'; test -n "$(includedir)" || list=; \
|
||||
for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
22
databases/unixodbc/patches/patch-ao
Normal file
22
databases/unixodbc/patches/patch-ao
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ao,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
|
||||
|
||||
--- odbcinst/Makefile.in.orig 2010-04-26 02:28:43.000000000 +0000
|
||||
+++ odbcinst/Makefile.in
|
||||
@@ -440,7 +440,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
||||
$(am__aclocal_m4_deps):
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
|
||||
list2=; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
@@ -557,7 +557,7 @@ clean-libtool:
|
||||
-rm -rf .libs _libs
|
||||
install-sysconfDATA: $(sysconf_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
|
||||
+ test -z "$(DESTDIR)$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
|
||||
@list='$(sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
|
||||
for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
Loading…
Reference in a new issue