Update to 1.2.0:
Highlights: * Movie preview. * GTK2 compatibility. * BSD compatibility. * Hide/show list columns. * ED2K Browser Integration. Madcat's contributions: * Made ED2K integration HOWTO. * Enabled multiple selections in all lists. * Item selected when right-clicked. * Sort order stays when sources/items are added to list during global search. * Search tabs can be closed during global search. * Double-clicking on a server in Server List now connects to that server. * Original idea and implementation of column hiding. * Made LMule fully 0.26d GUI compliant. * Preview of movie files (mplayer+xine officially supported). * Preferences saved when OK is clicked in Preferences. * FIXED -- Shared Files tab Highest/Release priority issue. * FIXED -- Search Tab "Remove All" button. * FIXED -- Search Tab "Download All" resized. Un-Thesis' contributions: * Fully implemented column hiding for all lists. * Added full GTK2 compatibility. * Updated auto-server.met URL. * FIXED -- column hiding bugs in wxGTK code. * FIXED -- Freeze if wget failed. Pure_Ascii's contributions: * Tested tray icon in KDE3. * Spoofed up wxLocale() i18n implementation. * Now detects new mlDonkey clients. * FIXED -- Buffer Overflow: too long lines in the retrieved server lists - will freeze lmule (reported by Gib[S]on) Lioux's contributions: * Added *BSD compatibility. * Substituted direct pthread calls for wxMutex calls. Simbal's contributions: * FIXED -- SuSE 8.2 compilation errors. Pterjan's contributions: * Added a much better French translation. Based on patches provided by Juan RP and ACiarcinski at iss.net.
This commit is contained in:
parent
d93eb7731d
commit
df88674cbb
10 changed files with 19 additions and 221 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.3 2003/05/02 11:56:07 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2003/05/05 20:25:14 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lmule-1.1.13
|
||||
PKGREVISION= 2
|
||||
DISTNAME= lmule-1.2.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lmule/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= jrp@hispabsd.org
|
||||
HOMEPAGE= http://lmule.sourceforge.net/
|
||||
|
|
|
@ -1,12 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/05/05 20:25:15 jmmv Exp $
|
||||
|
||||
SHA1 (lmule-1.1.13.tar.gz) = 34de6f170766fd7504d9cfa083135a91a721045b
|
||||
Size (lmule-1.1.13.tar.gz) = 1759826 bytes
|
||||
SHA1 (patch-aa) = c7ab7025cf510961af79ab6a984c9fa6819479dc
|
||||
SHA1 (patch-ab) = c0f6544fd595ddb45312765e7e00556e6116ef43
|
||||
SHA1 (patch-ac) = 36519b66c1106bd914f23c20c5235697133beed9
|
||||
SHA1 (patch-ad) = 934528991c13e09dbd19f50b69af91783d47c4fb
|
||||
SHA1 (patch-ae) = d5ded1eeb75045c9140275c1a9144ecd777a6a56
|
||||
SHA1 (patch-af) = 9496549f044d9ea83d8350495b1a008c1032cfc4
|
||||
SHA1 (patch-ag) = c935a6cf082baeef0975b7ce475e00136bcba96a
|
||||
SHA1 (patch-ah) = 12956dc41956e73d4bda742d2e52f645d307beb9
|
||||
SHA1 (lmule-1.2.0.tar.bz2) = c3701dce8dbf290e38b34a622345f2da69b08922
|
||||
Size (lmule-1.2.0.tar.bz2) = 1231218 bytes
|
||||
SHA1 (patch-ag) = 7d804f8306efe306fed77f1c998f3cb115cabe0d
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/CFile.cpp.orig Sun Mar 23 00:13:37 2003
|
||||
+++ src/CFile.cpp Sun Mar 23 00:16:34 2003
|
||||
@@ -53,6 +53,10 @@
|
||||
#define NOMCX
|
||||
#endif
|
||||
|
||||
+#if !defined(USG) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#elif (defined(__UNIX__) || defined(__GNUWIN32__))
|
||||
#include <unistd.h>
|
||||
#ifdef __GNUWIN32__
|
||||
@@ -116,7 +120,11 @@
|
||||
#endif
|
||||
|
||||
#ifndef MAX_PATH
|
||||
- #define MAX_PATH 512
|
||||
+# if (defined(BSD) && (BSD >= 199103))
|
||||
+# define MAX_PATH MAXPATHLEN
|
||||
+# else
|
||||
+# define MAX_PATH 512
|
||||
+# endif
|
||||
#endif
|
||||
|
||||
// some broken compilers don't have 3rd argument in open() and creat()
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/PPgDirectories.cpp.orig Sun Mar 23 00:10:03 2003
|
||||
+++ src/PPgDirectories.cpp Sun Mar 23 00:10:42 2003
|
||||
@@ -1,6 +1,10 @@
|
||||
// PPgDirectories.cpp : implementation file
|
||||
//
|
||||
|
||||
+#if !defined(USG) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
//#include "stdafx.h"
|
||||
#include "wintypes.h"
|
||||
#include "emule.h"
|
||||
@@ -13,7 +17,11 @@
|
||||
#include "wx/xrc/xmlres.h"
|
||||
#include "wx/xrc/xh_all.h"
|
||||
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+#define MAX_PATH MAXPATHLEN
|
||||
+#else
|
||||
#define MAX_PATH 2048
|
||||
+#endif
|
||||
|
||||
#define GetDlgItem(x,clas) XRCCTRL(*this,#x,clas)
|
||||
#define IsDlgButtonChecked(x) XRCCTRL(*this,#x,wxCheckBox)->GetValue()
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/PartFile.cpp.orig Sun Mar 23 00:11:08 2003
|
||||
+++ src/PartFile.cpp Sun Mar 23 00:12:13 2003
|
||||
@@ -14,6 +14,10 @@
|
||||
//along with this program; if not, write to the Free Software
|
||||
//Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
|
||||
+#if !defined(USG) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#include "PartFile.h"
|
||||
#include "emule.h"
|
||||
#include "updownclient.h"
|
||||
@@ -177,7 +181,11 @@
|
||||
delete gaplist.GetAt(pos);
|
||||
}
|
||||
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+#define MAX_PATH MAXPATHLEN
|
||||
+#else
|
||||
#define MAX_PATH 1024
|
||||
+#endif
|
||||
|
||||
void CPartFile::CreatePartFile(){
|
||||
// use lowest free partfilenumber for free file (InterCeptor)
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/Preferences.cpp.orig 2003-03-27 09:04:13.000000000 +0100
|
||||
+++ src/Preferences.cpp 2003-03-27 09:05:40.000000000 +0100
|
||||
@@ -22,6 +22,10 @@
|
||||
#include <config.h>
|
||||
#endif // HAVE_CONFIG_H
|
||||
|
||||
+#if !defined(USG) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#include "wintypes.h"
|
||||
#include "Preferences.h"
|
||||
#include <time.h>
|
||||
@@ -41,11 +45,16 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+#define MAX_PATH MAXPATHLEN
|
||||
+#else
|
||||
#define MAX_PATH 2048
|
||||
+#endif
|
||||
|
||||
extern int sprintf(char *__restrict __s,__const char*__restrict __format,...) __attribute__ ((__format__ (__printf__, 2,3)));
|
||||
|
||||
#ifdef __FreeBSD__
|
||||
+#elif defined(__NetBSD__)
|
||||
extern long long atoll(char *s);
|
||||
#endif /* __FreeBSD__ */
|
||||
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/ServerList.cpp.orig Sun Mar 23 00:12:47 2003
|
||||
+++ src/ServerList.cpp Sun Mar 23 00:13:13 2003
|
||||
@@ -15,6 +15,9 @@
|
||||
//along with this program; if not, write to the Free Software
|
||||
//Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
|
||||
+#if !defined(USG) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
|
||||
//#include "stdafx.h"
|
||||
#include "ServerList.h"
|
||||
@@ -346,7 +349,12 @@
|
||||
|
||||
#include <wx/txtstrm.h>
|
||||
#include <wx/wfstream.h>
|
||||
+
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+#define MAX_PATH MAXPATHLEN
|
||||
+#else
|
||||
#define MAX_PATH 1024
|
||||
+#endif
|
||||
|
||||
void CServerList::AddServersFromTextFile(CString strFilename,bool isstaticserver) {
|
||||
wxString strLine;
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/SharedFileList.cpp.orig 2003-03-30 16:24:44.000000000 +0200
|
||||
+++ src/SharedFileList.cpp 2003-03-30 16:26:48.000000000 +0200
|
||||
@@ -37,7 +37,9 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#ifdef __FreeBSD__
|
||||
+#elif defined(__NetBSD__) || defined(__OpenBSD__)
|
||||
#include <libgen.h>
|
||||
+#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
CSharedFileList::CSharedFileList(CPreferences* in_prefs,CServerConnect* in_server,CKnownFileList* in_filelist){
|
|
@ -1,50 +1,22 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2003/05/05 20:25:16 jmmv Exp $
|
||||
|
||||
--- src/UDPSocket.cpp.orig 2003-03-27 09:19:17.000000000 +0100
|
||||
+++ src/UDPSocket.cpp 2003-03-27 09:21:40.000000000 +0100
|
||||
@@ -25,7 +25,8 @@
|
||||
--- src/UDPSocket.cpp.orig 2003-04-01 17:26:21.000000000 +0200
|
||||
+++ src/UDPSocket.cpp
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
static pthread_attr_t attr;//=PTHREAD_CREATE_DETACHED;
|
||||
|
||||
#ifdef __FreeBSD__
|
||||
-static pthread_mutex_t gethostby_mutex = PTHREAD_MUTEX_INITIALIZER;
|
||||
+#elif defined(__NetBSD__)
|
||||
+static wxMutex *s_mutexProtectingGetHostByName;
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
static wxMutex *s_mutexProtectingGetHostByName;
|
||||
|
||||
static int
|
||||
convert (struct hostent *host, struct hostent *result,
|
||||
@@ -131,7 +132,7 @@
|
||||
{
|
||||
struct hostent *host;
|
||||
|
||||
- pthread_mutex_lock (&gethostby_mutex);
|
||||
+ s_mutexProtectingGetHostByName->Lock();
|
||||
|
||||
host = gethostbyname (name);
|
||||
if (!host ||
|
||||
@@ -140,11 +141,11 @@
|
||||
result = NULL;
|
||||
}
|
||||
|
||||
- pthread_mutex_unlock (&gethostby_mutex);
|
||||
+ s_mutexProtectingGetHostByName->Unlock();
|
||||
return result;
|
||||
}
|
||||
|
||||
-#endif /* __FreeBSD__ */
|
||||
+#endif /* __FreeBSD__ || __NetBSD__ */
|
||||
|
||||
#define TM_DNSDONE 17851
|
||||
|
||||
@@ -170,10 +171,11 @@
|
||||
@@ -169,7 +169,7 @@ wxThread::ExitCode AsyncDNS::Entry()
|
||||
int errorno=0;
|
||||
char dataBuf[512]={0};
|
||||
|
||||
#ifdef __FreeBSD__
|
||||
+#elif defined(__NetBSD__)
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
result = gethostbyname_r(ipName.GetData(),&ret,dataBuf,sizeof(dataBuf),&errorno);
|
||||
#else
|
||||
gethostbyname_r(ipName.GetData(),&ret,dataBuf,sizeof(dataBuf),&result,&errorno);
|
||||
-#endif /* __FreeBSD__ */
|
||||
+#endif /* __FreeBSD__ || __NetBSD__ */
|
||||
if(result) {
|
||||
unsigned long addr=*(unsigned long*)ret.h_addr;
|
||||
struct sockaddr_in* newsi=(struct sockaddr_in*)malloc(sizeof(struct sockaddr_in));//new struct sockaddr_in;
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2003/03/31 20:58:41 jmmv Exp $
|
||||
|
||||
--- src/otherfunctions.cpp.orig 2003-03-27 09:06:24.000000000 +0100
|
||||
+++ src/otherfunctions.cpp 2003-03-27 09:06:56.000000000 +0100
|
||||
@@ -546,6 +546,7 @@
|
||||
}
|
||||
|
||||
#ifdef __FreeBSD__
|
||||
+#elif defined(__NetBSD__)
|
||||
long long atoll( char * s ){
|
||||
return strtoll(s, (char **)NULL, 10);
|
||||
}
|
Loading…
Reference in a new issue