Implicit int return type is not valid in C++. (clang objects, and then
the whole configure script fails.)
This commit is contained in:
parent
0221a51fe4
commit
df9c4b7c02
4 changed files with 52 additions and 2 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/02/23 20:39:49 agc Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/09/04 23:41:52 dholland Exp $
|
||||
|
||||
SHA1 (mp3info-0.2.16.tar.gz) = b4cb7feb0b2c52ce1c2a23b919f4ab3c3012b11f
|
||||
RMD160 (mp3info-0.2.16.tar.gz) = 61810736aff11e1e241d78f572acd4890f795851
|
||||
Size (mp3info-0.2.16.tar.gz) = 42950 bytes
|
||||
SHA1 (patch-aa) = 4b036972514390c517eed0d1a86acf871c7d2730
|
||||
SHA1 (patch-configure) = 995088079b05571d545eae85e0d22a574799b3b0
|
||||
|
|
15
audio/mp3info/patches/patch-configure
Normal file
15
audio/mp3info/patches/patch-configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.1 2011/09/04 23:41:52 dholland Exp $
|
||||
|
||||
Fix test program; implicit int return type is not valid in C++.
|
||||
|
||||
--- configure~ 1999-03-19 21:04:21.000000000 +0000
|
||||
+++ configure
|
||||
@@ -818,7 +818,7 @@ cross_compiling=$ac_cv_prog_cxx_cross
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 820 "configure"
|
||||
#include "confdefs.h"
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:824: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
|
||||
ac_cv_prog_cxx_works=yes
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2009/07/07 16:49:05 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2011/09/04 23:49:57 dholland Exp $
|
||||
|
||||
SHA1 (splay-0.8.2.tar.gz) = 25288afa1b52bf25be8f9c4ceb44325c50fa00c8
|
||||
RMD160 (splay-0.8.2.tar.gz) = f1a99ad9e7e70f5e0000aede05966cc5a0b36ad3
|
||||
|
@ -12,3 +12,4 @@ SHA1 (patch-af) = dfe6c6fba890fb0b413b6b73a42904d3ca6b7d66
|
|||
SHA1 (patch-ai) = 9ac8c7aa7a7d341585e57dec4ddba4e285db7b34
|
||||
SHA1 (patch-aj) = 840793d18ed577dea15108a3c56d9a66e0a8e9e5
|
||||
SHA1 (patch-ak) = dd0b54d9323102d92add8cc0e4b020c37b70b615
|
||||
SHA1 (patch-configure) = ae29732a586a19c7f85367391b19e5bf81c33e75
|
||||
|
|
33
audio/splay/patches/patch-configure
Normal file
33
audio/splay/patches/patch-configure
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-configure,v 1.1 2011/09/04 23:49:57 dholland Exp $
|
||||
|
||||
Fix test programs; implicit int return type is not valid in C++.
|
||||
|
||||
--- configure~ 1998-03-07 21:04:19.000000000 +0000
|
||||
+++ configure
|
||||
@@ -856,7 +856,7 @@ cross_compiling=$ac_cv_prog_cc_cross
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 858 "configure"
|
||||
#include "confdefs.h"
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:862: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
|
||||
ac_cv_prog_cc_works=yes
|
||||
@@ -982,7 +982,7 @@ cross_compiling=$ac_cv_prog_cxx_cross
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 984 "configure"
|
||||
#include "confdefs.h"
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:988: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
|
||||
ac_cv_prog_cxx_works=yes
|
||||
@@ -1688,7 +1688,7 @@ else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 1690 "configure"
|
||||
#include "confdefs.h"
|
||||
-main () {
|
||||
+int main () {
|
||||
/* Are we little or big endian? From Harbison&Steele. */
|
||||
union
|
||||
{
|
Loading…
Reference in a new issue