Update plp to 1.8

Changes included in 1.8 are:
	Control-D now does something sensible in rfsv
	mput and mget now accept unix filename wildcards '*' and '?'
	annoying description of file property flags has been moved elsewhere
		- type '??' in rfsv to see their meaning
	'defaults.h' has changed to support the S5 by default
	Compiles with gcc 2.95
This commit is contained in:
sakamoto 1999-12-06 02:19:23 +00:00
parent 1a2b44ac6b
commit dfbdb80403
9 changed files with 41 additions and 56 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.3 1999/05/21 05:07:19 sakamoto Exp $
# $NetBSD: Makefile,v 1.4 1999/12/06 02:19:23 sakamoto Exp $
DISTNAME= plp_1_7
PKGNAME= plp-1.7
DISTNAME= plp_1_8
PKGNAME= plp-1.8
CATEGORIES= comms
MASTER_SITES= http://www.proudman51.freeserve.co.uk/psion/
MAINTAINER= packages@netbsd.org
MAINTAINER= sakamoto@netbsd.org
HOMEPAGE= http://www.proudman51.freeserve.co.uk/psion/ncp.html
USE_GMAKE= yes

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: md5,v 1.2 1999/12/06 02:19:24 sakamoto Exp $
MD5 (plp_1_7.tar.gz) = 72bd98c5eb67f184e40560fe40bd9534
MD5 (plp_1_8.tar.gz) = 63c0871eb0504c69677c8e16f2d43ea2

View file

@ -1,8 +1,8 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 13:50:26 agc Exp $
$NetBSD: patch-sum,v 1.2 1999/12/06 02:19:25 sakamoto Exp $
MD5 (patch-aa) = ffa8f1139a30951adf2d119baad9b1d7
MD5 (patch-ab) = e7fea5a1b34bf111e7eaabaf682f310d
MD5 (patch-ac) = 980dbb27dcbb816eff74315447d9eb12
MD5 (patch-ad) = 17f2a0b8fd17276bf3a1959be994fcf1
MD5 (patch-ae) = 2a4e83c5884bd92eaafe550b0368ae70
MD5 (patch-af) = 75b6eb4bf640251f1f4ecb21778d7655
MD5 (patch-aa) = 1ded8b0ec9aab309561da3efa7188d08
MD5 (patch-ab) = 6a280e177bd7f2fae32df3e35b81f9b2
MD5 (patch-ac) = 949619283ad2bbc69d28239ca863dd39
MD5 (patch-ad) = e39c58df55c2b97383e4786a18f608a9
MD5 (patch-ae) = 55ea3fa09b4e72c60715acfff83c9c4d
MD5 (patch-af) = e1b18c090348602847cbefaf4d320136

View file

@ -1,13 +1,11 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-aa,v 1.2 1999/12/06 02:19:25 sakamoto Exp $
--- defaults.h.orig Tue Apr 13 07:25:01 1999
+++ defaults.h Mon Apr 19 10:36:39 1999
@@ -19,7 +19,7 @@
--- ./defaults.h.orig Wed Nov 3 05:51:01 1999
+++ ./defaults.h Mon Dec 6 11:04:20 1999
@@ -20,5 +20,5 @@
// This is the default device driver for the serial link
// N.B. This was "/dev/cua1" in the previous release
-#define DEFAULT_SERIAL_DEVICE "/dev/ttyS1"
+#define DEFAULT_SERIAL_DEVICE "/dev/tty00"
// This is the default drive to use on the psion
#define DEFAULT_DRIVE "C:\\"

View file

@ -1,9 +1,8 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-ab,v 1.2 1999/12/06 02:19:26 sakamoto Exp $
--- ncp/mp_serial.c.orig Mon Feb 1 19:14:31 1999
+++ ncp/mp_serial.c Mon Apr 19 10:51:46 1999
@@ -223,8 +223,8 @@
void ser_exit(int fd)
--- ./ncp/mp_serial.c.orig Wed Nov 3 05:47:06 1999
+++ ./ncp/mp_serial.c Mon Dec 6 11:04:20 1999
@@ -224,6 +224,6 @@
{
struct termios ti;
- if(ioctl(fd, TCGETS, (caddr_t)&ti) < 0) {
@ -12,4 +11,3 @@ $NetBSD: patch-ab,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
+ perror("TIOCGETA");
}
ti.c_cflag &= ~CRTSCTS;
if(tcsetattr(fd, TCSANOW, &ti) < 0) {

View file

@ -1,15 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-ac,v 1.2 1999/12/06 02:19:26 sakamoto Exp $
--- ncp/Makefile.orig Tue Feb 2 21:16:05 1999
+++ ncp/Makefile Mon Apr 19 11:58:15 1999
@@ -3,14 +3,14 @@
--- ./ncp/Makefile.orig Tue Feb 2 21:16:05 1999
+++ ./ncp/Makefile Mon Dec 6 11:04:20 1999
@@ -4,13 +4,13 @@
OBJ=$(CCSOURCE:%.cc=%.o) $(CSOURCE:%.c=%.o)
-../bin/ncp : $(OBJ)
- $(LD) $(OBJ) $(LIBS) -o $@
+ncp : $(OBJ)
+ $(LD) $(OBJ) $(LIBS) -o $@
$(LD) $(OBJ) $(LIBS) -o $@
%.o : %.cc
- $(CC) -c $< -o $@

View file

@ -1,15 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-ad,v 1.2 1999/12/06 02:19:26 sakamoto Exp $
--- rfsv/Makefile.orig Tue Feb 2 21:16:15 1999
+++ rfsv/Makefile Mon Apr 19 12:00:07 1999
@@ -3,14 +3,14 @@
--- ./rfsv/Makefile.orig Tue Feb 2 21:16:15 1999
+++ ./rfsv/Makefile Mon Dec 6 11:04:20 1999
@@ -4,13 +4,13 @@
OBJ=$(CCSOURCE:%.cc=%.o) $(CSOURCE:%.c=%.o)
-../bin/rfsv : $(OBJ)
- $(LD) $(OBJ) $(LIBS) -o $@
+rfsv : $(OBJ)
+ $(LD) $(OBJ) $(LIBS) -o $@
$(LD) $(OBJ) $(LIBS) -o $@
%.o : %.cc
- $(CC) -c $< -o $@

View file

@ -1,9 +1,8 @@
$NetBSD: patch-ae,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-ae,v 1.2 1999/12/06 02:19:26 sakamoto Exp $
--- utils/Makefile.orig Mon Jan 18 01:22:40 1999
+++ utils/Makefile Mon Apr 19 12:56:10 1999
@@ -3,14 +3,14 @@
--- ./utils/Makefile.orig Mon Jan 18 01:22:40 1999
+++ ./utils/Makefile Mon Dec 6 11:04:20 1999
@@ -4,13 +4,13 @@
OBJ=$(CCSOURCE:%.cc=%.o) $(CSOURCE:%.c=%.o)
-libutils.a : $(OBJ)

View file

@ -1,9 +1,8 @@
$NetBSD: patch-af,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
$NetBSD: patch-af,v 1.2 1999/12/06 02:19:27 sakamoto Exp $
--- Makefile.orig Sun Apr 11 21:15:17 1999
+++ Makefile Mon Apr 19 15:35:32 1999
@@ -17,17 +17,11 @@
# Compiler & flags
--- ./Makefile.orig Wed Nov 3 06:05:02 1999
+++ ./Makefile Mon Dec 6 11:04:20 1999
@@ -18,15 +18,9 @@
INCLUDE=-I../utils
CFLAGS= -Wall -g -O2
-CC=g++ $(CFLAGS) $(INCLUDE)
@ -22,9 +21,7 @@ $NetBSD: patch-af,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
+LD=$(LIBTOOL) --mode=link g++
#######################################
# You shouldn't need to look any further..
@@ -38,20 +32,23 @@
export LD
@@ -39,18 +33,21 @@
export LIBS
-all: bin/ncp bin/rfsv
@ -55,13 +52,10 @@ $NetBSD: patch-af,v 1.1.1.1 1999/05/06 07:39:08 sakamoto Exp $
+ cp ncp/ncp /usr/local/bin/ncp
clean:
cd utils; $(MAKE) clean
@@ -59,7 +56,7 @@
cd rfsv; $(MAKE) clean
@@ -60,5 +57,5 @@
rm -f ncp.log *~ core
-test: bin/ncp bin/rfsv
+test: all
PATH=`pwd`/bin:$${PATH}; export PATH;\
rfsv dir "C:/documents/"
@echo