Re-import of audio/gkrellm-xmms as audio/gkrellm1-xmms, to leave space for

the GKrellM-2 port of the xmms plugin.
This commit is contained in:
cube 2004-02-24 22:44:35 +00:00
parent 5b86184553
commit dfc2c2f542
5 changed files with 72 additions and 0 deletions

12
audio/gkrellm1-xmms/DESCR Normal file
View file

@ -0,0 +1,12 @@
gkrellm plugin for controlling XMMS from within GKrellM.
GKrellMMS Features:
-Local Playlist Editor
-Title scrolling
-Progress bar (Krell) to see where you are in a song
-Jumping in a file, by picking up the Krell
-LED indicator which indicates whether XMMS is on, off, stopped,
playing or paused
-Themeable buttons, to control XMMS
-A menu for some misc. XMMS-commands

View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/02/24 22:44:35 cube Exp $
DISTNAME= gkrellmms-0.5.6
PKGNAME= gkrellm-xmms-0.5.6
PKGREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://gkrellm.luon.net/files/
MAINTAINER= damon@NetBSD.org
HOMEPAGE= http://gkrellm.luon.net/gkrellmms.phtml
COMMENT= gkrellm xmms plugin
WRKSRC= ${WRKDIR}/gkrellmms
USE_BUILDLINK2= YES
pre-install:
${INSTALL_DATA_DIR} ${PREFIX}/lib/gkrellm/plugins
.include "../../audio/xmms/buildlink2.mk"
.include "../../sysutils/gkrellm1/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/02/24 22:44:35 cube Exp $
lib/gkrellm/plugins/gkrellmms.so

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/02/24 22:44:35 cube Exp $
SHA1 (gkrellmms-0.5.6.tar.gz) = a657f47c5e8f5a874c0ad0b91e238147065593bc
Size (gkrellmms-0.5.6.tar.gz) = 27249 bytes
SHA1 (patch-aa) = f0b0c9266046bcea9b97fd9ae57f41b595d1eb11

View file

@ -0,0 +1,32 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/02/24 22:44:35 cube Exp $
--- Makefile.orig Sat Jan 20 15:28:38 2001
+++ Makefile
@@ -10,14 +10,16 @@
XMMS_INCLUDE = `xmms-config --cflags`
XMMS_LIB = `xmms-config --libs`
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(XMMS_INCLUDE)
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(XMMS_INCLUDE)
LIBS = $(GTK_LIB) $(IMLIB_LIB) $(XMMS_LIB)
LFLAGS = -shared -lpthread
-CC = gcc $(CFLAGS) $(FLAGS)
+CC = gcc $(CFLAGS)
OBJS = gkrellmms.o options.o playlist.o
+all: $(BIN_FILENAME).so
+
$(BIN_FILENAME).so: $(OBJS)
$(CC) $(OBJS) -o $(BIN_FILENAME).so $(LFLAGS) $(LIBS)
@@ -25,7 +27,7 @@
rm -f *.o core *.so* *.bak *~
install:
- install -c -s -m 755 $(BIN_FILENAME).so /usr/share/gkrellm/plugins
+ install -c -s -m 644 $(BIN_FILENAME).so ${PREFIX}/lib/gkrellm/plugins
gkrellmms.c.o: gkrellmms.c
options.c.o: options.c