Update perl to 5.6.1nb3. User-visible changes from the previous version

include:

- Re-adding ${LOCALBASE}/include and ${LOCALBASE}/lib to the local compiler
  search paths,

Other changes include:

- Migrating the setting to not install man3 pages from patch-ab into the
  package Makefile so that they aren't installed across all pkgsrc platforms.

- Better document SYSLIBPATH.${OPSYS}.
This commit is contained in:
jlam 2001-09-12 18:58:57 +00:00
parent 93e440d36f
commit dfe309aab4
3 changed files with 22 additions and 21 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.41 2001/09/06 17:33:50 jlam Exp $
# $NetBSD: Makefile,v 1.42 2001/09/12 18:58:57 jlam Exp $
.include "../../lang/perl5/Makefile.common"
PKGNAME= perl-${PERL5_VERS}
PERL5_PKG_VERS= nb2
PERL5_PKG_VERS= nb3
CATEGORIES+= lang devel
MAINTAINER= jlam@netbsd.org
@ -35,11 +35,11 @@ MKPIC?= yes
#
LIBSWANTED.NetBSD= m crypt
# SYSLIBPATH should contain the directories in which the system libraries
# may be found.
# Nail down the directories in which the system libraries may be found.
# If this isn't defined, then use the perl defaults for the particular
# operating system.
#
SYSLIBPATH.NetBSD= /usr/lib
#SYSLIBPATH.Linux= /lib /usr/lib
.if defined(LIBSWANTED.${OPSYS})
CONFIGURE_ARGS+= -Dlibswanted="${LIBSWANTED.${OPSYS}}"
@ -71,15 +71,22 @@ PERL5_SITEARCH= ${PREFIX}/lib/perl5/site_perl/${PERL5_DIST_VERS}/${MACHINE_ARCH
PERL5_PACKLIST= ${PERL5_ARCHLIB}/.packlist
# It's tough to guess which hints file will be used, so add our modifications
# to all of them.
# to all of them:
#
# - Don't install any manpages in man3; make user use perldoc (to prevent
# confusion/conflicts with similarly named man2/man3 pages).
#
# - Explicitly set the local compiler search paths to contain only the
# pkgsrc-controlled directories.
#
post-patch:
hintdir="${WRKSRC}/hints"; \
for hints in $${hintdir}/*.sh; do \
${CHMOD} +w $${hints}; \
( ${ECHO} ""; \
${ECHO} "locincpth=''"; \
${ECHO} "loclibpth=''"; \
${ECHO} "man3dir=none"; \
${ECHO} "locincpth='${LOCALBASE}/include'"; \
${ECHO} "loclibpth='${LOCALBASE}/lib'"; \
) >> $${hints}; \
done
.if defined(SYSLIBPATH.${OPSYS})

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.1 2001/09/05 17:13:40 jlam Exp $
$NetBSD: distinfo,v 1.2 2001/09/12 18:58:57 jlam Exp $
SHA1 (perl-5.6.1.tar.gz) = c718b38685f90d51a9a6b1b008de0d7d198c0744
Size (perl-5.6.1.tar.gz) = 5983695 bytes
SHA1 (patch-aa) = 7b235dd5f4939f3b21789996514d165877cdea4d
SHA1 (patch-ab) = 9b142c7404beccc313961063128af68a685b79e3
SHA1 (patch-ab) = 65bbbb0d6a1ddf17bd5d718f0ac741faf37ce408
SHA1 (patch-ac) = dfebafeec171c86de3d6105e5543270a30f82691
SHA1 (patch-ad) = 7a3ca903d958026473f593fdeb172f86f2ef66d2
SHA1 (patch-ae) = 677797f38279b7602fc5bbac8ee80c0e09f6e285

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.8 2001/09/05 17:13:41 jlam Exp $
$NetBSD: patch-ab,v 1.9 2001/09/12 18:58:57 jlam Exp $
--- hints/netbsd.sh.orig Thu Feb 22 18:57:55 2001
+++ hints/netbsd.sh Sat Sep 1 03:57:59 2001
--- hints/netbsd.sh.orig Thu Feb 22 21:57:55 2001
+++ hints/netbsd.sh Wed Sep 12 14:41:45 2001
@@ -21,7 +21,11 @@
if [ -f /usr/libexec/ld.elf_so ]; then
d_dlopen=$define
@ -15,7 +15,7 @@ $NetBSD: patch-ab,v 1.8 2001/09/05 17:13:41 jlam Exp $
cccdlflags="-DPIC -fPIC $cccdlflags"
lddlflags="--whole-archive -shared $lddlflags"
elif [ "`uname -m`" = "pmax" ]; then
@@ -59,14 +63,18 @@
@@ -59,12 +63,13 @@
d_setruid="$undef"
# there's no problem with vfork.
@ -30,12 +30,6 @@ $NetBSD: patch-ab,v 1.8 2001/09/05 17:13:41 jlam Exp $
# Pre-empt the /usr/bin/perl question of installperl.
-installusrbinperl='n'
+installusrbinperl="$undef"
+
+# Don't install any manpages in man3; make user use perldoc
+# (to prevent confusion with similarly named man2/man3 pages).
+man3dir=none
# Recognize the NetBSD packages collection.
-# GDBM might be here.
test -d /usr/pkg/lib && loclibpth="$loclibpth /usr/pkg/lib"
test -d /usr/pkg/include && locincpth="$locincpth /usr/pkg/include"
# GDBM might be here.