Update xmill to v0.9.1 and remove unnecessary patches. Notable changes:
* portability fixes for makefiles and for newer C++ compilers * configuration options to build xmill without included zlib/bzlib * will work with libbz2 as well as libbz
This commit is contained in:
parent
59a9ad0d9d
commit
dfee3135e4
17 changed files with 25 additions and 490 deletions
|
@ -1,20 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.9 2004/01/22 07:18:44 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2004/03/29 05:12:01 ben Exp $
|
||||
|
||||
DISTNAME= xmill-0-7
|
||||
PKGNAME= xmill-0.7
|
||||
DISTNAME= xmill-0.9.1
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= # empty
|
||||
EXTRACT_SUFX= .zip
|
||||
MASTER_SITES= http://www.cs.washington.edu/homes/suciu/XMILL/
|
||||
|
||||
MAINTAINER= ben@NetBSD.org
|
||||
HOMEPAGE= http://www.research.att.com/sw/tools/xmill/
|
||||
HOMEPAGE= ${MASTER_SITES}
|
||||
COMMENT= Specialized compressor for XML
|
||||
|
||||
BUILD_DEPENDS= unzip-[0-9]*:../../archivers/unzip
|
||||
|
||||
EXTRACT_CMD= ${LOCALBASE}/bin/unzip -aq ${DOWNLOADED_DISTFILE}
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
USE_GNU_TOOLS+= make
|
||||
MAKEFILE= makefile
|
||||
|
||||
|
@ -24,26 +17,20 @@ NO_SRC_ON_CDROM= ${RESTRICTED}
|
|||
NO_BIN_ON_FTP= ${RESTRICTED}
|
||||
NO_BIN_ON_CDROM= ${RESTRICTED}
|
||||
|
||||
DOWNLOAD= http://www.research.att.com/sw/tools/xmill/download.html
|
||||
#DOWNLOAD= http://www.research.att.com/~mff/XMILL/xmill-0-7.zip
|
||||
|
||||
_FETCH_MESSAGE= \
|
||||
${ECHO} "==============================================================="; \
|
||||
${ECHO} " XMILL distribution package must be fetched"; \
|
||||
${ECHO} " into ${DISTDIR} from"; \
|
||||
${ECHO} " ${DOWNLOAD}"; \
|
||||
${ECHO} "==============================================================="
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYRIGHT.txt ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_DATA} ${WRKSRC}/MANUAL.txt ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_DATA} ${WRKSRC}/paper/xmill.ps.gz ${PREFIX}/share/doc/xmill
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unix/xmill ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unix/xdemill ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unix/xbmill ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unix/xbdemill ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/documentation/COPYRIGHT.txt \
|
||||
${WRKSRC}/documentation/LICENSE.txt \
|
||||
${WRKSRC}/documentation/MANUAL.txt \
|
||||
${WRKSRC}/documentation/README.txt \
|
||||
${WRKSRC}/documentation/xmill.ps.gz \
|
||||
${WRKSRC}/documentation/xmill-09-doc.txt \
|
||||
${PREFIX}/share/doc/xmill
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unix/xmill \
|
||||
${WRKSRC}/unix/xdemill \
|
||||
${WRKSRC}/unix/xmillexample \
|
||||
${WRKSRC}/unix/xmillinspect \
|
||||
${WRKSRC}/unix/xmilltest \
|
||||
${PREFIX}/bin
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,11 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/02/17 09:20:25 grant Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2004/03/29 05:12:01 ben Exp $
|
||||
bin/xmill
|
||||
bin/xdemill
|
||||
bin/xbmill
|
||||
bin/xbdemill
|
||||
bin/xmillexample
|
||||
bin/xmillinspect
|
||||
bin/xmilltest
|
||||
share/doc/xmill/COPYRIGHT.txt
|
||||
share/doc/xmill/LICENSE.txt
|
||||
share/doc/xmill/MANUAL.txt
|
||||
share/doc/xmill/README.txt
|
||||
share/doc/xmill/xmill-09-doc.txt
|
||||
share/doc/xmill/xmill.ps.gz
|
||||
@dirrm share/doc/xmill
|
||||
|
|
|
@ -1,18 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/10/07 03:45:13 rtr Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/03/29 05:12:01 ben Exp $
|
||||
|
||||
SHA1 (xmill-0-7.zip) = d4771e8fc860936e0d7360e5df4fce01152469c7
|
||||
Size (xmill-0-7.zip) = 1315864 bytes
|
||||
SHA1 (patch-aa) = 0c93f9dc66b283f9de7b12ad159023d94675126a
|
||||
SHA1 (patch-ab) = 1103d1d987fa070b80490e7a891a6869d32e7f0d
|
||||
SHA1 (patch-ac) = 33d8a8e1950de7e55bcdf579a2fbb3dc24709cc4
|
||||
SHA1 (patch-ad) = 13651a968e31e5aba1187e2cbb861812b8c288bc
|
||||
SHA1 (patch-ae) = 03dfca559d992b75d423bda40b8574d46c285c03
|
||||
SHA1 (patch-af) = 9e842cc608b9c111fc3235da1a6a3268ccf6f330
|
||||
SHA1 (patch-ag) = f9bbb4eb7970970dd88e7a13ba71798f1860da8a
|
||||
SHA1 (patch-ah) = 7428812657158714b6da2ff0fba34503fc1a477c
|
||||
SHA1 (patch-ai) = 6fedcc072a0b19dd98bd78126dda40b789cd889d
|
||||
SHA1 (patch-aj) = eda74f61fb265dfa33eba820aefa7c5b10259fd5
|
||||
SHA1 (patch-ak) = 5035bbf3f43886ae40b362658c5ce77cb413c613
|
||||
SHA1 (patch-al) = 47c9ab58135dacfe9a581ddd300363d907935189
|
||||
SHA1 (patch-am) = f1fdd4b0c06cc31526337d6c09e5fcc0d5166564
|
||||
SHA1 (patch-an) = c0dc3b3d58ebe018ca88611bd65198cb01bda1d9
|
||||
SHA1 (xmill-0.9.1.tar.gz) = 491e44ea9a66293af6837db4dc54ed63065c0d67
|
||||
Size (xmill-0.9.1.tar.gz) = 1021363 bytes
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/02/17 09:20:26 grant Exp $
|
||||
|
||||
--- makefile.orig Mon Nov 29 16:37:20 1999
|
||||
+++ makefile
|
||||
@@ -34,20 +34,17 @@ TMP = ./tmp
|
||||
SRC = ./src
|
||||
|
||||
CPP = g++
|
||||
-CPPFLAGS_XMILL = -O3 -c -Izlib -DXMILL
|
||||
-CPPFLAGS_XDEMILL = -O3 -c -Izlib -DXDEMILL
|
||||
+CPPFLAGS_XMILL = -c -DXMILL
|
||||
+CPPFLAGS_XDEMILL = -c -DXDEMILL
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -O3 -c
|
||||
+CFLAGS = -c
|
||||
LINK=g++
|
||||
# LINK_FLAGS = -L.
|
||||
|
||||
-ZLIB_OBJS = $(TMP)/adler32.o $(TMP)/crc32.o $(TMP)/deflate.o $(TMP)/trees.o $(TMP)/uncompr.o \
|
||||
- $(TMP)/inffast.o $(TMP)/inflate.o $(TMP)/inftrees.o $(TMP)/infutil.o $(TMP)/infblock.o \
|
||||
- $(TMP)/infcodes.o $(TMP)/zutil.o
|
||||
+ZLIB_OBJS = -lz
|
||||
|
||||
-BZLIB_OBJS= $(TMP)/blocksort.o $(TMP)/bzlib.o $(TMP)/compress_b.o $(TMP)/crctable.o $(TMP)/decompress.o \
|
||||
- $(TMP)/huffman.o $(TMP)/randtable.o
|
||||
+BZLIB_OBJS = -lbz2
|
||||
|
||||
XMILL_OBJSPART = $(TMP)/CompressMan.o $(TMP)/ContMan.o $(TMP)/PathDict.o $(TMP)/PathTree.o \
|
||||
$(TMP)/RepeatCompress.o $(TMP)/RunLenCompress.o $(TMP)/SAXClient.o \
|
||||
@@ -61,11 +58,11 @@ XDEMILL_OBJSPART = $(TMP)/CompressMan_u.
|
||||
$(TMP)/DivCompress_u.o $(TMP)/EnumCompress_u.o $(TMP)/Error_u.o \
|
||||
$(TMP)/Options_u.o $(TMP)/MemStreamer_u.o
|
||||
|
||||
-XMILLOBJS = $(ZLIB_OBJS) $(XMILL_OBJSPART) $(TMP)/ZLib.o
|
||||
-XBMILLOBJS = $(BZLIB_OBJS) $(XMILL_OBJSPART) $(TMP)/ZLib_b.o
|
||||
+XMILLOBJS = $(XMILL_OBJSPART) $(TMP)/ZLib.o $(ZLIB_OBJS)
|
||||
+XBMILLOBJS = $(XMILL_OBJSPART) $(TMP)/ZLib_b.o $(BZLIB_OBJS)
|
||||
|
||||
-XDEMILLOBJS = $(ZLIB_OBJS) $(XDEMILL_OBJSPART) $(TMP)/ZLib_u.o
|
||||
-XBDEMILLOBJS = $(BZLIB_OBJS) $(XDEMILL_OBJSPART) $(TMP)/ZLib_bu.o
|
||||
+XDEMILLOBJS = $(XDEMILL_OBJSPART) $(TMP)/ZLib_u.o $(ZLIB_OBJS)
|
||||
+XBDEMILLOBJS = $(XDEMILL_OBJSPART) $(TMP)/ZLib_bu.o $(BZLIB_OBJS)
|
||||
|
||||
$(BIN)/xmill : $(XMILLOBJS)
|
||||
$(LINK) -o $(BIN)/xmill $(LINK_FLAGS) $(XMILLOBJS)
|
||||
@@ -146,7 +143,7 @@ $(TMP)/ZLib.o : $(SRC)/ZLib.cp
|
||||
$(CPP) -o $*.o $(CPPFLAGS_XMILL) $(SRC)/ZLib.cpp
|
||||
|
||||
$(TMP)/ZLib_b.o : $(SRC)/ZLib.cpp
|
||||
- $(CPP) -o $*.o -I./bzlib $(CPPFLAGS_XMILL) -DUSE_BZIP $(SRC)/ZLib.cpp
|
||||
+ $(CPP) -o $*.o $(CPPFLAGS_XMILL) -DUSE_BZIP $(SRC)/ZLib.cpp
|
||||
|
||||
#********************************************************************
|
||||
|
||||
@@ -199,7 +196,7 @@ $(TMP)/ZLib_u.o : $(SRC)/ZLib.
|
||||
$(CPP) -o $*.o $(CPPFLAGS_XDEMILL) $(SRC)/ZLib.cpp
|
||||
|
||||
$(TMP)/ZLib_bu.o : $(SRC)/ZLib.cpp
|
||||
- $(CPP) -o $*.o -I./bzlib $(CPPFLAGS_XDEMILL) -DUSE_BZIP $(SRC)/ZLib.cpp
|
||||
+ $(CPP) -o $*.o $(CPPFLAGS_XDEMILL) -DUSE_BZIP $(SRC)/ZLib.cpp
|
||||
|
||||
#********************************************************************
|
||||
|
|
@ -1,152 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/02/17 09:20:26 grant Exp $
|
||||
|
||||
--- src/ZLib.cpp.orig Sat Feb 15 02:54:15 2003
|
||||
+++ src/ZLib.cpp
|
||||
@@ -125,7 +125,7 @@ Compressor::~Compressor()
|
||||
// We finish compression, if there has been some data in the queue
|
||||
{
|
||||
#ifdef USE_BZIP
|
||||
- bzCompressEnd(&state);
|
||||
+ BZ2_bzCompressEnd(&state);
|
||||
#else
|
||||
deflateEnd(&state);
|
||||
#endif
|
||||
@@ -175,7 +175,7 @@ void Compressor::CompressMemStream(MemSt
|
||||
if(isinitialized==0)
|
||||
{
|
||||
#ifdef USE_BZIP
|
||||
- if(bzCompressInit(&state,7,0,0)!=BZ_OK)
|
||||
+ if(BZ2_bzCompressInit(&state,7,0,0)!=BZ_OK)
|
||||
#else
|
||||
if(deflateInit(&state,zlib_compressidx)!=Z_OK)
|
||||
#endif
|
||||
@@ -183,8 +183,15 @@ void Compressor::CompressMemStream(MemSt
|
||||
Error("Error while compressing container!");
|
||||
Exit();
|
||||
}
|
||||
+#ifdef USE_BZIP
|
||||
+ state.total_out_lo32=0;
|
||||
+ state.total_out_hi32=0;
|
||||
+ state.total_in_lo32=0;
|
||||
+ state.total_in_hi32=0;
|
||||
+#else
|
||||
state.total_out=0;
|
||||
state.total_in=0;
|
||||
+#endif
|
||||
|
||||
isinitialized=1;
|
||||
}
|
||||
@@ -205,7 +212,7 @@ void Compressor::CompressMemStream(MemSt
|
||||
saveavail=state.avail_out;
|
||||
|
||||
#ifdef USE_BZIP
|
||||
- if(bzCompress(&state,BZ_RUN)!=BZ_RUN_OK)
|
||||
+ if(BZ2_bzCompress(&state,BZ_RUN)!=BZ_RUN_OK)
|
||||
#else
|
||||
if(deflate(&state,Z_NO_FLUSH)!=Z_OK)
|
||||
#endif
|
||||
@@ -259,7 +266,7 @@ void Compressor::CompressData(unsigned c
|
||||
if(isinitialized==0)
|
||||
{
|
||||
#ifdef USE_BZIP
|
||||
- if(bzCompressInit(&state,7,0,0)!=BZ_OK)
|
||||
+ if(BZ2_bzCompressInit(&state,7,0,0)!=BZ_OK)
|
||||
#else
|
||||
if(deflateInit(&state,zlib_compressidx)!=Z_OK)
|
||||
#endif
|
||||
@@ -267,8 +274,15 @@ void Compressor::CompressData(unsigned c
|
||||
Error("Error while compressing container!");
|
||||
Exit();
|
||||
}
|
||||
+#ifdef USE_BZIP
|
||||
+ state.total_out_lo32=0;
|
||||
+ state.total_out_hi32=0;
|
||||
+ state.total_in_lo32=0;
|
||||
+ state.total_in_hi32=0;
|
||||
+#else
|
||||
state.total_out=0;
|
||||
state.total_in=0;
|
||||
+#endif
|
||||
isinitialized=1;
|
||||
}
|
||||
|
||||
@@ -278,7 +292,7 @@ void Compressor::CompressData(unsigned c
|
||||
|
||||
// The actual compression
|
||||
#ifdef USE_BZIP
|
||||
- if(bzCompress(&state,BZ_RUN)!=BZ_RUN_OK)
|
||||
+ if(BZ2_bzCompress(&state,BZ_RUN)!=BZ_RUN_OK)
|
||||
#else
|
||||
if(deflate(&state,Z_NO_FLUSH)!=Z_OK)
|
||||
#endif
|
||||
@@ -326,7 +340,7 @@ void Compressor::FinishCompress(unsigned
|
||||
saveavail=state.avail_out;
|
||||
|
||||
#ifdef USE_BZIP
|
||||
- err=bzCompress(&state,BZ_FINISH);
|
||||
+ err=BZ2_bzCompress(&state,BZ_FINISH);
|
||||
#else
|
||||
err=deflate(&state,Z_FINISH);
|
||||
#endif
|
||||
@@ -353,15 +367,25 @@ void Compressor::FinishCompress(unsigned
|
||||
while(1);
|
||||
|
||||
// Let's store the input and output size
|
||||
+#ifdef USE_BZIP
|
||||
+ if(uncompressedsize!=NULL) *uncompressedsize =state.total_in_lo32;
|
||||
+ if(compressedsize!=NULL) *compressedsize =state.total_out_lo32;
|
||||
+
|
||||
+ state.total_out_lo32=0;
|
||||
+ state.total_out_hi32=0;
|
||||
+ state.total_in_lo32=0;
|
||||
+ state.total_in_hi32=0;
|
||||
+#else
|
||||
if(uncompressedsize!=NULL) *uncompressedsize =state.total_in;
|
||||
if(compressedsize!=NULL) *compressedsize =state.total_out;
|
||||
|
||||
state.total_out=0;
|
||||
state.total_in=0;
|
||||
+#endif
|
||||
|
||||
// Finally, we release the internal memory
|
||||
#ifdef USE_BZIP
|
||||
- if(bzCompressEnd(&state)!=BZ_OK)
|
||||
+ if(BZ2_bzCompressEnd(&state)!=BZ_OK)
|
||||
#else
|
||||
if(deflateReset(&state)!=Z_OK)
|
||||
#endif
|
||||
@@ -404,7 +428,7 @@ char Uncompressor::Uncompress(Input *inp
|
||||
#endif
|
||||
|
||||
#ifdef USE_BZIP
|
||||
- if(bzDecompressInit(&state,0,0)!=BZ_OK)
|
||||
+ if(BZ2_bzDecompressInit(&state,0,0)!=BZ_OK)
|
||||
#else
|
||||
if(inflateInit(&state)!=Z_OK)
|
||||
#endif
|
||||
@@ -439,7 +463,7 @@ char Uncompressor::Uncompress(Input *inp
|
||||
|
||||
// The actual decompression
|
||||
#ifdef USE_BZIP
|
||||
- switch(bzDecompress(&state))
|
||||
+ switch(BZ2_bzDecompress(&state))
|
||||
#else
|
||||
switch(inflate(&state,Z_NO_FLUSH))
|
||||
#endif
|
||||
@@ -454,11 +478,15 @@ char Uncompressor::Uncompress(Input *inp
|
||||
input->SkipData(save_in-state.avail_in);
|
||||
|
||||
// Let's store the overall amount of "decompressed" data.
|
||||
+#ifdef USE_BZIP
|
||||
+ *len=state.total_out_lo32;
|
||||
+#else
|
||||
*len=state.total_out;
|
||||
+#endif
|
||||
|
||||
// Let's finish the decompression entirely
|
||||
#ifdef USE_BZIP
|
||||
- if(bzDecompressEnd(&state)!=BZ_OK)
|
||||
+ if(BZ2_bzDecompressEnd(&state)!=BZ_OK)
|
||||
#else
|
||||
if(inflateReset(&state)!=Z_OK)
|
||||
#endif
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2003/02/17 09:20:26 grant Exp $
|
||||
|
||||
--- src/Main.cpp.orig Sat Feb 15 03:17:07 2003
|
||||
+++ src/Main.cpp
|
||||
@@ -599,7 +599,7 @@ void Compress(char *srcfile,char *destfi
|
||||
return;
|
||||
}
|
||||
|
||||
- if(output.CreateFile((no_output==0) ? destfile : "")==0)
|
||||
+ if(output.CreateFile((no_output==0) ? destfile : (char *)"")==0)
|
||||
{
|
||||
Error("Could not create output file '");
|
||||
ErrorCont(destfile);
|
||||
@@ -816,7 +816,7 @@ void Uncompress(char *sourcefile,char *d
|
||||
|
||||
globallabeldict.Init();
|
||||
|
||||
- if(output.CreateFile((no_output==0) ? destfile : "")==0)
|
||||
+ if(output.CreateFile((no_output==0) ? destfile : (char *)"")==0)
|
||||
{
|
||||
Error("Could not create output file '");
|
||||
ErrorCont(destfile);
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/ContMan.hpp.orig 2003-10-07 01:43:26.000000000 +1000
|
||||
+++ src/ContMan.hpp 2003-10-07 01:44:19.000000000 +1000
|
||||
@@ -64,7 +64,7 @@
|
||||
// The sequence of CompressContainers follow *directly* the container block object
|
||||
// in memory.
|
||||
{
|
||||
- friend CompressContainerMan;
|
||||
+ friend class CompressContainerMan;
|
||||
CompressContainerBlock *nextblock; // The next container block in the list
|
||||
unsigned short contnum; // Number of containers
|
||||
unsigned short userdatasize; // The compressor associated with the container
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/UserCompress.hpp.orig 1999-11-24 16:32:52.000000000 +1100
|
||||
+++ src/UserCompress.hpp 2003-10-07 02:11:37.000000000 +1000
|
||||
@@ -61,7 +61,7 @@
|
||||
// This object is then registered and provides basic capabilities
|
||||
// such as returning its name, instantiating compressor or decompressor
|
||||
{
|
||||
- friend CompressMan;
|
||||
+ friend class CompressMan;
|
||||
|
||||
UserCompressorFactory *next; // The next factory in the list of compressor factories
|
||||
|
||||
@@ -115,7 +115,7 @@
|
||||
|
||||
class UserCompressor
|
||||
{
|
||||
- friend CompressMan;
|
||||
+ friend class CompressMan;
|
||||
|
||||
protected:
|
||||
unsigned short datasize; // The memory space needed for representing the state
|
||||
@@ -182,7 +182,7 @@
|
||||
|
||||
class UserUncompressor
|
||||
{
|
||||
- friend CompressMan;
|
||||
+ friend class CompressMan;
|
||||
|
||||
protected:
|
||||
unsigned short datasize; // The size of the user compressor state space
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/PathDict.hpp.orig 2003-10-07 01:47:15.000000000 +1000
|
||||
+++ src/PathDict.hpp 2003-10-07 01:47:28.000000000 +1000
|
||||
@@ -66,7 +66,7 @@
|
||||
class PathDictNode
|
||||
// Each node is represented by this structure
|
||||
{
|
||||
- friend PathDict;
|
||||
+ friend class PathDict;
|
||||
|
||||
PathDictNode *parent; // The parent node.
|
||||
// Is NULL for the super root node
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/FSM.hpp.orig 2003-10-07 01:48:36.000000000 +1000
|
||||
+++ src/FSM.hpp 2003-10-07 01:49:08.000000000 +1000
|
||||
@@ -88,8 +88,8 @@
|
||||
class FSMState
|
||||
// Represents a state in the FSM
|
||||
{
|
||||
- friend FSM;
|
||||
- friend FSMEdge;
|
||||
+ friend class FSM;
|
||||
+ friend class FSMEdge;
|
||||
unsigned isfinal:1; // Final state?
|
||||
unsigned isaccepting:1; // Determines whether the FSM in that (final) state
|
||||
// will definitely accept
|
||||
@@ -177,8 +177,8 @@
|
||||
class FSMEdge
|
||||
// Represents an edge in the FSM
|
||||
{
|
||||
- friend FSMState;
|
||||
- friend FSM;
|
||||
+ friend class FSMState;
|
||||
+ friend class FSM;
|
||||
|
||||
unsigned type; // Type of the edge (EDGETYPE_...)
|
||||
FSMState *nextstate; // The state that is reached by this edge
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/VPathExprMan.hpp.orig 2003-10-07 01:49:53.000000000 +1000
|
||||
+++ src/VPathExprMan.hpp 2003-10-07 01:50:07.000000000 +1000
|
||||
@@ -44,7 +44,7 @@
|
||||
class VPathExpr
|
||||
// Represents a single container path expression
|
||||
{
|
||||
- friend VPathExprMan;
|
||||
+ friend class VPathExprMan;
|
||||
|
||||
VPathExpr *next; // The next container path expression in the path manager
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/RepeatCompress.cpp.orig 1999-11-24 16:32:42.000000000 +1100
|
||||
+++ src/RepeatCompress.cpp 2003-10-07 02:18:08.000000000 +1000
|
||||
@@ -174,7 +174,7 @@
|
||||
|
||||
class RepeatSepCompressor : public UserCompressor
|
||||
{
|
||||
- friend RepeatSepCompressorFactory;
|
||||
+ friend class RepeatSepCompressorFactory;
|
||||
protected:
|
||||
|
||||
RepeatSepCompressorInfo info;
|
||||
@@ -342,7 +342,7 @@
|
||||
|
||||
class RepeatSepUncompressor : public UserUncompressor
|
||||
{
|
||||
- friend RepeatSepCompressorFactory;
|
||||
+ friend class RepeatSepCompressorFactory;
|
||||
|
||||
RepeatSepCompressorInfo info;
|
||||
public:
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.2 2003/10/18 13:20:31 cjep Exp $
|
||||
--- src/CurPath.hpp.orig 2003-10-07 01:52:10.000000000 +1000
|
||||
+++ src/CurPath.hpp 2003-10-07 01:52:23.000000000 +1000
|
||||
@@ -49,7 +49,7 @@
|
||||
// The iterator is used to iterate forward and backward within the
|
||||
// the current path
|
||||
{
|
||||
- friend CurPath;
|
||||
+ friend class CurPath;
|
||||
CurPathLabelBlock *curblock; // The current block
|
||||
TLabelID *curlabel; // The current label (points into the current block)
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.2 2003/10/18 13:20:32 cjep Exp $
|
||||
--- src/OrCompress.cpp.orig 1999-11-24 16:32:42.000000000 +1100
|
||||
+++ src/OrCompress.cpp 2003-10-07 02:20:02.000000000 +1000
|
||||
@@ -111,7 +111,7 @@
|
||||
class OrSepCompressor : public UserCompressor
|
||||
// The compressor part of the Or-compressor,
|
||||
{
|
||||
- friend OrSepCompressorFactory;
|
||||
+ friend class OrSepCompressorFactory;
|
||||
protected:
|
||||
|
||||
OrSepCompressorInfo info; // The parameters
|
||||
@@ -271,7 +271,7 @@
|
||||
|
||||
class OrSepUncompressor : public UserUncompressor
|
||||
{
|
||||
- friend OrSepCompressorFactory;
|
||||
+ friend class OrSepCompressorFactory;
|
||||
OrSepCompressorInfo info;
|
||||
|
||||
void ComputeProperties()
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-al,v 1.2 2003/10/18 13:20:32 cjep Exp $
|
||||
--- src/DivCompress.cpp.orig 1999-11-24 16:32:42.000000000 +1100
|
||||
+++ src/DivCompress.cpp 2003-10-07 02:21:00.000000000 +1000
|
||||
@@ -159,7 +159,7 @@
|
||||
|
||||
class DivSepCompressor : public UserCompressor
|
||||
{
|
||||
- friend DivSepCompressorFactory;
|
||||
+ friend class DivSepCompressorFactory;
|
||||
protected:
|
||||
|
||||
DivSepComprInfo info; // The information about the subcompressors
|
||||
@@ -393,7 +393,7 @@
|
||||
|
||||
class DivSepUncompressor : public UserUncompressor
|
||||
{
|
||||
- friend DivSepCompressorFactory;
|
||||
+ friend class DivSepCompressorFactory;
|
||||
protected:
|
||||
|
||||
DivSepComprInfo info;
|
||||
@@ -545,7 +545,7 @@
|
||||
// The compressor class is inherited from DivSepCompressor so that
|
||||
// we can use 'ParseString'
|
||||
{
|
||||
- friend DivSepCompressorFactory;
|
||||
+ friend class DivSepCompressorFactory;
|
||||
|
||||
public:
|
||||
void ComputeProperties()
|
||||
@@ -657,7 +657,7 @@
|
||||
// Note that the class is denoted from 'DivSepUncompressor' so that
|
||||
// we can use the 'info' attribute
|
||||
{
|
||||
- friend DivSepCompressorFactory;
|
||||
+ friend class DivSepCompressorFactory;
|
||||
|
||||
public:
|
||||
void ComputeProperties()
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: patch-am,v 1.2 2003/10/18 13:20:32 cjep Exp $
|
||||
--- src/FSM.cpp.orig 2003-10-07 01:55:11.000000000 +1000
|
||||
+++ src/FSM.cpp 2003-10-07 01:55:25.000000000 +1000
|
||||
@@ -2044,3 +2044,4 @@
|
||||
}
|
||||
|
||||
*/
|
||||
\ No newline at end of file
|
||||
+
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: patch-an,v 1.2 2003/10/18 13:20:32 cjep Exp $
|
||||
--- src/Decode.cpp.orig 2003-10-07 02:21:58.000000000 +1000
|
||||
+++ src/Decode.cpp 2003-10-07 02:22:05.000000000 +1000
|
||||
@@ -84,3 +84,4 @@
|
||||
}
|
||||
|
||||
#endif
|
||||
\ No newline at end of file
|
||||
+
|
Loading…
Reference in a new issue