Work around TeXmacs build system so it looks for guile in the place

it's supposed to, if it were just using guile-config.
This commit is contained in:
wiz 2016-09-16 09:42:25 +00:00
parent f94c895a18
commit e001a51570
4 changed files with 34 additions and 5 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.112 2016/09/15 14:32:40 wiz Exp $
# $NetBSD: Makefile,v 1.113 2016/09/16 09:42:25 wiz Exp $
#
# changelog at http://www.texmacs.org/tmweb/about/changes.en.html
@ -62,6 +62,12 @@ REPLACE_PERL+= plugins/asymptote/bin/perl-tm_asy
REPLACE_PERL+= plugins/asymptote/bin/tm_asy2
REPLACE_PERL+= plugins/feynmf/bin/bbox_add.pl
SUBST_CLASSES+= linkpath
SUBST_SED.linkpath+= -e "s,-lguile,-L${PREFIX}/guile/1.8/lib -lguile,g"
SUBST_FILES.linkpath+= configure
SUBST_MESSAGE.linkpath= Search for guile library in proper directory.
SUBST_STAGE.linkpath= pre-configure
SUBST_CLASSES+= bash
SUBST_SED.bash+= -e "s,/bin/bash,${PREFIX}/bin/bash,"
SUBST_FILES.bash+= src/makefile.in src/Texmacs/Texmacs/texmacs.cpp Makefile.in

View file

@ -1,14 +1,15 @@
$NetBSD: distinfo,v 1.67 2016/07/16 21:13:22 wiz Exp $
$NetBSD: distinfo,v 1.68 2016/09/16 09:42:25 wiz Exp $
SHA1 (TeXmacs-1.99.5-src.tar.gz) = be6fdc39a094db6dc547490fa89a95876dbde002
RMD160 (TeXmacs-1.99.5-src.tar.gz) = eba10c9be4549d61240290878af429d80ede933f
SHA512 (TeXmacs-1.99.5-src.tar.gz) = a7d846fd8823e486cf724bfcbe04ae877dd64995d6131af59b49427a1178e36b52b9fcd9109783b9ae1e39c988ae9ed497b1540dce29645ebf2c4301ca7357a8
Size (TeXmacs-1.99.5-src.tar.gz) = 25014543 bytes
SHA1 (patch-aa) = 95b9e42fe1ff343e891fe299382c3647636eec99
SHA1 (patch-ab) = 7d91a754db5e38cd3661a943d0a3711cf43c1ca4
SHA1 (patch-ab) = a79814a9cdbf008ad08afa99822b707ab809599c
SHA1 (patch-ac) = e54a636e6e8f789bbdb0fc5a252b4a43525de72d
SHA1 (patch-ad) = 4a59f6e7b6f0225a5d74b1b500f9a6997ea78cb4
SHA1 (patch-ae) = c313a19db160d9f1c0dc950a1eb465869cec777f
SHA1 (patch-aj) = ed4d847ad8e7b12745b144e6790eab539cbc6bca
SHA1 (patch-al) = f7deed3d692af322aebe1a4068dfd3bde9e87a0a
SHA1 (patch-src_System_Link_socket__server.cpp) = dbc6b8e7012abf3f1833e44aedb7172de675b7e1
SHA1 (patch-src_makefile.in) = 34dc509a9e2834e376a5989d8500f3e473d266f0

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.13 2016/07/16 21:13:22 wiz Exp $
$NetBSD: patch-ab,v 1.14 2016/09/16 09:42:25 wiz Exp $
--- configure.orig 2016-07-07 18:34:10.000000000 +0000
+++ configure
@ -20,7 +20,16 @@ $NetBSD: patch-ab,v 1.13 2016/07/16 21:13:22 wiz Exp $
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: final adjustments for an Intel or AMD GNU/BSD host" >&5
$as_echo "final adjustments for an Intel or AMD GNU/BSD host" >&6; }
@@ -20141,13 +20141,13 @@ $as_echo "#define GUILE_HEADER_18 1" >>c
@@ -18545,8 +18545,6 @@ fi
fi
;;
- -Wl,*) { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Flag $LC_SCATTER_FLAGS_flag dropped for lib GUILE_TMP" >&5
-$as_echo "$as_me: WARNING: Flag $LC_SCATTER_FLAGS_flag dropped for lib GUILE_TMP" >&2;};;
-*)
as_CACHEVAR=`$as_echo "ax_cv_check_cxxflags__$LC_SCATTER_FLAGS_flag" | $as_tr_sh`
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts $LC_SCATTER_FLAGS_flag" >&5
@@ -20141,13 +20139,13 @@ $as_echo "#define GUILE_HEADER_18 1" >>c
*) { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Strange guile header name lib$GUILE_LIB.h" >&5
$as_echo "$as_me: WARNING: Strange guile header name lib$GUILE_LIB.h" >&2;} ;;
esac

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_makefile.in,v 1.1 2016/09/16 09:42:25 wiz Exp $
--- src/makefile.in.orig 2016-09-16 09:21:53.122589456 +0000
+++ src/makefile.in
@@ -32,7 +32,7 @@ CPPFLAGS := @CPPFLAGS@
CFLAGS := @CFLAGS@
CXXFLAGS := @CXXDEBUG@ @CXXFLAGS@
LDFLAGS := @LDFLAGS@
-LIBS := @LIBS@
+LIBS := -L${PREFIX}/guile/1.8/lib @LIBS@
AR = ar
ARFLAGS = -r