typedef struct _AFvirtualfile AFvirtualfile;
from af_vfs.h, the same line is in audiofile.h (which it includes),
and this breaks the build of musicpd.
Bump PGKREVISION.
This commit is contained in:
wiz 2011-11-30 11:59:39 +00:00
parent c109f4ca71
commit e015e45d8a
3 changed files with 19 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.48 2011/11/30 08:52:02 tron Exp $
# $NetBSD: Makefile,v 1.49 2011/11/30 11:59:39 wiz Exp $
DISTNAME= audiofile-0.3.1
PKGNAME= lib${DISTNAME}
PKGREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.68k.org/~michael/audiofile/

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.15 2011/11/29 19:39:30 wiz Exp $
$NetBSD: distinfo,v 1.16 2011/11/30 11:59:39 wiz Exp $
SHA1 (audiofile-0.3.1.tar.gz) = 39de137a691a7c12ea5dc468566eb7a146880ac3
RMD160 (audiofile-0.3.1.tar.gz) = 26126ae4e095bc9d37b5184853fa545283684d03
Size (audiofile-0.3.1.tar.gz) = 722557 bytes
SHA1 (patch-af) = 095d0bf52b7545718d8058f6474b6d9c05b6ceab
SHA1 (patch-configure) = 0bae38fd7634bca62d31173ccf04d2ae3ba140db
SHA1 (patch-libaudiofile_af__vfs.h) = 45cd5becf0e6f6f844bd8b50e189e45b6f682c9d
SHA1 (patch-libaudiofile_util.cpp) = be175d47b708fc8262926d014dca4f4ff50093e1

View file

@ -0,0 +1,15 @@
$NetBSD: patch-libaudiofile_af__vfs.h,v 1.1 2011/11/30 11:59:39 wiz Exp $
Conflicts with same definition in audiofile.h.
--- libaudiofile/af_vfs.h.orig 2011-09-13 03:59:06.000000000 +0000
+++ libaudiofile/af_vfs.h
@@ -34,8 +34,6 @@
extern "C" {
#endif
-typedef struct _AFvirtualfile AFvirtualfile;
-
struct _AFvirtualfile
{
ssize_t (*read) (AFvirtualfile *vfile, void *data, size_t nbytes);