Regenerate offset and fuzzy patches.
This commit is contained in:
parent
4cc2efeab0
commit
e01b589f8d
3 changed files with 32 additions and 32 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.6 1999/05/10 21:34:46 tron Exp $
|
||||
$NetBSD: patch-ab,v 1.7 1999/09/18 21:08:20 kim Exp $
|
||||
|
||||
--- configure.in.orig Mon May 10 23:27:44 1999
|
||||
+++ configure.in Mon May 10 23:27:53 1999
|
||||
@@ -317,9 +317,9 @@
|
||||
--- configure.in.orig Wed May 12 07:20:02 1999
|
||||
+++ configure.in Sat Sep 18 16:59:35 1999
|
||||
@@ -311,9 +311,9 @@
|
||||
|
||||
export CFLAGS CC
|
||||
|
||||
|
@ -15,7 +15,7 @@ $NetBSD: patch-ab,v 1.6 1999/05/10 21:34:46 tron Exp $
|
|||
|
||||
AC_MSG_CHECKING([that the compiler works])
|
||||
AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
|
||||
@@ -909,8 +909,8 @@
|
||||
@@ -903,8 +903,8 @@
|
||||
fi
|
||||
AC_MSG_RESULT(Assuming TIS headers and libraries are in $withval.)
|
||||
AC_DEFINE(HAVE_TIS)
|
||||
|
@ -26,7 +26,7 @@ $NetBSD: patch-ab,v 1.6 1999/05/10 21:34:46 tron Exp $
|
|||
AC_MSG_WARN(Remember to read README.TIS. The connection between sshd and TIS authentication
|
||||
server is clear text!)
|
||||
;;
|
||||
@@ -1236,14 +1236,14 @@
|
||||
@@ -1227,14 +1227,14 @@
|
||||
[ case "$enableval" in
|
||||
no)
|
||||
AC_MSG_RESULT(no)
|
||||
|
@ -44,7 +44,7 @@ $NetBSD: patch-ab,v 1.6 1999/05/10 21:34:46 tron Exp $
|
|||
)
|
||||
|
||||
AC_MSG_CHECKING(whether to enable TCP_NODELAY)
|
||||
@@ -1345,4 +1345,4 @@
|
||||
@@ -1336,4 +1336,4 @@
|
||||
AC_SUBST(SSHDCONFOBJS)
|
||||
AC_SUBST(SSHINSTALLMODE)
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
||||
$NetBSD: patch-ac,v 1.7 1999/09/18 21:08:20 kim Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Jul 8 18:40:39 1998
|
||||
+++ Makefile.in Fri Jul 10 21:55:03 1998
|
||||
@@ -298,8 +298,10 @@
|
||||
--- Makefile.in.orig Wed May 12 07:19:31 1999
|
||||
+++ Makefile.in Sat Sep 18 17:00:27 1999
|
||||
@@ -305,8 +305,10 @@
|
||||
GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
|
@ -15,7 +15,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
@@ -404,7 +406,7 @@
|
||||
@@ -411,7 +413,7 @@
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
|
@ -24,7 +24,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
@@ -452,14 +454,14 @@
|
||||
@@ -459,14 +461,14 @@
|
||||
$(GMPDIR)/libgmp.a:
|
||||
cd $(GMPDIR); $(MAKE)
|
||||
|
||||
|
@ -47,7 +47,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
@@ -516,10 +518,10 @@
|
||||
@@ -523,10 +525,10 @@
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
|
@ -61,7 +61,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
-mv $(install_prefix)$(bindir)/ssh1 $(install_prefix)$(bindir)/ssh1.old
|
||||
$(INSTALL_PROGRAM) -o root -m $(SSH_INSTALL_MODE) ssh $(install_prefix)$(bindir)/ssh1
|
||||
-if test -f $(install_prefix)$(bindir)/ssh2; then \
|
||||
@@ -542,7 +544,7 @@
|
||||
@@ -549,7 +551,7 @@
|
||||
-for p in $(NORMAL_PROGRAMS) $(X_PROGRAMS) $(OTHER_PROGRAMS); do \
|
||||
rm -f $(install_prefix)$(bindir)/$${p}1.old ; \
|
||||
mv $(install_prefix)$(bindir)/$${p}1 $(install_prefix)$(bindir)/$${p}1.old; \
|
||||
|
@ -70,7 +70,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
if test -f $(install_prefix)$(bindir)/$${p}2; then \
|
||||
echo "Ssh version 2 $$p utility found, installation doesn't touch $$p link"; \
|
||||
else \
|
||||
@@ -559,7 +561,7 @@
|
||||
@@ -566,7 +568,7 @@
|
||||
rm -f $(install_prefix)$(bindir)/$${p}1.old ; \
|
||||
mv $(install_prefix)$(bindir)/$${p}1 $(install_prefix)$(bindir)/$${p}1.old; \
|
||||
$(INSTALL_DATA) $$p $(install_prefix)$(bindir)/$${p}1; \
|
||||
|
@ -79,7 +79,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
if test -f $(install_prefix)$(bindir)/$${p}2; then \
|
||||
echo "Ssh version 2 $$p utility found, installation doesn't touch $$p link"; \
|
||||
else \
|
||||
@@ -575,7 +577,7 @@
|
||||
@@ -582,7 +584,7 @@
|
||||
-for p in $(SBIN_PROGRAMS); do \
|
||||
rm -f $(install_prefix)$(sbindir)/$${p}1.old ; \
|
||||
mv $(install_prefix)$(sbindir)/$${p}1 $(install_prefix)$(sbindir)/$${p}1.old; \
|
||||
|
@ -88,7 +88,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
if test -f $(install_prefix)$(sbindir)/$${p}2; then \
|
||||
echo "Ssh version 2 $$p utility found, installation doesn't touch $$p link"; \
|
||||
else \
|
||||
@@ -589,7 +591,7 @@
|
||||
@@ -596,7 +598,7 @@
|
||||
$(install_prefix)$(sbindir)/`echo $$p | sed '$(transform)'`; fi;\
|
||||
done
|
||||
-for p in $(MAN1PAGES); do \
|
||||
|
@ -97,7 +97,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
rm -f $(install_prefix)$(man1dir)/$$p.1 ;\
|
||||
$(LN_S) $${p}1.1 $(install_prefix)$(man1dir)/$$p.1 ;\
|
||||
if test "`echo $$p | sed '$(transform)'`" '!=' $$p; then \
|
||||
@@ -608,7 +610,7 @@
|
||||
@@ -615,7 +617,7 @@
|
||||
$(install_prefix)$(man1dir)/`echo slogin.1 | sed '$(transform)'`; \
|
||||
fi
|
||||
-for p in $(MAN1GENERATED); do \
|
||||
|
@ -106,7 +106,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
rm -f $(install_prefix)$(man1dir)/$$p.1 ; \
|
||||
$(LN_S) $${p}1.1 $(install_prefix)$(man1dir)/$$p.1 ; \
|
||||
if test "`echo $$p | sed '$(transform)'`" '!=' $$p; then \
|
||||
@@ -618,7 +620,7 @@
|
||||
@@ -625,7 +627,7 @@
|
||||
fi; \
|
||||
done
|
||||
-for p in $(MAN8GENERATED); do \
|
||||
|
@ -115,7 +115,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
rm -f $(install_prefix)$(man8dir)/$$p.8 ; \
|
||||
$(LN_S) $${p}1.8 $(install_prefix)$(man8dir)/$$p.8 ; \
|
||||
if test "`echo $$p | sed '$(transform)'`" '!=' $$p; then \
|
||||
@@ -629,12 +631,13 @@
|
||||
@@ -636,12 +638,13 @@
|
||||
|
||||
install-configs:
|
||||
-if test '!' -f $(install_prefix)$(HOST_CONFIG_FILE); then \
|
||||
|
@ -131,7 +131,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
$(install_prefix)$(SERVER_CONFIG_FILE); \
|
||||
rm -f /tmp/ssh_inst.$$$$; fi
|
||||
|
||||
@@ -674,13 +677,13 @@
|
||||
@@ -681,13 +684,13 @@
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
|
@ -147,7 +147,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
|
||||
dist: dist-free
|
||||
|
||||
@@ -713,8 +716,8 @@
|
||||
@@ -720,8 +723,8 @@
|
||||
gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
|
@ -158,7 +158,7 @@ $NetBSD: patch-ac,v 1.6 1998/08/07 11:13:49 agc Exp $
|
|||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
@@ -742,7 +745,7 @@
|
||||
@@ -749,7 +752,7 @@
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-au,v 1.1 1998/09/10 16:36:12 kim Exp $
|
||||
$NetBSD: patch-au,v 1.2 1999/09/18 21:08:21 kim Exp $
|
||||
|
||||
--- login.c.orig Tue Jan 20 07:24:05 1998
|
||||
+++ login.c Tue Feb 24 09:43:51 1998
|
||||
@@ -227,6 +227,19 @@
|
||||
--- login.c.orig Wed May 12 07:19:26 1999
|
||||
+++ login.c Sat Sep 18 17:03:20 1999
|
||||
@@ -271,6 +271,19 @@
|
||||
struct utmp u, u2;
|
||||
off_t offset;
|
||||
const char *utmp, *wtmp;
|
||||
|
@ -22,7 +22,7 @@ $NetBSD: patch-au,v 1.1 1998/09/10 16:36:12 kim Exp $
|
|||
|
||||
/* Construct an utmp/wtmp entry. */
|
||||
memset(&u, 0, sizeof(u));
|
||||
@@ -257,12 +270,14 @@
|
||||
@@ -301,12 +314,14 @@
|
||||
strncpy(u.ut_user, user, sizeof(u.ut_user));
|
||||
#endif /* HAVE_NAME_IN_UTMP */
|
||||
#ifdef HAVE_HOST_IN_UTMP
|
||||
|
@ -42,7 +42,7 @@ $NetBSD: patch-au,v 1.1 1998/09/10 16:36:12 kim Exp $
|
|||
#endif /* HAVE_HOST_IN_UTMP */
|
||||
#ifdef HAVE_ADDR_IN_UTMP
|
||||
if (addr)
|
||||
@@ -431,7 +446,12 @@
|
||||
@@ -490,7 +505,12 @@
|
||||
/* Update lastlog. */
|
||||
ll.ll_time = time(NULL);
|
||||
strncpy(ll.ll_line, ttyname + 5, sizeof(ll.ll_line));
|
||||
|
@ -54,5 +54,5 @@ $NetBSD: patch-au,v 1.1 1998/09/10 16:36:12 kim Exp $
|
|||
+ else
|
||||
+ strncpy(ll.ll_host, host, sizeof(ll.ll_host));
|
||||
#ifdef LASTLOG_IS_DIR
|
||||
sprintf(lastlogfile, "%.100s/%.100s", lastlog, user);
|
||||
fd = open(lastlogfile, O_WRONLY | O_CREAT, 0644);
|
||||
snprintf(lastlogfile, sizeof(lastlogfile),
|
||||
"%.100s/%.100s", lastlog, user);
|
||||
|
|
Loading…
Reference in a new issue