Update to 1.1.1:

Changes between 1.1.0 and 1.1.1:
--------------------------------

 * Various bugfixes (documentation, dvbinfo)
 * Check TDT and TOT in dvbpsi_CheckPSISection() both have b_syntax_indicator set to '0'.
 * Allow SDT with table_id 0x46
This commit is contained in:
wiz 2013-10-05 08:29:38 +00:00
parent 140e55d9ea
commit e040da0156
4 changed files with 11 additions and 27 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.18 2013/04/27 23:06:18 joerg Exp $
# $NetBSD: Makefile,v 1.19 2013/10/05 08:29:38 wiz Exp $
DISTNAME= libdvbpsi-1.1.0
DISTNAME= libdvbpsi-1.1.1
CATEGORIES= multimedia
MASTER_SITES= http://www.videolan.org/pub/libdvbpsi/${PKGVERSION_NOREV}/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.10 2013/04/23 13:22:22 wiz Exp $
$NetBSD: distinfo,v 1.11 2013/10/05 08:29:38 wiz Exp $
SHA1 (libdvbpsi-1.1.0.tar.bz2) = f83fde9986e90f93ad8ffd4a813be37c60e5137a
RMD160 (libdvbpsi-1.1.0.tar.bz2) = 5f3b0d8ab7fc7adc00072b3cf388fc781b3aa946
Size (libdvbpsi-1.1.0.tar.bz2) = 443464 bytes
SHA1 (patch-examples_dvbinfo_udp.c) = d91ac355e7df022bd587b250c8f903d89914d2d7
SHA1 (patch-src_descriptors_dr__7c.c) = ebd67c536ee7dcd1afade6145457c82781723db5
SHA1 (libdvbpsi-1.1.1.tar.bz2) = e72cc8f3c395ca9207cddc536fb387a072b5c3d3
RMD160 (libdvbpsi-1.1.1.tar.bz2) = f983878fa96438f015c3013bd09591116ff011b5
Size (libdvbpsi-1.1.1.tar.bz2) = 445085 bytes
SHA1 (patch-examples_dvbinfo_udp.c) = 7c1829ca0cfd7f1c6f051569bb8b0ab0e01f1f9e

View file

@ -1,11 +1,11 @@
$NetBSD: patch-examples_dvbinfo_udp.c,v 1.1 2013/04/23 13:22:22 wiz Exp $
$NetBSD: patch-examples_dvbinfo_udp.c,v 1.2 2013/10/05 08:29:38 wiz Exp $
Portability fix from upstream (Jean-Paul Saman <jpsaman@videolan.org>).
--- examples/dvbinfo/udp.c.orig 2013-02-20 11:25:27.000000000 +0000
--- examples/dvbinfo/udp.c.orig 2013-10-02 10:19:18.000000000 +0000
+++ examples/dvbinfo/udp.c
@@ -47,6 +47,16 @@
# include <arpa/inet.h>
@@ -61,6 +61,16 @@
# include <fcntl.h>
#endif
+#ifndef SOL_IP

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_descriptors_dr__7c.c,v 1.2 2013/04/23 13:22:22 wiz Exp $
clang fix, accepted upstream.
--- src/descriptors/dr_7c.c.orig 2013-02-25 14:29:08.000000000 +0000
+++ src/descriptors/dr_7c.c
@@ -245,7 +245,7 @@ dvbpsi_aac_dr_t *dvbpsi_DecodeAACDr(dvbp
/* Keep additional info bytes field */
if (p_descriptor->i_length > 1)
{
- uint8_t i_info_length = p_descriptor->i_length - p_decoded->b_type ? 3 : 2;
+ uint8_t i_info_length = p_descriptor->i_length - (p_decoded->b_type ? 3 : 2);
dvbpsi_aac_dr_t *p_tmp = realloc(p_decoded, sizeof(dvbpsi_aac_dr_t) + i_info_length);
if (!p_tmp)
{