Work around build failure with libc++ >=7.0 on case-insensitive
filesystems (issue #1051). Fixes macOS build, at least on Big Sur.
This commit is contained in:
parent
8ab72ef3d4
commit
e081713c86
5 changed files with 137 additions and 1 deletions
|
@ -1,7 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.9 2019/06/19 15:50:52 schmonz Exp $
|
||||
$NetBSD: distinfo,v 1.10 2021/05/13 10:47:49 schmonz Exp $
|
||||
|
||||
SHA1 (mosh-1.3.2.tar.gz) = 58411e5f4ccd27252e55ef2411411aa1502da89a
|
||||
RMD160 (mosh-1.3.2.tar.gz) = 09cec7da65f525c4a414c1506d153ac72ea38c8a
|
||||
SHA512 (mosh-1.3.2.tar.gz) = f400e8fe7ba2ab7362311fc12a00ec69587505f901988aeee500fc68d38a388218500a3f602111c883ff23a9d43572114fcf0a8bf505df203691e5b597615769
|
||||
Size (mosh-1.3.2.tar.gz) = 359574 bytes
|
||||
SHA1 (patch-Makefile.am) = 2ccdac3f0d10f9f2b2f0ea9d4dc060a2333b7254
|
||||
SHA1 (patch-Makefile.in) = c770356e9223cda8a058ce6fad315d7b5c3027c7
|
||||
SHA1 (patch-scripts_Makefile.am) = 6e727a0a8725ded9afe9cbdafbbb9de4ba42c4c6
|
||||
SHA1 (patch-scripts_Makefile.in) = 9e0746db6f1681eaec55c9dd4c168867285d8f89
|
||||
SHA1 (patch-src_network_network.cc) = cb3fbea57b2c9c208e61ba4c7a7d329aabb35d9e
|
||||
|
|
49
net/mosh/patches/patch-Makefile.am
Normal file
49
net/mosh/patches/patch-Makefile.am
Normal file
|
@ -0,0 +1,49 @@
|
|||
$NetBSD: patch-Makefile.am,v 1.1 2021/05/13 10:47:49 schmonz Exp $
|
||||
|
||||
Work around build failure with libc++ >=7.0 on case-insensitive
|
||||
filesystems (issue #1051).
|
||||
|
||||
--- Makefile.am.orig 2017-07-22 21:14:53.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -5,29 +5,29 @@ BUILT_SOURCES = version.h
|
||||
CLANG_SCAN_BUILD = scan-build
|
||||
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=distcheck --enable-examples
|
||||
|
||||
-.PHONY: VERSION
|
||||
+.PHONY: case-insensitive-VERSION
|
||||
|
||||
-VERSION:
|
||||
- @echo @PACKAGE_STRING@ > VERSION.dist
|
||||
- @set -e; if git describe --dirty --always > VERSION.git 2>&1 && \
|
||||
+case-insensitive-VERSION:
|
||||
+ @echo @PACKAGE_STRING@ > case-insensitive-VERSION.dist
|
||||
+ @set -e; if git describe --dirty --always > case-insensitive-VERSION.git 2>&1 && \
|
||||
[ -z `git rev-parse --show-prefix` ]; then \
|
||||
- if ! diff -q VERSION.git VERSION > /dev/null 2>&1; then \
|
||||
- mv -f VERSION.git VERSION; \
|
||||
+ if ! diff -q case-insensitive-VERSION.git case-insensitive-VERSION > /dev/null 2>&1; then \
|
||||
+ mv -f case-insensitive-VERSION.git case-insensitive-VERSION; \
|
||||
fi; \
|
||||
- elif ! diff -q VERSION.dist VERSION > /dev/null 2>&1; then \
|
||||
- mv -f VERSION.dist VERSION; \
|
||||
+ elif ! diff -q case-insensitive-VERSION.dist case-insensitive-VERSION > /dev/null 2>&1; then \
|
||||
+ mv -f case-insensitive-VERSION.dist case-insensitive-VERSION; \
|
||||
fi
|
||||
- @rm -f VERSION.dist VERSION.git
|
||||
+ @rm -f case-insensitive-VERSION.dist case-insensitive-VERSION.git
|
||||
|
||||
-version.h: VERSION
|
||||
- @printf '#define BUILD_VERSION "%s"\n' "$$(cat VERSION)" > version.h.new
|
||||
+version.h: case-insensitive-VERSION
|
||||
+ @printf '#define BUILD_VERSION "%s"\n' "$$(cat case-insensitive-VERSION)" > version.h.new
|
||||
@set -e; if ! diff -q version.h version.h.new > /dev/null 2>&1; then \
|
||||
mv -f version.h.new version.h; \
|
||||
fi
|
||||
@rm -f version.h.new
|
||||
|
||||
clean-local:
|
||||
- @rm -rf version.h VERSION cov-int mosh-coverity.txz
|
||||
+ @rm -rf version.h case-insensitive-VERSION cov-int mosh-coverity.txz
|
||||
|
||||
cppcheck: $(BUILT_SOURCES) config.h
|
||||
cppcheck --enable=all --template=gcc -include config.h -I . \
|
49
net/mosh/patches/patch-Makefile.in
Normal file
49
net/mosh/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,49 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2021/05/13 10:47:49 schmonz Exp $
|
||||
|
||||
Work around build failure with libc++ >=7.0 on case-insensitive
|
||||
filesystems (issue #1051).
|
||||
|
||||
--- Makefile.in.orig 2017-07-22 21:15:12.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -805,29 +805,29 @@ uninstall-am:
|
||||
.PRECIOUS: Makefile
|
||||
|
||||
|
||||
-.PHONY: VERSION
|
||||
+.PHONY: case-insensitive-VERSION
|
||||
|
||||
-VERSION:
|
||||
- @echo @PACKAGE_STRING@ > VERSION.dist
|
||||
- @set -e; if git describe --dirty --always > VERSION.git 2>&1 && \
|
||||
+case-insensitive-VERSION:
|
||||
+ @echo @PACKAGE_STRING@ > case-insensitive-VERSION.dist
|
||||
+ @set -e; if git describe --dirty --always > case-insensitive-VERSION.git 2>&1 && \
|
||||
[ -z `git rev-parse --show-prefix` ]; then \
|
||||
- if ! diff -q VERSION.git VERSION > /dev/null 2>&1; then \
|
||||
- mv -f VERSION.git VERSION; \
|
||||
+ if ! diff -q case-insensitive-VERSION.git case-insensitive-VERSION > /dev/null 2>&1; then \
|
||||
+ mv -f case-insensitive-VERSION.git case-insensitive-VERSION; \
|
||||
fi; \
|
||||
- elif ! diff -q VERSION.dist VERSION > /dev/null 2>&1; then \
|
||||
- mv -f VERSION.dist VERSION; \
|
||||
+ elif ! diff -q case-insensitive-VERSION.dist case-insensitive-VERSION > /dev/null 2>&1; then \
|
||||
+ mv -f case-insensitive-VERSION.dist case-insensitive-VERSION; \
|
||||
fi
|
||||
- @rm -f VERSION.dist VERSION.git
|
||||
+ @rm -f case-insensitive-VERSION.dist case-insensitive-VERSION.git
|
||||
|
||||
-version.h: VERSION
|
||||
- @printf '#define BUILD_VERSION "%s"\n' "$$(cat VERSION)" > version.h.new
|
||||
+version.h: case-insensitive-VERSION
|
||||
+ @printf '#define BUILD_VERSION "%s"\n' "$$(cat case-insensitive-VERSION)" > version.h.new
|
||||
@set -e; if ! diff -q version.h version.h.new > /dev/null 2>&1; then \
|
||||
mv -f version.h.new version.h; \
|
||||
fi
|
||||
@rm -f version.h.new
|
||||
|
||||
clean-local:
|
||||
- @rm -rf version.h VERSION cov-int mosh-coverity.txz
|
||||
+ @rm -rf version.h case-insensitive-VERSION cov-int mosh-coverity.txz
|
||||
|
||||
cppcheck: $(BUILT_SOURCES) config.h
|
||||
cppcheck --enable=all --template=gcc -include config.h -I . \
|
16
net/mosh/patches/patch-scripts_Makefile.am
Normal file
16
net/mosh/patches/patch-scripts_Makefile.am
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-scripts_Makefile.am,v 1.1 2021/05/13 10:47:49 schmonz Exp $
|
||||
|
||||
Work around build failure with libc++ >=7.0 on case-insensitive
|
||||
filesystems (issue #1051).
|
||||
|
||||
--- scripts/Makefile.am.orig 2017-07-22 21:14:53.000000000 +0000
|
||||
+++ scripts/Makefile.am
|
||||
@@ -4,6 +4,6 @@ if BUILD_CLIENT
|
||||
endif
|
||||
CLEANFILES = $(bin_SCRIPTS)
|
||||
|
||||
-mosh: mosh.pl ../VERSION Makefile
|
||||
- @sed -e "s/\@VERSION\@/`cat ../VERSION`/" -e "s/\@PACKAGE_STRING\@/@PACKAGE_STRING@/" $(srcdir)/mosh.pl > mosh
|
||||
+mosh: mosh.pl ../case-insensitive-VERSION Makefile
|
||||
+ @sed -e "s/\@VERSION\@/`cat ../case-insensitive-VERSION`/" -e "s/\@PACKAGE_STRING\@/@PACKAGE_STRING@/" $(srcdir)/mosh.pl > mosh
|
||||
@chmod a+x mosh
|
18
net/mosh/patches/patch-scripts_Makefile.in
Normal file
18
net/mosh/patches/patch-scripts_Makefile.in
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-scripts_Makefile.in,v 1.1 2021/05/13 10:47:49 schmonz Exp $
|
||||
|
||||
Work around build failure with libc++ >=7.0 on case-insensitive
|
||||
filesystems (issue #1051).
|
||||
|
||||
--- scripts/Makefile.in.orig 2017-07-22 21:15:12.000000000 +0000
|
||||
+++ scripts/Makefile.in
|
||||
@@ -513,8 +513,8 @@ uninstall-am: uninstall-binSCRIPTS
|
||||
.PRECIOUS: Makefile
|
||||
|
||||
|
||||
-mosh: mosh.pl ../VERSION Makefile
|
||||
- @sed -e "s/\@VERSION\@/`cat ../VERSION`/" -e "s/\@PACKAGE_STRING\@/@PACKAGE_STRING@/" $(srcdir)/mosh.pl > mosh
|
||||
+mosh: mosh.pl ../case-insensitive-VERSION Makefile
|
||||
+ @sed -e "s/\@VERSION\@/`cat ../case-insensitive-VERSION`/" -e "s/\@PACKAGE_STRING\@/@PACKAGE_STRING@/" $(srcdir)/mosh.pl > mosh
|
||||
@chmod a+x mosh
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
Loading…
Reference in a new issue