kwayland: update to 5.93.0
5.81.0 Bump required PlasmaWaylandProtocols Fix DTD check errors and a typo Add the activity management protocol client implementation 5.82.0 Add VRR to output device and management Use new version-controlled enumerator deprecation warning macros Add support for overscan Bump plasma-wayland-protocols dependency to 1.2.1 Bump required PlasmaWaylandProtocols 5.83.0 Use protocol files from plasma-wayland-protocols Update Plasma Wayland Protocols dependency to 1.3.0 Do not emit Surface::leave twice when an output is removed 5.85.0 Fix check for mmap failure 5.86.0 Implement set_frost in contrast protocol Implement org_kde_plasma_window_management::send_to_output Decouple activation feedback from plasma window management global plasma-window-management: Support new activation concepts 5.88.0 Correct the eglQueryWaylandBufferWL_func prototype 5.90.0 Make linux/input.h a hard dependency 5.91.0 Ensure when unmapped is emitted, ::windows() will not contain unmapped window Don't use hard-coded versions with targets and variables Install pkg-config file Deprecate PlasmaWindowModel::requestVirtualDesktop() kwayland server has been moved to plasma kwayland-server since 5.73 src/client: wrap deprecated methods in deprecation macros 5.92.0 Check executables exist in PATH before passing them to QProcess 5.93.0 Install Client headers in a dirs hierarchy matching the C++ namespaces We don't actually need Qt6WaylandCompositor
This commit is contained in:
parent
16b24bbea9
commit
e081d3566f
7 changed files with 202 additions and 59 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.15 2022/04/18 19:09:47 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
DISTNAME= kwayland-${KF5VER}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= x11
|
||||
|
||||
HOMEPAGE= https://community.kde.org/Frameworks
|
||||
|
@ -10,7 +9,7 @@ LICENSE= gnu-lgpl-v2.1
|
|||
|
||||
.include "../../meta-pkgs/kde/kf5.mk"
|
||||
|
||||
BUILD_DEPENDS+= plasma-wayland-protocols>=1.1:../../devel/plasma-wayland-protocols
|
||||
BUILD_DEPENDS+= plasma-wayland-protocols>=1.4:../../devel/plasma-wayland-protocols
|
||||
|
||||
USE_TOOLS+= pkg-config
|
||||
# Don't do autotests. Some builds are linux specific.
|
||||
|
|
|
@ -1,54 +1,54 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2021/03/30 10:58:24 markd Exp $
|
||||
include/KF5/KWayland/Client/appmenu.h
|
||||
include/KF5/KWayland/Client/blur.h
|
||||
include/KF5/KWayland/Client/buffer.h
|
||||
include/KF5/KWayland/Client/compositor.h
|
||||
include/KF5/KWayland/Client/connection_thread.h
|
||||
include/KF5/KWayland/Client/contrast.h
|
||||
include/KF5/KWayland/Client/datadevice.h
|
||||
include/KF5/KWayland/Client/datadevicemanager.h
|
||||
include/KF5/KWayland/Client/dataoffer.h
|
||||
include/KF5/KWayland/Client/datasource.h
|
||||
include/KF5/KWayland/Client/dpms.h
|
||||
include/KF5/KWayland/Client/event_queue.h
|
||||
include/KF5/KWayland/Client/fakeinput.h
|
||||
include/KF5/KWayland/Client/fullscreen_shell.h
|
||||
include/KF5/KWayland/Client/idle.h
|
||||
include/KF5/KWayland/Client/idleinhibit.h
|
||||
include/KF5/KWayland/Client/keyboard.h
|
||||
include/KF5/KWayland/Client/keystate.h
|
||||
include/KF5/KWayland/Client/kwaylandclient_export.h
|
||||
include/KF5/KWayland/Client/output.h
|
||||
include/KF5/KWayland/Client/outputconfiguration.h
|
||||
include/KF5/KWayland/Client/outputdevice.h
|
||||
include/KF5/KWayland/Client/outputmanagement.h
|
||||
include/KF5/KWayland/Client/plasmashell.h
|
||||
include/KF5/KWayland/Client/plasmavirtualdesktop.h
|
||||
include/KF5/KWayland/Client/plasmawindowmanagement.h
|
||||
include/KF5/KWayland/Client/plasmawindowmodel.h
|
||||
include/KF5/KWayland/Client/pointer.h
|
||||
include/KF5/KWayland/Client/pointerconstraints.h
|
||||
include/KF5/KWayland/Client/pointergestures.h
|
||||
include/KF5/KWayland/Client/region.h
|
||||
include/KF5/KWayland/Client/registry.h
|
||||
include/KF5/KWayland/Client/relativepointer.h
|
||||
include/KF5/KWayland/Client/remote_access.h
|
||||
include/KF5/KWayland/Client/seat.h
|
||||
include/KF5/KWayland/Client/server_decoration.h
|
||||
include/KF5/KWayland/Client/server_decoration_palette.h
|
||||
include/KF5/KWayland/Client/shadow.h
|
||||
include/KF5/KWayland/Client/shell.h
|
||||
include/KF5/KWayland/Client/shm_pool.h
|
||||
include/KF5/KWayland/Client/slide.h
|
||||
include/KF5/KWayland/Client/subcompositor.h
|
||||
include/KF5/KWayland/Client/subsurface.h
|
||||
include/KF5/KWayland/Client/surface.h
|
||||
include/KF5/KWayland/Client/textinput.h
|
||||
include/KF5/KWayland/Client/touch.h
|
||||
include/KF5/KWayland/Client/xdgdecoration.h
|
||||
include/KF5/KWayland/Client/xdgforeign.h
|
||||
include/KF5/KWayland/Client/xdgoutput.h
|
||||
include/KF5/KWayland/Client/xdgshell.h
|
||||
@comment $NetBSD: PLIST,v 1.5 2022/04/25 05:26:49 markd Exp $
|
||||
include/KF5/KWayland/KWayland/Client/appmenu.h
|
||||
include/KF5/KWayland/KWayland/Client/blur.h
|
||||
include/KF5/KWayland/KWayland/Client/buffer.h
|
||||
include/KF5/KWayland/KWayland/Client/compositor.h
|
||||
include/KF5/KWayland/KWayland/Client/connection_thread.h
|
||||
include/KF5/KWayland/KWayland/Client/contrast.h
|
||||
include/KF5/KWayland/KWayland/Client/datadevice.h
|
||||
include/KF5/KWayland/KWayland/Client/datadevicemanager.h
|
||||
include/KF5/KWayland/KWayland/Client/dataoffer.h
|
||||
include/KF5/KWayland/KWayland/Client/datasource.h
|
||||
include/KF5/KWayland/KWayland/Client/dpms.h
|
||||
include/KF5/KWayland/KWayland/Client/event_queue.h
|
||||
include/KF5/KWayland/KWayland/Client/fakeinput.h
|
||||
include/KF5/KWayland/KWayland/Client/fullscreen_shell.h
|
||||
include/KF5/KWayland/KWayland/Client/idle.h
|
||||
include/KF5/KWayland/KWayland/Client/idleinhibit.h
|
||||
include/KF5/KWayland/KWayland/Client/keyboard.h
|
||||
include/KF5/KWayland/KWayland/Client/keystate.h
|
||||
include/KF5/KWayland/KWayland/Client/kwaylandclient_export.h
|
||||
include/KF5/KWayland/KWayland/Client/output.h
|
||||
include/KF5/KWayland/KWayland/Client/outputconfiguration.h
|
||||
include/KF5/KWayland/KWayland/Client/outputdevice.h
|
||||
include/KF5/KWayland/KWayland/Client/outputmanagement.h
|
||||
include/KF5/KWayland/KWayland/Client/plasmashell.h
|
||||
include/KF5/KWayland/KWayland/Client/plasmavirtualdesktop.h
|
||||
include/KF5/KWayland/KWayland/Client/plasmawindowmanagement.h
|
||||
include/KF5/KWayland/KWayland/Client/plasmawindowmodel.h
|
||||
include/KF5/KWayland/KWayland/Client/pointer.h
|
||||
include/KF5/KWayland/KWayland/Client/pointerconstraints.h
|
||||
include/KF5/KWayland/KWayland/Client/pointergestures.h
|
||||
include/KF5/KWayland/KWayland/Client/region.h
|
||||
include/KF5/KWayland/KWayland/Client/registry.h
|
||||
include/KF5/KWayland/KWayland/Client/relativepointer.h
|
||||
include/KF5/KWayland/KWayland/Client/remote_access.h
|
||||
include/KF5/KWayland/KWayland/Client/seat.h
|
||||
include/KF5/KWayland/KWayland/Client/server_decoration.h
|
||||
include/KF5/KWayland/KWayland/Client/server_decoration_palette.h
|
||||
include/KF5/KWayland/KWayland/Client/shadow.h
|
||||
include/KF5/KWayland/KWayland/Client/shell.h
|
||||
include/KF5/KWayland/KWayland/Client/shm_pool.h
|
||||
include/KF5/KWayland/KWayland/Client/slide.h
|
||||
include/KF5/KWayland/KWayland/Client/subcompositor.h
|
||||
include/KF5/KWayland/KWayland/Client/subsurface.h
|
||||
include/KF5/KWayland/KWayland/Client/surface.h
|
||||
include/KF5/KWayland/KWayland/Client/textinput.h
|
||||
include/KF5/KWayland/KWayland/Client/touch.h
|
||||
include/KF5/KWayland/KWayland/Client/xdgdecoration.h
|
||||
include/KF5/KWayland/KWayland/Client/xdgforeign.h
|
||||
include/KF5/KWayland/KWayland/Client/xdgoutput.h
|
||||
include/KF5/KWayland/KWayland/Client/xdgshell.h
|
||||
include/KF5/KWayland/Server/appmenu_interface.h
|
||||
include/KF5/KWayland/Server/blur_interface.h
|
||||
include/KF5/KWayland/Server/buffer_interface.h
|
||||
|
@ -102,7 +102,7 @@ include/KF5/KWayland/Server/xdgdecoration_interface.h
|
|||
include/KF5/KWayland/Server/xdgforeign_interface.h
|
||||
include/KF5/KWayland/Server/xdgoutput_interface.h
|
||||
include/KF5/KWayland/Server/xdgshell_interface.h
|
||||
include/KF5/kwayland_version.h
|
||||
include/KF5/KWayland/kwayland_version.h
|
||||
lib/cmake/KF5Wayland/KF5WaylandConfig.cmake
|
||||
lib/cmake/KF5Wayland/KF5WaylandConfigVersion.cmake
|
||||
lib/cmake/KF5Wayland/KF5WaylandTargets-noconfig.cmake
|
||||
|
@ -113,6 +113,7 @@ lib/libKF5WaylandClient.so.${PKGVERSION}
|
|||
lib/libKF5WaylandServer.so
|
||||
lib/libKF5WaylandServer.so.5
|
||||
lib/libKF5WaylandServer.so.${PKGVERSION}
|
||||
lib/pkgconfig/KF5WaylandClient.pc
|
||||
libexec/org-kde-kf5-kwayland-testserver
|
||||
qt5/mkspecs/modules/qt_KWaylandClient.pri
|
||||
qt5/mkspecs/modules/qt_KWaylandServer.pri
|
||||
|
|
|
@ -1,5 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.7 2021/10/26 10:15:12 nia Exp $
|
||||
$NetBSD: distinfo,v 1.8 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
BLAKE2s (kwayland-5.80.0.tar.xz) = 6e53f03d5bc9f1486728630489196266c5e445022f4a9ce64c773ef4d5290118
|
||||
SHA512 (kwayland-5.80.0.tar.xz) = d681e7910a27c76925745dd508cc553a2ddb0b7cda9af150dbd59de3b69a19082e672c586b9e4de1da3fd8027f3aa8d85f36444a20db2604c76d7e407f269789
|
||||
Size (kwayland-5.80.0.tar.xz) = 344740 bytes
|
||||
BLAKE2s (kwayland-5.93.0.tar.xz) = 7eb79f98062bb656ca7d5a44a70cf701ff9724f7f7643d5d4ed9d5ad13bb638e
|
||||
SHA512 (kwayland-5.93.0.tar.xz) = 26157575ee49916ff1e75fccccfbd192536dbb1f914432c6e784d52eb95343c61caf26b5d3e5e6ddf1f7f439494debadbd29263631cb9489e12b98b1b9eb30c4
|
||||
Size (kwayland-5.93.0.tar.xz) = 335328 bytes
|
||||
SHA1 (patch-autotests_client_test__fake__input.cpp) = 56064dee8ee51c3d2e679c58b39a28501d7c1c9b
|
||||
SHA1 (patch-autotests_client_test__plasma__window__model.cpp) = 39a0016d99a1f3d3bcf9cf44133b7124afd81921
|
||||
SHA1 (patch-src_client_fakeinput.cpp) = 061318f6490efb8fd60b0f61d003433d7fa6bfae
|
||||
SHA1 (patch-src_server_seat__interface.cpp) = 85a6b5231e9784b025da7ee9481e37f23ff77151
|
||||
|
|
|
@ -0,0 +1,44 @@
|
|||
$NetBSD: patch-autotests_client_test__fake__input.cpp,v 1.1 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
linux/input.h only for linux
|
||||
|
||||
--- autotests/client/test_fake_input.cpp.orig 2022-04-02 10:04:14.000000000 +0000
|
||||
+++ autotests/client/test_fake_input.cpp
|
||||
@@ -15,7 +15,9 @@
|
||||
#include "../../src/server/display.h"
|
||||
#include "../../src/server/fakeinput_interface.h"
|
||||
|
||||
+#ifdef Q_OS_LINUX
|
||||
#include <linux/input.h>
|
||||
+#endif
|
||||
|
||||
using namespace KWayland::Client;
|
||||
using namespace KWayland::Server;
|
||||
@@ -198,9 +200,11 @@ void FakeInputTest::testPointerButtonQt_
|
||||
QTest::addColumn<Qt::MouseButton>("qtButton");
|
||||
QTest::addColumn<quint32>("linuxButton");
|
||||
|
||||
+#ifdef BTN_LEFT
|
||||
QTest::newRow("left") << Qt::LeftButton << quint32(BTN_LEFT);
|
||||
QTest::newRow("right") << Qt::RightButton << quint32(BTN_RIGHT);
|
||||
QTest::newRow("middle") << Qt::MiddleButton << quint32(BTN_MIDDLE);
|
||||
+#endif
|
||||
}
|
||||
|
||||
void FakeInputTest::testPointerButtonQt()
|
||||
@@ -247,6 +251,7 @@ void FakeInputTest::testPointerButtonLin
|
||||
{
|
||||
QTest::addColumn<quint32>("linuxButton");
|
||||
|
||||
+#ifdef BTN_LEFT
|
||||
QTest::newRow("left") << quint32(BTN_LEFT);
|
||||
QTest::newRow("right") << quint32(BTN_RIGHT);
|
||||
QTest::newRow("middle") << quint32(BTN_MIDDLE);
|
||||
@@ -255,6 +260,7 @@ void FakeInputTest::testPointerButtonLin
|
||||
QTest::newRow("forward") << quint32(BTN_FORWARD);
|
||||
QTest::newRow("back") << quint32(BTN_BACK);
|
||||
QTest::newRow("task") << quint32(BTN_TASK);
|
||||
+#endif
|
||||
}
|
||||
|
||||
void FakeInputTest::testPointerButtonLinux()
|
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-autotests_client_test__plasma__window__model.cpp,v 1.1 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
linux/input.h only for linux
|
||||
|
||||
--- autotests/client/test_plasma_window_model.cpp.orig 2022-04-02 10:04:14.000000000 +0000
|
||||
+++ autotests/client/test_plasma_window_model.cpp
|
||||
@@ -17,7 +17,9 @@
|
||||
#include "../../src/server/plasmavirtualdesktop_interface.h"
|
||||
#include "../../src/server/plasmawindowmanagement_interface.h"
|
||||
|
||||
+#ifdef Q_OS_LINUX
|
||||
#include <linux/input.h>
|
||||
+#endif
|
||||
|
||||
using namespace KWayland::Client;
|
||||
using namespace KWayland::Server;
|
36
devel/kwayland/patches/patch-src_client_fakeinput.cpp
Normal file
36
devel/kwayland/patches/patch-src_client_fakeinput.cpp
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-src_client_fakeinput.cpp,v 1.1 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
linux/input.h only for linux
|
||||
|
||||
--- src/client/fakeinput.cpp.orig 2022-04-02 10:04:14.000000000 +0000
|
||||
+++ src/client/fakeinput.cpp
|
||||
@@ -10,7 +10,9 @@
|
||||
#include <QPointF>
|
||||
#include <QSizeF>
|
||||
|
||||
+#ifdef Q_OS_LINUX
|
||||
#include <linux/input.h>
|
||||
+#endif
|
||||
|
||||
#include <wayland-fake-input-client-protocol.h>
|
||||
|
||||
@@ -98,13 +100,19 @@ void FakeInput::Private::sendPointerButt
|
||||
uint32_t b = 0;
|
||||
switch (button) {
|
||||
case Qt::LeftButton:
|
||||
+#ifdef BTN_LEFT
|
||||
b = BTN_LEFT;
|
||||
+#endif
|
||||
break;
|
||||
case Qt::RightButton:
|
||||
+#ifdef BTN_RIGHT
|
||||
b = BTN_RIGHT;
|
||||
+#endif
|
||||
break;
|
||||
case Qt::MiddleButton:
|
||||
+#ifdef BTN_MIDDLE
|
||||
b = BTN_MIDDLE;
|
||||
+#endif
|
||||
break;
|
||||
default:
|
||||
// TODO: more buttons, check implementation in QtWayland
|
43
devel/kwayland/patches/patch-src_server_seat__interface.cpp
Normal file
43
devel/kwayland/patches/patch-src_server_seat__interface.cpp
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-src_server_seat__interface.cpp,v 1.1 2022/04/25 05:26:49 markd Exp $
|
||||
|
||||
linux/input.h only for linux
|
||||
|
||||
--- src/server/seat_interface.cpp.orig 2022-04-02 10:04:14.000000000 +0000
|
||||
+++ src/server/seat_interface.cpp
|
||||
@@ -19,7 +19,9 @@
|
||||
#define WL_SEAT_NAME_SINCE_VERSION 2
|
||||
#endif
|
||||
|
||||
+#ifdef Q_OS_LINUX
|
||||
#include <linux/input.h>
|
||||
+#endif
|
||||
|
||||
#include <functional>
|
||||
|
||||
@@ -38,6 +40,10 @@ SeatInterface::Private::Private(SeatInte
|
||||
{
|
||||
}
|
||||
|
||||
+#ifndef Q_OS_LINUX
|
||||
+enum mouse_button { BTN_LEFT, BTN_RIGHT, BTN_MIDDLE, BTN_TOUCH };
|
||||
+#endif
|
||||
+
|
||||
#ifndef K_DOXYGEN
|
||||
const struct wl_seat_interface SeatInterface::Private::s_interface = {getPointerCallback, getKeyboardCallback, getTouchCallback, releaseCallback};
|
||||
#endif
|
||||
@@ -753,6 +759,7 @@ namespace
|
||||
static quint32 qtToWaylandButton(Qt::MouseButton button)
|
||||
{
|
||||
static const QHash<Qt::MouseButton, quint32> s_buttons({
|
||||
+#ifdef BTN_LEFT
|
||||
{Qt::LeftButton, BTN_LEFT},
|
||||
{Qt::RightButton, BTN_RIGHT},
|
||||
{Qt::MiddleButton, BTN_MIDDLE},
|
||||
@@ -769,6 +776,7 @@ static quint32 qtToWaylandButton(Qt::Mou
|
||||
{Qt::ExtraButton11, BTN_TASK + 6},
|
||||
{Qt::ExtraButton12, BTN_TASK + 7},
|
||||
{Qt::ExtraButton13, BTN_TASK + 8}
|
||||
+#endif
|
||||
// further mapping not possible, 0x120 is BTN_JOYSTICK
|
||||
});
|
||||
return s_buttons.value(button, 0);
|
Loading…
Reference in a new issue