Don't use inline when the code can't deal with inlining not happening.
This commit is contained in:
parent
2964390919
commit
e097da870f
2 changed files with 24 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2020/03/23 19:57:29 nia Exp $
|
||||
$NetBSD: distinfo,v 1.9 2020/04/12 19:49:18 joerg Exp $
|
||||
|
||||
SHA1 (beaver-0.4.1.tar.bz2) = 93b331d182d50cb3f59b9d7467229c24271d7f80
|
||||
RMD160 (beaver-0.4.1.tar.bz2) = 096563b5a1add9ad965408576de1df434cce5c89
|
||||
SHA512 (beaver-0.4.1.tar.bz2) = 3000bed3aa2a67d6c38a68a7782a9d5423bcec0b8420272b0f0dade604c094a7b52058b43222af38d56313f0aa27998028c984f69340bf28eeaa8b8a93548a1e
|
||||
Size (beaver-0.4.1.tar.bz2) = 436321 bytes
|
||||
SHA1 (patch-src_editor.c) = ba07ad0efb621e0feafe86e7fbf45952deb06db2
|
||||
|
|
22
editors/beaver/patches/patch-src_editor.c
Normal file
22
editors/beaver/patches/patch-src_editor.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_editor.c,v 1.3 2020/04/12 19:49:18 joerg Exp $
|
||||
|
||||
--- src/editor.c.orig 2020-04-12 01:01:00.903208293 +0000
|
||||
+++ src/editor.c
|
||||
@@ -537,7 +537,7 @@ inline gint is_matching_keyword (gint Lg
|
||||
}
|
||||
|
||||
|
||||
-inline void refresh_markers (GtkTextBuffer * Buffer)
|
||||
+void refresh_markers (GtkTextBuffer * Buffer)
|
||||
{
|
||||
gint CurrentPage;
|
||||
gint Lg;
|
||||
@@ -894,7 +894,7 @@ void search_for_keyword_correctly (gint
|
||||
END_FCN}
|
||||
|
||||
|
||||
-inline void search_for_keyword_fastly (gint page, GtkTextBuffer * Buffer,
|
||||
+void search_for_keyword_fastly (gint page, GtkTextBuffer * Buffer,
|
||||
gchar * text, gint * i, gint offset,
|
||||
gint Lg)
|
||||
{
|
Loading…
Reference in a new issue