Update ruby-facter pacakge to 1.5.
1.5: Fixed #1400 - OperatingSystemRelease should now work on CentOS Changed 'timeout' option to 'limit' to avoid scope issue Fixes #1376 - Display memory facts for AIX Fixes #1334 - Forced Facter to use LANG=C Fixes #1357 - Change ps syntax for OSX and BSD Set the timeout on the AIX kernelrelease fact to 5 seconds. Refactored so each fact resolution can specify a separate timeout, but the default is still 0.5. Refactered ipmess.rb and util/ip.rb to support separate *BSD logic for *BSD aliased interfaces. Updated dmidecode facts fixing ticket #60 Added AIX support for some facts Add lsbmajdistrelease fact for CentOS and Red Hat Updated Red Hat spec file for new version The 'facter' executable now has an option (-p|--puppet) for loading the Puppet libraries, which gives it access to Puppet's facts. Added autoloading to Facter with a default of not loading all facts, which results in a significant speedup when only one fact is sought. Facts are autoloaded in either a single file named after the fact or in any file in a directory named after the fact. Significantly refactored Facter's internals, including creating tests for all internal classes. A netmask fact has been added closing ticket #46. It only returns the netmask of the primary interface (in the same behaviour as the ipaddress and macaddress facts). Facts to return multiple interfaces on a host have also been updated. If you have multiple interfaces on Linux, *BSD, or Solaris/SunOS you will now get facts for each interface's IP address, MAC address and netmask. The facts will be structured like: ipaddress_int = 10.0.0.x macaddress_int = xx:xx:xx:xx netmask_int = 255.255.255.0 Facter now identifies Ubuntu hosts and their releases using the operatingsystem and operatingsystemrelease facts. The Debian operatingsystemrelease fact now correctly returns the current Debian release. Fixed ticket #48 - ioperatingsystem and operatingsystemrelease for CentOS Fixed ticket #44 and allowed support for Xen multiple interfaces and aliased interfaces. Supports both Linux and *BSD. Added interfaces fact to add as index for ip/MAC address facts Added Mandrake support for operatingsystem fact - closed ticket #47 Fixed ticket #45 Added netmask.rb closing ticket #46
This commit is contained in:
parent
de18d3348d
commit
e0a393a62d
4 changed files with 42 additions and 22 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2008/04/04 15:30:01 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2008/09/15 15:32:00 taca Exp $
|
||||
|
||||
DISTNAME= facter-1.3.8
|
||||
DISTNAME= facter-1.5
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= tonnerre@NetBSD.org
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2008/04/04 15:30:01 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2008/09/15 15:32:00 taca Exp $
|
||||
bin/facter
|
||||
${GEM_HOME}/cache/facter-${PKGVERSION}.gem
|
||||
${GEM_LIBDIR}/CHANGELOG
|
||||
|
@ -12,14 +12,49 @@ ${GEM_LIBDIR}/bin/facter
|
|||
${GEM_LIBDIR}/etc/facter.conf
|
||||
${GEM_LIBDIR}/install.rb
|
||||
${GEM_LIBDIR}/lib/facter.rb
|
||||
${GEM_LIBDIR}/lib/facter/Cfkey.rb
|
||||
${GEM_LIBDIR}/lib/facter/architecture.rb
|
||||
${GEM_LIBDIR}/lib/facter/domain.rb
|
||||
${GEM_LIBDIR}/lib/facter/facterversion.rb
|
||||
${GEM_LIBDIR}/lib/facter/fqdn.rb
|
||||
${GEM_LIBDIR}/lib/facter/hardwareisa.rb
|
||||
${GEM_LIBDIR}/lib/facter/hardwaremodel.rb
|
||||
${GEM_LIBDIR}/lib/facter/hostname.rb
|
||||
${GEM_LIBDIR}/lib/facter/id.rb
|
||||
${GEM_LIBDIR}/lib/facter/ipaddress.rb
|
||||
${GEM_LIBDIR}/lib/facter/iphostnumber.rb
|
||||
${GEM_LIBDIR}/lib/facter/ipmess.rb
|
||||
${GEM_LIBDIR}/lib/facter/kernel.rb
|
||||
${GEM_LIBDIR}/lib/facter/kernelrelease.rb
|
||||
${GEM_LIBDIR}/lib/facter/lsb.rb
|
||||
${GEM_LIBDIR}/lib/facter/lsbmajdistrelease.rb
|
||||
${GEM_LIBDIR}/lib/facter/macaddress.rb
|
||||
${GEM_LIBDIR}/lib/facter/macosx.rb
|
||||
${GEM_LIBDIR}/lib/facter/manufacturer.rb
|
||||
${GEM_LIBDIR}/lib/facter/memory.rb
|
||||
${GEM_LIBDIR}/lib/facter/netmask.rb
|
||||
${GEM_LIBDIR}/lib/facter/operatingsystem.rb
|
||||
${GEM_LIBDIR}/lib/facter/operatingsystemrelease.rb
|
||||
${GEM_LIBDIR}/lib/facter/processor.rb
|
||||
${GEM_LIBDIR}/lib/facter/ps.rb
|
||||
${GEM_LIBDIR}/lib/facter/puppetversion.rb
|
||||
${GEM_LIBDIR}/lib/facter/rubysitedir.rb
|
||||
${GEM_LIBDIR}/lib/facter/rubyversion.rb
|
||||
${GEM_LIBDIR}/lib/facter/ssh.rb
|
||||
${GEM_LIBDIR}/lib/facter/uniqueid.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/collection.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/confine.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/fact.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/ip.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/loader.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/macosx.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/manufacturer.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/memory.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/netmask.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/plist.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/plist/generator.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/plist/parser.rb
|
||||
${GEM_LIBDIR}/lib/facter/util/resolution.rb
|
||||
${GEM_HOME}/specifications/facter-${PKGVERSION}.gemspec
|
||||
@dirrm ${GEM_LIBDIR}/lib/facter/util/plist
|
||||
@dirrm ${GEM_LIBDIR}/lib/facter/util
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/04/04 15:30:01 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/09/15 15:32:00 taca Exp $
|
||||
|
||||
SHA1 (facter-1.3.8.gem) = 0cc38ff23b1316b23a6378744be1fea3e5d348a1
|
||||
RMD160 (facter-1.3.8.gem) = d2f889963724cd14fc03c19c1ad8099d00210cf5
|
||||
Size (facter-1.3.8.gem) = 32256 bytes
|
||||
SHA1 (patch-aa) = e0d792edf8438811398ffbb2b67253c832b98b64
|
||||
SHA1 (facter-1.5.gem) = 060c25aacb2b0094e8ae2b31ff25c1eb2f422c46
|
||||
RMD160 (facter-1.5.gem) = 9aee444e19587394de9b2f25461b75891e9912ca
|
||||
Size (facter-1.5.gem) = 36864 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/04/04 15:30:01 jlam Exp $
|
||||
|
||||
--- ../facter-1.3.8.gemspec.orig 2008-03-30 23:50:38.000000000 -0400
|
||||
+++ ../facter-1.3.8.gemspec
|
||||
@@ -3,8 +3,6 @@ name: facter
|
||||
version: !ruby/object:Gem::Version
|
||||
version: 1.3.8
|
||||
platform: ruby
|
||||
-authors:
|
||||
--
|
||||
autorequire:
|
||||
bindir: bin
|
||||
cert_chain:
|
Loading…
Reference in a new issue