Update ruby-ming pacakge to 0.1.8.

Ming/Ruby 0.1.8 - 2006-05-30

* works with Ming 0.3
This commit is contained in:
taca 2007-03-17 16:11:08 +00:00
parent 7bc661e317
commit e0ca1b03f3
3 changed files with 7 additions and 30 deletions

View file

@ -1,16 +1,16 @@
# $NetBSD: Makefile,v 1.5 2006/09/14 05:52:39 taca Exp $
# $NetBSD: Makefile,v 1.6 2007/03/17 16:11:08 taca Exp $
DISTNAME= ming-ruby-${VER}
PKGNAME= ${RUBY_PKGPREFIX}-ming-${VER}
CATEGORIES= multimedia
MASTER_SITES= http://rubyforge.org/frs/download.php/1841/
MASTER_SITES= http://rubyforge.org/frs/download.php/15678/
MAINTAINER= rasputnik@hellooperator.net
HOMEPAGE= http://mingruby.rubyforge.org/
COMMENT= Ruby extension to drive the Ming SWF library
USE_RUBY_SETUP= yes
VER= 0.1.7
VER= 0.1.8
EXAMPLES= README.examples action.rb drag.rb \
gradient.rb gradientxform.rb hello.rb keypress.rb \

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.3 2006/09/13 15:58:48 obache Exp $
$NetBSD: distinfo,v 1.4 2007/03/17 16:11:08 taca Exp $
SHA1 (ming-ruby-0.1.7.tar.gz) = c8481b8067d4cafc09b2a6a36fd1e1567b5c2ab5
RMD160 (ming-ruby-0.1.7.tar.gz) = 9f753ee057678f44ef2218ae1d8c76e3ed286e98
Size (ming-ruby-0.1.7.tar.gz) = 41507 bytes
SHA1 (patch-aa) = cabf19c4dbb7a80c19ebf0a99c1d2aedc15c368f
SHA1 (ming-ruby-0.1.8.tar.gz) = 5c6bf4f84d578f5b9f0ede60bc2e45e7ac0bdbc2
RMD160 (ming-ruby-0.1.8.tar.gz) = 43060ed6e903f27c17ca38512cfabaf747abcdcf
Size (ming-ruby-0.1.8.tar.gz) = 158877 bytes

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.1 2006/09/13 15:58:48 obache Exp $
--- ext/ming/mingc/swfmovie.c.orig 2004-10-31 22:52:10.000000000 +0900
+++ ext/ming/mingc/swfmovie.c
@@ -228,7 +228,7 @@ rb_SWFMovie_output(argc, argv, self)
level = NUM2INT(lobj);
Data_Get_Struct(self, struct RSWFMovie, m);
- len = SWFMovie_output(m->this, simpleOutputMethod, NULL, level);
+ len = SWFMovie_output(m->this, simpleOutputMethod, NULL);
return INT2NUM(len);
}
@@ -249,7 +249,7 @@ rb_SWFMovie_save(argc, argv, self)
level = NUM2INT(lobj);
Data_Get_Struct(self, struct RSWFMovie, m);
- count = SWFMovie_save(m->this, STR2CSTR(s), level);
+ count = SWFMovie_save(m->this, STR2CSTR(s));
return INT2NUM(count);
}