Fix build with Clang

This commit is contained in:
joerg 2011-08-20 15:27:09 +00:00
parent 6a86d8a7d5
commit e0df43795d
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.11 2011/02/18 23:56:48 shattered Exp $
$NetBSD: distinfo,v 1.12 2011/08/20 15:27:09 joerg Exp $
SHA1 (abook-0.6.0pre2.tar.gz) = 42a939fba43e51aa011fa185113c12ec4bc1e1ec
RMD160 (abook-0.6.0pre2.tar.gz) = 7b69dff4678e6deccc48ee3040f019c9a95463a9
Size (abook-0.6.0pre2.tar.gz) = 411412 bytes
SHA1 (patch-database.h) = 7debc679591bf0d05c345e36ab38035786ce693b

View file

@ -0,0 +1,13 @@
$NetBSD: patch-database.h,v 1.1 2011/08/20 15:27:09 joerg Exp $
--- database.h.orig 2011-08-20 13:47:08.000000000 +0000
+++ database.h
@@ -60,7 +60,7 @@ struct db_enumerator {
/*
* Field operations
*/
-inline int field_id(int i);
+int field_id(int i);
abook_field *find_standard_field(char *key, int do_declare);
abook_field *real_find_field(char *key, abook_field_list *list, int *nb);
#define find_field(key, list) real_find_field(key, list, NULL)