Initial import of SDL, a multimedia library mainly for games.

Currently using pth instead of 'real' pthreads, and some parts (mainly
audio and obviously thread support) don't work correctly because of
that (unproven-pthreads misses pthread_cancel & friends to make it
work), but there are some programs that do.
This commit is contained in:
wiz 2000-06-26 01:09:08 +00:00
parent c3e293259d
commit e0f058e5ad
17 changed files with 650 additions and 0 deletions

35
devel/SDL/Makefile Normal file
View file

@ -0,0 +1,35 @@
# $NetBSD: Makefile,v 1.1.1.1 2000/06/26 01:09:08 wiz Exp $
#
DISTNAME= SDL-1.1.3
CATEGORIES= devel games
MASTER_SITES= http://www.libsdl.org/release/
MAINTAINER= wiz@netbsd.org
HOMEPAGE= http://www.libsdl.org/
BUILD_DEPENDS+= ${LOCALBASE}/bin/autoconf:../../devel/autoconf
BUILD_DEPENDS+= ${LOCALBASE}/bin/automake:../../devel/automake
DEPENDS+= pth>=1.3.5:../../devel/pth
#DEPENDS+= unproven-pthreads>=0.16
DEPENDS+= Mesa-*:../../graphics/Mesa
DEPENDS+= esound>=0.2.18:../../audio/esound
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_X11= YES
USE_LIBTOOL= YES
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
LDFLAGS+= -Wl,-R${X11BASE}/lib
#CC= ${LOCALBASE}/pthreads/bin/pgcc
pre-patch:
cd ${WRKSRC} && ${MKDIR} src/audio/netbsd
post-patch:
cd ${WRKSRC} && autoconf
post-configure:
cd ${WRKSRC}/src/audio && ${CP} *.[ch] netbsd/
.include "../../mk/bsd.pkg.mk"

3
devel/SDL/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
MD5 (SDL-1.1.3.tar.gz) = 675cd5df455b32e7648c86cd734d5a33

13
devel/SDL/files/patch-sum Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
MD5 (patch-aa) = 9f1f063534b7a1687ee160a02ba55957
MD5 (patch-ab) = 9b3e6e48901394b9af2146c9e3d23bad
MD5 (patch-ac) = 6cc0b292c6d1704e24cdf9a3ef92b1ca
MD5 (patch-ad) = 1b09e6e6dd5647323d486d5cb19afc06
MD5 (patch-ae) = 4deec123b2cc9244e970161e015c2c8e
MD5 (patch-af) = bfb4ca65f34df8034c3a580087ce6d43
MD5 (patch-ag) = d65ea50c5e770d265b1be404df5b4e60
MD5 (patch-ah) = 5dcfce9c64721177b198ccf2dd584f14
MD5 (patch-ai) = a87655d1307a2482af8b26a9b94dea7e
MD5 (patch-aj) = 616ba95aaea20fa79f9bbb5406ac6324
MD5 (patch-ak) = 7f8029d5b1194f50454e634582f1c1bb

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/netbsd/Makefile.am.orig Fri Jun 23 03:53:49 2000
+++ src/audio/netbsd/Makefile.am Fri Jun 23 03:53:49 2000
@@ -0,0 +1,17 @@
+
+## Makefile.am for the SDL NetBSD audio subsystem
+
+noinst_LTLIBRARIES = libaudio_arch.la
+
+if TARGET_NETBSD
+ARCH_SRCS = SDL_audiodev.c SDL_audiodev_c.h \
+ SDL_lowaudio.h SDL_sysaudio.c \
+ SDL_esdaudio.c SDL_esdaudio.h
+else
+ARCH_SRCS =
+endif
+
+libaudio_arch_la_SOURCES = $(ARCH_SRCS)
+
+# All of the sources come from other architecture directories
+DISTCLEANFILES = $(ARCH_SRCS)

342
devel/SDL/patches/patch-ab Normal file
View file

@ -0,0 +1,342 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/netbsd/Makefile.in.orig Fri Jun 23 03:53:50 2000
+++ src/audio/netbsd/Makefile.in Fri Jun 23 03:54:43 2000
@@ -0,0 +1,337 @@
+# Makefile.in generated automatically by automake 1.4 from Makefile.am
+
+# Copyright (C) 1994, 1995-8, 1999 Free Software Foundation, Inc.
+# This Makefile.in is free software; the Free Software Foundation
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
+
+
+SHELL = @SHELL@
+
+srcdir = @srcdir@
+top_srcdir = @top_srcdir@
+VPATH = @srcdir@
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+
+bindir = @bindir@
+sbindir = @sbindir@
+libexecdir = @libexecdir@
+datadir = @datadir@
+sysconfdir = @sysconfdir@
+sharedstatedir = @sharedstatedir@
+localstatedir = @localstatedir@
+libdir = @libdir@
+infodir = @infodir@
+mandir = @mandir@
+includedir = @includedir@
+oldincludedir = /usr/include
+
+DESTDIR =
+
+pkgdatadir = $(datadir)/@PACKAGE@
+pkglibdir = $(libdir)/@PACKAGE@
+pkgincludedir = $(includedir)/@PACKAGE@
+
+top_builddir = ../../..
+
+ACLOCAL = @ACLOCAL@
+AUTOCONF = @AUTOCONF@
+AUTOMAKE = @AUTOMAKE@
+AUTOHEADER = @AUTOHEADER@
+
+INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
+INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+transform = @program_transform_name@
+
+NORMAL_INSTALL = :
+PRE_INSTALL = :
+POST_INSTALL = :
+NORMAL_UNINSTALL = :
+PRE_UNINSTALL = :
+POST_UNINSTALL = :
+host_alias = @host_alias@
+host_triplet = @host@
+ARCH = @ARCH@
+AS = @AS@
+AUDIO_ARCH = @AUDIO_ARCH@
+AUDIO_ARCH_LIB = @AUDIO_ARCH_LIB@
+CC = @CC@
+CXX = @CXX@
+DLLTOOL = @DLLTOOL@
+ESD_CFLAGS = @ESD_CFLAGS@
+ESD_CONFIG = @ESD_CONFIG@
+ESD_LIBS = @ESD_LIBS@
+EXEEXT = @EXEEXT@
+LD = @LD@
+LIBTOOL = @LIBTOOL@
+LN_S = @LN_S@
+LT_AGE = @LT_AGE@
+LT_CURRENT = @LT_CURRENT@
+LT_RELEASE = @LT_RELEASE@
+LT_REVISION = @LT_REVISION@
+MAKEINFO = @MAKEINFO@
+NASM = @NASM@
+NASMFLAGS = @NASMFLAGS@
+NM = @NM@
+OBJDUMP = @OBJDUMP@
+OBJEXT = @OBJEXT@
+PACKAGE = @PACKAGE@
+RANLIB = @RANLIB@
+SDL_BINARY_AGE = @SDL_BINARY_AGE@
+SDL_CFLAGS = @SDL_CFLAGS@
+SDL_EXTRADIRS = @SDL_EXTRADIRS@
+SDL_EXTRALIBS = @SDL_EXTRALIBS@
+SDL_INTERFACE_AGE = @SDL_INTERFACE_AGE@
+SDL_LIBS = @SDL_LIBS@
+SDL_MAJOR_VERSION = @SDL_MAJOR_VERSION@
+SDL_MICRO_VERSION = @SDL_MICRO_VERSION@
+SDL_MINOR_VERSION = @SDL_MINOR_VERSION@
+SDL_RLD_FLAGS = @SDL_RLD_FLAGS@
+SDL_VERSION = @SDL_VERSION@
+STRIP = @STRIP@
+SYSTEM_LIBS = @SYSTEM_LIBS@
+VERSION = @VERSION@
+VIDEO_DRIVERS = @VIDEO_DRIVERS@
+VIDEO_SUBDIRS = @VIDEO_SUBDIRS@
+with_gcc = @with_gcc@
+with_gnu_ld = @with_gnu_ld@
+
+noinst_LTLIBRARIES = libaudio_arch.la
+@TARGET_NETBSD_TRUE@ARCH_SRCS = SDL_audiodev.c SDL_audiodev_c.h SDL_lowaudio.h SDL_sysaudio.c SDL_esdaudio.c SDL_esdaudio.h
+@TARGET_NETBSD_FALSE@ARCH_SRCS =
+
+libaudio_arch_la_SOURCES = $(ARCH_SRCS)
+
+# All of the sources come from other architecture directories
+DISTCLEANFILES = $(ARCH_SRCS)
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+CONFIG_CLEAN_FILES =
+LTLIBRARIES = $(noinst_LTLIBRARIES)
+
+
+DEFS = @DEFS@ -I. -I$(srcdir)
+CPPFLAGS = @CPPFLAGS@
+LDFLAGS = @LDFLAGS@
+LIBS = @LIBS@
+X_CFLAGS = @X_CFLAGS@
+X_LIBS = @X_LIBS@
+X_EXTRA_LIBS = @X_EXTRA_LIBS@
+X_PRE_LIBS = @X_PRE_LIBS@
+libaudio_arch_la_LDFLAGS =
+libaudio_arch_la_LIBADD =
+@TARGET_NETBSD_FALSE@libaudio_arch_la_OBJECTS =
+@TARGET_NETBSD_TRUE@libaudio_arch_la_OBJECTS = SDL_audiodev.lo \
+@TARGET_NETBSD_TRUE@SDL_sysaudio.lo SDL_esdaudio.lo
+CFLAGS = @CFLAGS@
+COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+CCLD = $(CC)
+LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+DIST_COMMON = Makefile.am Makefile.in
+
+
+DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
+
+TAR = tar
+GZIP_ENV = --best
+SOURCES = $(libaudio_arch_la_SOURCES)
+OBJECTS = $(libaudio_arch_la_OBJECTS)
+
+all: all-redirect
+.SUFFIXES:
+.SUFFIXES: .S .c .lo .o .obj .s
+$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+ cd $(top_srcdir) && $(AUTOMAKE) --foreign --include-deps src/audio/netbsd/Makefile
+
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+
+mostlyclean-noinstLTLIBRARIES:
+
+clean-noinstLTLIBRARIES:
+ -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
+
+distclean-noinstLTLIBRARIES:
+
+maintainer-clean-noinstLTLIBRARIES:
+
+.c.o:
+ $(COMPILE) -c $<
+
+# FIXME: We should only use cygpath when building on Windows,
+# and only if it is available.
+.c.obj:
+ $(COMPILE) -c `cygpath -w $<`
+
+.s.o:
+ $(COMPILE) -c $<
+
+.S.o:
+ $(COMPILE) -c $<
+
+mostlyclean-compile:
+ -rm -f *.o core *.core
+ -rm -f *.$(OBJEXT)
+
+clean-compile:
+
+distclean-compile:
+ -rm -f *.tab.c
+
+maintainer-clean-compile:
+
+.c.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
+
+.s.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
+
+.S.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
+
+mostlyclean-libtool:
+ -rm -f *.lo
+
+clean-libtool:
+ -rm -rf .libs _libs
+
+distclean-libtool:
+
+maintainer-clean-libtool:
+
+libaudio_arch.la: $(libaudio_arch_la_OBJECTS) $(libaudio_arch_la_DEPENDENCIES)
+ $(LINK) $(libaudio_arch_la_LDFLAGS) $(libaudio_arch_la_OBJECTS) $(libaudio_arch_la_LIBADD) $(LIBS)
+
+tags: TAGS
+
+ID: $(HEADERS) $(SOURCES) $(LISP)
+ list='$(SOURCES) $(HEADERS)'; \
+ unique=`for i in $$list; do echo $$i; done | \
+ awk ' { files[$$0] = 1; } \
+ END { for (i in files) print i; }'`; \
+ here=`pwd` && cd $(srcdir) \
+ && mkid -f$$here/ID $$unique $(LISP)
+
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) $(LISP)
+ tags=; \
+ here=`pwd`; \
+ list='$(SOURCES) $(HEADERS)'; \
+ unique=`for i in $$list; do echo $$i; done | \
+ awk ' { files[$$0] = 1; } \
+ END { for (i in files) print i; }'`; \
+ test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
+ || (cd $(srcdir) && etags $(ETAGS_ARGS) $$tags $$unique $(LISP) -o $$here/TAGS)
+
+mostlyclean-tags:
+
+clean-tags:
+
+distclean-tags:
+ -rm -f TAGS ID
+
+maintainer-clean-tags:
+
+distdir = $(top_builddir)/$(PACKAGE)-$(VERSION)/$(subdir)
+
+subdir = src/audio/netbsd
+
+distdir: $(DISTFILES)
+ @for file in $(DISTFILES); do \
+ d=$(srcdir); \
+ if test -d $$d/$$file; then \
+ cp -pr $$/$$file $(distdir)/$$file; \
+ else \
+ test -f $(distdir)/$$file \
+ || ln $$d/$$file $(distdir)/$$file 2> /dev/null \
+ || cp -p $$d/$$file $(distdir)/$$file || :; \
+ fi; \
+ done
+info-am:
+info: info-am
+dvi-am:
+dvi: dvi-am
+check-am: all-am
+check: check-am
+installcheck-am:
+installcheck: installcheck-am
+install-exec-am:
+install-exec: install-exec-am
+
+install-data-am:
+install-data: install-data-am
+
+install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+install: install-am
+uninstall-am:
+uninstall: uninstall-am
+all-am: Makefile $(LTLIBRARIES)
+all-redirect: all-am
+install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
+installdirs:
+
+
+mostlyclean-generic:
+
+clean-generic:
+
+distclean-generic:
+ -rm -f Makefile $(CONFIG_CLEAN_FILES)
+ -rm -f config.cache config.log stamp-h stamp-h[0-9]*
+ -test -z "$(DISTCLEANFILES)" || rm -f $(DISTCLEANFILES)
+
+maintainer-clean-generic:
+mostlyclean-am: mostlyclean-noinstLTLIBRARIES mostlyclean-compile \
+ mostlyclean-libtool mostlyclean-tags \
+ mostlyclean-generic
+
+mostlyclean: mostlyclean-am
+
+clean-am: clean-noinstLTLIBRARIES clean-compile clean-libtool \
+ clean-tags clean-generic mostlyclean-am
+
+clean: clean-am
+
+distclean-am: distclean-noinstLTLIBRARIES distclean-compile \
+ distclean-libtool distclean-tags distclean-generic \
+ clean-am
+ -rm -f libtool
+
+distclean: distclean-am
+
+maintainer-clean-am: maintainer-clean-noinstLTLIBRARIES \
+ maintainer-clean-compile maintainer-clean-libtool \
+ maintainer-clean-tags maintainer-clean-generic \
+ distclean-am
+ @echo "This command is intended for maintainers to use;"
+ @echo "it deletes files that may require special tools to rebuild."
+
+maintainer-clean: maintainer-clean-am
+
+.PHONY: mostlyclean-noinstLTLIBRARIES distclean-noinstLTLIBRARIES \
+clean-noinstLTLIBRARIES maintainer-clean-noinstLTLIBRARIES \
+mostlyclean-compile distclean-compile clean-compile \
+maintainer-clean-compile mostlyclean-libtool distclean-libtool \
+clean-libtool maintainer-clean-libtool tags mostlyclean-tags \
+distclean-tags clean-tags maintainer-clean-tags distdir info-am info \
+dvi-am dvi check check-am installcheck-am installcheck install-exec-am \
+install-exec install-data-am install-data install-am install \
+uninstall-am uninstall all-redirect all-am all installdirs \
+mostlyclean-generic distclean-generic clean-generic \
+maintainer-clean-generic clean mostlyclean distclean maintainer-clean
+
+
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT:

View file

@ -0,0 +1,23 @@
$NetBSD: patch-ac,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/SDL_audio.c.orig Wed Apr 12 20:44:19 2000
+++ src/audio/SDL_audio.c Fri Jun 23 03:53:50 2000
@@ -45,6 +45,9 @@
#ifdef unix
&AUDIO_bootstrap,
#endif
+#ifdef __NetBSD__
+ &AUDIO_bootstrap,
+#endif
#ifdef linux
&DMA_bootstrap,
#endif
@@ -170,7 +173,7 @@
/* Select the proper audio driver */
audio = NULL;
idx = 0;
-#ifdef unix
+#if defined(unix) || defined (__NetBSD__)
if ( (driver_name == NULL) && (getenv("ESPEAKER") != NULL) ) {
/* Ahem, we know that if ESPEAKER is set, user probably wants
to use ESD, but don't start it if it's not already running.

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/SDL_audiomem.c.orig Thu Mar 16 16:20:37 2000
+++ src/audio/SDL_audiomem.c Fri Jun 23 03:53:50 2000
@@ -33,6 +33,7 @@
#include <sys/types.h>
#include <sys/ipc.h>
#include <sys/shm.h>
+#include <stdlib.h>
#else
#include <stdlib.h>
#endif

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ae,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/SDL_sysaudio.h.orig Thu Mar 16 16:20:37 2000
+++ src/audio/SDL_sysaudio.h Fri Jun 23 03:53:51 2000
@@ -102,6 +102,9 @@
#ifdef unix
extern AudioBootStrap AUDIO_bootstrap;
#endif
+#ifdef __NetBSD__
+extern AudioBootStrap AUDIO_bootstrap;
+#endif
#ifdef ENABLE_WINDIB
extern AudioBootStrap WAVEOUT_bootstrap;
#endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/audio/Makefile.am.orig Fri Apr 7 08:29:23 2000
+++ src/audio/Makefile.am Fri Jun 23 03:53:51 2000
@@ -3,7 +3,7 @@
noinst_LTLIBRARIES = libaudio.la
-EXTRA_SUBDIRS = aix beos irix linux macos openbsd solaris win32
+EXTRA_SUBDIRS = aix beos irix linux macos netbsd openbsd solaris win32
SUBDIRS = @AUDIO_ARCH@

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ag,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/video/SDL_yuv_sw.c.orig Wed May 24 04:33:58 2000
+++ src/video/SDL_yuv_sw.c Fri Jun 23 04:00:45 2000
@@ -905,7 +905,7 @@
case SDL_IYUV_OVERLAY:
cpu_mmx = CPU_Flags() & MMX_CPU;
if ( display->format->BytesPerPixel == 2 ) {
-#if defined(i386) && defined(__GNUC__) /* inline assembly functions */
+#if defined(i386) && defined(__GNUC__) && !defined(__NetBSD__) /* inline assembly functions */
if ( cpu_mmx && (Rmask == 0xF800) &&
(Gmask == 0x07E0) &&
(Bmask == 0x001F) ) {
@@ -920,7 +920,7 @@
#endif
swdata->Display2X = Color16DitherYV12Mod2X;
} else {
-#if defined(i386) && defined(__GNUC__) /* inline assembly functions */
+#if defined(i386) && defined(__GNUC__) && !defined(__NetBSD__) /* inline assembly functions */
if ( cpu_mmx && (Rmask == 0x00FF0000) &&
(Gmask == 0x0000FF00) &&
(Bmask == 0x000000FF) ) {

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ah,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- src/cdrom/freebsd/SDL_syscdrom.c.orig Sun Apr 23 21:43:28 2000
+++ src/cdrom/freebsd/SDL_syscdrom.c Fri Jun 23 03:53:51 2000
@@ -27,6 +27,7 @@
/* Functions for system-level CD-ROM audio control */
+#include <sys/ioctl.h>
#include <sys/types.h>
#include <stdlib.h>
#include <sys/stat.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- include/SDL_syswm.h.orig Thu Mar 16 16:20:37 2000
+++ include/SDL_syswm.h Fri Jun 23 03:53:52 2000
@@ -49,7 +49,7 @@
#else
/* This is the structure for custom window manager events */
-#if defined(unix) || defined(__unix__) || defined(_AIX)
+#if defined(unix) || defined(__unix__) || defined(_AIX) || defined(__NetBSD__)
/* AIX is unix, of course, but the native compiler CSet doesn't define unix */
#include <X11/Xlib.h>
#include <X11/Xatom.h>

View file

@ -0,0 +1,72 @@
$NetBSD: patch-aj,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- configure.in.orig Tue Jun 6 06:36:10 2000
+++ configure.in Fri Jun 23 03:53:52 2000
@@ -810,6 +810,51 @@
COPY_ARCH_SRC(src/timer, linux, SDL_systimer.c)
fi
;;
+ *-*-netbsd*)
+ ARCH=netbsd
+ CheckESD
+ CheckX11
+ CheckAAlib
+ CheckOpenGL
+ CheckPTHREAD
+ # Set up files for the main() stub
+ COPY_ARCH_SRC(src/main, linux, SDL_main.c)
+ # Set up files for the audio library
+ AUDIO_ARCH=netbsd
+ AUDIO_ARCH_LIB=$AUDIO_ARCH/libaudio_arch.la
+ if test x$enable_audio = xyes; then
+ COPY_ARCH_SRC(src/audio, solaris, SDL_audiodev_c.h)
+ COPY_ARCH_SRC(src/audio, linux, SDL_audiodev.c)
+ COPY_ARCH_SRC(src/audio, linux, SDL_esdaudio.h)
+ COPY_ARCH_SRC(src/audio, linux, SDL_esdaudio.c)
+ COPY_ARCH_SRC(src/audio, solaris, SDL_lowaudio.h)
+ COPY_ARCH_SRC(src/audio, solaris, SDL_sysaudio.c)
+ fi
+ # Set up files for the joystick library
+ # (No joystick support yet)
+ if test x$enable_joystick = xyes; then
+ COPY_ARCH_SRC(src/joystick, dummy, SDL_sysjoystick.c)
+ fi
+ # Set up files for the cdrom library
+ if test x$enable_cdrom = xyes; then
+ COPY_ARCH_SRC(src/cdrom, freebsd, SDL_syscdrom.c)
+ fi
+ # Set up files for the thread library
+ if test x$enable_threads = xyes; then
+ COPY_ARCH_SRC(src/thread, linux, SDL_systhread.c)
+ COPY_ARCH_SRC(src/thread, linux, SDL_systhread_c.h)
+ COPY_ARCH_SRC(src/thread, linux, SDL_sysmutex.c)
+ COPY_ARCH_SRC(src/thread, linux, SDL_sysmutex_c.h)
+ COPY_ARCH_SRC(src/thread, generic, SDL_syssem.c)
+ COPY_ARCH_SRC(src/thread, generic, SDL_syssem_c.h)
+ COPY_ARCH_SRC(src/thread, linux, SDL_syscond.c)
+ COPY_ARCH_SRC(src/thread, generic, SDL_syscond_c.h)
+ fi
+ # Set up files for the timer library
+ if test x$enable_timers = xyes; then
+ COPY_ARCH_SRC(src/timer, linux, SDL_systimer.c)
+ fi
+ ;;
*-*-openbsd*)
ARCH=openbsd
CheckESD
@@ -1147,6 +1192,7 @@
AM_CONDITIONAL(TARGET_SOLARIS, test $ARCH = solaris)
AM_CONDITIONAL(TARGET_IRIX, test $ARCH = irix)
AM_CONDITIONAL(TARGET_FREEBSD, test $ARCH = freebsd)
+AM_CONDITIONAL(TARGET_NETBSD, test $ARCH = netbsd)
AM_CONDITIONAL(TARGET_OPENBSD, test $ARCH = openbsd)
AM_CONDITIONAL(TARGET_AIX, test $ARCH = aix)
AM_CONDITIONAL(TARGET_WIN32, test $ARCH = win32)
@@ -1214,6 +1260,7 @@
src/audio/irix/Makefile
src/audio/linux/Makefile
src/audio/macos/Makefile
+src/audio/netbsd/Makefile
src/audio/openbsd/Makefile
src/audio/solaris/Makefile
src/audio/win32/Makefile

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ak,v 1.1.1.1 2000/06/26 01:09:09 wiz Exp $
--- sdl-config.in.orig Mon May 22 20:01:18 2000
+++ sdl-config.in Sun Jun 25 16:19:04 2000
@@ -46,7 +46,7 @@
;;
--libs)
libdirs="-L@libdir@ @SDL_RLD_FLAGS@"
- echo $libdirs @SDL_LIBS@
+ echo $libdirs @SDL_LIBS@ @SYSTEM_LIBS@
;;
--static-libs)
libdirs="-L@libdir@ @SDL_RLD_FLAGS@"

1
devel/SDL/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
Simple DirectMedia Layer, a cross-platform multimedia library

4
devel/SDL/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
Simple DirectMedia Layer is a cross-platform multimedia library
designed to provide fast access to the graphics framebuffer and audio
device. It is used by MPEG playback software, emulators, and many
popular games.

36
devel/SDL/pkg/PLIST Normal file
View file

@ -0,0 +1,36 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/06/26 01:09:08 wiz Exp $
bin/sdl-config
include/SDL/SDL.h
include/SDL/SDL_active.h
include/SDL/SDL_audio.h
include/SDL/SDL_byteorder.h
include/SDL/SDL_cdrom.h
include/SDL/SDL_copying.h
include/SDL/SDL_endian.h
include/SDL/SDL_error.h
include/SDL/SDL_events.h
include/SDL/SDL_joystick.h
include/SDL/SDL_keyboard.h
include/SDL/SDL_keysym.h
include/SDL/SDL_main.h
include/SDL/SDL_mouse.h
include/SDL/SDL_mutex.h
include/SDL/SDL_quit.h
include/SDL/SDL_rwops.h
include/SDL/SDL_syswm.h
include/SDL/SDL_thread.h
include/SDL/SDL_timer.h
include/SDL/SDL_types.h
include/SDL/SDL_version.h
include/SDL/SDL_video.h
include/SDL/begin_code.h
include/SDL/close_code.h
@dirrm include/SDL
lib/libSDL.a
lib/libSDL.la
lib/libSDL.so
lib/libSDL-1.1.so.3.0
lib/libSDLmain.a
share/aclocal/sdl.m4
@comment libSDL.so doesn't get deleted correctly for some reason
@unexec rm -f %D/lib/libSDL.so